• 1369阅读
  • 19回复

QT+Echart动态生成酷炫表格【开源】 [复制链接]

上一主题 下一主题
离线微笑内敛
 

图酷模式  只看楼主 倒序阅读 楼主  发表于: 2017-12-24
使用了一段时间的js开源库Echart,发现这是一款非常强大的表格图形化工具。
大概总结了一个简单的Demo,通过QT调用js接口向Echart传递数据,动态生成图表
注:本人使用环境QT 5.5.1,QT 5.0之前版本使用需要有少量改动。QT5.6以上因移除QWebkit,无法使用。



csdn源码下载地址:http://download.csdn.net/download/luan1010/10171238
离线liudianwu

只看该作者 1楼 发表于: 2017-12-24
建议最好备注下,Qt5.0到5.5可用,其他版本不可用!
在线沉默小ai

只看该作者 2楼 发表于: 2017-12-24
没有CSDN分数了,尴尬啊
离线微笑内敛

只看该作者 3楼 发表于: 2017-12-24
回 liudianwu 的帖子
liudianwu:建议最好备注下,Qt5.0到5.5可用,其他版本不可用! (2017-12-24 17:58) 

恩,是的!感谢刘神提醒~
离线微笑内敛

只看该作者 4楼 发表于: 2017-12-24
回 沉默小ai 的帖子
沉默小ai:没有CSDN分数了,尴尬啊 (2017-12-24 18:58) 

啊,你需要吗?需要留个邮箱我发你。
离线liuchangyin

只看该作者 5楼 发表于: 2017-12-25
离线liuchangyin

只看该作者 6楼 发表于: 2017-12-25
动态图666
离线如鱼得水

只看该作者 7楼 发表于: 2017-12-25
能否搞一个5.6以上的?
离线15927174837

只看该作者 8楼 发表于: 2017-12-25
离线calvin.huang

只看该作者 9楼 发表于: 2017-12-25
回 liudianwu 的帖子
liudianwu:建议最好备注下,Qt5.0到5.5可用,其他版本不可用! (2017-12-24 17:58) 

请问大神,想要用Echart,必须得使用5.0~5.5的版本吗
离线liudianwu

只看该作者 10楼 发表于: 2017-12-25
回 calvin.huang 的帖子
calvin.huang:请问大神,想要用Echart,必须得使用5.0~5.5的版本吗 (2017-12-25 17:47) 

webkit只有5.5以下版本才有!而且作者用到了QJson,这个是5.0以上版本才有,所以交集一下,初中数学!
在线clickto

只看该作者 11楼 发表于: 2017-12-25
像这种类似的要使用web相关的东西,对于mingw版的5.6及以上的应该怎么办?
离线xdh873939316

只看该作者 12楼 发表于: 2017-12-27
回 liudianwu 的帖子
liudianwu:建议最好备注下,Qt5.0到5.5可用,其他版本不可用! (2017-12-24 17:58) 

刘大师你好,本人是新手,Qt5.6以上,MingG版本,能不能采用QAxwidget 来使用Webkit控件,这样的话,这个Echart是依托于Web 的,是不是可以直接显示了。
离线微笑内敛

只看该作者 13楼 发表于: 2017-12-27
回 clickto 的帖子
clickto:像这种类似的要使用web相关的东西,对于mingw版的5.6及以上的应该怎么办? (2017-12-25 20:23) 

QWebEngine或QT+cef框架
离线yuzhongcheng

只看该作者 14楼 发表于: 01-04
我也要一份源码,QQ:2946457494@qq.com
在线chenjinb2008

只看该作者 15楼 发表于: 01-05
动态图很炫,期待您的源码。
chenjinb2008@163.com
离线yangliu8623

只看该作者 16楼 发表于: 01-08
QWebKit可以自己编译的嘛
离线alone_work

只看该作者 17楼 发表于: 01-09
楼主,求一个demo,感激不尽!!
lijiangjun931026@outlook.com
离线q小玩家

只看该作者 18楼 发表于: 01-12
很酷~求一份源码~ 214563468@qq.com
在线mscheng

只看该作者 19楼 发表于: 01-20
楼主,请你一份给我,CSDN上面没有积分,下载不了.谢谢!
mscheng@qq.com
快速回复
限100 字节
 
上一个 下一个