• 1540阅读
  • 7回复

[提问]fatal error: 'type_traits' file not found [复制链接]

上一主题 下一主题
离线foxgod
 

只看楼主 倒序阅读 楼主  发表于: 2019-06-04
qt5.12.3按照网上的教程,都配置好了,写了一个很简单的窗口程序,编译出现fatal error: 'type_traits' file not found


这是什么问题呢??电脑里面有两个qt,一个qt5.8(msvc),一个是qt5.12.3(安卓)
离线20091001753

只看该作者 1楼 发表于: 2019-06-04
Qt 5.12 编译安卓APP 至少 ndk 19
v8a 需要 SDK Build-Tools 28.0.2
v7 需要 SDK Build-Tools 26.0.2
(づ ̄ 3 ̄)づ
离线fsu0413

只看该作者 2楼 发表于: 2019-06-04
回 20091001753 的帖子
20091001753:Qt 5.12 编译安卓APP 至少 ndk 19
v8a 需要 SDK Build-Tools 28.0.2
v7 需要 SDK Build-Tools 26.0.2 (2019-06-04 18:18) 

官方编译5.12都没用ndk r19。。。。。用的是r18
不过说实话Qt官方这波升级实在是突然,当然这也不怪Qt,怪谷歌
离线foxgod

只看该作者 3楼 发表于: 2019-06-05
回 20091001753 的帖子
20091001753:Qt 5.12 编译安卓APP 至少 ndk 19
v8a 需要 SDK Build-Tools 28.0.2
v7 需要 SDK Build-Tools 26.0.2 (2019-06-04 18:18) 

nd我的版本比较低,sdk我是用这个下载的installer_r24.4.1-windows-----android sdk:Android 9(API 28),这个没问题吧
离线foxgod

只看该作者 4楼 发表于: 2019-06-05
回 fsu0413 的帖子
fsu0413:官方编译5.12都没用ndk r19。。。。。用的是r18
不过说实话Qt官方这波升级实在是突然,当然这也不怪Qt,怪谷歌 (2019-06-04 21:55) 

我是因为NDK和sdk的版本问题,导致的这个问题吗
离线foxgod

只看该作者 5楼 发表于: 2019-06-05
回 20091001753 的帖子
20091001753:Qt 5.12 编译安卓APP 至少 ndk 19
v8a 需要 SDK Build-Tools 28.0.2
v7 需要 SDK Build-Tools 26.0.2 (2019-06-04 18:18) 

感谢你的提醒,ndk更换到ndk19c以后,编译通过了,谢谢,这个哪个版本的qt,需要什么版本的ndk这个在哪里看呢?
离线20091001753

只看该作者 6楼 发表于: 2019-06-05
你新建一个工程,如果无法通过编译,那就只能是环境配置的问题。
然后就是尝试,先尝试 ndk 的最新稳定版本,依旧不行就继续降,直到找到合适的。
(づ ̄ 3 ̄)づ
离线fsu0413

只看该作者 7楼 发表于: 2019-06-05
回 foxgod 的帖子
foxgod:我是因为NDK和sdk的版本问题,导致的这个问题吗 (2019-06-05 09:28) 

是NDK和Qt版本的问题
Qt5.9以及之前肯定用的都是r10e,5.10和5.11不清楚,5.12开始必须要用r18及以后的版本

顺便 r11以后的GCC有问题不能用
快速回复
限100 字节
 
上一个 下一个