• 3249阅读
  • 14回复

[公告]Qt 5.14 发布 [复制链接]

上一主题 下一主题
在线20091001753
 

只看楼主 倒序阅读 楼主  发表于: 2019-12-12
Qt 5.14 发布于2019年12月11日
https://www.qt.io/blog/qt-5.14-has-released

Qt 5.14 新特性
https://wiki.qt.io/New_Features_in_Qt_5.14

接下来的 Qt 5.15 将会是 LTS,之后将是 Qt6 的到来。

下载地址:
http://download.qt.io/official_releases/qt/5.14/5.14.0/



若 VS 出现编译错误,需要更新  vsaddin 至最新版(2.4.2-rev.14.vsix)
https://download.qt.io/development_releases/vsaddin/

编译安卓APP 需要 ndk 20
v8a 需要 SDK Build-Tools 28.0.3
v7 需要 SDK Build-Tools 26.0.2
4条评分好评度+1贡献值+1金钱+1威望+1
liulin188 好评度 +1 优秀文章,支持!n神马都是浮云 2019-12-12
liulin188 贡献值 +1 优秀文章,支持!n神马都是浮云 2019-12-12
liulin188 威望 +1 优秀文章,支持!n神马都是浮云 2019-12-12
liulin188 金钱 +1 优秀文章,支持!n神马都是浮云 2019-12-12
(づ ̄ 3 ̄)づ
在线liulin188

只看该作者 1楼 发表于: 2019-12-12
安装包小了很多,这不是qt的风格啊
https://wiki.qt.io/Qt_5.12_Release
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
在线20091001753

只看该作者 2楼 发表于: 2019-12-12
5.14 的安卓,以下简称该版本:

该版本开始,支持 ndk 20 了,之前最高 19c

且以前版本的 AndroidManifest.xml 与 该版本生成的并不兼容
(或许是我从 ndk 19c 更换到了 20 的缘故)

widgets 也比之前版本也更美观了
(づ ̄ 3 ̄)づ
离线九重水

只看该作者 3楼 发表于: 2019-12-13
好吧,刚下完5.13.2,出了5.14,,,,
在线liulin188

只看该作者 4楼 发表于: 2019-12-13
回 20091001753 的帖子
20091001753:5.14 的安卓,以下简称该版本:
该版本开始,支持 ndk 20 了,之前最高 19c
且以前版本的 AndroidManifest.xml 与 该版本生成的并不兼容
....... (2019-12-12 19:08) 

这个版本bug也修复了不少
https://wiki.qt.io/Qt_5.14.0_Change_Files
https://wiki.qt.io/Qt_5.12_Release
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
离线XChinux

只看该作者 5楼 发表于: 2019-12-14
等5.15出来再升级,LTS版,能用好久
二笔 openSUSE Vim N9 BB10 XChinux@163.com 网易博客 腾讯微博
承接C++/Qt、Qt UI界面、PHP及预算报销系统开发业务
离线eagleyang

只看该作者 6楼 发表于: 2019-12-17
貌似 vs插件对于5.14版本失效了?vsaddin/2.4.2/*.vsix。同样的配置,使用5.13.2版本的可以编译,在5.14里编译过不去。提示error MSB4018: “GetVarsFromMakefile”任务意外失败。
离线rpdhunter

只看该作者 7楼 发表于: 2019-12-19
这个版本win版打包工具windeployqt失效了?

在线20091001753

只看该作者 8楼 发表于: 2019-12-20
回 rpdhunter 的帖子
用这段代码测试,是正常的。
http://www.qtcn.org/bbs/read-htm-tid-85441.html
(づ ̄ 3 ̄)づ
离线snow_man_0

只看该作者 9楼 发表于: 2019-12-20
vs2019 vsaddin 在5.13.2版本 就不能用了,害的我换回vs2017
1条评分金钱+1
20091001753 金钱 +1 更新  vsaddin 至最新版(2.4.2-rev.14.vsix) 01-01
离线eagleyang

只看该作者 10楼 发表于: 2019-12-21
回 snow_man_0 的帖子
snow_man_0:
vs2019 vsaddin 在5.13.2版本 就不能用了,害的我换回vs2017

我这是可以用的,估计是你的哪个配置冲突了。
离线snow_man_0

只看该作者 11楼 发表于: 2019-12-21
回 eagleyang 的帖子
eagleyang:我这是可以用的,[图片]估计是你的哪个配置冲突了。 (2019-12-21 11:20) 

是vs2019中vsaddin的qmake不兼容老的pro文件
1条评分金钱+1
20091001753 金钱 +1 更新  vsaddin 至最新版(2.4.2-rev.14.vsix) 01-01
离线eagleyang

只看该作者 12楼 发表于: 2019-12-28
回 snow_man_0 的帖子
snow_man_0:是vs2019中vsaddin的qmake不兼容老的pro文件 (2019-12-21 21:45) 

是的,使用vs建qt的项目,环境变量获取的不完全。有点难搞,在路径里添加也是有问题。
离线snow_man_0

只看该作者 13楼 发表于: 2019-12-30
回 eagleyang 的帖子
eagleyang:是的,使用vs建qt的项目,环境变量获取的不完全。有点难搞,在路径里添加也是有问题。 (2019-12-28 22:35) 

我是手用PRO文件,然后用VSADD打开PRO文件,这样MOC可以并行、很多配置不需要在VS里一一设置

又测试下,VSADD2.4.2+VS2019 16.4.2又正常使用了
离线llong

只看该作者 14楼 发表于: 2019-12-31
Qt5.14 + VS2019 出现编译错误
更新 vsaddin 至最新版,可以解决这个问题:
https://download.qt.io/development_releases/vsaddin/

BUG描述:
https://bugreports.qt.io/browse/QTVSADDINBUG-722
4条评分好评度+1贡献值+1金钱+10威望+1
20091001753 好评度 +1 - 01-01
20091001753 贡献值 +1 - 01-01
20091001753 威望 +1 - 01-01
20091001753 金钱 +10 - 01-01
快速回复
限100 字节
 
上一个 下一个