• 2358阅读
  • 30回复

Qt 5.15 在线安装 [复制链接]

上一主题 下一主题
在线20091001753
 

只看楼主 倒序阅读 楼主  发表于: 05-28
Qt 发布公告:
http://download.qt.io/official_releases/qt/5.15/5.15.0/OFFLINE_REAMDE.txt

内容是:从 Qt 5.15 开始,开源版本,无论是不是 LTS,都只能在线安装

如果确实需要离线安装包,则要购买 Qt for Small Business 产品:
https://www.qt.io/blog/available-now-qt-for-small-business

这里举例 Qt 5.15 的在线安装方法。
下载速度大概在 3M/s

下载 Qt 在线安装器
http://download.qt.io/official_releases/online_installers/










(づ ̄ 3 ̄)づ
离线liulin188

只看该作者 1楼 发表于: 05-28
vs2017没有了啊,真蛋疼了
参考这个帖子:https://www.qt.io/blog/qt-offering-changes-2020
以后开源用户没法离线安装了,不过在线安装好像丰富了很多内容,也是不错的




https://wiki.qt.io/Qt_5.12_Release
https://wiki.qt.io/New_Features_in_Qt_5.12
https://wiki.qt.io/Qt_5.12.0_Known_Issues
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
https://wiki.qt.io/Qt_5.12_Tools_and_Versions
在线20091001753

只看该作者 2楼 发表于: 05-28
回 liulin188 的帖子
我目前就是 VS2017
我本计划,将 VS2017 删除后,安装 VS2019

令我无语的是:
VS2017 提示说,删除前,请先将它更新到最新。。。

我都要删了,竟然还让我更新先。
(づ ̄ 3 ̄)づ
离线liulin188

只看该作者 3楼 发表于: 05-28
回 20091001753 的帖子
关键有很多c++的三方库,如果要换vs2019的话,还要重头编译一遍,头大。。。。
https://wiki.qt.io/Qt_5.12_Release
https://wiki.qt.io/New_Features_in_Qt_5.12
https://wiki.qt.io/Qt_5.12.0_Known_Issues
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
https://wiki.qt.io/Qt_5.12_Tools_and_Versions
离线lemonzll

只看该作者 4楼 发表于: 05-28
vs2015到2019一直是二进制兼容的,也就是第三方库2017或者2015编译的,你用2019写的程序,直接用第三方库就行了,唯一有影响的是不要启用LTO优化选项
离线liulin188

只看该作者 5楼 发表于: 05-28
回 lemonzll 的帖子
lemonzll:vs2015到2019一直是二进制兼容的,也就是第三方库2017或者2015编译的,你用2019写的程序,直接用第三方库就行了,唯一有影响的是不要启用LTO优化选项 (2020-05-28 13:14) 

好像是纯c的库没问题,但是c++的不行
https://wiki.qt.io/Qt_5.12_Release
https://wiki.qt.io/New_Features_in_Qt_5.12
https://wiki.qt.io/Qt_5.12.0_Known_Issues
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
https://wiki.qt.io/Qt_5.12_Tools_and_Versions
离线lemonzll

只看该作者 6楼 发表于: 05-28
vs2015到vs2019这几个版本c++的库也可以通用的。纯C的本来就跟编译器版本没关系,C语言ABI稳定的,随便换编译器版本都可以的,C++ ABI不稳定,所以跟编译器版本有关,但是2015到2019的ABI一直没变动。qt官方之前一直没有2019的开发包,说的就是ABI稳定的,你可以用2017的编译器,我就一直这样用的,我电脑上就装了个vs2019,装了2017的qt以后设置下编译器就行
离线liulin188

只看该作者 7楼 发表于: 05-28
回 lemonzll 的帖子
lemonzll:vs2015到vs2019这几个版本c++的库也可以通用的。纯C的本来就跟编译器版本没关系,C语言ABI稳定的,随便换编译器版本都可以的,C++ ABI不稳定,所以跟编译器版本有关,但是2015到2019的ABI一直没变动。qt官方之前一直没有2019的开发包,说的就是ABI稳定的,你可以用2017的编译器, .. (2020-05-28 14:29) 

那这么说,就是vs2017依然可以用Qt5.15(vs2019)了

这就可能是vs直接去掉2017的原因吧
https://wiki.qt.io/Qt_5.12_Release
https://wiki.qt.io/New_Features_in_Qt_5.12
https://wiki.qt.io/Qt_5.12.0_Known_Issues
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
https://wiki.qt.io/Qt_5.12_Tools_and_Versions
离线天下无雪

只看该作者 8楼 发表于: 05-28
没有离线安装很蛋疼啊,很多内网机器根本没法联网。。。。。
离线liulin188

只看该作者 9楼 发表于: 05-28
回 天下无雪 的帖子
天下无雪:没有离线安装很蛋疼啊,很多内网机器根本没法联网。。。。。 (2020-05-28 17:15)

安装好以后,试试能不能直接把安装文件夹整体拷贝过去用
https://wiki.qt.io/Qt_5.12_Release
https://wiki.qt.io/New_Features_in_Qt_5.12
https://wiki.qt.io/Qt_5.12.0_Known_Issues
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
https://wiki.qt.io/Qt_5.12_Tools_and_Versions
离线lemonzll

只看该作者 10楼 发表于: 05-28
回 liulin188 的帖子
liulin188:那这么说,就是vs2017依然可以用Qt5.15(vs2019)了
这就可能是vs直接去掉2017的原因吧 (2020-05-28 16:15) 

是的。那个qtcreator里面设置kits那里你设置编译器就行了
离线lemonzll

只看该作者 11楼 发表于: 05-28
回 liulin188 的帖子
liulin188:安装好以后,试试能不能直接把安装文件夹整体拷贝过去用 (2020-05-28 17:54) 

应该可以的。我没测试过,不过之前看新特性有个就是5.14.0开始qt是relocatable,感觉意思就是安装以后你可以挪到其他文件夹了。之前官方说过这个 https://www.qt.io/blog/qt-is-relocatable
离线liulin188

只看该作者 12楼 发表于: 05-28
回 lemonzll 的帖子
lemonzll:应该可以的。我没测试过,不过之前看新特性有个就是5.14.0开始qt是relocatable,感觉意思就是安装以后你可以挪到其他文件夹了。之前官方说过这个 https://www.qt.io/blog/qt-is-relocatable (2020-05-28 18:14) 

大佬牛逼啊,哈哈,以后多多指教~~~
https://wiki.qt.io/Qt_5.12_Release
https://wiki.qt.io/New_Features_in_Qt_5.12
https://wiki.qt.io/Qt_5.12.0_Known_Issues
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
https://wiki.qt.io/Qt_5.12_Tools_and_Versions
离线snow_man_0

只看该作者 13楼 发表于: 05-28
终于有vs2019版了
vs2019下每次都要切回2017,实在麻烦
离线天下无雪

只看该作者 14楼 发表于: 05-28
回 lemonzll 的帖子
lemonzll:应该可以的。我没测试过,不过之前看新特性有个就是5.14.0开始qt是relocatable,感觉意思就是安装以后你可以挪到其他文件夹了。之前官方说过这个 https://www.qt.io/blog/qt-is-relocatable (2020-05-28 18:14) 

这个好,就是文件关联还得自己改一下
离线neomissing

只看该作者 15楼 发表于: 05-28
在线安装测试出现bug,选择msvc2019和mingw8.1.0 同时安装32和64位版本 ,出现mingw8.1.0的64版本被错误安装成mingw7.3.0的64位版本
离线realfan

只看该作者 16楼 发表于: 05-29
回 neomissing 的帖子
neomissing:
在线安装测试出现bug,选择msvc2019和mingw8.1.0 同时安装32和64位版本 ,出现mingw8.1.0的64版本被错误安装成mingw7.3.0的64位版本

我安装msvc2019 64加mingw8.1.0 32+64都是正常的
离线realfan

只看该作者 17楼 发表于: 05-29
回 lemonzll 的帖子
lemonzll:是的。那个qtcreator里面设置kits那里你设置编译器就行了 (2020-05-28 18:08) 

你试过吗?我昨天装了Qt5.15.0, 用VS2017,不行。改VS2019可以了
离线liulin188

只看该作者 18楼 发表于: 05-29
回 realfan 的帖子
realfan:你试过吗?我昨天装了Qt5.15.0, 用VS2017,不行。改VS2019可以了
 (2020-05-29 09:56) 

我草,兄弟
好久不见了
https://wiki.qt.io/Qt_5.12_Release
https://wiki.qt.io/New_Features_in_Qt_5.12
https://wiki.qt.io/Qt_5.12.0_Known_Issues
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
https://wiki.qt.io/Qt_5.12_Tools_and_Versions
离线realfan

只看该作者 19楼 发表于: 05-29
回 liulin188 的帖子
liulin188:我草,兄弟
好久不见了
 (2020-05-29 12:11) 

离线XChinux

只看该作者 20楼 发表于: 05-29
回 lemonzll 的帖子
lemonzll:vs2015到vs2019这几个版本c++的库也可以通用的。纯C的本来就跟编译器版本没关系,C语言ABI稳定的,随便换编译器版本都可以的,C++ ABI不稳定,所以跟编译器版本有关,但是2015到2019的ABI一直没变动。qt官方之前一直没有2019的开发包,说的就是ABI稳定的,你可以用2017的编译器, .. (2020-05-28 14:29) 

这个确认是这样的?我没研究过,我安装了MSVC2019,也带了vc2015和vc2017,
看VC的版本,确实是
vc140 是msvc2015
vc141 (14.16)是msvc2017
vc142   (14.23)是msvc2019
二笔 openSUSE Vim N9 BB10 XChinux@163.com 网易博客 腾讯微博
承接C++/Qt、Qt UI界面、PHP及预算报销系统开发业务
离线lemonzll

只看该作者 21楼 发表于: 05-29
没测试过在线安装的,我这边在线安装没网速。找到微软的说明了,https://docs.microsoft.com/en-us/cpp/porting/binary-compat-2015-2017?view=vs-2019,我之前说的是有问题,2015到2019是ABI没变过,但是需要不同版本编译的文件link的时候用最高版本的编译器。也就是现在qt提供的2019版本的,是需要用vs2019才行了,不过第三方库用vs2017或2015编译的可以不用重新编译,加进去就可以用的
4条评分好评度+1贡献值+1金钱+10威望+1
XChinux 好评度 +1 - 05-30
XChinux 贡献值 +1 - 05-30
XChinux 威望 +1 - 05-30
XChinux 金钱 +10 - 05-30
离线rabor

只看该作者 22楼 发表于: 05-31

看到论坛发布Qt 15.5在线安装包了,赶紧下载研究了下。在配置android开发环境时出现OpenSSL配置错误问题.请教各位大佬,这个问题怎么解决。谢谢。
离线rabor

只看该作者 23楼 发表于: 05-31
看到论坛发布Qt 15.5在线安装包了,赶紧下载研究了下。在配置android开发环境时出现OpenSSL配置错误问题,如下图

请教各位大佬,这个问题怎么解决。谢谢。
在线20091001753

只看该作者 24楼 发表于: 05-31
回 rabor 的帖子
我也遇到了同样的问题。

在安装的时候,其实有 openssl 选项,然后我也选了。

安装好后,发现只有x64 x86,并没有适用于安卓的。

也根本找不到 openssl.pri 这个文件。
(づ ̄ 3 ̄)づ
离线lemonzll

只看该作者 25楼 发表于: 05-31
回 rabor 的帖子
rabor:看到论坛发布Qt 15.5在线安装包了,赶紧下载研究了下。在配置android开发环境时出现OpenSSL配置错误问题,如下图
[图片]
请教各位大佬,这个问题怎么解决。谢谢。 (2020-05-31 13:58)

手动下载下这个库,https://github.com/KDAB/android_openssl,用git或者直接下载下,有50多M,设置目录是这个库就可以了。app如果要用到openssl,项目设置里面选Build,Additional Libraries里面有个Include prebuild OpenSSL libraries,把这个勾选上编译出来的就能正常使用ssl了。


4条评分好评度+1贡献值+1金钱+10威望+1
20091001753 好评度 +1 - 05-31
20091001753 贡献值 +1 - 05-31
20091001753 威望 +1 - 05-31
20091001753 金钱 +10 - 05-31
离线rabor

只看该作者 26楼 发表于: 06-01
回 lemonzll 的帖子
lemonzll:手动下载下这个库,https://github.com/KDAB/android_openssl,用git或者直接下载下,有50多M,设置目录是这个库就可以了。app如果要用到openssl,项目设置里面选Build,Additional Libraries里面有个Include prebuild OpenSSL libraries,把这个勾选上编译出来的就能正常使用ss .. (2020-05-31 16:21) 

谢谢大佬,我试试
离线neomissing

只看该作者 27楼 发表于: 06-03
回 realfan 的帖子
realfan:我安装msvc2019 64加mingw8.1.0 32+64都是正常的
 (2020-05-29 09:53) 

建议你自己看下,mingw版本,肯定是不对的,32位mingw和64位mingw不都是8.1.0版本
离线realfan

只看该作者 28楼 发表于: 06-04
回 neomissing 的帖子

建议你自己看下,mingw版本,肯定是不对的,32位mingw和64位mingw不都是8.1.0版本


离线realfan

只看该作者 29楼 发表于: 06-04
回 neomissing 的帖子
neomissing:建议你自己看下,mingw版本,肯定是不对的,32位mingw和64位mingw不都是8.1.0版本 (2020-06-03 09:31) 

上面的截图是笔记本电脑上的,没有mingw32位,台式机上装了32位
离线apud

只看该作者 30楼 发表于: 06-08
Qt 15.5.0那几个组件选项要怎么勾选适合。强迫症啊。
快速回复
限100 字节
 
上一个 下一个