• 220阅读
  • 0回复

[讨论]Qt5.15.2编译Android时Warning解决记录 [复制链接]

上一主题 下一主题
离线mugua001
 

只看楼主 倒序阅读 楼主  发表于: 2022-11-14

Gradle不匹配的Warning;
升级Gradle:
修改 gradle/wrapper/gradle-wrapper.properties 文件中的 Gradle 分发引用:
distributionUrl = "https\://services.gradle.org/distributions/gradle-7.2-all.zip"
为了保持兼容性,请务必在 build.gradle:

    dependencies {
        //classpath 'com.android.tools.build:gradle:3.6.0'
        //classpath 'com.android.tools.build:gradle:4.1.0'
        classpath 'com.android.tools.build:gradle:7.0.1'
        //classpath 'com.android.tools.build:gradle:7.2'
    }

与Gradle7.0匹配的JDK为jdk11.0以上版本:
jdk-11.0.17_linux-x64_bin.tar.gz


若遇到
Warning: This version only understands SDK XML versions up to 2 but an SDK XML file of version 3 was encountered.

需要在AndroidManifest.xml文件中的 <activity>中加上
android:exported=“true”
快速回复
限100 字节
 
上一个 下一个