查看完整版本: [-- Qt 5.14 发布 --]

QTCN开发网 -> 网站公告 -> Qt 5.14 发布 [打印本页] 登录 -> 注册 -> 回复主题 -> 发表主题

20091001753 2019-12-12 16:54

Qt 5.14 发布

Qt 5.14 发布于2019年12月11日
https://www.qt.io/blog/qt-5.14-has-released

Qt 5.14 新特性
https://wiki.qt.io/New_Features_in_Qt_5.14

接下来的 Qt 5.15 将会是 LTS,之后将是 Qt6 的到来。

下载地址:
http://download.qt.io/official_releases/qt/5.14/5.14.0/

[attachment=21155]

若 VS 出现编译错误,需要更新  vsaddin 至最新版(2.4.2-rev.14.vsix)
https://download.qt.io/development_releases/vsaddin/

编译安卓APP 需要 ndk 20
SDK Build-Tools 28.0.3
SDK Build-Tools 26.0.2

liulin188 2019-12-12 17:28
安装包小了很多,这不是qt的风格啊

20091001753 2019-12-12 19:08
5.14 的安卓,以下简称该版本:

该版本开始,支持 ndk 20 了,之前最高 19c

且以前版本的 AndroidManifest.xml 与 该版本生成的并不兼容
(或许是我从 ndk 19c 更换到了 20 的缘故)

widgets 也比之前版本也更美观了

九重水 2019-12-13 09:18
好吧,刚下完5.13.2,出了5.14,,,,

liulin188 2019-12-13 11:50
20091001753:5.14 的安卓,以下简称该版本:
该版本开始,支持 ndk 20 了,之前最高 19c
且以前版本的 AndroidManifest.xml 与 该版本生成的并不兼容
....... (2019-12-12 19:08) 

这个版本bug也修复了不少
https://wiki.qt.io/Qt_5.14.0_Change_Files

XChinux 2019-12-14 08:15
等5.15出来再升级,LTS版,能用好久

eagleyang 2019-12-17 15:56
貌似 vs插件对于5.14版本失效了?vsaddin/2.4.2/*.vsix。同样的配置,使用5.13.2版本的可以编译,在5.14里编译过不去。提示error MSB4018: “GetVarsFromMakefile”任务意外失败。

rpdhunter 2019-12-19 17:04
这个版本win版打包工具windeployqt失效了?


20091001753 2019-12-20 16:32
用这段代码测试,是正常的。
http://www.qtcn.org/bbs/read-htm-tid-85441.html

snow_man_0 2019-12-20 19:23
vs2019 vsaddin 在5.13.2版本 就不能用了,害的我换回vs2017

eagleyang 2019-12-21 11:20
snow_man_0:
vs2019 vsaddin 在5.13.2版本 就不能用了,害的我换回vs2017

我这是可以用的,[attachment=21186]估计是你的哪个配置冲突了。

snow_man_0 2019-12-21 21:45
eagleyang:我这是可以用的,[图片]估计是你的哪个配置冲突了。 (2019-12-21 11:20) 

是vs2019中vsaddin的qmake不兼容老的pro文件

eagleyang 2019-12-28 22:35
snow_man_0:是vs2019中vsaddin的qmake不兼容老的pro文件 (2019-12-21 21:45) 

是的,使用vs建qt的项目,环境变量获取的不完全。有点难搞,在路径里添加也是有问题。

snow_man_0 2019-12-30 21:57
eagleyang:是的,使用vs建qt的项目,环境变量获取的不完全。有点难搞,在路径里添加也是有问题。 (2019-12-28 22:35) 

我是手用PRO文件,然后用VSADD打开PRO文件,这样MOC可以并行、很多配置不需要在VS里一一设置

又测试下,VSADD2.4.2+VS2019 16.4.2又正常使用了

llong 2019-12-31 13:32
Qt5.14 + VS2019 出现编译错误
更新 vsaddin 至最新版,可以解决这个问题:
https://download.qt.io/development_releases/vsaddin/

BUG描述:
https://bugreports.qt.io/browse/QTVSADDINBUG-722


查看完整版本: [-- Qt 5.14 发布 --] [-- top --]



Powered by phpwind v8.7 Code ©2003-2011 phpwind
Gzip disabled