Tianchi: 命名空间列表

Tianchi v0.0.1 build 20130425
C++ library for Qt with VC & mingW
  • 首页
  • 命名空间
  • 类
  • 文件
  • 命名空间列表
  • 命名空间成员
命名空间列表
这里列出了所有文档化的命名空间定义,附带简要说明:
\ N OperMode 操作模式的标识常量
生成于 2013年 四月 25日 星期四 10:48:15 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: OperMode 命名空间参考

  • 命名空间
  • 类
  • 文件
  • 命名空间列表
  • 命名空间成员
变量
OperMode 命名空间参考

操作模式的标识常量 更多...

变量

const int | Append = 1
添加或新建
const int | Change = 2
修改
const int | Delete = 4
删除

详细描述

操作模式的标识常量


Tianchi: 命名空间成员

  • 命名空间列表
  • 命名空间成员
  • 全部
  • 变量
这里列出了所有文档化的命名空间成员，并附带其所属的文件:
  • Append : OperMode
  • Change : OperMode
  • Delete : OperMode


Tianchi: 命名空间成员

  • 命名空间列表
  • 命名空间成员
  • 全部
  • 变量
  • Append : OperMode
  • Change : OperMode
  • Delete : OperMode


Tianchi: 类列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
类列表
这里列出了所有类、结构、联合以及接口定义等，并附带简要说明:
o N OperMode | 操作模式的标识常量
o C Chinese | 汉语相关处理类
o C CInvokeObject | 映射执行对象类
o C ClickLabel | Emit clicked() signal's label while mouse clicked
o C CursorBusy | 后台忙光标的设置和自动恢复处理类
o C CursorCustom | 光标形态变化类的根类，一般不直接使用
o C CursorWait | 等待光标的设置和自动恢复处理类
o C DateEdit | 可以输入或显示为空的日期选择控件
o C DBFields | Key=value 数据格式转换类
o C Directory |
o C Download | 用于下载文件（或文件的一部分） 注意：此类尚未进行严格测试
o C DownloadList | 用于管理文件的下载
o C FileUtils | 文件操作常用处理类
o C FlowLayout | 流式布局FlowLayout
o C GlowEffect |
o C JSONObject | 兼容 Qt 4.x 的 JSON文生成和解析类
o C LineEdit | Extended QLineEdit widget
o C LogTiny | 简单的文本文件输出日志。
o C MarqueeLabel | 跑马灯类MarqueeLabel,点击时自动打开网址
o C MSExcel | 通过 OLE 方式操作 Microsoft Excel
o C MSSQL | 读取 ODBC 驱动和版本信息
o C OS | 与操作系统相关的操作类
o C Player | 玩家信息类，常用在 C/S 中的客户端用户信息保存
o C SingleInstance | 应用程序单实例类
o C String | 字符串功能增强与扩展
o C StringList | 字符串集功能增强与扩展
o C TreeWidgetHeaderSetupDialog | 设置 QTreeWidget 标题的对话框
\ C Utils | 常用小功能综合函数集


Tianchi: Chinese类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
静态 Public 成员函数 | 所有成员列表
Chinese类 参考

汉语相关处理类 更多...

#include <Chinese.h>

静态 Public 成员函数

static QString | firstPinyins (const QString &HzString)
static QString | toPinyin (const QString &Str, bool Tonality=false)
static QString | toChars (const QString &Str, bool Tonality=false)

详细描述

汉语相关处理类

注解
此类仅限在 Windows 下有效，使用时需要在 .pro 文件中加上 LIB += -lole32

成员函数说明

static QString Chinese::firstPinyins ( const QString & HzString )
static

取得多个汉字的首字母

参数
[in] HzString 汉字字符串
返回
每个汉字拼音的首字符
示例:
qDebug()<<TIANCHI::Chinese::firstPinyins(QS("中华人民共和国"));
> zhrmghg
qDebug()<<TIANCHI::Chinese::firstPinyins(QS("中华大地Qt论坛 - www.qtcn.org"));
> zhddlt
static QString Chinese::toChars | ( | const QString & | Str,
 |  | bool | Tonality = false
 | ) |  |
static

混合字符时，转换中不过滤英数符号等

参数
[in] | Str | 汉字字符串
[in] | Tonality | 音调不转换成拼音
返回
汉字的首字母
示例:
qDebug()<<TIANCHI::Chinese::toChars(QS("中华大地Qt论坛 - www.qtcn.org"), true);
> zhōnghuádàdìQtlùntán - www.qtcn.org
qDebug()<<TIANCHI::Chinese::toChars(QS("中华大地Qt论坛 - www.qtcn.org"));
> zhonghuadadiQtluntan - www.qtcn.org
static QString Chinese::toPinyin | ( | const QString & | Str,
 |  | bool | Tonality = false
 | ) |  |
static

取得多个汉字的全部拼音

参数
[in] | Str | 汉字字符串
[in] | Tonality | 音调不转换成拼音
返回
汉语拼音
示例:
含音调的输出
qDebug()<<TIANCHI::Chinese::toPinyin(QS("中华人民共和国"), true);
> zhōnghuárénmíngònghéguó
不含音调的输出
qDebug()<<TIANCHI::Chinese::toPinyin(QS("中华人民共和国"), false);
> zhonghuarenmingongheguo
qDebug()<<TIANCHI::Chinese::toPinyin(QS("中华大地Qt论坛 - www.qtcn.org"));
> zhonghuadadiluntan
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Chinese/Chinese.h


Tianchi: CInvokeObject类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | 所有成员列表
CInvokeObject类 参考

映射执行对象类 更多...

#include <Classes.h>

Public 成员函数

CInvokeObject (QObject *o=NULL, QByteArray m="")
构造方法
CInvokeObject & | operator= (const CInvokeObject &from)
复制对象
bool | queued (QGenericArgument val0=QGenericArgument(0), QGenericArgument val1=QGenericArgument(), QGenericArgument val2=QGenericArgument(), QGenericArgument val3=QGenericArgument(), QGenericArgument val4=QGenericArgument(), QGenericArgument val5=QGenericArgument(), QGenericArgument val6=QGenericArgument(), QGenericArgument val7=QGenericArgument(), QGenericArgument val8=QGenericArgument(), QGenericArgument val9=QGenericArgument())
以队列方式调用映射方法
bool | invoke (QGenericArgument val0=QGenericArgument(0), QGenericArgument val1=QGenericArgument(), QGenericArgument val2=QGenericArgument(), QGenericArgument val3=QGenericArgument(), QGenericArgument val4=QGenericArgument(), QGenericArgument val5=QGenericArgument(), QGenericArgument val6=QGenericArgument(), QGenericArgument val7=QGenericArgument(), QGenericArgument val8=QGenericArgument(), QGenericArgument val9=QGenericArgument())
调用映射方法
bool | isValid () const
返回当前对象是否有效？ 更多...

详细描述

映射执行对象类

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员函数说明

bool CInvokeObject::isValid ( ) const
inline

返回当前对象是否有效？

返回
true: 有效，可以进行映射方式的调用
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Core/Classes.h


Tianchi: ClickLabel类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
信号 | Public 成员函数 | Protected 成员函数 | 所有成员列表
ClickLabel类 参考

emit clicked() signal's label while mouse clicked 更多...

#include <ClickLabel.h>

类 ClickLabel 继承关系图:

信号

void clicked ()
emit when mouse click label

Public 成员函数

ClickLabel (QWidget *parent=0, Qt::WindowFlags f=0)
ClickLabel (const QString &text, QWidget *parent=0, Qt::WindowFlags f=0)

Protected 成员函数

virtual void | mousePressEvent (QMouseEvent *e)
virtual void | mouseReleaseEvent (QMouseEvent *e)

详细描述

emit clicked() signal's label while mouse clicked

该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/ClickLabel.h


Tianchi: CursorBusy类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | 所有成员列表
CursorBusy类 参考

后台忙光标的设置和自动恢复处理类 更多...

#include <GuiUtils.h>

类 CursorBusy 继承关系图:
CursorCustom

Public 成员函数

CursorBusy (QWidget *parent=0)

额外继承的成员函数

- Protected 成员函数 继承自 CursorCustom
CursorCustom (QWidget *parent, Qt::CursorShape shape)
- Protected 属性 继承自 CursorCustom
QWidget * | m_parent
QCursor | m_cursor

详细描述

后台忙光标的设置和自动恢复处理类

示例:
void myForm::onClick()
{
CursorBusy busy; // 自动变成后台忙光标
... 处理代码 ...
} // 退出块时，busy 被释放，使光标自动恢复为原先的光标形态
参见
class CursorBusy
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-15
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/GuiUtils.h


Tianchi: CursorCustom类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Protected 成员函数 | Protected 属性 | 所有成员列表
CursorCustom类 参考

光标形态变化类的根类，一般不直接使用 更多...

#include <GuiUtils.h>

类 CursorCustom 继承关系图:
CursorBusy CursorWait

Protected 成员函数

CursorCustom (QWidget *parent, Qt::CursorShape shape)

Protected 属性

QWidget * | m_parent
QCursor | m_cursor

详细描述

光标形态变化类的根类，一般不直接使用

参见
class CursorWait
class CursorBusy
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-15
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/GuiUtils.h


Tianchi: CursorWait类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | 所有成员列表
CursorWait类 参考

等待光标的设置和自动恢复处理类 更多...

#include <GuiUtils.h>

类 CursorWait 继承关系图:
CursorCustom

Public 成员函数

CursorWait (QWidget *parent=0)

额外继承的成员函数

- Protected 成员函数 继承自 CursorCustom
CursorCustom (QWidget *parent, Qt::CursorShape shape)
- Protected 属性 继承自 CursorCustom
QWidget * | m_parent
QCursor | m_cursor

详细描述

等待光标的设置和自动恢复处理类

示例:
void myForm::onClick()
{
CursorWait wait; // 自动变成等待光标
... 处理代码 ...
} // 退出块时，wait 被释放，使光标自动恢复为原先的光标形态
参见
class CursorBusy
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-15
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/GuiUtils.h


Tianchi: DateEdit类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | Protected 成员函数 | 属性 | 所有成员列表
DateEdit类 参考

可以输入或显示为空的日期选择控件 更多...

#include <DateEdit.h>

类 DateEdit 继承关系图:

Public 成员函数

DateEdit (QWidget *parent=0)
QDate | date () const
void | setDate (QDate value)
void | unsetDate ()
void | setDate (QDateTime value)

Protected 成员函数

void | focusInEvent (QFocusEvent *e)
void | mousePressEvent (QMouseEvent *e)

属性

QDate date

详细描述

可以输入或显示为空的日期选择控件

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/DateEdit.h


Tianchi: DBFields类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | 静态 Public 成员函数 | 所有成员列表
DBFields类 参考

key=value 数据格式转换类 更多...

#include <Classes.h>

Public 成员函数

DBFields (QHash< QString, QByteArray > fields)
void | setFields (QHash< QString, QByteArray > fields)
QByteArray | value (const QString &key) const

静态 Public 成员函数

static void | addField (QByteArray &fieldBytes, const QString &name, const QVariant &value)
static QHash< QString, QByteArray > | getFields (const QByteArray &fieldBytes)

详细描述

key=value 数据格式转换类

注解
C/S 架构中，所以信息都以 key=value 格式传递，此类用于 k=v 信息的读取
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Core/Classes.h


Tianchi: Directory类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
信号 | Public 成员函数 | 所有成员列表
Directory类 参考

#include <Directory.h>

类 Directory 继承关系图:

信号

void currentFile (int count, const QString &name)
信号：当前复制的文件的计数和文件名 更多...

Public 成员函数

Directory (QObject *parent=0)
QStringList | findFiles (const QString &path, const QStringList &nameFilters=QStringList())
查找文件夹内所有的文件 更多...
int | copyDirectories (const QString &fromPath, const QString &toPath, const QStringList &nameFilters=QStringList(), bool overWrite=true)
复制目录树下所有的文件到新文件夹 更多...
int | copyFiles (const QStringList &files, const QString &toPath, bool overWrite=true)
复制文件列表到新文件夹 更多...
void | resetCopyFileCount ()
重置m_copyFileCount为0

详细描述

作者
南果梨 cnhem.nosp@m.iya@.nosp@m.gmail.nosp@m..com
日期
2013-04-21

成员函数说明

int Directory::copyDirectories | ( | const QString & | fromPath,
 |  | const QString & | toPath,
 |  | const QStringList & | nameFilters = QStringList(),
 |  | bool | overWrite = true
 | ) |  |

复制目录树下所有的文件到新文件夹

参数
fromPath | 源文件夹
toPath | 目的文件夹
nameFilters | 文件过滤
overWrite | 是否覆盖
返回
复制的文件数量
int Directory::copyFiles | ( | const QStringList & | files,
 |  | const QString & | toPath,
 |  | bool | overWrite = true
 | ) |  |

复制文件列表到新文件夹

参数
files | 源文件列表
toPath | 目的文件夹
overWrite | 是否覆盖
返回
复制的文件数量
void Directory::currentFile | ( | int | count,
 |  | const QString & | name
 | ) |  |
signal

信号：当前复制的文件的计数和文件名

参数
count | 第几个文件
name | 源文件名
QStringList Directory::findFiles | ( | const QString & | path,
 |  | const QStringList & | nameFilters = QStringList()
 | ) |  |

查找文件夹内所有的文件

参数
path | 要查找的文件夹
nameFilters | 文件过滤
返回
找到的文件列表
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/File/Directory.h


Tianchi: Download类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 槽 | 信号 | Public 成员函数 | 所有成员列表
Download类 参考

用于下载文件（或文件的一部分） 注意：此类尚未进行严格测试 更多...

#include <DownloadHttp.h>

类 Download 继承关系图:

Public 槽

void | FinishedSlot ()
void | HttpReadyRead ()

信号

void DownloadFinished ()

Public 成员函数

Download (int index, QObject *parent=0)
void StartDownload (const QUrl &url, QFile *file, qint64 startPoint=0, qint64 endPoint=-1)

详细描述

用于下载文件（或文件的一部分） 注意：此类尚未进行严格测试

作者
来自互联网
日期
2013-04-19
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Network/DownloadHttp.h


Tianchi: DownloadList类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
信号 | Public 成员函数 | 所有成员列表
DownloadList类 参考

用于管理文件的下载 更多...

#include <DownloadHttp.h>

类 DownloadList 继承关系图:

信号

void FileDownloadFinished ()

Public 成员函数

DownloadList (QObject *parent=0)
void | StartFileDownload (const QString &url, int count)
qint64 | GetFileSize (QUrl url)

详细描述

用于管理文件的下载

该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Network/DownloadHttp.h


Tianchi: FileUtils类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
静态 Public 成员函数 | 所有成员列表
FileUtils类 参考

文件操作常用处理类 更多...

#include <FileUtils.h>

静态 Public 成员函数

static bool | loadFromFile (QString &context, const QString &filename)
装载文本文件
static QString | uniqueFileName (const QString &dir, const QString &fileTemplate, const QString &suffix="")
在指定目录中返回一个临时文件名 更多...
static QString | fileVersion (const QString &exeFile)
取执行文件的版本，仅支持 Windows 更多...
static QStringList | searchFiles (const QString &path)
从目录及子目录中检索出所有文件名

详细描述

文件操作常用处理类

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-15

成员函数说明

static QString FileUtils::fileVersion ( const QString & exeFile )
static

取执行文件的版本，仅支持 Windows

参数
[in] exeFile 包含版本信息的文件名(.exe, .dll等)
返回
版本信息(xxx.xxx.xxx.xxx)
static QString FileUtils::uniqueFileName | ( | const QString & | dir,
 |  | const QString & | fileTemplate,
 |  | const QString & | suffix = ""
 | ) |  |
static

在指定目录中返回一个临时文件名

返回
返回临时文件名，注意不创建该文件
注解
此方法不会自动创建文件
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/File/FileUtils.h


Tianchi: FlowLayout类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | 所有成员列表
FlowLayout类 参考

流式布局FlowLayout 更多...

#include <FlowLayout.h>

类 FlowLayout 继承关系图:

Public 成员函数

FlowLayout (QWidget *parent, int margin=-1, int hSpacing=-1, int vSpacing=-1)
FlowLayout (int margin=-1, int hSpacing=-1, int vSpacing=-1)
void | addItem (QLayoutItem *item)
int | horizontalSpacing () const
int | verticalSpacing () const
Qt::Orientations | expandingDirections () const
bool | hasHeightForWidth () const
int | heightForWidth (int) const
int | count () const
QLayoutItem * | itemAt (int index) const
QSize | minimumSize () const
void | setGeometry (const QRect &rect)
QSize | sizeHint () const
QLayoutItem * | takeAt (int index)

详细描述

流式布局FlowLayout

该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/FlowLayout.h


Tianchi: GlowEffect类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | Protected 成员函数 | 所有成员列表
GlowEffect类 参考
类 GlowEffect 继承关系图:

Public 成员函数

GlowEffect (QObject *parent=0)
void | setRadius (int radius)
set radius 更多...
void | setGlowColor (const QColor &color)
set glow color 更多...
virtual QRectF | boundingRectFor (const QRectF &sourceRect) const

Protected 成员函数

virtual void | draw (QPainter *painter)
virtual void | sourceChanged (ChangeFlags flags)

成员函数说明

void GlowEffect::setGlowColor ( const QColor & color )

set glow color

参数
[in] QColor color
void GlowEffect::setRadius ( int radius )

set radius

参数
[in] int radius
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/GlowEffect.h


Tianchi: JSONObject类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 类型 | Public 成员函数 | 静态 Public 成员函数 | Protected 成员函数 | 静态 Protected 成员函数 | Protected 属性 | 所有成员列表
JSONObject类 参考

兼容 Qt 4.x 的 JSON文生成和解析类 更多...

#include <Json.h>

Public 类型

enum ValueTypeFlag {
vtfObject = 0, vtfString = 1, vtfInt = 2, vtfDouble = 3,
vtfBool = 4, vtfDateTime =5, vtfNull =6, vtfArray =99
}

Public 成员函数

JSONObject (const QString &key="")
int | type () const
void | setType (int value)
QString | key () const
void | setKey (const QString &value)
QVariant | value () const
QVariant | value (const QString &key) const
bool | value (const QString &key, QVariant &v) const
bool | exists (const QString &key) const
int | count () const
JSONObject * | get (const QString &key) const
QList< JSONObject * > | children () const
JSONObject * | addObject (const QString &key="")
JSONObject * | addArray (const QString &key)
JSONObject * | addNull (const QString &key)
JSONObject * | add (const QString &key, const char *value)
JSONObject * | add (const QString &key, const QString &value)
JSONObject * | add (const QString &key, int value)
JSONObject * | add (const QString &key, double value)
JSONObject * | add (const QString &key, bool value)
JSONObject * | add (const QString &key, QDateTime value)
JSONObject * | addNull ()
JSONObject * | add (const char *value)
JSONObject * | add (const QString &value)
JSONObject * | add (int value)
JSONObject * | add (double value)
JSONObject * | add (bool value)
JSONObject * | add (QDateTime value)
void | deleteChildren (const QString &key)
void | clearChildren ()
void | clear ()
virtual QString | toString () const
bool | fromString (QString jsonText)

静态 Public 成员函数

static QString | quote (const QString &Text)
static QString | dequote (const QString &S)

Protected 成员函数

QString | jsonKey () const
QString | jsonValue () const
void | init ()
const wchar_t * | fromObject (const QString &Key, const wchar_t *ptr)
const wchar_t * | fromArray (const wchar_t *ptr)
QString | newKey (const QString &key)
const wchar_t * | parseKey (QString &Value, const wchar_t *ptr)
const wchar_t * | parseValue (QString Key, const wchar_t *ptr)
const wchar_t * | parseNumber (QString &Value, const wchar_t *ptr)

静态 Protected 成员函数

static const wchar_t * skip (const wchar_t *in)

Protected 属性

JSONObject * | parent
int | m_index
QMap< QString, JSONObject * > | m_list
ValueTypeFlag | m_type
QString | m_key
QVariant | m_value

详细描述

兼容 Qt 4.x 的 JSON文生成和解析类

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/File/Json.h


Tianchi: LineEdit类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 槽 | 信号 | Public 成员函数 | Protected 成员函数 | 属性 | 所有成员列表
LineEdit类 参考

extended QLineEdit widget 更多...

#include <LineEdit.h>

类 LineEdit 继承关系图:

Public 槽

void | setLabelText (const QString &labelText)
set labelText property
void | setData (const QVariant &userData)
set data property

信号

void | labelTextChanged (const QString &labelText)
emit this signal when labelText property changed
void | dataChanged (const QVariant &userData)
emit this signal when data property changed
void | doubleClicked ()
emit this signal when mouse double clicked

Public 成员函数

LineEdit (QWidget *parent=0)
QString | labelText () const
QVariant | data () const

Protected 成员函数

virtual void | paintEvent (QPaintEvent *event)
virtual void | mouseDoubleClickEvent (QMouseEvent *event)
virtual void | contextMenuEvent (QContextMenuEvent *event)

属性

QString | labelText
labelText property, shown in non-edit mode
QVariant | data
data property, save user's data

详细描述

extended QLineEdit widget

作者
XChinux XChin.nosp@m.ux@1.nosp@m.63.co.nosp@m.m
日期
2013-04-22
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/LineEdit.h


Tianchi: LogTiny类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | 所有成员列表
LogTiny类 参考

简单的文本文件输出日志。 更多...

#include <LogTiny.h>

Public 成员函数

void | setAppFile (const QString &AppFile)
指定全路径的执行文件名，自动设置与执行文件同目录、同名，且后缀为 .log 的日志文件。 更多...
void | setLogFile (const QString &LogFile)
指定全路径的日志文件名。 更多...
void | write (const QString &S, const QString &SourceName="", int SourceLine=0)
写日志 更多...
void | debug (const QString &S, const QString &SourceName="", int SourceLine=0)
调试模式(Debug)下输出日志，在 Release 模式下没有作用。 更多...

详细描述

简单的文本文件输出日志。

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员函数说明

void LogTiny::debug | ( | const QString & | S,
 |  | const QString & | SourceName = "",
 |  | int | SourceLine = 0
 | ) |  |
inline

调试模式(Debug)下输出日志，在 Release 模式下没有作用。

参数
[in] | S | 日志内容。
[in] | SourceName | 源文件名，建议用__FILE__作为参数。
[in] | SourceLine | 源文件行，建议用__LINE__作为参数。
void LogTiny::setAppFile ( const QString & AppFile )

指定全路径的执行文件名，自动设置与执行文件同目录、同名，且后缀为 .log 的日志文件。

参数
[in] AppFile 执行文件名。
示例:
QApplication app(argc, argv);
LogTiny log;
// 建议把执行文件名作为参数
log.setAppFile(app.applicationFilePath());
参见
setLogFile
void LogTiny::setLogFile ( const QString & LogFile )

指定全路径的日志文件名。

参数
[in] LogFile 日志文件名。
示例:
log.setLogFile("C:\\Temp\\app.log");
参见
setAppFile
void LogTiny::write | ( | const QString & | S,
 |  | const QString & | SourceName = "",
 |  | int | SourceLine = 0
 | ) |  |

写日志

参数
[in] | S | 日志内容。
[in] | SourceName | 源文件名，建议用__FILE__作为参数。
[in] | SourceLine | 源文件行，建议用__LINE__作为参数。
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/File/LogTiny.h


Tianchi: MarqueeLabel类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 槽 | Public 成员函数 | Protected 成员函数 | 所有成员列表
MarqueeLabel类 参考

跑马灯类MarqueeLabel,点击时自动打开网址 更多...

#include <MarqueeLabel.h>

类 MarqueeLabel 继承关系图:

Public 槽

void setText (const QString &text)

Public 成员函数

MarqueeLabel (QWidget *parent=0, Qt::WindowFlags f=0)
MarqueeLabel (const QString &text, QWidget *parent=0, Qt::WindowFlags f=0)

Protected 成员函数

virtual void | resizeEvent (QResizeEvent *event)
virtual void | leaveEvent (QEvent *event)
virtual void | enterEvent (QEvent *event)

详细描述

跑马灯类MarqueeLabel,点击时自动打开网址

作者
XChinux XChin.nosp@m.ux@1.nosp@m.63.co.nosp@m.m
日期
2013-04-18
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/MarqueeLabel.h


Tianchi: MSExcel类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 类型 | Public 成员函数 | 所有成员列表
MSExcel类 参考

通过 OLE 方式操作 Microsoft Excel 更多...

#include <MSExcel.h>

Public 类型

enum Alignment {
xlTop = -4160, xlLeft = -4131, xlRight = -4152, xlCenter = -4108,
xlBottom = -4107
}
设置方向的常数 更多...

Public 成员函数

MSExcel ()
构造方法
virtual | ~MSExcel ()
析构方法
bool | create (const QString &filename="")
创建一个Microsoft Excel文件
bool | open (const QString &filename="")
打开一个Microsoft Excel文件
void | save (const QString &filename="")
保存Microsoft Excel文件
void | close ()
关闭Microsoft Excel文件
void | kick ()
踢出当前打开的 Microsoft Excel
更多...
void | setVisible (bool value)
设置当前打开的 Excel 是否可见
void | setCaption (const QString &value)
设置 Excel 文档的标题
QAxObject * | addBook ()
新建一本 Excel 文档
int | sheetCount ()
返回当前 Excel 的 Sheet 数量
QAxObject * | sheet (int index)
设置并指定当前 Sheet. 更多...
QAxObject * | currentSheet ()
返回当前 Sheet.
QVariant | read (int row, int col)
读取单元格 Sheet 的内容 更多...
void | write (int row, int col, const QVariant &value)
写入单元格 Sheet 的内容 更多...
void | cellFormat (int row, int col, const QString &format)
void | cellAlign (int row, int col, Alignment hAlign, Alignment vAlign)
bool | usedRange ()
获取有效区域信息 更多...
QStringList | sheetNames ()
返回当前打开的 Excel 全部 Sheet 名
QString | sheetName () const
当前打开的 Excel 的 Sheet 名
int | rowStart () const
当前 Sheet 有效区域的开始行 更多...
int | rowEnd () const
当前 Sheet 有效区域的结束行 更多...
int | colStart () const
当前 Sheet 有效区域的开始列 更多...
int | colEnd () const
当前 Sheet 有效区域的结束列 更多...

详细描述

通过 OLE 方式操作 Microsoft Excel

注解
通过 OLE 方式操作 Microsoft Excel
警告
只能在 Windows 下，并已安装了 Excel 时才能使用
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员枚举类型说明

enum MSExcel::Alignment

设置方向的常数

枚举值
xlTop | 靠上
xlLeft | 靠左
xlRight | 靠右
xlCenter | 居中
xlBottom | 靠下

成员函数说明

int MSExcel::colEnd ( ) const
inline

当前 Sheet 有效区域的结束列

注解
需要先执行 usedRange() 获取有效区域信息后才能访问
参见
sheetName() const
int MSExcel::colStart ( ) const
inline

当前 Sheet 有效区域的开始列

注解
需要先执行 usedRange() 获取有效区域信息后才能访问
参见
sheetName() const
void MSExcel::kick ( )

踢出当前打开的 Microsoft Excel

放弃此对象对该 Excel 的控制权
Excel 文件仍保持打开，但丧失了控制权

QVariant MSExcel::read | ( | int | row,
 |  | int | col
 | ) |  |

读取单元格 Sheet 的内容

参数
[in] | row | 行号，从 1 开始
[in] | col | 列号，从 1 开始
返回
返回指定单元格的内容
int MSExcel::rowEnd ( ) const
inline

当前 Sheet 有效区域的结束行

注解
需要先执行 usedRange() 获取有效区域信息后才能访问
参见
sheetName() const
int MSExcel::rowStart ( ) const
inline

当前 Sheet 有效区域的开始行

注解
需要先执行 usedRange() 获取有效区域信息后才能访问
参见
sheetName() const
QAxObject* MSExcel::sheet ( int index )

设置并指定当前 Sheet.

参数
[in] 当前 Sheet 索引，从 1 开始
bool MSExcel::usedRange ( )

获取有效区域信息

参见
rowStart() const
rowEnd() const
colStart() const
colEnd() const
void MSExcel::write | ( | int | row,
 |  | int | col,
 |  | const QVariant & | value
 | ) |  |

写入单元格 Sheet 的内容

参数
[in] | row | 行号，从 1 开始
[in] | col | 列号，从 1 开始
[in] | value | 准备写入的内容
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/File/MSExcel.h


Tianchi: MSSQL类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
静态 Public 成员函数 | 所有成员列表
MSSQL类 参考

读取 ODBC 驱动和版本信息 更多...

#include <MSSQL.h>

静态 Public 成员函数

static QStringList availableODBCDrivers ()
读取 ODBC 驱动和版本信息 更多...

详细描述

读取 ODBC 驱动和版本信息

作者
XChinux XChin.nosp@m.ux@1.nosp@m.63.co.nosp@m.m
日期
2013-04-18

成员函数说明

static QStringList MSSQL::availableODBCDrivers ( )
static

读取 ODBC 驱动和版本信息

日期
2013-04-18
返回
以 / 分隔版本号和驱动名称:
10.00/SQL Server Native Client 10.0
09.00/SQL Native Client
03.50/SQL Server
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Sql/MSSQL.h


Tianchi: OS类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
静态 Public 成员函数 | 所有成员列表
OS类 参考

与操作系统相关的操作类 更多...

#include <OS.h>

静态 Public 成员函数

static QString | name ()
取操作系统名称，仅支持 Windows
static QString | language ()
取操作系统的语言，仅支持 Windows
static bool | login (const QString &Domain, const QString &UserID, const QString &Password)
Windows 域用户登录，仅支持 Windows. 更多...

详细描述

与操作系统相关的操作类

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员函数说明

static bool OS::login | ( | const QString & | Domain,
 |  | const QString & | UserID,
 |  | const QString & | Password
 | ) |  |
static

Windows 域用户登录，仅支持 Windows.

参数
[in] | Domain | Windows 域名或本机机器名
[in] | UserID | 域用户名或本机用户名
[in] | Password | 用户密码
返回
true 登录成功
false 登录失败
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/OS/OS.h


Tianchi: Player类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 类型 | Public 成员函数 | 属性 | 所有成员列表
Player类 参考

玩家信息类，常用在 C/S 中的客户端用户信息保存 更多...

#include <Classes.h>

类 Player 继承关系图:

Public 类型

enum AuthLevel {
AUTH_SYSADMIN = 999, AUTH_ADMIN = 888, AUTH_MANAGER = 99, AUTH_USER = 9,
AUTH_GUEST = 1
}
用户权限 更多...

Public 成员函数

Player ()
构造方法
Player & | operator= (const Player &)
复制对象
int | userNo () const
返回用户的 No
void | setUserNo (int value)
指定用户的 No
QString | userID () const
返回用户的 ID
void | setUserID (const QString &value)
指定用户的 ID
QString | username () const
返回用户姓名
void | setUsername (const QString &value)
指定用户的 username
int | userLevel () const
返回用户的级别
void | setUserLevel (int value)
指定用户的权限级别
int | authority (const QString &key) const
根据权限单元返回用户权限 更多...
void | setAuthority (const QString &key, int auth)
指定用户的权限模块级别
void | setAuthorityText (const QString &value)
快速设置用户的全部权限级别
void | setAuthorityText (const QStringList &value)
快速设置用户的全部权限级别
QString | loginID () const
返回登录ID
void | setLoginID (const QString &value)
保存用户的登录名称
QString | password () const
返回用户的密码
void | setPassword (const QString &value)
保存用户的密码
bool | loggedIn () const
玩家是否已登录
void | setLoggedIn (bool value)
指定玩家是否已登录
void | setLoggedIn ()
将玩家设为已登录
QDateTime | loginTime () const
玩家的登录时间
void | setLoginTime (QDateTime value)
指定玩家的登录时间
int | noLoginTime ()
返回玩家距今未登录的秒数
常用于意外断线后，显示已脱机的时间
void | clear ()
清除玩家的所有信息

属性

int | userNo
用户序号
QString | userID
用户ID
QString | username
用户全名
bool | loggedIn
是否已登录
QDateTime | loginTime
登录时间

详细描述

玩家信息类，常用在 C/S 中的客户端用户信息保存

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员枚举类型说明

enum Player::AuthLevel

用户权限

枚举值
AUTH_SYSADMIN | 最高系统级管理员权限
AUTH_ADMIN | 最高用户级管理员权限
AUTH_MANAGER | 用户级：管理权限
AUTH_USER | 用户级：普通用户权限
AUTH_GUEST | 用户级：访客级权限

成员函数说明

int Player::authority ( const QString & key ) const

根据权限单元返回用户权限

参数
key 权限单元
返回
权限级别，参见 AuthLevel
参见
AuthLevel
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Core/Classes.h


Tianchi: SingleInstance类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | Protected 属性 | 所有成员列表
SingleInstance类 参考

应用程序单实例类 更多...

#include <SingleInstance.h>

Public 成员函数

SingleInstance (QString instanceName)
初始化方法 更多...
SingleInstance (QObject *parent, QString instanceName)
初始化方法 更多...
bool first () const
是否首次运行的实例 更多...

Protected 属性

bool | m_first
首次运行实例
QString | m_instanceName
实例名称
QLocalSocket | m_localSocket
外访 socket 句柄
QLocalServer * | m_localServer
受访 socket 句柄

详细描述

应用程序单实例类

示例:
#include "Network/SingleInstance.h"
int main(int argc, char *argv[])
{
QApplication app(argc, argv);
TIANCHI::SingleInstance si(app, "myApp");
if ( si.first() )
{
// 首次运行
}else
{
// 已存在其它实例
}
...
}
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-19

构造及析构函数说明

SingleInstance::SingleInstance ( QString instanceName )
inline

初始化方法

参数
[in] instanceName 识别是否重复开启的实例名称
SingleInstance::SingleInstance | ( | QObject * | parent,
 |  | QString | instanceName
 | ) |  |
inline

初始化方法

参数
[in] | parent | app对象
[in] | instanceName | 识别是否重复开启的实例名称

成员函数说明

bool SingleInstance::first ( ) const
inline

是否首次运行的实例

返回
true: 首次运行的实例
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Network/SingleInstance.h


Tianchi: String类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
静态 Public 成员函数 | 所有成员列表
String类 参考

字符串功能增强与扩展 更多...

#include <String.h>

静态 Public 成员函数

static QByteArray | first (QByteArray &str, const QByteArray &split="\t")
截取字符串的首部分 更多...
static int | find (const QStringList &ss, const QString &s)
在字符串序列中查到一个字符串 更多...
static int | findOf (const QStringList &list, const QString &key)
在字符串序列中查到一个字符串 更多...
static bool | filter (const QString &findText, const QStringList &filters)
判断一个字符串的合部工部分是否存在于一个字符串队列中 更多...
static QString | getTextByIndex (const char *strings, int index)
从一个字符串队列中返回指定索引行的字符串 更多...
static int | splitHumanName (QString full, QString &sur, QString &real, QString &english)
分割中文全名中的姓氏、名字和英文名

详细描述

字符串功能增强与扩展

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-16

成员函数说明

static bool String::filter | ( | const QString & | findText,
 |  | const QStringList & | filters
 | ) |  |
static

判断一个字符串的合部工部分是否存在于一个字符串队列中

参数
[in] | findText | 需要查找的子字符串
[in] | filters | 被查找的字符串队列
返回
true 存在
false 不存在
static int String::find | ( | const QStringList & | ss,
 |  | const QString & | s
 | ) |  |
static

在字符串序列中查到一个字符串

注解
未来可能会删除
参见
findOf
static int String::findOf | ( | const QStringList & | list,
 |  | const QString & | key
 | ) |  |
static

在字符串序列中查到一个字符串

注解
未来可能会删除
参见
find
static QByteArray String::first | ( | QByteArray & | str,
 |  | const QByteArray & | split = "\t"
 | ) |  |
static

截取字符串的首部分

参数
[in,out] | str | 被截取的字符串
[in] | split | 字符串的分隔符
返回
截取出的字符串
注解
分隔符将被丢弃，不含分隔符时截取整个字符串，被截取的字符串将被修改
static QString String::getTextByIndex | ( | const char * | strings,
 |  | int | index
 | ) |  |
static

从一个字符串队列中返回指定索引行的字符串

参数
[in] | strings | 字符串队列，以"\n"作为分隔
[in] | index | 需要返回的索引行，从 0 开始
返回
索引行的字符串，索引值越界时返回空字符串
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Core/String.h


Tianchi: StringList类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | 所有成员列表
StringList类 参考

字符串集功能增强与扩展 更多...

#include <String.h>

类 StringList 继承关系图:

Public 成员函数

bool | loadFrom (const QString &fileName)
装入一个文本文件的全部内容 更多...
bool | saveTo (const QString &fileName)
保存当前内容到一个文本文件中 更多...
QString | lineBreak () const
返回文本文件的行结尾符
void | lineBreak (const QString &value)
设置文本文件的行结尾符

详细描述

字符串集功能增强与扩展

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-16

成员函数说明

bool StringList::loadFrom ( const QString & fileName )

装入一个文本文件的全部内容

参数
[in] fileName 路径文件名
返回
操作成功
bool StringList::saveTo ( const QString & fileName )

保存当前内容到一个文本文件中

参数
[in] fileName 路径文件名
返回
操作成功
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Core/String.h


Tianchi: TreeWidgetHeaderSetupDialog类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Public 成员函数 | 所有成员列表
TreeWidgetHeaderSetupDialog类 参考

设置 QTreeWidget 标题的对话框 更多...

#include <TreeWidgetHeaderSetupDialog.h>

类 TreeWidgetHeaderSetupDialog 继承关系图:

Public 成员函数

TreeWidgetHeaderSetupDialog (QWidget *parent=0)
void setHeader (QTreeWidget *view, int max=-1)
指定 QTreeView 对象 更多...

详细描述

设置 QTreeWidget 标题的对话框

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员函数说明

void TreeWidgetHeaderSetupDialog::setHeader | ( | QTreeWidget * | view,
 |  | int | max = -1
 | ) |  |

指定 QTreeView 对象

参数
[in] | view | QTreeView 对象
[in] | max | 最大设置的列数，超过部分将被忽略
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Gui/TreeWidgetHeaderSetupDialog.h


Tianchi: Utils类 参考

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
静态 Public 成员函数 | 所有成员列表
Utils类 参考

常用小功能综合函数集 更多...

#include <Utils.h>

静态 Public 成员函数

static QHash< QString, QString > | StringToMap (const QString &mapStrings)
把 key=value 结构的文本转换为 map 结构
static QHash< QString, QString > | StringToMap (const QStringList &mapStrings)
把 key=value 结构的文本转换为 map 结构
static char | typeFrom (QVariant::Type type)
类型转字符代码
static char | typeFrom (const QVariant &v)
类型转字符代码
static QString | YYYY_MM_DD_HH_MM_SS_ZZZ ()
返回当前时间字符串：yyyy-MM-dd HH:mm:ss.zzz
static QString | YYYY_MM_DD_HH_MM_SS ()
返回当前时间字符串：yyyy-MM-dd HH:mm:ss
static QDateTime | toDateTime (const QString &text)
转换字符串为日期时间
static char | getIDCardVerifyCode (const QByteArray &id)
返回18位身位证的最后一位校验码
static QDateTime | complieDateTime (const QString &complieDate, const QString &complieTime)
取编译日期和时间，调用处的代码必须重新编译

详细描述

常用小功能综合函数集

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/inc/Core/Utils.h


Tianchi: 类索引

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
类索引
C | D | F | G | J | L | M | O | P | S | T | U
C
DBFields
J
MSSQL StringList
Directory
O
T
Chinese Download JSONObject
CInvokeObject DownloadList
L
OS TreeWidgetHeaderSetupDialog
ClickLabel
F
P
U
CursorBusy LineEdit
CursorCustom FileUtils LogTiny Player Utils
CursorWait FlowLayout
M
S
D
G
MarqueeLabel SingleInstance
DateEdit GlowEffect MSExcel String
C | D | F | G | J | L | M | O | P | S | T | U


Tianchi: 类继承关系

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
类继承关系
此继承关系列表按字典顺序粗略的排序:
[详情级别 12]
o C Chinese | 汉语相关处理类
o C CInvokeObject | 映射执行对象类
o C CursorCustom | 光标形态变化类的根类，一般不直接使用
| o C CursorBusy | 后台忙光标的设置和自动恢复处理类
| \ C CursorWait | 等待光标的设置和自动恢复处理类
o C DBFields | Key=value 数据格式转换类
o C FileUtils | 文件操作常用处理类
o C JSONObject | 兼容 Qt 4.x 的 JSON文生成和解析类
o C LogTiny | 简单的文本文件输出日志。
o C MSExcel | 通过 OLE 方式操作 Microsoft Excel
o C MSSQL | 读取 ODBC 驱动和版本信息
o C OS | 与操作系统相关的操作类
o C QComboBox |
| \ C DateEdit | 可以输入或显示为空的日期选择控件
o C QDialog |
| \ C TreeWidgetHeaderSetupDialog | 设置 QTreeWidget 标题的对话框
o C QGraphicsEffect |
| \ C GlowEffect |
o C QLabel |
| o C ClickLabel | Emit clicked() signal's label while mouse clicked
| \ C MarqueeLabel | 跑马灯类MarqueeLabel,点击时自动打开网址
o C QLayout |
| \ C FlowLayout | 流式布局FlowLayout
o C QLineEdit |
| \ C LineEdit | Extended QLineEdit widget
o C QObject |
| o C Directory |
| o C Download | 用于下载文件（或文件的一部分） 注意：此类尚未进行严格测试
| o C DownloadList | 用于管理文件的下载
| \ C Player | 玩家信息类，常用在 C/S 中的客户端用户信息保存
o C QStringList |
| \ C StringList | 字符串集功能增强与扩展
o C SingleInstance | 应用程序单实例类
o C String | 字符串功能增强与扩展
\ C Utils | 常用小功能综合函数集


Tianchi: 类成员

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- a -

  • addBook() : MSExcel
  • Alignment : MSExcel
  • AUTH_ADMIN : Player
  • AUTH_GUEST : Player
  • AUTH_MANAGER : Player
  • AUTH_SYSADMIN : Player
  • AUTH_USER : Player
  • AuthLevel : Player
  • authority() : Player
  • availableODBCDrivers() : MSSQL

- c -

  • CInvokeObject() : CInvokeObject
  • clear() : Player
  • clicked() : ClickLabel
  • close() : MSExcel
  • colEnd() : MSExcel
  • colStart() : MSExcel
  • complieDateTime() : Utils
  • copyDirectories() : Directory
  • copyFiles() : Directory
  • create() : MSExcel
  • currentFile() : Directory
  • currentSheet() : MSExcel

- d -

  • data : LineEdit
  • dataChanged() : LineEdit
  • debug() : LogTiny
  • doubleClicked() : LineEdit

- f -

  • fileVersion() : FileUtils
  • filter() : String
  • find() : String
  • findFiles() : Directory
  • findOf() : String
  • first() : String , SingleInstance
  • firstPinyins() : Chinese

- g -

  • getIDCardVerifyCode() : Utils
  • getTextByIndex() : String

- i -

  • invoke() : CInvokeObject
  • isValid() : CInvokeObject

- k -

  • kick() : MSExcel

- l -

  • labelText : LineEdit
  • labelTextChanged() : LineEdit
  • language() : OS
  • lineBreak() : StringList
  • loadFrom() : StringList
  • loadFromFile() : FileUtils
  • loggedIn : Player
  • login() : OS
  • loginID() : Player
  • loginTime() : Player

- m -

  • m_first : SingleInstance
  • m_instanceName : SingleInstance
  • m_localServer : SingleInstance
  • m_localSocket : SingleInstance
  • MSExcel() : MSExcel

- n -

  • name() : OS
  • noLoginTime() : Player

- o -

  • open() : MSExcel
  • operator=() : CInvokeObject , Player

- p -

  • password() : Player
  • Player() : Player

- q -

  • queued() : CInvokeObject

- r -

  • read() : MSExcel
  • resetCopyFileCount() : Directory
  • rowEnd() : MSExcel
  • rowStart() : MSExcel

- s -

  • save() : MSExcel
  • saveTo() : StringList
  • searchFiles() : FileUtils
  • setAppFile() : LogTiny
  • setAuthority() : Player
  • setAuthorityText() : Player
  • setCaption() : MSExcel
  • setData() : LineEdit
  • setGlowColor() : GlowEffect
  • setHeader() : TreeWidgetHeaderSetupDialog
  • setLabelText() : LineEdit
  • setLogFile() : LogTiny
  • setLoggedIn() : Player
  • setLoginID() : Player
  • setLoginTime() : Player
  • setPassword() : Player
  • setRadius() : GlowEffect
  • setUserID() : Player
  • setUserLevel() : Player
  • setUsername() : Player
  • setUserNo() : Player
  • setVisible() : MSExcel
  • sheet() : MSExcel
  • sheetCount() : MSExcel
  • sheetName() : MSExcel
  • sheetNames() : MSExcel
  • SingleInstance() : SingleInstance
  • splitHumanName() : String
  • StringToMap() : Utils

- t -

  • toChars() : Chinese
  • toDateTime() : Utils
  • toPinyin() : Chinese
  • typeFrom() : Utils

- u -

  • uniqueFileName() : FileUtils
  • usedRange() : MSExcel
  • userID() : Player
  • userLevel() : Player
  • username : Player
  • userNo() : Player

- w -

  • write() : LogTiny , MSExcel

- x -

  • xlBottom : MSExcel
  • xlCenter : MSExcel
  • xlLeft : MSExcel
  • xlRight : MSExcel
  • xlTop : MSExcel

- y -

  • YYYY_MM_DD_HH_MM_SS() : Utils
  • YYYY_MM_DD_HH_MM_SS_ZZZ() : Utils

- ~ -

  • ~MSExcel() : MSExcel


Tianchi: 类成员 - 函数

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • y
  • ~

- a -

  • addBook() : MSExcel
  • authority() : Player
  • availableODBCDrivers() : MSSQL

- c -

  • CInvokeObject() : CInvokeObject
  • clear() : Player
  • clicked() : ClickLabel
  • close() : MSExcel
  • colEnd() : MSExcel
  • colStart() : MSExcel
  • complieDateTime() : Utils
  • copyDirectories() : Directory
  • copyFiles() : Directory
  • create() : MSExcel
  • currentFile() : Directory
  • currentSheet() : MSExcel

- d -

  • dataChanged() : LineEdit
  • debug() : LogTiny
  • doubleClicked() : LineEdit

- f -

  • fileVersion() : FileUtils
  • filter() : String
  • find() : String
  • findFiles() : Directory
  • findOf() : String
  • first() : String , SingleInstance
  • firstPinyins() : Chinese

- g -

  • getIDCardVerifyCode() : Utils
  • getTextByIndex() : String

- i -

  • invoke() : CInvokeObject
  • isValid() : CInvokeObject

- k -

  • kick() : MSExcel

- l -

  • labelTextChanged() : LineEdit
  • language() : OS
  • lineBreak() : StringList
  • loadFrom() : StringList
  • loadFromFile() : FileUtils
  • loggedIn() : Player
  • login() : OS
  • loginID() : Player
  • loginTime() : Player

- m -

  • MSExcel() : MSExcel

- n -

  • name() : OS
  • noLoginTime() : Player

- o -

  • open() : MSExcel
  • operator=() : CInvokeObject , Player

- p -

  • password() : Player
  • Player() : Player

- q -

  • queued() : CInvokeObject

- r -

  • read() : MSExcel
  • resetCopyFileCount() : Directory
  • rowEnd() : MSExcel
  • rowStart() : MSExcel

- s -

  • save() : MSExcel
  • saveTo() : StringList
  • searchFiles() : FileUtils
  • setAppFile() : LogTiny
  • setAuthority() : Player
  • setAuthorityText() : Player
  • setCaption() : MSExcel
  • setData() : LineEdit
  • setGlowColor() : GlowEffect
  • setHeader() : TreeWidgetHeaderSetupDialog
  • setLabelText() : LineEdit
  • setLogFile() : LogTiny
  • setLoggedIn() : Player
  • setLoginID() : Player
  • setLoginTime() : Player
  • setPassword() : Player
  • setRadius() : GlowEffect
  • setUserID() : Player
  • setUserLevel() : Player
  • setUsername() : Player
  • setUserNo() : Player
  • setVisible() : MSExcel
  • sheet() : MSExcel
  • sheetCount() : MSExcel
  • sheetName() : MSExcel
  • sheetNames() : MSExcel
  • SingleInstance() : SingleInstance
  • splitHumanName() : String
  • StringToMap() : Utils

- t -

  • toChars() : Chinese
  • toDateTime() : Utils
  • toPinyin() : Chinese
  • typeFrom() : Utils

- u -

  • uniqueFileName() : FileUtils
  • usedRange() : MSExcel
  • userID() : Player
  • userLevel() : Player
  • username() : Player
  • userNo() : Player

- w -

  • write() : LogTiny , MSExcel

- y -

  • YYYY_MM_DD_HH_MM_SS() : Utils
  • YYYY_MM_DD_HH_MM_SS_ZZZ() : Utils

- ~ -

  • ~MSExcel() : MSExcel


Tianchi: 类成员 - 变量

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • m_first : SingleInstance
  • m_instanceName : SingleInstance
  • m_localServer : SingleInstance
  • m_localSocket : SingleInstance


Tianchi: 类成员 - 枚举

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • Alignment : MSExcel
  • AuthLevel : Player


Tianchi: 类成员 - 枚举值

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • AUTH_ADMIN : Player
  • AUTH_GUEST : Player
  • AUTH_MANAGER : Player
  • AUTH_SYSADMIN : Player
  • AUTH_USER : Player
  • xlBottom : MSExcel
  • xlCenter : MSExcel
  • xlLeft : MSExcel
  • xlRight : MSExcel
  • xlTop : MSExcel


Tianchi: 类成员 - 属性

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • data : LineEdit
  • labelText : LineEdit
  • loggedIn : Player
  • loginTime : Player
  • userID : Player
  • username : Player
  • userNo : Player


Tianchi: 文件列表

  • 文件列表
  • 文件成员
文件列表
这里列出了所有文档化的文件，并附带简要说明:
[详情级别 123]
\ - inc |
o - Chinese |
| \ * Chinese.h | 汉语相关处理
o - Core |
| o * Classes.h | 一些常用的小类
| o * Common.h | 公共单元，此单元不使用 namespace Tianchi
| o * String.h | 字符串功能增强与扩展
| \ * Utils.h | 常用功能函数
o - File |
| o * Directory.h | 可以复制目录树的类，也可以查找文件夹内所有的文件
| o * FileUtils.h | 文件操作常用处理类
| o * Json.h | JSON 创建和解析类
| o * LogTiny.h | 简单的 Log 输出类
| \ * MSExcel.h | 通过 OLE 方式操作 Microsoft Excel（仅限 Windows 下使用，要求已安装 Excel）
o - Gui |
| o * ClickLabel.h | 可发出clicked信号的Label部件
| o * DateEdit.h | 允许为空的日期选择控件
| o * FlowLayout.h | 流式布局FlowLayout
| o * GlowEffect.h | 发光效果的QGraphicsEffect
| o * GuiUtils.h | GUI相关常用单元
| o * LineEdit.h | Extended QLineEdit widget
| o * MarqueeLabel.h | 跑马灯Label,点击时自动打开网址
| \ * TreeWidgetHeaderSetupDialog.h | 修改 QTreeWidget 列设置的对话框
o - Network |
| o * DownloadHttp.h | HTTP 文件多线程下载器
| \ * SingleInstance.h | 应用程序单实例类
o - OS |
| \ * OS.h | 与操作系统相关
o - Sql |
| \ * MSSQL.h | SQL Server 相关应用
o * Global.h |
\ * tianchi.h | 引用单元头文件


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc 目录参考

  • inc
inc 目录参考

目录

目录 | Chinese
目录 | Core
目录 | File
目录 | Gui
目录 | Network
目录 | OS
目录 | Sql

文件

文件 | Global.h [代码]
文件 | tianchi.h [代码]
引用单元头文件


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Chinese 目录参考

  • inc
  • Chinese
Chinese 目录参考

文件

文件 Chinese.h [代码]
汉语相关处理


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Chinese/Chinese.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Chinese
类
Chinese.h 文件参考

汉语相关处理 更多...

#include "Global.h"
#include <QString>

浏览源代码.

类

class Chinese
汉语相关处理类 更多...

详细描述

汉语相关处理


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Core 目录参考

  • inc
  • Core
Core 目录参考

文件

文件 | Classes.h [代码]
一些常用的小类
文件 | Common.h [代码]
公共单元，此单元不使用 namespace Tianchi
文件 | String.h [代码]
字符串功能增强与扩展
文件 | Utils.h [代码]
常用功能函数


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Core/Classes.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Core
类
Classes.h 文件参考

一些常用的小类 更多...

#include "Global.h"
#include <QDateTime>
#include <QObject>
#include <QString>
#include <QStringList>
#include <QElapsedTimer>
#include <QHash>

浏览源代码.

类

class | Player
玩家信息类，常用在 C/S 中的客户端用户信息保存 更多...
class | CInvokeObject
映射执行对象类 更多...
class | DBFields
key=value 数据格式转换类 更多...

详细描述

一些常用的小类


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Core/Common.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Core
宏定义 | 函数
Common.h 文件参考

公共单元，此单元不使用 namespace Tianchi 更多...

#include "Global.h"
#include <QTextCodec>
#include <QDateTime>

浏览源代码.

宏定义

#define | max(a, b) (((a) > (b)) ? (a) : (b))
取最大值
#define | min(a, b) (((a) < (b)) ? (a) : (b))
取最小值
#define | DEBUG_STEP
为了方便运行时调试显示当前文件和行号，用于运行时跟踪执行步骤。
#define | DEBUG_OUT(x)
为了方便运行时调试设置的宏

函数

QString | QS (const char *s)
汉字字符集转换 更多...
int | iif (bool logic, int v1, int v2=0)
分支逻辑判断
QString | iif (bool logic, const QString &v1, const QString &v2="")
分支逻辑判断

详细描述

公共单元，此单元不使用 namespace Tianchi

函数说明

QString QS ( const char * s )
inline

汉字字符集转换

参数
[in] s 汉字常量，或 char* 型的变量
示例:
int main(int argc, char *argv[])
{
QApplication app(argc, argv);
// 先为应用程序设置字符集
QTextCodec* pCodec=QTextCodec::codecForName("GBK");
QTextCodec::setCodecForLocale(pCodec);
...
}
void MyFunction()
{
qDebug()<<QS("显示为汉字，而不是乱码！");
}
返回
转换后的汉字字符串类型
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-15


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Core/String.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Core
类
String.h 文件参考

字符串功能增强与扩展 更多...

#include "Global.h"
#include <QString>
#include <QStringList>

浏览源代码.

类

class | String
字符串功能增强与扩展 更多...
class | StringList
字符串集功能增强与扩展 更多...

详细描述

字符串功能增强与扩展


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Core/Utils.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Core
类 | 命名空间 | 变量
Utils.h 文件参考

常用功能函数 更多...

#include "Global.h"
#include <QTextCodec>
#include <QVariant>
#include <QDateTime>
#include <QString>
#include <QStringList>
#include <QByteArray>
#include <QComboBox>
#include <QThread>

浏览源代码.

类

class Utils
常用小功能综合函数集 更多...

命名空间

namespace OperMode
操作模式的标识常量

变量

const int | OperMode::Append = 1
添加或新建
const int | OperMode::Change = 2
修改
const int | OperMode::Delete = 4
删除

详细描述

常用功能函数


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File 目录参考

  • inc
  • File
File 目录参考

文件

文件 | Directory.h [代码]
可以复制目录树的类，也可以查找文件夹内所有的文件
文件 | FileUtils.h [代码]
文件操作常用处理类
文件 | Json.h [代码]
JSON 创建和解析类
文件 | LogTiny.h [代码]
简单的 Log 输出类
文件 | MSExcel.h [代码]
通过 OLE 方式操作 Microsoft Excel（仅限 Windows 下使用，要求已安装 Excel）


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/Directory.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • File
类
Directory.h 文件参考

可以复制目录树的类，也可以查找文件夹内所有的文件 更多...

#include "Global.h"
#include <QObject>
#include <QStringList>

浏览源代码.

类

class Directory

详细描述

可以复制目录树的类，也可以查找文件夹内所有的文件


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/FileUtils.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • File
类
FileUtils.h 文件参考

文件操作常用处理类 更多...

#include "Global.h"
#include <QString>

浏览源代码.

类

class FileUtils
文件操作常用处理类 更多...

详细描述

文件操作常用处理类


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/Json.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • File
类
Json.h 文件参考

JSON 创建和解析类 更多...

#include "Global.h"
#include <QDateTime>
#include <QMap>
#include <QList>
#include <QVariant>
#include <QString>
#include <QStringList>

浏览源代码.

类

class JSONObject
兼容 Qt 4.x 的 JSON文生成和解析类 更多...

详细描述

JSON 创建和解析类


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/LogTiny.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • File
类 | 宏定义
LogTiny.h 文件参考

简单的 Log 输出类 更多...

#include "Global.h"
#include <QString>

浏览源代码.

类

class LogTiny
简单的文本文件输出日志。 更多...

宏定义

#define | Log_Step TIANCHI_NAMESPACE::Log.write("<<STEP>>", __FILE__, __LINE__);
向日志输出代码所在文件和行号，用于运行时跟踪执行步骤。
#define | Debug_Log(s)
调试模式下输出日志，自动添加代码所在文件和行号。

详细描述

简单的 Log 输出类


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/MSExcel.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • File
类
MSExcel.h 文件参考

通过 OLE 方式操作 Microsoft Excel（仅限 Windows 下使用，要求已安装 Excel） 更多...

#include "Global.h"
#include <QString>
#include <QStringList>

浏览源代码.

类

class MSExcel
通过 OLE 方式操作 Microsoft Excel 更多...

详细描述

通过 OLE 方式操作 Microsoft Excel（仅限 Windows 下使用，要求已安装 Excel）


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui 目录参考

  • inc
  • Gui
Gui 目录参考

文件

文件 | ClickLabel.h [代码]
可发出clicked信号的Label部件
文件 | DateEdit.h [代码]
允许为空的日期选择控件
文件 | FlowLayout.h [代码]
流式布局FlowLayout
文件 | GlowEffect.h [代码]
发光效果的QGraphicsEffect
文件 | GuiUtils.h [代码]
GUI相关常用单元
文件 | LineEdit.h [代码]
extended QLineEdit widget
文件 | MarqueeLabel.h [代码]
跑马灯Label,点击时自动打开网址
文件 | TreeWidgetHeaderSetupDialog.h [代码]
修改 QTreeWidget 列设置的对话框


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/ClickLabel.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Gui
类
ClickLabel.h 文件参考

可发出clicked信号的Label部件 更多...

#include <Global.h>
#include <QLabel>

浏览源代码.

类

class ClickLabel
emit clicked() signal's label while mouse clicked 更多...

详细描述

可发出clicked信号的Label部件


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/DateEdit.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Gui
类
DateEdit.h 文件参考

允许为空的日期选择控件 更多...

#include "Global.h"
#include <QComboBox>
#include <QCalendarWidget>

浏览源代码.

类

class DateEdit
可以输入或显示为空的日期选择控件 更多...

详细描述

允许为空的日期选择控件


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/FlowLayout.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Gui
类
FlowLayout.h 文件参考

流式布局FlowLayout 更多...

#include "Global.h"
#include <QLayout>

浏览源代码.

类

class FlowLayout
流式布局FlowLayout 更多...

详细描述

流式布局FlowLayout


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/GlowEffect.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Gui
类
GlowEffect.h 文件参考

发光效果的QGraphicsEffect 更多...

#include "Global.h"
#include <QGraphicsEffect>

浏览源代码.

类

class GlowEffect

详细描述

发光效果的QGraphicsEffect


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/GuiUtils.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Gui
类
GuiUtils.h 文件参考

GUI相关常用单元 更多...

#include "Global.h"
#include <QWidget>
#include <QCursor>

浏览源代码.

类

class | CursorCustom
光标形态变化类的根类，一般不直接使用 更多...
class | CursorWait
等待光标的设置和自动恢复处理类 更多...
class | CursorBusy
后台忙光标的设置和自动恢复处理类 更多...

详细描述

GUI相关常用单元


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/LineEdit.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Gui
类
LineEdit.h 文件参考

extended QLineEdit widget 更多...

#include <Global.h>
#include <QLineEdit>

浏览源代码.

类

class LineEdit
extended QLineEdit widget 更多...

详细描述

extended QLineEdit widget


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/MarqueeLabel.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Gui
类
MarqueeLabel.h 文件参考

跑马灯Label,点击时自动打开网址 更多...

#include "Global.h"
#include <QLabel>

浏览源代码.

类

class MarqueeLabel
跑马灯类MarqueeLabel,点击时自动打开网址 更多...

详细描述

跑马灯Label,点击时自动打开网址


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/TreeWidgetHeaderSetupDialog.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Gui
类
TreeWidgetHeaderSetupDialog.h 文件参考

修改 QTreeWidget 列设置的对话框 更多...

#include "Global.h"
#include <QDialog>
#include <QTreeWidget>

浏览源代码.

类

class TreeWidgetHeaderSetupDialog
设置 QTreeWidget 标题的对话框 更多...

详细描述

修改 QTreeWidget 列设置的对话框


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Network 目录参考

  • inc
  • Network
Network 目录参考

文件

文件 | DownloadHttp.h [代码]
HTTP 文件多线程下载器
文件 | SingleInstance.h [代码]
应用程序单实例类


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Network/DownloadHttp.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Network
类
DownloadHttp.h 文件参考

HTTP 文件多线程下载器 更多...

#include "Global.h"
#include <QtCore>
#include <QtNetwork>

浏览源代码.

类

class | Download
用于下载文件（或文件的一部分） 注意：此类尚未进行严格测试 更多...
class | DownloadList
用于管理文件的下载 更多...

详细描述

HTTP 文件多线程下载器


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Network/SingleInstance.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Network
类
SingleInstance.h 文件参考

应用程序单实例类 更多...

#include "Global.h"
#include <QLocalSocket>
#include <QLocalServer>

浏览源代码.

类

class SingleInstance
应用程序单实例类 更多...

详细描述

应用程序单实例类


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/OS 目录参考

  • inc
  • OS
OS 目录参考

文件

文件 OS.h [代码]
与操作系统相关


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/OS/OS.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • OS
类
OS.h 文件参考

与操作系统相关 更多...

#include "Global.h"
#include <QString>

浏览源代码.

类

class OS
与操作系统相关的操作类 更多...

详细描述

与操作系统相关


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Sql 目录参考

  • inc
  • Sql
Sql 目录参考

文件

文件 MSSQL.h [代码]
SQL Server 相关应用


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Sql/MSSQL.h 文件参考

  • 文件列表
  • 文件成员
  • inc
  • Sql
类
MSSQL.h 文件参考

SQL Server 相关应用 更多...

#include <Global.h>
#include <QStringList>

浏览源代码.

类

class MSSQL
读取 ODBC 驱动和版本信息 更多...

详细描述

SQL Server 相关应用


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Global.h 源文件

  • 文件列表
  • 文件成员
  • inc
Global.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：常用功能函数
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.11 cnhemiya 建立
13 // 2013.04.17 XChinux 参照Qt/qglobal.h文件重写Global.h
14 // ==========================================================================
15 // 注意事项:
16 // 1. 编译Tianchi DLL时请在 .pro 中添加：
17 // DEFINES += TIANCHI_EXPORT
18 // 2. 使用Tianchi DLL时请在.pro中添加
19 // DEFINES += TIANCHI_IMPORT
20 // ==========================================================================
21
22 #ifndef TIANCHI_GLOBAL_H
23 #define TIANCHI_GLOBAL_H
24
25
29 #ifndef TIANCHI_NAMESPACE
30
31 # define TIANCHI Tianchi
32
33 # define TIANCHI_NAMESPACE Tianchi
34 #else
35 # define TIANCHI TIANCHI_NAMESPACE
36 #endif
37
38
39 #include <QtCore/qglobal.h>
40
41 #ifndef __cplusplus
42 # error "Tianchi library only support C++ Compilers"
43 #endif
44
45
46 #define TIANCHI_VERSION_STR "0.0.1"
47 /*
48 TIANCHI_VERSION is (major << 16) + (minor << 8) + patch.
49 */
50 #define TIANCHI_VERSION 0x000001
51 /*
52 can be used like #if (TIANCHI_VERSION >= TIANCHI_VERSION_CHECK(4, 4, 0))
53 */
54 #define TIANCHI_VERSION_CHECK(major, minor, patch) ((major<<16)|(minor<<8)|(patch))
55
56 #if !defined(TIANCHI_NAMESPACE) // user namespace, copy from qglobal.h
57
58 # define TIANCHI_PREPEND_NAMESPACE(name) ::name
59 # define TIANCHI_USE_NAMESPACE
60 # define TIANCHI_BEGIN_NAMESPACE
61 # define TIANCHI_END_NAMESPACE
62
63 #else /* user namespace */
64
65 # define TIANCHI_PREPEND_NAMESPACE(name) ::TIANCHI_NAMESPACE::name
66 # define TIANCHI_USE_NAMESPACE using namespace ::TIANCHI_NAMESPACE;
67
68 # define TIANCHI_BEGIN_NAMESPACE namespace TIANCHI_NAMESPACE {
69
70 # define TIANCHI_END_NAMESPACE }
71
72 namespace TIANCHI_NAMESPACE {}
73
74 #endif /* user namespace */
75
76
77 #define TIANCHI_BEGIN_HEADER
78 #define TIANCHI_END_HEADER
79
80 #if defined(TIANCHI_EXPORT)
81 # define TIANCHI_API Q_DECL_EXPORT
82 #elif defined(TIANCHI_IMPORT)
83 # define TIANCHI_API Q_DECL_IMPORT
84 #else
85 # define TIANCHI_API
86 #endif
87
88
89 #endif // TIANCHI_GLOBAL_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/tianchi.h 文件参考

  • 文件列表
  • 文件成员
  • inc
tianchi.h 文件参考

引用单元头文件 更多...

#include "Chinese/Chinese.h"
#include "Core/Classes.h"
#include "Core/Common.h"
#include "Core/String.h"
#include "Core/Utils.h"
#include "File/Directory.h"
#include "File/FileUtils.h"
#include "File/Json.h"
#include "File/LogTiny.h"
#include "File/MSExcel.h"
#include "Gui/ClickLabel.h"
#include "Gui/DateEdit.h"
#include "Gui/GuiUtils.h"
#include "Gui/MarqueeLabel.h"
#include "Gui/TreeWidgetHeaderSetupDialog.h"
#include "Network/DownloadHttp.h"
#include "Network/SingleInstance.h"
#include "OS/OS.h"
#include "Sql/MSSQL.h"

浏览源代码.

详细描述

引用单元头文件


Tianchi: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 宏定义
这里列出了所有文档化的文件成员,并附带其详细说明:
  • Debug_Log : LogTiny.h
  • DEBUG_OUT : Common.h
  • DEBUG_STEP : Common.h
  • iif() : Common.h
  • Log_Step : LogTiny.h
  • max : Common.h
  • min : Common.h
  • QS() : Common.h


Tianchi: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 宏定义
  • iif() : Common.h
  • QS() : Common.h


Tianchi: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 宏定义
  • Debug_Log : LogTiny.h
  • DEBUG_OUT : Common.h
  • DEBUG_STEP : Common.h
  • Log_Step : LogTiny.h
  • max : Common.h
  • min : Common.h


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Chinese/Chinese.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Chinese
Chinese.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi share library for Qt (C++)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明： 汉语相关处理
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.15 圣域天子 建立
13 //
14 // ====================================================================================================================
16 #ifndef TIANCHI_CHINESE_H
17 #define TIANCHI_CHINESE_H
18
19 #include "Global.h"
20
21 #include <QString>
22
23 TIANCHI_BEGIN_NAMESPACE
24
27 class TIANCHI_API Chinese
28 {
29 public:
42 static QString firstPinyins(const QString& HzString);
43
62 static QString toPinyin(const QString& Str, bool Tonality=false);
63
77 static QString toChars(const QString& Str, bool Tonality=false);
78 };
79
80 TIANCHI_END_NAMESPACE
81
82 #endif // TIANCHI_CHINESE_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Core/Classes.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Core
Classes.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：一些常用的小类
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ====================================================================================================================
16 #ifndef TIANCHI_CLASSES_H
17 #define TIANCHI_CLASSES_H
18
19 #include "Global.h"
20
21 #include <QDateTime>
22 #include <QObject>
23 #include <QString>
24 #include <QStringList>
25 #include <QElapsedTimer>
26 #include <QHash>
27
28 TIANCHI_BEGIN_NAMESPACE
29
30 QT_USE_NAMESPACE
31
35 class TIANCHI_API Player : public QObject
36 {
37 Q_OBJECT
38
39 Q_PROPERTY(int userNo READ userNo WRITE setUserNo )
40 Q_PROPERTY(QString userID READ userID WRITE setUserID )
41 Q_PROPERTY(QString username READ username WRITE setUsername )
42 Q_PROPERTY(bool loggedIn READ loggedIn WRITE setLoggedIn )
43 Q_PROPERTY(QDateTime loginTime READ loginTime WRITE setLoginTime)
44
45 public:
47 typedef enum AuthLevel
48 {
49 AUTH_SYSADMIN = 999,
50 AUTH_ADMIN = 888,
51 AUTH_MANAGER = 99,
52 AUTH_USER = 9,
53 AUTH_GUEST = 1,
54 };
55
57 Player();
58
60 Player &operator=(const Player&);
61
63 inline int userNo() const { return m_userNo; }
65 inline void setUserNo(int value) { m_userNo = value; }
67 inline QString userID() const { return m_userID; }
69 inline void setUserID(const QString& value) { m_userID = value.trimmed(); }
71 inline QString username() const { return m_username; }
73 inline void setUsername(const QString& value) { m_username = value.trimmed(); }
75 inline int userLevel() const { return m_userLevel; }
77 inline void setUserLevel(int value) { m_userLevel = value; }
78
83 int authority(const QString& key) const;
85 inline void setAuthority(const QString& key, int auth) { m_authority[key] = auth; }
87 void setAuthorityText(const QString& value);
89 void setAuthorityText(const QStringList& value);
90
92 inline QString loginID() const { return m_loginID; }
94 inline void setLoginID(const QString& value) { m_loginID = value.trimmed(); }
96 inline QString password() const { return m_password; }
98 inline void setPassword(const QString& value) { m_password = value.trimmed(); }
100 inline bool loggedIn() const { return m_loggedIn; }
102 void setLoggedIn(bool value);
104 inline void setLoggedIn() { setLoggedIn(true); }
106 inline QDateTime loginTime() const { return m_loginTime; }
108 inline void setLoginTime(QDateTime value) { m_loginTime = value; m_loggedIn = true; }
109
112 inline int noLoginTime() { return m_loggedIn ? 0 : m_noLoginTimer.elapsed()/1000; }
113
115 void clear();
116
117 private:
118 int m_userNo;
119 QString m_userID;
120 QString m_username;
121 int m_userLevel;
122 QHash<QString, int> m_authority;
123
124 QString m_loginID;
125 QString m_password;
126
127 bool m_loggedIn;
128 QDateTime m_loginTime;
129 QElapsedTimer m_noLoginTimer;
130 };
131
135 class TIANCHI_API CInvokeObject
136 {
137 public:
139 CInvokeObject(QObject* o=NULL, QByteArray m="")
140 {
141 init(o, m);
142 }
144 CInvokeObject &operator=(const CInvokeObject& from)
145 {
146 if ( this != &from )
147 {
148 this->m_object = from.m_object;
149 this->m_method = from.m_method;
150 }
151 return *this;
152 }
153
155 inline bool queued(QGenericArgument val0 = QGenericArgument(0),
156 QGenericArgument val1 = QGenericArgument(),
157 QGenericArgument val2 = QGenericArgument(),
158 QGenericArgument val3 = QGenericArgument(),
159 QGenericArgument val4 = QGenericArgument(),
160 QGenericArgument val5 = QGenericArgument(),
161 QGenericArgument val6 = QGenericArgument(),
162 QGenericArgument val7 = QGenericArgument(),
163 QGenericArgument val8 = QGenericArgument(),
164 QGenericArgument val9 = QGenericArgument())
165 {
166 try {
167 return m_object != NULL ? m_object->metaObject()->invokeMethod(m_object, m_method,
168 Qt::QueuedConnection,
169 val0, val1, val2, val3, val4,
170 val5, val6, val7, val8, val9)
171 : false;
172 }catch(...)
173 {
174 return false;
175 }
176 }
177
179 bool invoke(QGenericArgument val0 = QGenericArgument(0),
180 QGenericArgument val1 = QGenericArgument(),
181 QGenericArgument val2 = QGenericArgument(),
182 QGenericArgument val3 = QGenericArgument(),
183 QGenericArgument val4 = QGenericArgument(),
184 QGenericArgument val5 = QGenericArgument(),
185 QGenericArgument val6 = QGenericArgument(),
186 QGenericArgument val7 = QGenericArgument(),
187 QGenericArgument val8 = QGenericArgument(),
188 QGenericArgument val9 = QGenericArgument());
189
192 inline bool isValid() const { return m_object != NULL && ! m_method.isEmpty(); }
193
194 private:
195 QObject* m_object;
196 QByteArray m_method;
197
198 inline void init(QObject* o, QByteArray m)
199 {
200 m_object = o;
201 m_method = m;
202 }
203 };
204
209 class TIANCHI_API DBFields
210 {
211 public:
212 DBFields() {}
213 inline DBFields(QHash<QString, QByteArray> fields)
214 { setFields(fields); }
215
216 static void addField(QByteArray& fieldBytes, const QString& name, const QVariant& value);
217 static QHash<QString, QByteArray> getFields(const QByteArray& fieldBytes);
218
219 void setFields(QHash<QString, QByteArray> fields)
220 {
221 m_fields.clear();
222 m_keys.clear();
223
224 m_fields = fields;
225 m_keys = m_fields.keys();
226 }
227 inline QByteArray value(const QString& key) const
228 {
229 return m_fields.value(key.trimmed().toLower());
230 }
231
232 private:
233 QHash<QString, QByteArray> m_fields;
234 QStringList m_keys;
235 };
236
237
238 TIANCHI_END_NAMESPACE
239
240 #endif // TIANCHI_CLASSES_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/ClickLabel.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Gui
ClickLabel.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：可发出clicked信号的Label部件
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.17 XChinux 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_CLICKLABEL_H
18 #define TIANCHI_CLICKLABEL_H
19
20 #include <Global.h>
21 #include <QLabel>
22
23 TIANCHI_BEGIN_HEADER
24
25 TIANCHI_BEGIN_NAMESPACE
26
27 class ClickLabelPrivate;
28
29 QT_USE_NAMESPACE
30
32 class TIANCHI_API ClickLabel : public QLabel
33 {
34 Q_OBJECT
35 public:
36 ClickLabel(QWidget *parent = 0, Qt::WindowFlags f = 0);
37 ClickLabel(const QString &text, QWidget *parent = 0,
38 Qt::WindowFlags f = 0);
39 virtual ~ClickLabel();
40 Q_SIGNALS:
42 void clicked();
43 protected:
44 virtual void mousePressEvent(QMouseEvent *e);
45 virtual void mouseReleaseEvent(QMouseEvent *e);
46 private:
47 Q_DISABLE_COPY(ClickLabel)
48 Q_DECLARE_PRIVATE(ClickLabel)
49 ClickLabelPrivate *d_ptr;
50 };
51
52 TIANCHI_END_NAMESPACE
53
54 TIANCHI_END_HEADER
55
56 #endif


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Core/Common.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Core
Common.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：公共单元，此单元不使用 namespace Tianchi
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.15 圣域天子 建立
13 //
14 // ====================================================================================================================
16 #ifndef TIANCHI_COMMON_H
17 #define TIANCHI_COMMON_H
18
19 #include "Global.h"
20
21 #include <QTextCodec>
22 #include <QDateTime>
23
24 #ifdef QT_WIDGETS_LIB
25 #include <QMessageBox>
26 #endif
27
28 #if defined(QT_DEBUG)
29 #include <iostream>
30 using namespace std;
31 #endif
32
56 inline QString QS(const char* s)
57 {
58 return QTextCodec::codecForLocale()->toUnicode(s);
59 }
60
62 #define max(a,b) (((a) > (b)) ? (a) : (b))
63
64 #define min(a,b) (((a) < (b)) ? (a) : (b))
65
66 inline int iif(bool logic, int v1, int v2=0) { return logic ? v1 : v2; }
68 inline QString iif(bool logic, const QString& v1, const QString& v2="") { return logic ? v1 : v2; }
69
70 #ifdef QT_WIDGETS_LIB
71
72
73
74 inline void MsgBox(const QString& s)
75 {
76 QMessageBox::information(NULL, "", s);
77 }
78 #endif
79
80 #if defined(QT_DEBUG)
81
82
83
84
85 inline void debug_out(const char* file, int line, const QString& text="")
86 {
87 cout<<QDateTime::currentDateTime().toString("yyyy/MM/dd HH:mm:ss->").toLocal8Bit().data()<<file<<"("<<line<<"): "<<text.toLocal8Bit().data()<<endl;
88 }
93 inline void debug_out(const char* file, int line, int value)
94 {
95 debug_out(file, line, QString::number(value));
96 }
97
99 #define DEBUG_STEP debug_out(__FILE__, __LINE__);
100
101 #define DEBUG_OUT(x) debug_out(__FILE__, __LINE__, x);
102 #else
103
104 #define DEBUG_STEP
105
106 #define DEBUG_OUT(x)
107 #endif
108
109 #endif // TIANCHI_COMMON_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/DateEdit.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Gui
DateEdit.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：允许为空的日期选择控件
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ====================================================================================================================
16 // ====================================================================================================================
17 #ifndef TIANCHI_DATEEDIT_H
18 #define TIANCHI_DATEEDIT_H
19
20 #include "Global.h"
21
22 #include <QComboBox>
23 #include <QCalendarWidget>
24
25 TIANCHI_BEGIN_NAMESPACE
26
27 QT_USE_NAMESPACE
28
32 class TIANCHI_API DateEdit : public QComboBox
33 {
34 Q_OBJECT
35
36 Q_PROPERTY(QDate date READ date WRITE setDate RESET unsetDate)
37
38 private Q_SLOTS:
39 void calendarClicked(QDate);
40
41 private:
42 QCalendarWidget *m_calendar;
43
44 protected:
45 void focusInEvent(QFocusEvent *e);
46 void mousePressEvent(QMouseEvent *e);
47
48 public:
49 DateEdit(QWidget *parent = 0);
50 virtual ~DateEdit();
51
52 QDate date() const;
53 void setDate(QDate value);
54 void unsetDate();
55
56 inline void setDate(QDateTime value) { setDate(value.date()); }
57 };
58
59 TIANCHI_END_NAMESPACE
60
61 #endif


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/Directory.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • File
Directory.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi share library for Qt (C++)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：可以复制目录树的类，也可以查找文件夹内所有的文件
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.21 cnhemiya@gmail.com 建立
13 //
14 // ====================================================================================================================
16 // ====================================================================================================================
17 #ifndef TIANCHI_DIRECTORY_H
18 #define TIANCHI_DIRECTORY_H
19
20 #include "Global.h"
21
22 #include <QObject>
23 #include <QStringList>
24
25 TIANCHI_BEGIN_NAMESPACE
26
27 QT_USE_NAMESPACE
28
31 class TIANCHI_API Directory : public QObject
32 {
33 Q_OBJECT
34
35 public:
36 explicit Directory(QObject *parent = 0);
37
42 QStringList findFiles(const QString &path, const QStringList &nameFilters = QStringList());
43
50 int copyDirectories(const QString &fromPath, const QString &toPath,
51 const QStringList &nameFilters = QStringList(), bool overWrite = true);
52
58 int copyFiles(const QStringList &files, const QString &toPath, bool overWrite = true);
59
61 void resetCopyFileCount();
62
63 Q_SIGNALS:
67 void currentFile(int count, const QString &name);
68
69 private:
70 int m_copyFileCount;
71
72 void doDirTree(const QString &fromPath, const QString &toPath,
73 const QStringList &nameFilters, bool overWrite,
74 QStringList &findFiles, bool isFind);
75 QString formatPath(const QString &path);
76 };
77
78 TIANCHI_END_NAMESPACE
79
80 #endif // TIANCHI_DIRECTORY_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Network/DownloadHttp.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Network
DownloadHttp.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：HTTP 文件多线程下载器
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.19 圣域天子 建立
13 //
14 // ====================================================================================================================
16 #ifndef TIANCHI_DOWNLOADHTTP_H
17 #define TIANCHI_DOWNLOADHTTP_H
18
19 #include "Global.h"
20
21 #include <QtCore>
22 #include <QtNetwork>
23
24 TIANCHI_BEGIN_NAMESPACE
25
30 class TIANCHI_API Download : public QObject
31 {
32 Q_OBJECT
33
34 public:
35 Download(int index, QObject *parent = 0);
36 void StartDownload(const QUrl &url, QFile* file, qint64 startPoint=0, qint64 endPoint=-1);
37
38 Q_SIGNALS:
39 void DownloadFinished();
40
41 public Q_SLOTS:
42 void FinishedSlot();
43 void HttpReadyRead();
44
45 private:
46 QNetworkAccessManager m_Qnam;
47 QNetworkReply* m_Reply;
48 QFile* m_File;
49
50 const int m_Index;
51 qint64 m_HaveDoneBytes;
52 qint64 m_StartPoint;
53 qint64 m_EndPoint;
54
55 };
56
57 // 用于管理文件的下载
59 class TIANCHI_API DownloadList : public QObject
60 {
61 Q_OBJECT
62 public:
63 DownloadList(QObject *parent = 0);
64
65 void StartFileDownload(const QString &url, int count);
66 qint64 GetFileSize(QUrl url);
67
68 Q_SIGNALS:
69 void FileDownloadFinished();
70
71 private Q_SLOTS:
72 void SubPartFinished();
73
74 private:
75 int m_DownloadCount;
76 int m_FinishedNum;
77 int m_FileSize;
78 QUrl m_Url;
79 QFile *m_File;
80 };
81
82 TIANCHI_END_NAMESPACE
83
84 #endif // TIANCHI_DOWNLOADHTTP_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/FileUtils.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • File
FileUtils.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：文件操作常用处理类
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.15 圣域天子 建立
13 //
14 // ====================================================================================================================
16 // ====================================================================================================================
17 #ifndef TIANCHI_FILEUTILS_H
18 #define TIANCHI_FILEUTILS_H
19
20 #include "Global.h"
21
22 #include <QString>
23
24 TIANCHI_BEGIN_NAMESPACE
25
29 class TIANCHI_API FileUtils
30 {
31 public:
33 static bool loadFromFile(QString& context, const QString& filename);
34
38 static QString uniqueFileName(const QString& dir, const QString& fileTemplate, const QString& suffix="");
39
43 static QString fileVersion(const QString& exeFile);
44
46 static QStringList searchFiles(const QString& path);
47 };
48
49 TIANCHI_END_NAMESPACE
50
51 #endif // TIANCHI_FILEUTILS_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/FlowLayout.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Gui
FlowLayout.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：可发出clicked信号的Label部件
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.21 XChinux 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_FLOWLAYOUT_H
18 #define TIANCHI_FLOWLAYOUT_H
19
20 #include "Global.h"
21 #include <QLayout>
22
23 TIANCHI_BEGIN_HEADER
24 TIANCHI_BEGIN_NAMESPACE
25
26 class FlowLayoutPrivate;
27
28 QT_USE_NAMESPACE
29
31 class TIANCHI_API FlowLayout : public QLayout
32 {
33 public:
34 FlowLayout(QWidget *parent, int margin = -1, int hSpacing = -1,
35 int vSpacing = -1);
36 FlowLayout(int margin = -1, int hSpacing = -1, int vSpacing = -1);
37 virtual ~FlowLayout();
38
39 void addItem(QLayoutItem *item);
40 int horizontalSpacing() const;
41 int verticalSpacing() const;
42 Qt::Orientations expandingDirections() const;
43 bool hasHeightForWidth() const;
44 int heightForWidth(int) const;
45 int count() const;
46 QLayoutItem *itemAt(int index) const;
47 QSize minimumSize() const;
48 void setGeometry(const QRect &rect);
49 QSize sizeHint() const;
50 QLayoutItem *takeAt(int index);
51
52 private:
53 Q_DISABLE_COPY(FlowLayout)
54 Q_DECLARE_PRIVATE(FlowLayout)
55 FlowLayoutPrivate *d_ptr;
56 };
57
58 TIANCHI_END_HEADER
59 TIANCHI_END_NAMESPACE
60
61
62 #endif


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/GlowEffect.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Gui
GlowEffect.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：发光效果的QGraphicsEffect
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2012.08.23 roywillow 原创
13 // 2013.04.22 XChinux 修改
14 //
15 // ==========================================================================
17 // ==========================================================================
26 #ifndef TIANCHI_GLOWEFFECT_H
27 #define TIANCHI_GLOWEFFECT_H
28
29 #include "Global.h"
30 #include <QGraphicsEffect>
31
32 TIANCHI_BEGIN_HEADER
33 TIANCHI_BEGIN_NAMESPACE
34
35 class GlowEffectPrivate;
36
37 QT_USE_NAMESPACE
38
39
40 class TIANCHI_API GlowEffect : public QGraphicsEffect
41 {
42 Q_OBJECT
43 public:
44 GlowEffect(QObject *parent = 0);
45 virtual ~GlowEffect();
46
49 void setRadius(int radius);
52 void setGlowColor(const QColor &color);
53 virtual QRectF boundingRectFor(const QRectF &sourceRect) const;
54 protected:
55 virtual void draw(QPainter *painter);
56 virtual void sourceChanged(ChangeFlags flags);
57
58 private:
59 Q_DISABLE_COPY(GlowEffect)
60 Q_DECLARE_PRIVATE(GlowEffect)
61 GlowEffectPrivate *d_ptr;
62 };
63
64 TIANCHI_END_NAMESPACE
65 TIANCHI_END_HEADER
66
67 #endif // GLOWEFFECT_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/GuiUtils.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Gui
GuiUtils.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：GUI相关常用单元
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.15 圣域天子 建立
13 //
14 // ==========================================================================
16 #ifndef TIANCHI_GUIUTILS_H
17 #define TIANCHI_GUIUTILS_H
18
19 #include "Global.h"
20
21 #if defined(QT_GUI_LIB)
22 #include <QWidget>
23 #include <QCursor>
24
25 TIANCHI_BEGIN_NAMESPACE
26
27 QT_USE_NAMESPACE
28
34 class TIANCHI_API CursorCustom
35 {
36 protected:
37 CursorCustom(QWidget* parent, Qt::CursorShape shape)
38 {
39 m_parent = parent;
40 m_cursor = m_parent->cursor();
41 m_parent->setCursor(QCursor(shape));
42 }
43 virtual ~CursorCustom()
44 {
45 m_parent->setCursor(m_cursor);
46 }
47 QWidget* m_parent;
48 QCursor m_cursor;
49 };
50
65 class TIANCHI_API CursorWait : public CursorCustom
66 {
67 public:
68 CursorWait(QWidget* parent = 0)
69 : CursorCustom(parent, Qt::WaitCursor)
70 {
71 }
72 };
73
89 class TIANCHI_API CursorBusy : public CursorCustom
90 {
91 public:
92 CursorBusy(QWidget* parent = 0)
93 : CursorCustom(parent, Qt::BusyCursor)
94 {
95 }
96 };
97
98 TIANCHI_END_NAMESPACE
99
100 #endif // QT_GUI_LIB
101
102 #endif // TIANCHI_GUIUTILS_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/Json.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • File
Json.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：JSON 创建和解析类
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ====================================================================================================================
16 #ifndef TIANCHI_JSON_H
17 #define TIANCHI_JSON_H
18
19 #include "Global.h"
20
21 #include <QDateTime>
22 #include <QMap>
23 #include <QList>
24 #include <QVariant>
25 #include <QString>
26 #include <QStringList>
27
28 TIANCHI_BEGIN_NAMESPACE
29
33 class TIANCHI_API JSONObject
34 {
35 public:
36 enum ValueTypeFlag
37 {
38 vtfObject = 0,
39 vtfString = 1,
40 vtfInt = 2,
41 vtfDouble = 3,
42 vtfBool = 4, vtfDateTime=5, vtfNull=6, vtfArray=99 };
43
44 JSONObject(const QString& key="");
45 virtual ~JSONObject();
46
47 static QString quote(const QString& Text);
48 static QString dequote(const QString& S);
49
50 protected:
51 JSONObject* parent;
52
53 int m_index;
54 QMap<QString, JSONObject*> m_list;
55
56 ValueTypeFlag m_type;
57 QString m_key;
58 QVariant m_value;
59
60 QString jsonKey() const;
61 QString jsonValue() const;
62
63 void init();
64 const wchar_t* fromObject(const QString& Key, const wchar_t* ptr);
65 const wchar_t* fromArray(const wchar_t* ptr);
66
67 inline QString newKey(const QString& key)
68 { return key.trimmed().isEmpty() ? QString::number(m_index++) : key.trimmed(); }
69
70 const wchar_t* parseKey(QString& Value, const wchar_t* ptr);
71 const wchar_t* parseValue(QString Key, const wchar_t* ptr);
72 const wchar_t* parseNumber(QString& Value, const wchar_t* ptr);
73 static inline const wchar_t* skip(const wchar_t* in)
74 {
75 while(in && *in && *in<=32)
76 {
77 in++;
78 }
79 return in;
80 }
81
82 public:
83 int type() const { return m_type; }
84 void setType(int value) { m_type = (ValueTypeFlag) value; }
85
86 QString key() const;
87 void setKey(const QString& value);
88 QVariant value() const;
89 inline QVariant value(const QString& key) const
90 { QVariant ret; value(key, ret); return ret; }
91 bool value(const QString& key, QVariant& v) const;
92 inline bool exists(const QString& key) const
93 {
94 QMap<QString, JSONObject*>::const_iterator child = m_list.find(key);
95 return child != m_list.constEnd() && child.key() == key;
96 }
97 inline int count() const { return m_list.count(); }
98 inline JSONObject* get(const QString& key) const
99 { return m_list[key]; }
100 QList<JSONObject*> children() const;
101
102
103 JSONObject* addObject(const QString& key="");
104 JSONObject* addArray(const QString& key);
105 JSONObject* addNull(const QString& key);
106 inline JSONObject* add(const QString& key, const char* value) { return add(key, QString(value)); }
107 JSONObject* add(const QString& key, const QString& value);
108 JSONObject* add(const QString& key, int value);
109 JSONObject* add(const QString& key, double value);
110 JSONObject* add(const QString& key, bool value);
111 JSONObject* add(const QString& key, QDateTime value);
112
113 JSONObject* addNull();
114 inline JSONObject* add(const char* value) { return add(QString(value)); }
115 inline JSONObject* add(const QString& value) { return add(QString::number(m_index++), value); }
116 inline JSONObject* add(int value) { return add(QString::number(m_index++), value); }
117 inline JSONObject* add(double value) { return add(QString::number(m_index++), value); }
118 inline JSONObject* add(bool value) { return add(QString::number(m_index++), value); }
119 inline JSONObject* add(QDateTime value) { return add(QString::number(m_index++), value); }
120
121 void deleteChildren(const QString& key);
122 void clearChildren();
123 void clear();
124
125 virtual QString toString() const; // 取得
126
127 bool fromString(QString jsonText);
128 };
129 // =====================================================================================================================
130
131 TIANCHI_END_NAMESPACE
132
133 #endif // TIANCHI_JSON_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/LineEdit.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Gui
LineEdit.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：extended QLineEdit widget
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.22 XChinux 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_LINEEDIT_H
18 #define TIANCHI_LINEEDIT_H
19
20 #include <Global.h>
21 #include <QLineEdit>
22
23 QT_BEGIN_NAMESPACE
24 class QPaintEvent;
25 class QMouseEvent;
26 class QContextMenuEvent;
27 QT_END_NAMESPACE
28
29 TIANCHI_BEGIN_HEADER
30 TIANCHI_BEGIN_NAMESPACE
31
32 class LineEditPrivate;
33
34 QT_USE_NAMESPACE
35
39 class TIANCHI_API LineEdit : public QLineEdit
40 {
41 Q_OBJECT
42
44 Q_PROPERTY(QString labelText
45 READ labelText
46 WRITE setLabelText
47 NOTIFY labelTextChanged
48 DESIGNABLE true)
50 Q_PROPERTY(QVariant data
51 READ data
52 WRITE setData
53 NOTIFY dataChanged
54 DESIGNABLE false)
55 public:
56 LineEdit(QWidget *parent = 0);
57 virtual ~LineEdit();
58 QString labelText() const;
59 QVariant data() const;
60 Q_SIGNALS:
62 void labelTextChanged(const QString &labelText);
64 void dataChanged(const QVariant &userData);
66 void doubleClicked();
67 public Q_SLOTS:
69 void setLabelText(const QString &labelText);
71 void setData(const QVariant &userData);
72 protected:
73 virtual void paintEvent(QPaintEvent *event);
74 virtual void mouseDoubleClickEvent(QMouseEvent *event);
75 virtual void contextMenuEvent(QContextMenuEvent *event);
76 private:
77 Q_DISABLE_COPY(LineEdit)
78 Q_DECLARE_PRIVATE(LineEdit)
79 LineEditPrivate *d_ptr;
80 };
81
82 TIANCHI_END_NAMESPACE
83 TIANCHI_END_HEADER
84
85 #endif


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/LogTiny.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • File
LogTiny.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：简单的 Log 输出类
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ====================================================================================================================
16 // ====================================================================================================================
17 #ifndef TIANCHI_LOGTINY_H
18 #define TIANCHI_LOGTINY_H
19
20 #include "Global.h"
21
22 #include <QString>
23
24 TIANCHI_BEGIN_NAMESPACE
25
29 class TIANCHI_API LogTiny
30 {
31 public:
44 void setAppFile(const QString& AppFile);
45
53 void setLogFile(const QString& LogFile);
54
59 void write(const QString& S, const QString& SourceName="", int SourceLine=0);
60
65 inline void debug(const QString& S, const QString& SourceName="", int SourceLine=0)
66 {
67 #ifdef _DEBUG
68 write(S, SourceName, SourceLine);
69 #endif
70 }
71
72 private:
73 QString m_FileName;
74 };
75
76 TIANCHI_END_NAMESPACE
77
79 #define Log_Step TIANCHI_NAMESPACE::Log.write("<<STEP>>", __FILE__, __LINE__);
80
82 #ifdef _DEBUG
83 #define Debug_Log(s) TIANCHI_NAMESPACE::Log.write(s, __FILE__, __LINE__);
84 #else
85 #define Debug_Log(s)
86 #endif
87
88 #endif // TIANCHI_LOGTINY_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/File/MSExcel.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • File
MSExcel.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：通过 OLE 方式操作 Microsoft Excel（仅限 Windows 下使用，要求已安装 Excel）
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ====================================================================================================================
16 // ====================================================================================================================
17 #ifndef TIANCHI_MSEXCEL_H
18 #define TIANCHI_MSEXCEL_H
19
20 #include "Global.h"
21
22 #include <QString>
23 #include <QStringList>
24
25
26 QT_BEGIN_NAMESPACE
27
28 class QAxObject;
29 class QAxWidget;
30 #ifdef QT_WIDGETS_LIB
31 class QTreeWidget;
32 #endif
33
34 QT_END_NAMESPACE
35
36 TIANCHI_BEGIN_NAMESPACE
37
38 QT_USE_NAMESPACE
39
45 class TIANCHI_API MSExcel
46 {
47 public:
49 MSExcel();
51 virtual ~MSExcel();
52
53 private:
54 QAxWidget* m_excel;
55 QAxObject* m_books;
56 QAxObject* m_book;
57 QAxObject* m_sheets;
58 QAxObject* m_sheet;
59 QString m_filename;
60 QString m_sheetName;
61
62 int m_rowStart;
63 int m_colStart;
64 int m_rowEnd;
65 int m_colEnd;
66
67 public:
69 enum Alignment
70 {
71 xlTop = -4160,
72 xlLeft = -4131,
73 xlRight = -4152,
74 xlCenter = -4108,
75 xlBottom = -4107,
76 };
77
79 bool create(const QString& filename="");
81 bool open(const QString& filename="");
83 void save(const QString& filename="");
85 void close();
89 void kick();
90
92 void setVisible(bool value);
94 void setCaption(const QString& value);
95
97 QAxObject* addBook();
98
100 int sheetCount();
101
104 QAxObject* sheet(int index);
105
107 QAxObject* currentSheet();
108
113 QVariant read(int row, int col);
114
119 void write(int row, int col, const QVariant& value);
120
121
122 void cellFormat(int row, int col, const QString& format);
123 void cellAlign(int row, int col, Alignment hAlign, Alignment vAlign);
124
125
131 bool usedRange();
132
134 QStringList sheetNames();
136 QString sheetName() const { return m_sheetName; }
137
141 inline int rowStart() const { return m_rowStart; }
145 inline int rowEnd() const { return m_rowEnd; }
149 inline int colStart() const { return m_colStart; }
153 inline int colEnd() const { return m_colEnd; }
154
155 #ifdef QT_WIDGETS_LIB
156
157
158 class TIANCHI_API Exporter
159 {
160 public:
167 Exporter(QTreeWidget* view, int mode, TIANCHI::MSExcel* excel, int row=1, int col=1);
168
171 void setMode(int mode) { m_mode = mode; }
173 void setStart(int row, int col) { m_row = row; m_col = col; }
175 void setExcel(TIANCHI::MSExcel* excel) { m_excel = excel; }
176
178 int exec();
179
180 private:
181 QTreeWidget* m_view;
182 int m_mode;
183 TIANCHI::MSExcel* m_excel;
184 int m_row;
185 int m_col;
186
187 QStringList formats;
188 QStringList cellTypes;
189 };
190 #endif
191 };
192
193 TIANCHI_END_NAMESPACE
194
195 #endif // TIANCHI_MSEXCEL_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Sql/MSSQL.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Sql
MSSQL.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：SQL Server 相关应用
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.18 XChinux 建立
13 //
14 // ====================================================================================================================
16 #ifndef TIANCHI_SQL_MSSQL_H
17 #define TIANCHI_SQL_MSSQL_H
18
19 #include <Global.h>
20 #include <QStringList>
21
22 TIANCHI_BEGIN_HEADER
23 TIANCHI_BEGIN_NAMESPACE
24
25 QT_USE_NAMESPACE
26
27
31 class TIANCHI_API MSSQL
32 {
33 public:
40 static QStringList availableODBCDrivers();
41 };
42
43 TIANCHI_END_HEADER
44 TIANCHI_END_NAMESPACE
45
46 #endif


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/MarqueeLabel.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Gui
MarqueeLabel.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：可发出clicked信号的Label部件
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.18 XChinux 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_MARQUEELABEL_H
18 #define TIANCHI_MARQUEELABEL_H
19
20 #include "Global.h"
21
22 #include <QLabel>
23
24 QT_BEGIN_NAMESPACE
25 class QEvent;
26 class QResizeEvent;
27 QT_END_NAMESPACE
28
29 TIANCHI_BEGIN_HEADER
30 TIANCHI_BEGIN_NAMESPACE
31
32 class MarqueeLabelPrivate;
33
34 QT_USE_NAMESPACE
35
39 class TIANCHI_API MarqueeLabel : public QLabel
40 {
41 Q_OBJECT
42 public:
43 MarqueeLabel(QWidget * parent = 0, Qt::WindowFlags f = 0);
44 MarqueeLabel(const QString &text, QWidget *parent = 0,
45 Qt::WindowFlags f = 0);
46 virtual ~MarqueeLabel();
47 public Q_SLOTS:
48 void setText(const QString &text);
49 protected:
50 virtual void resizeEvent(QResizeEvent *event);
51 virtual void leaveEvent(QEvent *event);
52 virtual void enterEvent(QEvent *event);
53 private:
54 Q_DISABLE_COPY(MarqueeLabel)
55 Q_DECLARE_PRIVATE(MarqueeLabel)
56 Q_PRIVATE_SLOT(d_func(), void _q_openLink(const QString &))
57 MarqueeLabelPrivate *d_ptr;
58 };
59
60 TIANCHI_END_HEADER
61 TIANCHI_END_NAMESPACE
62
63
64 #endif


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/OS/OS.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • OS
OS.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：与操作系统相关
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ====================================================================================================================
16 #ifndef TIANCHI_OS_H
17 #define TIANCHI_OS_H
18
19 #include "Global.h"
20
21 #include <QString>
22
23 TIANCHI_BEGIN_NAMESPACE
24
28 class TIANCHI_API OS
29 {
30 public:
32 static QString name();
33
35 static QString language();
36
43 static bool login(const QString& Domain, const QString& UserID, const QString& Password);
44 };
45
46 TIANCHI_END_NAMESPACE
47
48 #endif // TIANCHI_OS_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Network/SingleInstance.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Network
SingleInstance.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：应用程序单实例类
8 // 使用了 QLocalSocket / QLocalServer 方式实现，为本地多实例应用间通讯保留扩展的可能。
9 // ====================================================================================================================
10 // 开发日志：
11 // 日期 人员 说明
12 // --------------------------------------------------------------------------------------------------------------------
13 // 2013.04.19 圣域天子 建立
14 //
15 // ====================================================================================================================
17 // ====================================================================================================================
18 #ifndef TIANCHI_SINGLEINSTANCE_H
19 #define TIANCHI_SINGLEINSTANCE_H
20
21 #include "Global.h"
22
23 #include <QLocalSocket>
24 #include <QLocalServer>
25
26 TIANCHI_BEGIN_NAMESPACE
27
51 class TIANCHI_API SingleInstance
52 {
53 public:
56 SingleInstance(QString instanceName)
57 {
58 init(0, instanceName);
59 }
63 SingleInstance(QObject* parent, QString instanceName)
64 {
65 init(parent, instanceName);
66 }
69 bool first() const { return m_first; }
70
71 protected:
72 bool m_first;
73 QString m_instanceName;
74 QLocalSocket m_localSocket;
75 QLocalServer* m_localServer;
76
77 private:
78 void init(QObject* parent, QString instanceName);
79 };
80
81 TIANCHI_END_NAMESPACE
82
83 #endif // TIANCHI_SINGLEINSTANCE_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Core/String.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Core
String.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：字符串功能增强与扩展
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.16 圣域天子 建立
13 //
14 // ====================================================================================================================
16 #ifndef TIANCHI_STRING_H
17 #define TIANCHI_STRING_H
18
19 #include "Global.h"
20
21 #include <QString>
22 #include <QStringList>
23
24 TIANCHI_BEGIN_NAMESPACE
25
29 class TIANCHI_API String
30 {
31 public:
32 String();
33
39 static QByteArray first(QByteArray& str, const QByteArray& split="\t");
40
44 static int find(const QStringList& ss, const QString& s);
45
49 static int findOf(const QStringList& list, const QString& key);
50
56 static bool filter(const QString& findText, const QStringList& filters);
57
62 static QString getTextByIndex(const char* strings, int index);
63
65 static int splitHumanName(QString full, QString& sur, QString& real, QString& english);
66
67 };
68
72 class TIANCHI_API StringList : public QStringList
73 {
74 public:
75 StringList();
79 bool loadFrom(const QString& fileName);
83 bool saveTo(const QString& fileName);
84
86 inline QString lineBreak() const
87 {
88 return m_lineBreak;
89 }
91 inline void lineBreak(const QString& value)
92 {
93 m_lineBreak = value;
94 }
95
96 private:
97 QString m_lineBreak;
98 };
99
100 TIANCHI_END_NAMESPACE
101
102 #endif // TIANCHI_STRING_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Gui/TreeWidgetHeaderSetupDialog.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Gui
TreeWidgetHeaderSetupDialog.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：修改 QTreeWidget 列设置的对话框
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 // ====================================================================================================================
15 #ifndef TIANCHI_DLGHEADERSETUP_H
16 #define TIANCHI_DLGHEADERSETUP_H
17
18 #include "Global.h"
19
20 #include <QDialog>
21 #include <QTreeWidget>
22
23 TIANCHI_BEGIN_NAMESPACE
24
25 namespace Ui {
26 class TreeWidgetHeaderSetupDialog;
27 }
28
32 class TIANCHI_API TreeWidgetHeaderSetupDialog : public QDialog
33 {
34 Q_OBJECT
35
36 public:
37 explicit TreeWidgetHeaderSetupDialog(QWidget *parent = 0);
38 ~TreeWidgetHeaderSetupDialog();
39
43 void setHeader(QTreeWidget* view, int max=-1);
44
45 private Q_SLOTS:
46 void on_bnUpward_clicked();
47 void on_bnDownawrd_clicked();
48
49 void on_MasterView_itemClicked(QTreeWidgetItem *item, int column);
50 void on_bnLeft_clicked();
51 void on_bnCenter_clicked();
52 void on_bnRight_clicked();
53
54 private:
55 Ui::TreeWidgetHeaderSetupDialog *ui;
56
57 QTreeWidget* m_view;
58 };
59
60 TIANCHI_END_NAMESPACE
61
62 #endif // TIANCHI_DLGHEADERSETUP_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/Core/Utils.h 源文件

  • 文件列表
  • 文件成员
  • inc
  • Core
Utils.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：常用功能函数
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ====================================================================================================================
16 // ====================================================================================================================
17 #ifndef TIANCHI_UTILS_H
18 #define TIANCHI_UTILS_H
19
20 #include "Global.h"
21
22 #ifdef QT_WIDGETS_LIB
23 #include <QMessageBox>
24 #endif
25
26 #include <QTextCodec>
27 #include <QVariant>
28
29 #include <QDateTime>
30
31 #include <QString>
32 #include <QStringList>
33 #include <QByteArray>
34 #include <QComboBox>
35
36 #include <QThread>
37
38
39 TIANCHI_BEGIN_NAMESPACE
40
42 namespace OperMode
43 {
44 const int Append = 1;
45 const int Change = 2;
46 const int Delete = 4;
47 };
48
52 class TIANCHI_API Utils
53 {
54 public:
56 static QHash<QString, QString> StringToMap(const QString& mapStrings);
58 static QHash<QString, QString> StringToMap(const QStringList& mapStrings);
59
61 static char typeFrom(QVariant::Type type);
63 static char typeFrom(const QVariant& v)
64 {
65 return typeFrom(v.type());
66 }
67
69 static QString YYYY_MM_DD_HH_MM_SS_ZZZ();
71 static QString YYYY_MM_DD_HH_MM_SS();
73 static QDateTime toDateTime(const QString& text);
74
76 static char getIDCardVerifyCode(const QByteArray& id);
77
79 static QDateTime complieDateTime(const QString& complieDate, const QString& complieTime);
80 };
81
82 TIANCHI_END_NAMESPACE
83
84
85 #endif // TIANCHI_UTILS_H


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
CInvokeObject 成员列表

成员的完整列表，这些成员属于 CInvokeObject,包括所有继承而来的类成员

CInvokeObject(QObject *o=NULL, QByteArray m="") | CInvokeObject | inline
invoke(QGenericArgument val0=QGenericArgument(0), QGenericArgument val1=QGenericArgument(), QGenericArgument val2=QGenericArgument(), QGenericArgument val3=QGenericArgument(), QGenericArgument val4=QGenericArgument(), QGenericArgument val5=QGenericArgument(), QGenericArgument val6=QGenericArgument(), QGenericArgument val7=QGenericArgument(), QGenericArgument val8=QGenericArgument(), QGenericArgument val9=QGenericArgument()) | CInvokeObject |
isValid() const | CInvokeObject | inline
operator=(const CInvokeObject &from) | CInvokeObject | inline
queued(QGenericArgument val0=QGenericArgument(0), QGenericArgument val1=QGenericArgument(), QGenericArgument val2=QGenericArgument(), QGenericArgument val3=QGenericArgument(), QGenericArgument val4=QGenericArgument(), QGenericArgument val5=QGenericArgument(), QGenericArgument val6=QGenericArgument(), QGenericArgument val7=QGenericArgument(), QGenericArgument val8=QGenericArgument(), QGenericArgument val9=QGenericArgument()) | CInvokeObject | inline


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Chinese 成员列表

成员的完整列表，这些成员属于 Chinese,包括所有继承而来的类成员

firstPinyins(const QString &HzString) | Chinese | static
toChars(const QString &Str, bool Tonality=false) | Chinese | static
toPinyin(const QString &Str, bool Tonality=false) | Chinese | static


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
ClickLabel 成员列表

成员的完整列表，这些成员属于 ClickLabel,包括所有继承而来的类成员

clicked() | ClickLabel | signal
ClickLabel(QWidget *parent=0, Qt::WindowFlags f=0) (定义于 ClickLabel) | ClickLabel |
ClickLabel(const QString &text, QWidget *parent=0, Qt::WindowFlags f=0) (定义于 ClickLabel) | ClickLabel |
mousePressEvent(QMouseEvent *e) (定义于 ClickLabel) | ClickLabel | protectedvirtual
mouseReleaseEvent(QMouseEvent *e) (定义于 ClickLabel) | ClickLabel | protectedvirtual
~ClickLabel() (定义于 ClickLabel) | ClickLabel | virtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
CursorBusy 成员列表

成员的完整列表，这些成员属于 CursorBusy,包括所有继承而来的类成员

CursorBusy(QWidget *parent=0) (定义于 CursorBusy) | CursorBusy | inline
CursorCustom(QWidget *parent, Qt::CursorShape shape) (定义于 CursorCustom) | CursorCustom | inlineprotected
m_cursor (定义于 CursorCustom) | CursorCustom | protected
m_parent (定义于 CursorCustom) | CursorCustom | protected
~CursorCustom() (定义于 CursorCustom) | CursorCustom | inlineprotectedvirtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
CursorCustom 成员列表

成员的完整列表，这些成员属于 CursorCustom,包括所有继承而来的类成员

CursorCustom(QWidget *parent, Qt::CursorShape shape) (定义于 CursorCustom) | CursorCustom | inlineprotected
m_cursor (定义于 CursorCustom) | CursorCustom | protected
m_parent (定义于 CursorCustom) | CursorCustom | protected
~CursorCustom() (定义于 CursorCustom) | CursorCustom | inlineprotectedvirtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
CursorWait 成员列表

成员的完整列表，这些成员属于 CursorWait,包括所有继承而来的类成员

CursorCustom(QWidget *parent, Qt::CursorShape shape) (定义于 CursorCustom) | CursorCustom | inlineprotected
CursorWait(QWidget *parent=0) (定义于 CursorWait) | CursorWait | inline
m_cursor (定义于 CursorCustom) | CursorCustom | protected
m_parent (定义于 CursorCustom) | CursorCustom | protected
~CursorCustom() (定义于 CursorCustom) | CursorCustom | inlineprotectedvirtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
DBFields 成员列表

成员的完整列表，这些成员属于 DBFields,包括所有继承而来的类成员

addField(QByteArray &fieldBytes, const QString &name, const QVariant &value) (定义于 DBFields) | DBFields | static
DBFields() (定义于 DBFields) | DBFields | inline
DBFields(QHash< QString, QByteArray > fields) (定义于 DBFields) | DBFields | inline
getFields(const QByteArray &fieldBytes) (定义于 DBFields) | DBFields | static
setFields(QHash< QString, QByteArray > fields) (定义于 DBFields) | DBFields | inline
value(const QString &key) const (定义于 DBFields) | DBFields | inline


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
DateEdit 成员列表

成员的完整列表，这些成员属于 DateEdit,包括所有继承而来的类成员

date (定义于 DateEdit) | DateEdit |
date() const (定义于 DateEdit) | DateEdit |
DateEdit(QWidget *parent=0) (定义于 DateEdit) | DateEdit |
focusInEvent(QFocusEvent *e) (定义于 DateEdit) | DateEdit | protected
mousePressEvent(QMouseEvent *e) (定义于 DateEdit) | DateEdit | protected
setDate(QDate value) (定义于 DateEdit) | DateEdit |
setDate(QDateTime value) (定义于 DateEdit) | DateEdit | inline
unsetDate() (定义于 DateEdit) | DateEdit |
~DateEdit() (定义于 DateEdit) | DateEdit | virtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Directory 成员列表

成员的完整列表，这些成员属于 Directory,包括所有继承而来的类成员

copyDirectories(const QString &fromPath, const QString &toPath, const QStringList &nameFilters=QStringList(), bool overWrite=true) | Directory |
copyFiles(const QStringList &files, const QString &toPath, bool overWrite=true) | Directory |
currentFile(int count, const QString &name) | Directory | signal
Directory(QObject *parent=0) (定义于 Directory) | Directory | explicit
findFiles(const QString &path, const QStringList &nameFilters=QStringList()) | Directory |
resetCopyFileCount() | Directory |


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Download 成员列表

成员的完整列表，这些成员属于 Download,包括所有继承而来的类成员

Download(int index, QObject *parent=0) (定义于 Download) | Download |
DownloadFinished() (定义于 Download) | Download | signal
FinishedSlot() (定义于 Download) | Download | slot
HttpReadyRead() (定义于 Download) | Download | slot
StartDownload(const QUrl &url, QFile *file, qint64 startPoint=0, qint64 endPoint=-1) (定义于 Download) | Download |


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
DownloadList 成员列表

成员的完整列表，这些成员属于 DownloadList,包括所有继承而来的类成员

DownloadList(QObject *parent=0) (定义于 DownloadList) | DownloadList |
FileDownloadFinished() (定义于 DownloadList) | DownloadList | signal
GetFileSize(QUrl url) (定义于 DownloadList) | DownloadList |
StartFileDownload(const QString &url, int count) (定义于 DownloadList) | DownloadList |


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
FileUtils 成员列表

成员的完整列表，这些成员属于 FileUtils,包括所有继承而来的类成员

fileVersion(const QString &exeFile) | FileUtils | static
loadFromFile(QString &context, const QString &filename) | FileUtils | static
searchFiles(const QString &path) | FileUtils | static
uniqueFileName(const QString &dir, const QString &fileTemplate, const QString &suffix="") | FileUtils | static


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
FlowLayout 成员列表

成员的完整列表，这些成员属于 FlowLayout,包括所有继承而来的类成员

addItem(QLayoutItem *item) (定义于 FlowLayout) | FlowLayout |
count() const (定义于 FlowLayout) | FlowLayout |
expandingDirections() const (定义于 FlowLayout) | FlowLayout |
FlowLayout(QWidget *parent, int margin=-1, int hSpacing=-1, int vSpacing=-1) (定义于 FlowLayout) | FlowLayout |
FlowLayout(int margin=-1, int hSpacing=-1, int vSpacing=-1) (定义于 FlowLayout) | FlowLayout |
hasHeightForWidth() const (定义于 FlowLayout) | FlowLayout |
heightForWidth(int) const (定义于 FlowLayout) | FlowLayout |
horizontalSpacing() const (定义于 FlowLayout) | FlowLayout |
itemAt(int index) const (定义于 FlowLayout) | FlowLayout |
minimumSize() const (定义于 FlowLayout) | FlowLayout |
setGeometry(const QRect &rect) (定义于 FlowLayout) | FlowLayout |
sizeHint() const (定义于 FlowLayout) | FlowLayout |
takeAt(int index) (定义于 FlowLayout) | FlowLayout |
verticalSpacing() const (定义于 FlowLayout) | FlowLayout |
~FlowLayout() (定义于 FlowLayout) | FlowLayout | virtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
GlowEffect 成员列表

成员的完整列表，这些成员属于 GlowEffect,包括所有继承而来的类成员

boundingRectFor(const QRectF &sourceRect) const (定义于 GlowEffect) | GlowEffect | virtual
draw(QPainter *painter) (定义于 GlowEffect) | GlowEffect | protectedvirtual
GlowEffect(QObject *parent=0) (定义于 GlowEffect) | GlowEffect |
setGlowColor(const QColor &color) | GlowEffect |
setRadius(int radius) | GlowEffect |
sourceChanged(ChangeFlags flags) (定义于 GlowEffect) | GlowEffect | protectedvirtual
~GlowEffect() (定义于 GlowEffect) | GlowEffect | virtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
JSONObject 成员列表

成员的完整列表，这些成员属于 JSONObject,包括所有继承而来的类成员

add(const QString &key, const char *value) (定义于 JSONObject) | JSONObject | inline
add(const QString &key, const QString &value) (定义于 JSONObject) | JSONObject |
add(const QString &key, int value) (定义于 JSONObject) | JSONObject |
add(const QString &key, double value) (定义于 JSONObject) | JSONObject |
add(const QString &key, bool value) (定义于 JSONObject) | JSONObject |
add(const QString &key, QDateTime value) (定义于 JSONObject) | JSONObject |
add(const char *value) (定义于 JSONObject) | JSONObject | inline
add(const QString &value) (定义于 JSONObject) | JSONObject | inline
add(int value) (定义于 JSONObject) | JSONObject | inline
add(double value) (定义于 JSONObject) | JSONObject | inline
add(bool value) (定义于 JSONObject) | JSONObject | inline
add(QDateTime value) (定义于 JSONObject) | JSONObject | inline
addArray(const QString &key) (定义于 JSONObject) | JSONObject |
addNull(const QString &key) (定义于 JSONObject) | JSONObject |
addNull() (定义于 JSONObject) | JSONObject |
addObject(const QString &key="") (定义于 JSONObject) | JSONObject |
children() const (定义于 JSONObject) | JSONObject |
clear() (定义于 JSONObject) | JSONObject |
clearChildren() (定义于 JSONObject) | JSONObject |
count() const (定义于 JSONObject) | JSONObject | inline
deleteChildren(const QString &key) (定义于 JSONObject) | JSONObject |
dequote(const QString &S) (定义于 JSONObject) | JSONObject | static
exists(const QString &key) const (定义于 JSONObject) | JSONObject | inline
fromArray(const wchar_t *ptr) (定义于 JSONObject) | JSONObject | protected
fromObject(const QString &Key, const wchar_t *ptr) (定义于 JSONObject) | JSONObject | protected
fromString(QString jsonText) (定义于 JSONObject) | JSONObject |
get(const QString &key) const (定义于 JSONObject) | JSONObject | inline
init() (定义于 JSONObject) | JSONObject | protected
jsonKey() const (定义于 JSONObject) | JSONObject | protected
JSONObject(const QString &key="") (定义于 JSONObject) | JSONObject |
jsonValue() const (定义于 JSONObject) | JSONObject | protected
key() const (定义于 JSONObject) | JSONObject |
m_index (定义于 JSONObject) | JSONObject | protected
m_key (定义于 JSONObject) | JSONObject | protected
m_list (定义于 JSONObject) | JSONObject | protected
m_type (定义于 JSONObject) | JSONObject | protected
m_value (定义于 JSONObject) | JSONObject | protected
newKey(const QString &key) (定义于 JSONObject) | JSONObject | inlineprotected
parent (定义于 JSONObject) | JSONObject | protected
parseKey(QString &Value, const wchar_t *ptr) (定义于 JSONObject) | JSONObject | protected
parseNumber(QString &Value, const wchar_t *ptr) (定义于 JSONObject) | JSONObject | protected
parseValue(QString Key, const wchar_t *ptr) (定义于 JSONObject) | JSONObject | protected
quote(const QString &Text) (定义于 JSONObject) | JSONObject | static
setKey(const QString &value) (定义于 JSONObject) | JSONObject |
setType(int value) (定义于 JSONObject) | JSONObject | inline
skip(const wchar_t *in) (定义于 JSONObject) | JSONObject | inlineprotectedstatic
toString() const (定义于 JSONObject) | JSONObject | virtual
type() const (定义于 JSONObject) | JSONObject | inline
value() const (定义于 JSONObject) | JSONObject |
value(const QString &key) const (定义于 JSONObject) | JSONObject | inline
value(const QString &key, QVariant &v) const (定义于 JSONObject) | JSONObject |
ValueTypeFlag 枚举名称 (定义于 JSONObject) | JSONObject |
vtfArray 枚举值 (定义于 JSONObject) | JSONObject |
vtfBool 枚举值 (定义于 JSONObject) | JSONObject |
vtfDateTime 枚举值 (定义于 JSONObject) | JSONObject |
vtfDouble 枚举值 (定义于 JSONObject) | JSONObject |
vtfInt 枚举值 (定义于 JSONObject) | JSONObject |
vtfNull 枚举值 (定义于 JSONObject) | JSONObject |
vtfObject 枚举值 (定义于 JSONObject) | JSONObject |
vtfString 枚举值 (定义于 JSONObject) | JSONObject |
~JSONObject() (定义于 JSONObject) | JSONObject | virtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
LineEdit 成员列表

成员的完整列表，这些成员属于 LineEdit,包括所有继承而来的类成员

contextMenuEvent(QContextMenuEvent *event) (定义于 LineEdit) | LineEdit | protectedvirtual
data | LineEdit |
data() const (定义于 LineEdit) | LineEdit |
dataChanged(const QVariant &userData) | LineEdit | signal
doubleClicked() | LineEdit | signal
labelText | LineEdit |
labelText() const (定义于 LineEdit) | LineEdit |
labelTextChanged(const QString &labelText) | LineEdit | signal
LineEdit(QWidget *parent=0) (定义于 LineEdit) | LineEdit |
mouseDoubleClickEvent(QMouseEvent *event) (定义于 LineEdit) | LineEdit | protectedvirtual
paintEvent(QPaintEvent *event) (定义于 LineEdit) | LineEdit | protectedvirtual
setData(const QVariant &userData) | LineEdit | slot
setLabelText(const QString &labelText) | LineEdit | slot
~LineEdit() (定义于 LineEdit) | LineEdit | virtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
LogTiny 成员列表

成员的完整列表，这些成员属于 LogTiny,包括所有继承而来的类成员

debug(const QString &S, const QString &SourceName="", int SourceLine=0) | LogTiny | inline
setAppFile(const QString &AppFile) | LogTiny |
setLogFile(const QString &LogFile) | LogTiny |
write(const QString &S, const QString &SourceName="", int SourceLine=0) | LogTiny |


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
MSExcel 成员列表

成员的完整列表，这些成员属于 MSExcel,包括所有继承而来的类成员

addBook() | MSExcel |
Alignment 枚举名称 | MSExcel |
cellAlign(int row, int col, Alignment hAlign, Alignment vAlign) (定义于 MSExcel) | MSExcel |
cellFormat(int row, int col, const QString &format) (定义于 MSExcel) | MSExcel |
close() | MSExcel |
colEnd() const | MSExcel | inline
colStart() const | MSExcel | inline
create(const QString &filename="") | MSExcel |
currentSheet() | MSExcel |
kick() | MSExcel |
MSExcel() | MSExcel |
open(const QString &filename="") | MSExcel |
read(int row, int col) | MSExcel |
rowEnd() const | MSExcel | inline
rowStart() const | MSExcel | inline
save(const QString &filename="") | MSExcel |
setCaption(const QString &value) | MSExcel |
setVisible(bool value) | MSExcel |
sheet(int index) | MSExcel |
sheetCount() | MSExcel |
sheetName() const | MSExcel | inline
sheetNames() | MSExcel |
usedRange() | MSExcel |
write(int row, int col, const QVariant &value) | MSExcel |
xlBottom 枚举值 | MSExcel |
xlCenter 枚举值 | MSExcel |
xlLeft 枚举值 | MSExcel |
xlRight 枚举值 | MSExcel |
xlTop 枚举值 | MSExcel |
~MSExcel() | MSExcel | virtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
MSSQL 成员列表

成员的完整列表，这些成员属于 MSSQL,包括所有继承而来的类成员

availableODBCDrivers() MSSQL static


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
MarqueeLabel 成员列表

成员的完整列表，这些成员属于 MarqueeLabel,包括所有继承而来的类成员

enterEvent(QEvent *event) (定义于 MarqueeLabel) | MarqueeLabel | protectedvirtual
leaveEvent(QEvent *event) (定义于 MarqueeLabel) | MarqueeLabel | protectedvirtual
MarqueeLabel(QWidget *parent=0, Qt::WindowFlags f=0) (定义于 MarqueeLabel) | MarqueeLabel |
MarqueeLabel(const QString &text, QWidget *parent=0, Qt::WindowFlags f=0) (定义于 MarqueeLabel) | MarqueeLabel |
resizeEvent(QResizeEvent *event) (定义于 MarqueeLabel) | MarqueeLabel | protectedvirtual
setText(const QString &text) (定义于 MarqueeLabel) | MarqueeLabel | slot
~MarqueeLabel() (定义于 MarqueeLabel) | MarqueeLabel | virtual


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
OS 成员列表

成员的完整列表，这些成员属于 OS,包括所有继承而来的类成员

language() | OS | static
login(const QString &Domain, const QString &UserID, const QString &Password) | OS | static
name() | OS | static


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Player 成员列表

成员的完整列表，这些成员属于 Player,包括所有继承而来的类成员

AUTH_ADMIN 枚举值 | Player |
AUTH_GUEST 枚举值 | Player |
AUTH_MANAGER 枚举值 | Player |
AUTH_SYSADMIN 枚举值 | Player |
AUTH_USER 枚举值 | Player |
AuthLevel 枚举名称 | Player |
authority(const QString &key) const | Player |
clear() | Player |
loggedIn | Player |
loggedIn() const | Player | inline
loginID() const | Player | inline
loginTime | Player |
loginTime() const | Player | inline
noLoginTime() | Player | inline
operator=(const Player &) | Player |
password() const | Player | inline
Player() | Player |
setAuthority(const QString &key, int auth) | Player | inline
setAuthorityText(const QString &value) | Player |
setAuthorityText(const QStringList &value) | Player |
setLoggedIn(bool value) | Player |
setLoggedIn() | Player | inline
setLoginID(const QString &value) | Player | inline
setLoginTime(QDateTime value) | Player | inline
setPassword(const QString &value) | Player | inline
setUserID(const QString &value) | Player | inline
setUserLevel(int value) | Player | inline
setUsername(const QString &value) | Player | inline
setUserNo(int value) | Player | inline
userID | Player |
userID() const | Player | inline
userLevel() const | Player | inline
username | Player |
username() const | Player | inline
userNo | Player |
userNo() const | Player | inline


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
SingleInstance 成员列表

成员的完整列表，这些成员属于 SingleInstance,包括所有继承而来的类成员

first() const | SingleInstance | inline
m_first | SingleInstance | protected
m_instanceName | SingleInstance | protected
m_localServer | SingleInstance | protected
m_localSocket | SingleInstance | protected
SingleInstance(QString instanceName) | SingleInstance | inline
SingleInstance(QObject *parent, QString instanceName) | SingleInstance | inline


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
String 成员列表

成员的完整列表，这些成员属于 String,包括所有继承而来的类成员

filter(const QString &findText, const QStringList &filters) | String | static
find(const QStringList &ss, const QString &s) | String | static
findOf(const QStringList &list, const QString &key) | String | static
first(QByteArray &str, const QByteArray &split="\t") | String | static
getTextByIndex(const char *strings, int index) | String | static
splitHumanName(QString full, QString &sur, QString &real, QString &english) | String | static
String() (定义于 String) | String |


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
StringList 成员列表

成员的完整列表，这些成员属于 StringList,包括所有继承而来的类成员

lineBreak() const | StringList | inline
lineBreak(const QString &value) | StringList | inline
loadFrom(const QString &fileName) | StringList |
saveTo(const QString &fileName) | StringList |
StringList() (定义于 StringList) | StringList |


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
TreeWidgetHeaderSetupDialog 成员列表

成员的完整列表，这些成员属于 TreeWidgetHeaderSetupDialog,包括所有继承而来的类成员

setHeader(QTreeWidget *view, int max=-1) | TreeWidgetHeaderSetupDialog |
TreeWidgetHeaderSetupDialog(QWidget *parent=0) (定义于 TreeWidgetHeaderSetupDialog) | TreeWidgetHeaderSetupDialog | explicit
~TreeWidgetHeaderSetupDialog() (定义于 TreeWidgetHeaderSetupDialog) | TreeWidgetHeaderSetupDialog |


Tianchi: 成员列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
Utils 成员列表

成员的完整列表，这些成员属于 Utils,包括所有继承而来的类成员

complieDateTime(const QString &complieDate, const QString &complieTime) | Utils | static
getIDCardVerifyCode(const QByteArray &id) | Utils | static
StringToMap(const QString &mapStrings) | Utils | static
StringToMap(const QStringList &mapStrings) | Utils | static
toDateTime(const QString &text) | Utils | static
typeFrom(QVariant::Type type) | Utils | static
typeFrom(const QVariant &v) | Utils | inlinestatic
YYYY_MM_DD_HH_MM_SS() | Utils | static
YYYY_MM_DD_HH_MM_SS_ZZZ() | Utils | static


Tianchi: 首页

Tianchi 文档


Tianchi: D:/work/Tianchi/xchinux_tianchi/inc/tianchi.h 源文件

  • 文件列表
  • 文件成员
  • inc
tianchi.h
浏览该文件的文档.
1 // ********************************************************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // ********************************************************************************************************************
7 // 文档说明：引用单元头文件
8 // ====================================================================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------------------------------------------------
12 // 2013.04.16 圣域天子 建立
13 // ====================================================================================================================
15 #ifndef TIANCHI_H
16 #define TIANCHI_H
17
18 #include "Chinese/Chinese.h"
19
20 #include "Core/Classes.h"
21 #include "Core/Common.h"
22 #include "Core/String.h"
23 #include "Core/Utils.h"
24
25 #include "File/Directory.h"
26 #include "File/FileUtils.h"
27 #include "File/Json.h"
28 #include "File/LogTiny.h"
29 #include "File/MSExcel.h"
30
31 #include "Gui/ClickLabel.h"
32 #include "Gui/DateEdit.h"
33 #include "Gui/GuiUtils.h"
34 #include "Gui/MarqueeLabel.h"
35 #include "Gui/TreeWidgetHeaderSetupDialog.h"
36
37 #include "Network/DownloadHttp.h"
38 #include "Network/SingleInstance.h"
39
40 #include "OS/OS.h"
41
42 #include "Sql/MSSQL.h"
43
44 #endif // TIANCHI_H