Tianchi: 命名空间列表

Tianchi v0.0.2 build 20130701
C++ library for Qt with VC & mingW
  • 首页
  • 命名空间
  • 类
  • 文件
  • 命名空间列表
命名空间列表
这里列出了所有文档化的命名空间定义,附带简要说明:
\ N _tc_tuple_ns_ 简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: _tc_tuple_ns_ 命名空间参考

  • 命名空间
  • 类
  • 文件
  • 命名空间列表
类
_tc_tuple_ns_ 命名空间参考

简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版 更多...

类

class null_type

详细描述

简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版

作者
cnhem.nosp@m.iya@.nosp@m.gmail.nosp@m..com
日期
2013-05-25
示例:
int main()
{
TcTuple<int, double> demo;
demo.set0(99);
demo.set1(3.14);
cout << demo.get0() << endl;
cout << demo.get1() << endl;
}
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
类列表
这里列出了所有类、结构、联合以及接口定义等，并附带简要说明:
[详情级别 12]
o N _tc_tuple_ns_ | 简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版
| \ C null_type |
o C TcChinese | 汉语相关处理类
o C TcClickLabel | Emit clicked() signal's label while mouse clicked
o C TcCursorBusy | 后台忙光标的设置和自动恢复处理类
o C TcCursorCustom | 光标形态变化类的根类，一般不直接使用
o C TcCursorWait | 等待光标的设置和自动恢复处理类
o C TcDataAccess |
o C TcDataAccessStatement |
o C TcDatabase |
| \ C SQLContext |
o C TcDateEdit | 可以输入或显示为空的日期选择控件
o C TcDBFields | Key=value 数据格式转换类
o C TcDir |
o C TcDownload | 用于下载文件（或文件的一部分） 注意：此类尚未进行严格测试
o C TcDownloadList | 用于管理文件的下载
o C TcExcelReader | Simple excel reader class, limit to read first sheet
o C TcFile | 文件操作常用处理类
o C TcFileIO | 一些文件复制和提取功能的类
o C TcFlowLayout | 流式布局FlowLayout
o C TcFormUtils |
o C TcFunctionalSortFilterProxyModel | 依所设过滤参数(QVariantMap)来使用已设滤函数进行过滤的 SortFilterProxyModel,使用时分三部分:
o C TcGlowEffect | 发光效果的QGraphicsEffect
o C TcHeaderSetupDialog | 设置 QTreeWidget 标题的对话框
o C TcInvoke | 映射执行对象类
o C TcJSONObject | 兼容 Qt 4.x 的 JSON文生成和解析类
o C TcLineEdit | Extended QLineEdit widget
o C TcLog | 简单的文本文件输出日志。
o C TcMarqueeLabel | 跑马灯类MarqueeLabel,点击时自动打开网址
o C TcMSExcel | 通过 OLE 方式操作 Microsoft Excel
o C TcMSSQL | 读取 ODBC 驱动和版本信息
o C TcOperMode | 操作模式的标识常量
o C TcOracle | 读取 ODBC 驱动和版本信息
o C TcOS | 与操作系统相关的操作类
o C TcPlayer | 玩家信息类，常用在 C/S 中的客户端用户信息保存
o C TcSingleInstance | 应用程序单实例类
o C TcSingleton | 用指针实现的单例模式的模版类
o C TcSortPaginationTableView | 可排序和分页的TableView,使用时主要分两步:
o C TcString | 字符串功能增强与扩展
o C TcStringList | 字符串集功能增强与扩展
o C TcTreeEx | 把 QTreeWidget 的扩展功能，可直接导出到 Excel 中
o C TcTreeItem |
o C TcTuple |
o C TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > |
o C TcUdp |
o C TcUtils | 常用小功能综合函数集
\ C TcVariantMapTableModel | 以QVariantMap作为数据行的model,只可追加和清除,不可任意插入与任意 删除,使用时主要分成三部分：
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: _tc_tuple_ns_::null_type类 参考

  • 类成员
  • _tc_tuple_ns_
  • null_type
_tc_tuple_ns_::null_type类 参考
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: TcChinese类 参考

  • 类成员
静态 Public 成员函数 | 所有成员列表
TcChinese类 参考

汉语相关处理类 更多...

#include <tcchinese.h>

静态 Public 成员函数

static QString | firstPinyins (const QString &HzString)
static QString | toPinyin (const QString &Str, bool Tonality=false)
static QString | toChars (const QString &Str, bool Tonality=false)

详细描述

汉语相关处理类

注解
此类仅限在 Windows 下有效，使用时需要在 .pro 文件中加上 LIB += -lole32

成员函数说明

static QString TcChinese::firstPinyins ( const QString & HzString )
static

取得多个汉字的首字母

参数
[in] HzString 汉字字符串
返回
每个汉字拼音的首字符
示例:
qDebug()<<TIANCHI::Chinese::firstPinyins(QS("中华人民共和国"));
> zhrmghg
qDebug()<<TIANCHI::Chinese::firstPinyins(QS("中华大地Qt论坛 - www.qtcn.org"));
> zhddlt
static QString TcChinese::toChars | ( | const QString & | Str,
 |  | bool | Tonality = false
 | ) |  |
static

混合字符时，转换中不过滤英数符号等

参数
[in] | Str | 汉字字符串
[in] | Tonality | 音调不转换成拼音
返回
汉字的首字母
示例:
qDebug()<<TIANCHI::Chinese::toChars(QS("中华大地Qt论坛 - www.qtcn.org"), true);
> zhōnghuádàdìQtlùntán - www.qtcn.org
qDebug()<<TIANCHI::Chinese::toChars(QS("中华大地Qt论坛 - www.qtcn.org"));
> zhonghuadadiQtluntan - www.qtcn.org
static QString TcChinese::toPinyin | ( | const QString & | Str,
 |  | bool | Tonality = false
 | ) |  |
static

取得多个汉字的全部拼音

参数
[in] | Str | 汉字字符串
[in] | Tonality | 音调不转换成拼音
返回
汉语拼音
示例:
含音调的输出
qDebug()<<TIANCHI::Chinese::toPinyin(QS("中华人民共和国"), true);
> zhōnghuárénmíngònghéguó
不含音调的输出
qDebug()<<TIANCHI::Chinese::toPinyin(QS("中华人民共和国"), false);
> zhonghuarenmingongheguo
qDebug()<<TIANCHI::Chinese::toPinyin(QS("中华大地Qt论坛 - www.qtcn.org"));
> zhonghuadadiluntan
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/chinese/tcchinese.h
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: TcClickLabel类 参考

  • 类成员
信号 | Public 成员函数 | Protected 成员函数 | 所有成员列表
TcClickLabel类 参考

emit clicked() signal's label while mouse clicked 更多...

#include <tcclicklabel.h>

类 TcClickLabel 继承关系图:

信号

void clicked ()
emit when mouse click label

Public 成员函数

TcClickLabel (QWidget *parent=0, Qt::WindowFlags f=0)
TcClickLabel (const QString &text, QWidget *parent=0, Qt::WindowFlags f=0)

Protected 成员函数

virtual void | mousePressEvent (QMouseEvent *e)
virtual void | mouseReleaseEvent (QMouseEvent *e)

详细描述

emit clicked() signal's label while mouse clicked

该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcclicklabel.h


Tianchi: TcCursorBusy类 参考

  • 类成员
所有成员列表
TcCursorBusy类 参考

后台忙光标的设置和自动恢复处理类 更多...

#include <tcguiutils.h>

类 TcCursorBusy 继承关系图:
TcCursorCustom

额外继承的成员函数

- Public 成员函数 继承自 TcCursorCustom
void | restore ()
立即恢复最初的光标
- Protected 成员函数 继承自 TcCursorCustom
TcCursorCustom (Qt::CursorShape shape)
- Protected 属性 继承自 TcCursorCustom
QWidget * | m_parent
QCursor | m_cursor

详细描述

后台忙光标的设置和自动恢复处理类

示例:
void myForm::onClick()
{
TcCursorBusy busy; // 自动变成后台忙光标
... 处理代码 ...
} // 退出块时，busy 被释放，使光标自动恢复为原先的光标形态
参见
class CursorBusy
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-15
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcguiutils.h


Tianchi: TcCursorCustom类 参考

  • 类成员
Public 成员函数 | Protected 成员函数 | Protected 属性 | 所有成员列表
TcCursorCustom类 参考

光标形态变化类的根类，一般不直接使用 更多...

#include <tcguiutils.h>

类 TcCursorCustom 继承关系图:
TcCursorBusy TcCursorWait

Public 成员函数

void restore ()
立即恢复最初的光标

Protected 成员函数

TcCursorCustom (Qt::CursorShape shape)

Protected 属性

QWidget * | m_parent
QCursor | m_cursor

详细描述

光标形态变化类的根类，一般不直接使用

参见
class CursorWait
class CursorBusy
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-15
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcguiutils.h


Tianchi: TcCursorWait类 参考

  • 类成员
所有成员列表
TcCursorWait类 参考

等待光标的设置和自动恢复处理类 更多...

#include <tcguiutils.h>

类 TcCursorWait 继承关系图:
TcCursorCustom

额外继承的成员函数

- Public 成员函数 继承自 TcCursorCustom
void | restore ()
立即恢复最初的光标
- Protected 成员函数 继承自 TcCursorCustom
TcCursorCustom (Qt::CursorShape shape)
- Protected 属性 继承自 TcCursorCustom
QWidget * | m_parent
QCursor | m_cursor

详细描述

等待光标的设置和自动恢复处理类

示例:
void myForm::onClick()
{
TcCursorWait wait; // 自动变成等待光标
... 处理代码 ...
} // 退出块时，wait 被释放，使光标自动恢复为原先的光标形态
参见
class CursorBusy
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-15
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcguiutils.h


Tianchi: TcDataAccess类 参考

  • 类成员
Public 类型 | Public 成员函数 | 静态 Public 成员函数 | 所有成员列表
TcDataAccess类 参考

Public 类型

enum | AttrCase { CaseNatural, CaseLower, CaseUpper }
enum | AttrTrim { TrimNone, TrimAll }

Public 成员函数

TcDataAccess (const QString &connectionName=QLatin1String(QSqlDatabase::defaultConnection))
TcDataAccess (const QSqlDatabase &other)
QString | connectionName () const
QSqlQuery | sqlQuery () const
QSqlDatabase | sqlDatabase () const
QList< QVariantMap > | fetchAll (const QString &sql, const QVariantList &bind=QVariantList())
QList< QVariantMap > | fetchAll (const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList())
QList< QVariantList > | fetchAllList (const QString &sql, const QVariantList &bind=QVariantList())
QList< QVariantList > | fetchAllList (const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList())
QVariantMap | fetchRow (const QString &sql, const QVariantList &bind=QVariantList())
QVariantMap | fetchRow (const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList())
QVariantList | fetchCol (const QString &sql, const QVariantList &bind=QVariantList())
QVariantList | fetchCol (const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList())
QVariant | fetchOne (const QString &sql, const QVariantList &bind=QVariantList())
QVariant | fetchOne (const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList())
template<typename T >
QMap< T, QVariant > | fetchPairs (const QString &sql, const QVariantList &bind=QVariantList())
template<typename T >
QMap< T, QVariant > | fetchPairs (const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList())
template<typename T >
QMap< T, QVariantMap > | fetchAssoc (const QString &sql, const QVariantList &bind=QVariantList())
template<typename T >
QMap< T, QVariantMap > | fetchAssoc (const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList())
QString | limitPage (const QString &sql, int page, int rowCount) const
QString | limit (const QString &sql, int count, int offset=0) const
QVariant | lastInsertId (const QString &table=QString(), const QString &primaryKey=QString()) const
QSqlError | lastError () const
int | doDelete (const QString &table, const QString &where=QString(), const QVariantList &bind=QVariantList())
int | doUpdate (const QString &table, const QVariantMap &field, const QString &where=QString(), const QVariantList &bind=QVariantList())
int | doInsert (const QString &table, const QVariantMap &field)
TcDataAccess & | operator= (const TcDataAccess &da)
TcDataAccess & | operator= (const QSqlDatabase &db)

静态 Public 成员函数

static AttrCase | attrCase ()
static AttrTrim | attrTrim ()
static void | setAttrCase (AttrCase attrCase)
static void | setAttrTrim (AttrTrim attrTrim)
static TcDataAccess * | db (const QString &connectionName=QLatin1String(QSqlDatabase::defaultConnection))
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcdataaccess.h


Tianchi: TcDataAccessStatement类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcDataAccessStatement类 参考

Public 成员函数

TcDataAccessStatement (const TcDataAccessStatement &da)
TcDataAccessStatement (const QString &table, const QString &fields=QString("*"))
void | clear ()
TcDataAccessStatement & | select (const QString &fields=QString("*"))
TcDataAccessStatement & | from (const QString &tables)
TcDataAccessStatement & | leftJoin (const QString &table, const QString &cond, const QVariantList &bind=QVariantList())
TcDataAccessStatement & | where (const QString &expr, const QVariantList &bind=QVariantList())
TcDataAccessStatement & | orWhere (const QString &expr, const QVariantList &bind=QVariantList())
TcDataAccessStatement & | group (const QString &fields)
TcDataAccessStatement & | order (const QString &fields)
TcDataAccessStatement & | limit (int count, int offset=0)
TcDataAccessStatement & | limitPage (int page, int rowCount)
QString | toString () const
QString | whereString () const
QVariantList | whereBind () const
QVariantList | bind () const
TcDataAccessStatement & | operator= (const TcDataAccessStatement &da)
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcdataaccess.h


Tianchi: TcDatabase类 参考

  • 类成员
类 | Public 类型 | Public 成员函数 | 静态 Public 成员函数 | Public 属性 | Protected 成员函数 | Protected 属性 | 所有成员列表
TcDatabase类 参考

类

struct SQLContext

Public 类型

enum DBType { SQLSERVER = 1, SQLITE = 11 }

Public 成员函数

void | setDatabase (int dbType, const QString &hostName, int hostPort, const QString &dbName, const QString &username, const QString &password)
设置网络数据库
bool | setDatabase (const QString &typeName, const QString &hostName, int hostPort, const QString &dbName, const QString &username, const QString &password)
设置网络数据库
void | setDatabase (int dbType, const QString &dbName, const QString &username=QString(), const QString &password=QString())
设置本地数据库
bool | setDatabase (const QString &typeName, const QString &dbName, const QString &username=QString(), const QString &password=QString())
设置本地数据库
QString | lastError ()
int | dbType () const
QString | typeName () const
QString | hostName () const
int | hostPort () const
QString | dbName () const
QSqlDatabase | handle () const
int | sqlCount () const
int | open ()
void | close ()
关闭数据库 更多...
bool | isOpened () const
数据库是否已打开
void | loadEngine ()
重新载入数据库的操作SQL集
void | loadEngine (const QString &filename)
载入数据库的操作SQL集
bool | exec (int &result, const QString &sqlID, const TcParams &prams, int userNo=0, const QString &userID=QString(), const QString &username=QString())
执行操作SQLID，无返回数据集
bool | exec (QVariantList &list, const QString &sqlID, const TcParams &params, int userNo=0, const QString &userID=QString(), const QString &username=QString())
执行操作SQLID，可返回数据集
int | exec (int &result, QVariantList &list, const QString &sqlID, const TcParams &params, int userNo=0, const QString &userID=QString(), const QString &username=QString())
执行操作SQLID，可返回数据集
int | exec (int &result, QList< QByteArray > &list, const QString &sqlID, const TcParams &params, int userNo=0, const QString &userID=QString(), const QString &username=QString())
执行操作SQLID，可返回数据集

静态 Public 成员函数

static char | typeFrom (QVariant::Type type)
static int | dbType (const QString &typeName)
static TcParams | addParams (const QStringList &keys, const QList< QByteArray > &values)

Public 属性

QString | CreateDDL
本地数据库不存在时，使用此DDL进行重建
QString | SqlLibrary
QStringList | errors
数据库操作时的错误信息

Protected 成员函数

void | clearComment (QString &s)
QSqlQuery * | prepare (const QString &sqlID, TcParams prams, QString &error, int userNo=0, const QString &userID=QString(), const QString &username=QString())
数据库操作准备, 注意 params 的 key 必须全小写

Protected 属性

int | m_dbType
QString | m_typeName
QString | m_hostName
int | m_hostPort
QString | m_dbName
QString | m_username
QString | m_password
QSqlDatabase | m_handle
QString | m_engineFile
QHash< QString, SQLContext > | m_sqls

成员函数说明

void TcDatabase::close ( )

关闭数据库

参见
open
int TcDatabase::open ( )

打开数据库

返回
操作结果 1 操作成功 0 操作失败 -1 数据库无法创建或更新 -2 数据库不兼容 -3 版本太新，程序不支持
参见
close
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcdatabase.h


Tianchi: TcDatabase::SQLContext结构体 参考

  • 类成员
  • TcDatabase
  • SQLContext
Public 属性 | 所有成员列表
TcDatabase::SQLContext结构体 参考

Public 属性

QString | id
QString | text
QMultiHash< QString, QString > | params
该结构体的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcdatabase.h


Tianchi: TcDateEdit类 参考

  • 类成员
Public 成员函数 | Protected 成员函数 | 属性 | 所有成员列表
TcDateEdit类 参考

可以输入或显示为空的日期选择控件 更多...

#include <tcdateedit.h>

类 TcDateEdit 继承关系图:

Public 成员函数

TcDateEdit (QWidget *parent=0)
QDate | date () const
void | setDate (QDate value)
void | unsetDate ()
void | setDate (QDateTime value)

Protected 成员函数

void | focusInEvent (QFocusEvent *e)
void | mousePressEvent (QMouseEvent *e)

属性

QDate date

详细描述

可以输入或显示为空的日期选择控件

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcdateedit.h


Tianchi: TcDBFields类 参考

  • 类成员
Public 成员函数 | 静态 Public 成员函数 | 所有成员列表
TcDBFields类 参考

key=value 数据格式转换类 更多...

#include <tcclasses.h>

Public 成员函数

TcDBFields (QHash< QString, QByteArray > fields)
void | setFields (QHash< QString, QByteArray > fields)
QByteArray | value (const QString &key) const

静态 Public 成员函数

static void | addField (QByteArray &fieldBytes, const QString &name, const QVariant &value)
static QHash< QString, QByteArray > | getFields (const QByteArray &fieldBytes)

详细描述

key=value 数据格式转换类

注解
C/S 架构中，所以信息都以 key=value 格式传递，此类用于 k=v 信息的读取
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcclasses.h


Tianchi: TcDir类 参考

  • 类成员
信号 | Public 成员函数 | 所有成员列表
TcDir类 参考

#include <tcdir.h>

类 TcDir 继承关系图:

信号

void currentFile (int count, const QString &name)
信号：当前复制的文件的计数和文件名 更多...

Public 成员函数

TcDir (QObject *parent=0)
QStringList | findFiles (const QString &path, const QStringList &nameFilters=QStringList())
查找文件夹内所有的文件 更多...
int | copyDirs (const QString &fromPath, const QString &toPath, const QStringList &nameFilters=QStringList(), bool overWrite=true)
复制目录树下所有的文件到新文件夹 更多...
int | copyFiles (const QStringList &files, const QString &toPath, bool overWrite=true)
复制文件列表到新文件夹 更多...
void | resetCopyFileCount ()
重置m_copyFileCount为0

详细描述

作者
南果梨 cnhem.nosp@m.iya@.nosp@m.gmail.nosp@m..com
日期
2013-04-21

成员函数说明

int TcDir::copyDirs | ( | const QString & | fromPath,
 |  | const QString & | toPath,
 |  | const QStringList & | nameFilters = QStringList(),
 |  | bool | overWrite = true
 | ) |  |

复制目录树下所有的文件到新文件夹

参数
fromPath | 源文件夹
toPath | 目的文件夹
nameFilters | 文件过滤
overWrite | 是否覆盖
返回
复制的文件数量
int TcDir::copyFiles | ( | const QStringList & | files,
 |  | const QString & | toPath,
 |  | bool | overWrite = true
 | ) |  |

复制文件列表到新文件夹

参数
files | 源文件列表
toPath | 目的文件夹
overWrite | 是否覆盖
返回
复制的文件数量
void TcDir::currentFile | ( | int | count,
 |  | const QString & | name
 | ) |  |
signal

信号：当前复制的文件的计数和文件名

参数
count | 第几个文件
name | 源文件名
QStringList TcDir::findFiles | ( | const QString & | path,
 |  | const QStringList & | nameFilters = QStringList()
 | ) |  |

查找文件夹内所有的文件

参数
path | 要查找的文件夹
nameFilters | 文件过滤
返回
找到的文件列表
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcdir.h


Tianchi: TcDownload类 参考

  • 类成员
Public 槽 | 信号 | Public 成员函数 | 所有成员列表
TcDownload类 参考

用于下载文件（或文件的一部分） 注意：此类尚未进行严格测试 更多...

#include <tcdownloadhttp.h>

类 TcDownload 继承关系图:

Public 槽

void | FinishedSlot ()
void | HttpReadyRead ()

信号

void DownloadFinished ()

Public 成员函数

TcDownload (int index, QObject *parent=0)
void StartDownload (const QUrl &url, QFile *file, qint64 startPoint=0, qint64 endPoint=-1)

详细描述

用于下载文件（或文件的一部分） 注意：此类尚未进行严格测试

作者
来自互联网
日期
2013-04-19
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/network/tcdownloadhttp.h


Tianchi: TcDownloadList类 参考

  • 类成员
信号 | Public 成员函数 | 所有成员列表
TcDownloadList类 参考

用于管理文件的下载 更多...

#include <tcdownloadhttp.h>

类 TcDownloadList 继承关系图:

信号

void FileDownloadFinished ()

Public 成员函数

TcDownloadList (QObject *parent=0)
void | StartFileDownload (const QString &url, int count)
qint64 | GetFileSize (QUrl url)

详细描述

用于管理文件的下载

该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/network/tcdownloadhttp.h


Tianchi: TcExcelReader类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcExcelReader类 参考

simple excel reader class, limit to read first sheet 更多...

#include <tcexcelreader.h>

Public 成员函数

bool | isNull () const
if is null, it can do nothing
bool | open (const QString &file)
open excel file, success to return true
QVariant | cell (int row, int col)
read cell's value 更多...
int | sheetCount ()
get sheets count
QStringList | sheetNames ()
get sheets name list
bool | setCurrentSheet (int index)
set current sheet by index(from 1 start)
bool | setCurrentSheet (const QString &sheetName)
set current sheet by name
int | currentSheetIndex ()
get current sheet index(from 1 start)
QString | currentSheetName ()
get current sheet name

详细描述

simple excel reader class, limit to read first sheet

作者
XChinux xchin.nosp@m.ux@q.nosp@m.tcn.o.nosp@m.rg
日期
2013-05-02

成员函数说明

QVariant TcExcelReader::cell | ( | int | row,
 |  | int | col
 | ) |  |

read cell's value

参数
[in] | row,index | of row, from 1 start
[in] | col,index | of column, from 1 start
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcexcelreader.h


Tianchi: TcFile类 参考

  • 类成员
静态 Public 成员函数 | 所有成员列表
TcFile类 参考

文件操作常用处理类 更多...

#include <tcfile.h>

静态 Public 成员函数

static bool | loadFromFile (QString &context, const QString &filename, const QString &codec=QString())
装载文本文件,参数codec指定读取的编码,若为空,则不预设
static QString | uniqueFileName (const QString &dir, const QString &fileTemplate, const QString &suffix=QString())
在指定目录中返回一个临时文件名 更多...
static QString | fileVersion (const QString &exeFile)
取执行文件的版本，仅支持 Windows 更多...
static QStringList | searchFiles (const QString &path)
从目录及子目录中检索出所有文件名

详细描述

文件操作常用处理类

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-15

成员函数说明

static QString TcFile::fileVersion ( const QString & exeFile )
static

取执行文件的版本，仅支持 Windows

参数
[in] exeFile 包含版本信息的文件名(.exe, .dll等)
返回
版本信息(xxx.xxx.xxx.xxx)
static QString TcFile::uniqueFileName | ( | const QString & | dir,
 |  | const QString & | fileTemplate,
 |  | const QString & | suffix = QString()
 | ) |  |
static

在指定目录中返回一个临时文件名

返回
返回临时文件名，注意不创建该文件
注解
此方法不会自动创建文件
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcfile.h


Tianchi: TcFileIO类 参考

  • 类成员
静态 Public 成员函数 | 静态 Public 属性 | 所有成员列表
TcFileIO类 参考

一些文件复制和提取功能的类 更多...

#include <tcfileio.h>

静态 Public 成员函数

static qint64 | copy (const QString &fromFile, const QString &toFile, qint64 bufferSize=defaultBufferSize)
复制文件 更多...
static qint64 | copy (const QString &fromFile, const QString &toFile, qint64 fromFileOffset, qint64 copySize=-1, qint64 bufferSize=defaultBufferSize)
复制文件 更多...
static qint64 | append (const QString &fromFile, const QString &toFile, qint64 bufferSize=defaultBufferSize)
从源文件追加复制到目的文件结尾处 更多...
static qint64 | append (const QString &fromFile, const QString &toFile, qint64 fromFileOffset, qint64 appendSize=-1, qint64 bufferSize=defaultBufferSize)
从源文件追加复制到目的文件结尾处 更多...
static int | split (const QString &fromFile, const QString &toDir, qint64 splitSize, qint64 bufferSize=defaultBufferSize)
按字节分解文件 更多...
static qint64 | join (const QStringList &fromFileList, const QString &toFile, qint64 bufferSize=defaultBufferSize)
按字节合并文件 更多...
static qint64 | makeDummyFile (const QString &fileName, qint64 fileSize, const char fill=0x00, qint64 bufferSize=defaultBufferSize)
生成指定字符填充的“大笨蛋”文档，常用于光盘映像 更多...

静态 Public 属性

static const int | KB
1KB = 1024
static const int | MB
1MB = 1024 * 1024 = 1048576
static const int | GB
1GB = 1024 * 1024 * 1024 = 1073741824
static const int | defaultBufferSize
默认的缓冲大小 4MB

详细描述

一些文件复制和提取功能的类

作者
cnhem.nosp@m.iya@.nosp@m.gmail.nosp@m..com
日期
2013-05-24

成员函数说明

static qint64 TcFileIO::append | ( | const QString & | fromFile,
 |  | const QString & | toFile,
 |  | qint64 | bufferSize = defaultBufferSize
 | ) |  |
static

从源文件追加复制到目的文件结尾处

参数
fromFile | 源文件名
toFile | 目的文件名
bufferSize | 缓冲大小，默认是 defaultBufferSize
参见
defaultBufferSize
返回
追加复制的数据大小
static qint64 TcFileIO::append | ( | const QString & | fromFile,
 |  | const QString & | toFile,
 |  | qint64 | fromFileOffset,
 |  | qint64 | appendSize = -1,
 |  | qint64 | bufferSize = defaultBufferSize
 | ) |  |
static

从源文件追加复制到目的文件结尾处

参数
fromFile | 源文件名
toFile | 目的文件名
fromFileOffset | 源文件相对于文件开始处的偏移量
appendSize | 追加复制的大小，默认是 -1，复制到源文件结尾处
bufferSize | 缓冲大小，默认是 defaultBufferSize
参见
defaultBufferSize
返回
追加复制的数据大小
static qint64 TcFileIO::copy | ( | const QString & | fromFile,
 |  | const QString & | toFile,
 |  | qint64 | bufferSize = defaultBufferSize
 | ) |  |
static

复制文件

参数
fromFile | 源文件名
toFile | 目的文件名
bufferSize | 缓冲大小，默认是 defaultBufferSize
参见
defaultBufferSize
返回
复制的数据大小
static qint64 TcFileIO::copy | ( | const QString & | fromFile,
 |  | const QString & | toFile,
 |  | qint64 | fromFileOffset,
 |  | qint64 | copySize = -1,
 |  | qint64 | bufferSize = defaultBufferSize
 | ) |  |
static

复制文件

参数
fromFile | 源文件名
toFile | 目的文件名
fromFileOffset | 源文件相对于文件开始处的偏移量
copySize | 复制的大小，默认是 -1，复制到源文件结尾处
bufferSize | 缓冲大小，默认是 defaultBufferSize
参见
defaultBufferSize
返回
复制的数据大小
static qint64 TcFileIO::join | ( | const QStringList & | fromFileList,
 |  | const QString & | toFile,
 |  | qint64 | bufferSize = defaultBufferSize
 | ) |  |
static

按字节合并文件

参数
fromFileList | 源文件列表
toFile | 目的文件名
bufferSize | 缓冲大小，默认是 defaultBufferSize
参见
defaultBufferSize
返回
合并的数据
static qint64 TcFileIO::makeDummyFile | ( | const QString & | fileName,
 |  | qint64 | fileSize,
 |  | const char | fill = 0x00,
 |  | qint64 | bufferSize = defaultBufferSize
 | ) |  |
static

生成指定字符填充的“大笨蛋”文档，常用于光盘映像

参数
fileName | 生成的文件名
fileSize | 文件大小
fill | 填充字符，默认 0x00
bufferSize | 缓冲大小，默认是 defaultBufferSize
参见
defaultBufferSize
返回
生成的数据大小
static int TcFileIO::split | ( | const QString & | fromFile,
 |  | const QString & | toDir,
 |  | qint64 | splitSize,
 |  | qint64 | bufferSize = defaultBufferSize
 | ) |  |
static

按字节分解文件

参数
fromFile | 源文件名
toDir | 目的文件夹
splitSize | 分解后单个文件大小
bufferSize | 缓冲大小，默认是 defaultBufferSize
参见
defaultBufferSize
返回
分解后的文件个数
示例:
如果源文件是 d:\123.iso，目的文件夹是d:\11，
分解后的文件名是123.iso.1,123.iso.2,...这种形式
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcfileio.h


Tianchi: TcFlowLayout类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcFlowLayout类 参考

流式布局FlowLayout 更多...

#include <tcflowlayout.h>

类 TcFlowLayout 继承关系图:

Public 成员函数

TcFlowLayout (QWidget *parent, int margin=-1, int hSpacing=-1, int vSpacing=-1)
TcFlowLayout (int margin=-1, int hSpacing=-1, int vSpacing=-1)
void | addItem (QLayoutItem *item)
int | horizontalSpacing () const
int | verticalSpacing () const
Qt::Orientations | expandingDirections () const
bool | hasHeightForWidth () const
int | heightForWidth (int) const
int | count () const
QLayoutItem * | itemAt (int index) const
QSize | minimumSize () const
void | setGeometry (const QRect &rect)
QSize | sizeHint () const
QLayoutItem * | takeAt (int index)

详细描述

流式布局FlowLayout

该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcflowlayout.h


Tianchi: TcFormUtils类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcFormUtils类 参考

Public 成员函数

QWidget * | parentForm () const
void | setParentForm (QWidget *value)
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcformutils.h


Tianchi: TcFunctionalSortFilterProxyModel类 参考

  • 类成员
Public 槽 | Public 成员函数 | Protected 成员函数 | 所有成员列表
TcFunctionalSortFilterProxyModel类 参考

依所设过滤参数(QVariantMap)来使用已设滤函数进行过滤的 SortFilterProxyModel,使用时分三部分: 更多...

#include <tcfunctionalsortfilterproxymodel.h>

类 TcFunctionalSortFilterProxyModel 继承关系图:

Public 槽

void setFilterParam (const QVariantMap &param)
设定过滤参数

Public 成员函数

TcFunctionalSortFilterProxyModel (QObject *parent=0)
void setFilterFunction (TcFunctionalSortFilterProxyModelFilterFunction func)
设定过滤函数

Protected 成员函数

virtual bool filterAcceptsRow (int source_row, const QModelIndex &source_parent) const

详细描述

依所设过滤参数(QVariantMap)来使用已设滤函数进行过滤的 SortFilterProxyModel,使用时分三部分:

        1. 定义过滤函数
        2. 创建TcFunctionalSortFilterProxyModel实例，并设定过滤函数
        3. 条件改变时，调用setFilterParam()应用过滤参数并使其生效

1.先定义过滤函数(示例为MyFilter)

bool MyFilter(const QVariantMap &param, const QModelIndex &index)
{
QModelIndex idx1 = index; // 第一列
QModelIndex idx2 = idx1.sibling(idx1.row(), 1); // 第二列
QString str1 = param["col1"].toString(); // 第一列过滤内容
QString str2 = param["col2"].toString(); // 第二列过滤内容
// 如果第一个过滤参数不为空，那么要求第一列显示字符串必须以str1开头
if (!str1.isEmpty())
{
if (idx1.data(Qt::DisplayRole).toString().indexOf(str1) != 0)
{
return false;
}
}
// 如果第二个过滤参数不为空，那么要求第二列显示字符串必须包含str2
if (!str2.isEmpty())
{
if (idx2.data(Qt::DisplayRole).toString().indexOf(str1) == -1)
{
return false;
}
}
return true;
}

2.创建模型时，设置过滤函数

model = new QStandardItemModel(this);
......
TcFunctionalSortFilterProxyModel *proxy =
new TcFunctionalSortFilterProxyModel(this);
proxy->setFilterFunction(&MyFilter);
proxy->setSourceModel(model);

3.设置完过滤条件后，调用setFilterParam()来应用过滤参数

QVariantMap param;
param["col1"] = "0102"; // 假设要求过滤以"0102"开头的字符串
param["col2"] = "HFX"; // 假设要求过滤包含"HFX"的字符串
proxy->setFilterParam(param);
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcfunctionalsortfilterproxymodel.h


Tianchi: TcGlowEffect类 参考

  • 类成员
Public 成员函数 | Protected 成员函数 | 所有成员列表
TcGlowEffect类 参考

发光效果的QGraphicsEffect 更多...

#include <tcgloweffect.h>

类 TcGlowEffect 继承关系图:

Public 成员函数

TcGlowEffect (QObject *parent=0)
void | setRadius (int radius)
set radius 更多...
void | setGlowColor (const QColor &color)
set glow color 更多...
virtual QRectF | boundingRectFor (const QRectF &sourceRect) const

Protected 成员函数

virtual void | draw (QPainter *painter)
virtual void | sourceChanged (ChangeFlags flags)

详细描述

发光效果的QGraphicsEffect

示例:
GlowEffect *effect = new GlowEffect(this);
effect->setRadius(5);
effect->setGlowColor(Qt::blue);
lbl->setGraphicsEffect(effect);
参见
setLogFile

成员函数说明

void TcGlowEffect::setGlowColor ( const QColor & color )

set glow color

参数
[in] QColor color
void TcGlowEffect::setRadius ( int radius )

set radius

参数
[in] int radius
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcgloweffect.h


Tianchi: TcHeaderSetupDialog类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcHeaderSetupDialog类 参考

设置 QTreeWidget 标题的对话框 更多...

#include <tcheadersetupdialog.h>

类 TcHeaderSetupDialog 继承关系图:

Public 成员函数

TcHeaderSetupDialog (QWidget *parent=0)
void setHeader (QTreeWidget *view, int max=-1)
指定 QTreeView 对象 更多...

详细描述

设置 QTreeWidget 标题的对话框

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员函数说明

void TcHeaderSetupDialog::setHeader | ( | QTreeWidget * | view,
 |  | int | max = -1
 | ) |  |

指定 QTreeView 对象

参数
[in] | view | QTreeView 对象
[in] | max | 最大设置的列数，超过部分将被忽略
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcheadersetupdialog.h


Tianchi: TcInvoke类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcInvoke类 参考

映射执行对象类 更多...

#include <tcclasses.h>

Public 成员函数

TcInvoke (QObject *o=NULL, QByteArray m="")
构造方法
TcInvoke & | operator= (const TcInvoke &from)
复制对象
bool | queued (QGenericArgument val0=QGenericArgument(0), QGenericArgument val1=QGenericArgument(), QGenericArgument val2=QGenericArgument(), QGenericArgument val3=QGenericArgument(), QGenericArgument val4=QGenericArgument(), QGenericArgument val5=QGenericArgument(), QGenericArgument val6=QGenericArgument(), QGenericArgument val7=QGenericArgument(), QGenericArgument val8=QGenericArgument(), QGenericArgument val9=QGenericArgument())
以队列方式调用映射方法
bool | invoke (QGenericArgument val0=QGenericArgument(0), QGenericArgument val1=QGenericArgument(), QGenericArgument val2=QGenericArgument(), QGenericArgument val3=QGenericArgument(), QGenericArgument val4=QGenericArgument(), QGenericArgument val5=QGenericArgument(), QGenericArgument val6=QGenericArgument(), QGenericArgument val7=QGenericArgument(), QGenericArgument val8=QGenericArgument(), QGenericArgument val9=QGenericArgument())
调用映射方法
bool | isValid () const
返回当前对象是否有效？ 更多...

详细描述

映射执行对象类

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员函数说明

bool TcInvoke::isValid ( ) const
inline

返回当前对象是否有效？

返回
true: 有效，可以进行映射方式的调用
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcclasses.h


Tianchi: TcJSONObject类 参考

  • 类成员
Public 类型 | Public 成员函数 | 静态 Public 成员函数 | Protected 成员函数 | 静态 Protected 成员函数 | Protected 属性 | 所有成员列表
TcJSONObject类 参考

兼容 Qt 4.x 的 JSON文生成和解析类 更多...

#include <tcjson.h>

Public 类型

enum ValueTypeFlag {
vtfObject = 0, vtfString = 1, vtfInt = 2, vtfDouble = 3,
vtfBool = 4, vtfDateTime =5, vtfNull =6, vtfArray =99
}

Public 成员函数

TcJSONObject (const QString &key="")
int | type () const
void | setType (int value)
QString | key () const
void | setKey (const QString &value)
QVariant | value () const
QVariant | value (const QString &key) const
bool | value (const QString &key, QVariant &v) const
bool | exists (const QString &key) const
int | count () const
TcJSONObject * | get (const QString &key) const
QList< TcJSONObject * > | children () const
TcJSONObject * | addObject (const QString &key="")
TcJSONObject * | addArray (const QString &key)
TcJSONObject * | addNull (const QString &key)
TcJSONObject * | add (const QString &key, const char *value)
TcJSONObject * | add (const QString &key, const QString &value)
TcJSONObject * | add (const QString &key, int value)
TcJSONObject * | add (const QString &key, double value)
TcJSONObject * | add (const QString &key, bool value)
TcJSONObject * | add (const QString &key, QDateTime value)
TcJSONObject * | addNull ()
TcJSONObject * | add (const char *value)
TcJSONObject * | add (const QString &value)
TcJSONObject * | add (int value)
TcJSONObject * | add (double value)
TcJSONObject * | add (bool value)
TcJSONObject * | add (QDateTime value)
void | deleteChildren (const QString &key)
void | clearChildren ()
void | clear ()
virtual QString | toString () const
bool | fromString (QString jsonText)

静态 Public 成员函数

static QString | quote (const QString &Text)
static QString | dequote (const QString &S)

Protected 成员函数

QString | jsonKey () const
QString | jsonValue () const
void | init ()
const wchar_t * | fromObject (const QString &Key, const wchar_t *ptr)
const wchar_t * | fromArray (const wchar_t *ptr)
QString | newKey (const QString &key)
const wchar_t * | parseKey (QString &Value, const wchar_t *ptr)
const wchar_t * | parseValue (QString Key, const wchar_t *ptr)
const wchar_t * | parseNumber (QString &Value, const wchar_t *ptr)

静态 Protected 成员函数

static const wchar_t * skip (const wchar_t *in)

Protected 属性

TcJSONObject * | parent
int | m_index
QMap< QString, TcJSONObject * > | m_list
ValueTypeFlag | m_type
QString | m_key
QVariant | m_value

详细描述

兼容 Qt 4.x 的 JSON文生成和解析类

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcjson.h


Tianchi: TcLineEdit类 参考

  • 类成员
Public 槽 | 信号 | Public 成员函数 | Protected 成员函数 | 属性 | 所有成员列表
TcLineEdit类 参考

extended QLineEdit widget 更多...

#include <tclineedit.h>

类 TcLineEdit 继承关系图:

Public 槽

void | setLabelText (const QString &labelText)
set labelText property
void | setData (const QVariant &userData)
set data property
void | clear ()
clear text/labelText/data property

信号

void | labelTextChanged (const QString &labelText)
emit this signal when labelText property changed
void | dataChanged (const QVariant &userData)
emit this signal when data property changed
void | doubleClicked ()
emit this signal when mouse double clicked

Public 成员函数

TcLineEdit (QWidget *parent=0)
QString | labelText () const
QVariant | data () const

Protected 成员函数

virtual void | paintEvent (QPaintEvent *event)
virtual void | mouseDoubleClickEvent (QMouseEvent *event)
virtual void | contextMenuEvent (QContextMenuEvent *event)

属性

QString | labelText
labelText property, shown in non-edit mode
QVariant | data
data property, save user's data

详细描述

extended QLineEdit widget

作者
XChinux XChin.nosp@m.ux@1.nosp@m.63.co.nosp@m.m
日期
2013-04-22
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tclineedit.h


Tianchi: TcLog类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcLog类 参考

简单的文本文件输出日志。 更多...

#include <tclog.h>

Public 成员函数

void | setAppFile (const QString &AppFile)
指定全路径的执行文件名，自动设置与执行文件同目录、同名，且后缀为 .log 的日志文件。 更多...
void | setLogFile (const QString &LogFile)
指定全路径的日志文件名。 更多...
void | write (const QString &S, const QString &SourceName=QString(), int SourceLine=0)
写日志 更多...
void | debug (const QString &S, const QString &SourceName=QString(), int SourceLine=0)
调试模式(Debug)下输出日志，在 Release 模式下没有作用。 更多...

详细描述

简单的文本文件输出日志。

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员函数说明

void TcLog::debug | ( | const QString & | S,
 |  | const QString & | SourceName = QString(),
 |  | int | SourceLine = 0
 | ) |  |
inline

调试模式(Debug)下输出日志，在 Release 模式下没有作用。

参数
[in] | S | 日志内容。
[in] | SourceName | 源文件名，建议用__FILE__作为参数。
[in] | SourceLine | 源文件行，建议用__LINE__作为参数。
void TcLog::setAppFile ( const QString & AppFile )

指定全路径的执行文件名，自动设置与执行文件同目录、同名，且后缀为 .log 的日志文件。

参数
[in] AppFile 执行文件名。
示例:
QApplication app(argc, argv);
TcLog log;
// 建议把执行文件名作为参数
log.setAppFile(app.applicationFilePath());
参见
setLogFile
void TcLog::setLogFile ( const QString & LogFile )

指定全路径的日志文件名。

参数
[in] LogFile 日志文件名。
示例:
log.setLogFile("C:\\Temp\\app.log");
参见
setAppFile
void TcLog::write | ( | const QString & | S,
 |  | const QString & | SourceName = QString(),
 |  | int | SourceLine = 0
 | ) |  |

写日志

参数
[in] | S | 日志内容。
[in] | SourceName | 源文件名，建议用__FILE__作为参数。
[in] | SourceLine | 源文件行，建议用__LINE__作为参数。
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tclog.h


Tianchi: TcMarqueeLabel类 参考

  • 类成员
Public 类型 | Public 槽 | 信号 | Public 成员函数 | Protected 成员函数 | 属性 | 所有成员列表
TcMarqueeLabel类 参考

跑马灯类MarqueeLabel,点击时自动打开网址 更多...

#include <tcmarqueelabel.h>

类 TcMarqueeLabel 继承关系图:

Public 类型

enum Direction { RightToLeft = 0, BottomToTop = 1 }

Public 槽

void | reset ()
停止移动并且复位位置为0 更多...
void | setActive (bool active)
设置运行状态 更多...
void | setInterval (int msec)
设置每移动一像素所需时间 更多...
void | start ()
启动运行 setActive(bool active), stop()
void | stop ()
停止运行 更多...
void | setDirection (Direction direciton)
设置移动方向 更多...

信号

void | intervalChanged (int interval)
interval属性变化时发出此信号
void | activeChanged (bool active)
active属性变化时发出此信号
void | directionChanged (Direction direction)
direction属性变化时发出错信号

Public 成员函数

TcMarqueeLabel (QWidget *parent=0, Qt::WindowFlags f=0)
TcMarqueeLabel (const QString &text, QWidget *parent=0, Qt::WindowFlags f=0)
int | interval () const
返回interval
bool | isActive () const
返回当前状态
Direction | direction () const
void | setAlignment (Qt::Alignment align)

Protected 成员函数

virtual void | enterEvent (QEvent *event)
virtual void | leaveEvent (QEvent *event)
virtual void | resizeEvent (QResizeEvent *event)
virtual void | timerEvent (QTimerEvent *event)
virtual void | paintEvent (QPaintEvent *event)

属性

Direction | direction
int | interval
设置每移动一像素所需时间(毫秒)
bool | active
设置是否启动移动状态
Qt::Alignment | alignment

详细描述

跑马灯类MarqueeLabel,点击时自动打开网址

作者
XChinux XChin.nosp@m.ux@1.nosp@m.63.co.nosp@m.m
日期
2013-04-18

成员函数说明

void TcMarqueeLabel::reset ( )
slot

停止移动并且复位位置为0

参见
stop()
void TcMarqueeLabel::setActive ( bool active )
slot

设置运行状态

参见
start(), stop()
void TcMarqueeLabel::setDirection ( Direction direciton )
slot

设置移动方向

参见
direction(), directionChagned(Direction direction)
void TcMarqueeLabel::setInterval ( int msec )
slot

设置每移动一像素所需时间

参见
interval()
void TcMarqueeLabel::stop ( )
slot

停止运行

参见
setActive(bool active), start()
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcmarqueelabel.h


Tianchi: TcMSExcel类 参考

  • 类成员
Public 类型 | Public 成员函数 | 所有成员列表
TcMSExcel类 参考

通过 OLE 方式操作 Microsoft Excel 更多...

#include <tcmsexcel.h>

Public 类型

enum Alignment {
xlTop = -4160, xlLeft = -4131, xlRight = -4152, xlCenter = -4108,
xlBottom = -4107
}
设置方向的常数 更多...

Public 成员函数

TcMSExcel ()
构造方法
virtual | ~TcMSExcel ()
析构方法
bool | create (const QString &filename=QString())
创建一个Microsoft Excel文件
bool | open (const QString &filename=QString())
打开一个Microsoft Excel文件
void | save (const QString &filename=QString())
保存Microsoft Excel文件
void | close ()
关闭Microsoft Excel文件
void | kick ()
踢出当前打开的 Microsoft Excel
更多...
void | setVisible (bool value)
设置当前打开的 Excel 是否可见
void | setCaption (const QString &value)
设置 Excel 文档的标题
bool | addBook ()
新建一本 Excel 文档
int | sheetCount ()
返回当前 Excel 的 Sheet 数量
QStringList | sheetNames ()
返回当前打开的 Excel 全部 Sheet 名
bool | currentSheet ()
返回当前 Sheet.
bool | setCurrentSheet (int index)
设置并指定当前 Sheet. 更多...
QString | currentSheetName ()
当前打开的 Excel 的 Sheet 名
QVariant | read (int row, int col)
读取单元格 Sheet 的内容 更多...
QVariant | cell (int row, int col)
读取单元格 Sheet 的内容 更多...
void | write (int row, int col, const QVariant &value)
写入单元格 Sheet 的内容 更多...
void | cellFormat (int row, int col, const QString &format)
void | cellAlign (int row, int col, Alignment hAlign, Alignment vAlign)
bool | usedRange (int &rowStart, int &colStart, int &rowEnd, int &colEnd)
获取有效区域信息 更多...

详细描述

通过 OLE 方式操作 Microsoft Excel

注解
通过 OLE 方式操作 Microsoft Excel
警告
只能在 Windows 下，并已安装了 Excel 时才能使用
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员枚举类型说明

enum TcMSExcel::Alignment

设置方向的常数

枚举值
xlTop | 靠上
xlLeft | 靠左
xlRight | 靠右
xlCenter | 居中
xlBottom | 靠下

成员函数说明

QVariant TcMSExcel::cell | ( | int | row,
 |  | int | col
 | ) |  |
inline

读取单元格 Sheet 的内容

参数
[in] | row | 行号，从 1 开始
[in] | col | 列号，从 1 开始
返回
返回指定单元格的内容
void TcMSExcel::kick ( )

踢出当前打开的 Microsoft Excel

放弃此对象对该 Excel 的控制权
Excel 文件仍保持打开，但丧失了控制权

QVariant TcMSExcel::read | ( | int | row,
 |  | int | col
 | ) |  |

读取单元格 Sheet 的内容

参数
[in] | row | 行号，从 1 开始
[in] | col | 列号，从 1 开始
返回
返回指定单元格的内容
bool TcMSExcel::setCurrentSheet ( int index )

设置并指定当前 Sheet.

参数
[in] 当前 Sheet 索引，从 1 开始
bool TcMSExcel::usedRange | ( | int & | rowStart,
 |  | int & | colStart,
 |  | int & | rowEnd,
 |  | int & | colEnd
 | ) |  |

获取有效区域信息

参见
rowStart() const
rowEnd() const
colStart() const
colEnd() const
void TcMSExcel::write | ( | int | row,
 |  | int | col,
 |  | const QVariant & | value
 | ) |  |

写入单元格 Sheet 的内容

参数
[in] | row | 行号，从 1 开始
[in] | col | 列号，从 1 开始
[in] | value | 准备写入的内容
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcmsexcel.h


Tianchi: TcMSSQL类 参考

  • 类成员
静态 Public 成员函数 | 所有成员列表
TcMSSQL类 参考

读取 ODBC 驱动和版本信息 更多...

#include <tcmssql.h>

静态 Public 成员函数

static QStringList | availableODBCDrivers ()
读取 ODBC 驱动和版本信息 更多...
static QString | ODBCDSN (const QString &driver, const QString &server, const QString &dbname, const QString &user=QString(), const QString &pass=QString())
构造ODBC DSN字符串 更多...

详细描述

读取 ODBC 驱动和版本信息

作者
XChinux XChin.nosp@m.ux@1.nosp@m.63.co.nosp@m.m
日期
2013-04-18

成员函数说明

static QStringList TcMSSQL::availableODBCDrivers ( )
static

读取 ODBC 驱动和版本信息

日期
2013-04-18
返回
以 / 分隔版本号和驱动名称:
10.00/SQL Server Native Client 10.0
09.00/SQL Native Client
03.50/SQL Server
static QString TcMSSQL::ODBCDSN | ( | const QString & | driver,
 |  | const QString & | server,
 |  | const QString & | dbname,
 |  | const QString & | user = QString(),
 |  | const QString & | pass = QString()
 | ) |  |
static

构造ODBC DSN字符串

日期
2013-06-04
参数
driver | 可用ODBC驱动名称
server | host 格式,如果为默认实例，则直接为host
dbname | 数据库名
user | 连接用户名
pass | 连接密码
返回
返回DSN字符串
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcmssql.h


Tianchi: TcOperMode结构体 参考

  • 类成员
静态 Public 属性 | 所有成员列表
TcOperMode结构体 参考

操作模式的标识常量 更多...

#include <tcutils.h>

静态 Public 属性

static const int | Append = 1
添加或新建
static const int | Change = 2
修改
static const int | Delete = 4
删除
static const int | CopyCell = 301
复制一个单元格
static const int | CopyCells = 302
复制多个单元格
static const int | CopyColumn = 303
复制列
static const int | CopyLine = 304
复制行
static const int | CopyTable = 305
复制一张表，默认表示含标题

详细描述

操作模式的标识常量

该结构体的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcutils.h


Tianchi: TcOracle类 参考

  • 类成员
静态 Public 成员函数 | 所有成员列表
TcOracle类 参考

读取 ODBC 驱动和版本信息 更多...

#include <tcoracle.h>

静态 Public 成员函数

static QStringList | availableODBCDrivers ()
读取 ODBC 驱动和版本信息 更多...
static QString | ODBCDSN (const QString &driver, const QString &tns, const QString &user=QString(), const QString &pass=QString())
构造ODBC DSN字符串 更多...

详细描述

读取 ODBC 驱动和版本信息

作者
XChinux XChin.nosp@m.ux@1.nosp@m.63.co.nosp@m.m
日期
2013-04-18

成员函数说明

static QStringList TcOracle::availableODBCDrivers ( )
static

读取 ODBC 驱动和版本信息

日期
2013-04-18
返回
以 / 分隔版本号和驱动名称:
11.2.0.3/Oracle in instantclient_11_2
11.2.0.2/Oracle in XE
static QString TcOracle::ODBCDSN | ( | const QString & | driver,
 |  | const QString & | tns,
 |  | const QString & | user = QString(),
 |  | const QString & | pass = QString()
 | ) |  |
static

构造ODBC DSN字符串

日期
2013-06-04
参数
driver | 可用ODBC驱动名称
tns | TNS Service Name
user | 连接用户名
pass | 连接密码
返回
返回DSN字符串
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcoracle.h


Tianchi: TcOS类 参考

  • 类成员
静态 Public 成员函数 | 所有成员列表
TcOS类 参考

与操作系统相关的操作类 更多...

#include <tcos.h>

静态 Public 成员函数

static QString | name ()
取操作系统名称，支持Windows和Linux 更多...
static QString | language ()
取操作系统的语言，仅支持 Windows 更多...
static bool | login (const QString &Domain, const QString &UserID, const QString &Password)
Windows 域用户登录，仅支持 Windows. 更多...

详细描述

与操作系统相关的操作类

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员函数说明

static QString TcOS::language ( )
static

取操作系统的语言，仅支持 Windows

注解
仅支持 Windows
static bool TcOS::login | ( | const QString & | Domain,
 |  | const QString & | UserID,
 |  | const QString & | Password
 | ) |  |
static

Windows 域用户登录，仅支持 Windows.

参数
[in] | Domain | Windows 域名或本机机器名
[in] | UserID | 域用户名或本机用户名
[in] | Password | 用户密码
返回
true 登录成功
false 登录失败
注解
仅支持 Windows
static QString TcOS::name ( )
static

取操作系统名称，支持Windows和Linux

注解
Windows从注册表中获取,Linux从依次从/etc下的os-release lsb-release, *-release文件获取
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/os/tcos.h


Tianchi: TcPlayer类 参考

  • 类成员
Public 类型 | Public 成员函数 | 属性 | 所有成员列表
TcPlayer类 参考

玩家信息类，常用在 C/S 中的客户端用户信息保存 更多...

#include <tcclasses.h>

类 TcPlayer 继承关系图:

Public 类型

enum AuthLevel {
AUTH_SYSADMIN = 999, AUTH_ADMIN = 888, AUTH_MANAGER = 99, AUTH_USER = 9,
AUTH_GUEST = 1
}
用户权限 更多...

Public 成员函数

TcPlayer ()
构造方法
TcPlayer & | operator= (const TcPlayer &)
复制对象
int | userNo () const
返回用户的 No
void | setUserNo (int value)
指定用户的 No
QString | userID () const
返回用户的 ID
void | setUserID (const QString &value)
指定用户的 ID
QString | username () const
返回用户姓名
void | setUsername (const QString &value)
指定用户的 username
int | userLevel () const
返回用户的级别
void | setUserLevel (int value)
指定用户的权限级别
int | authority (const QString &key) const
根据权限单元返回用户权限 更多...
void | setAuthority (const QString &key, int auth)
指定用户的权限模块级别
void | setAuthorityText (const QString &value)
快速设置用户的全部权限级别
void | setAuthorityText (const QStringList &value)
快速设置用户的全部权限级别
QString | loginID () const
返回登录ID
void | setLoginID (const QString &value)
保存用户的登录名称
QString | password () const
返回用户的密码
void | setPassword (const QString &value)
保存用户的密码
bool | loggedIn () const
玩家是否已登录
void | setLoggedIn (bool value)
指定玩家是否已登录
void | setLoggedIn ()
将玩家设为已登录
QDateTime | loginTime () const
玩家的登录时间
void | setLoginTime (QDateTime value)
指定玩家的登录时间
int | noLoginTime ()
返回玩家距今未登录的秒数
常用于意外断线后，显示已脱机的时间
void | clear ()
清除玩家的所有信息

属性

int | userNo
用户序号
QString | userID
用户ID
QString | username
用户全名
bool | loggedIn
是否已登录
QDateTime | loginTime
登录时间

详细描述

玩家信息类，常用在 C/S 中的客户端用户信息保存

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10

成员枚举类型说明

enum TcPlayer::AuthLevel

用户权限

枚举值
AUTH_SYSADMIN | 最高系统级管理员权限
AUTH_ADMIN | 最高用户级管理员权限
AUTH_MANAGER | 用户级：管理权限
AUTH_USER | 用户级：普通用户权限
AUTH_GUEST | 用户级：访客级权限

成员函数说明

int TcPlayer::authority ( const QString & key ) const

根据权限单元返回用户权限

参数
key 权限单元
返回
权限级别，参见 AuthLevel
参见
AuthLevel
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcclasses.h


Tianchi: TcSingleInstance类 参考

  • 类成员
Public 成员函数 | Protected 属性 | 所有成员列表
TcSingleInstance类 参考

应用程序单实例类 更多...

#include <tcsingleinstance.h>

Public 成员函数

TcSingleInstance (QString instanceName)
初始化方法 更多...
TcSingleInstance (QObject *parent, QString instanceName)
初始化方法 更多...
bool first () const
是否首次运行的实例 更多...

Protected 属性

bool | m_first
首次运行实例
QString | m_instanceName
实例名称
QLocalSocket | m_localSocket
外访 socket 句柄
QLocalServer * | m_localServer
受访 socket 句柄

详细描述

应用程序单实例类

示例:
#include "Network/SingleInstance.h"
int main(int argc, char *argv[])
{
QApplication app(argc, argv);
TcSingleInstance si(app, "myApp");
if ( si.first() )
{
// 首次运行
}else
{
// 已存在其它实例
}
...
}
作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-19

构造及析构函数说明

TcSingleInstance::TcSingleInstance ( QString instanceName )
inline

初始化方法

参数
[in] instanceName 识别是否重复开启的实例名称
TcSingleInstance::TcSingleInstance | ( | QObject * | parent,
 |  | QString | instanceName
 | ) |  |
inline

初始化方法

参数
[in] | parent | app对象
[in] | instanceName | 识别是否重复开启的实例名称

成员函数说明

bool TcSingleInstance::first ( ) const
inline

是否首次运行的实例

返回
true: 首次运行的实例
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/network/tcsingleinstance.h


Tianchi: TcSingleton< T > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcSingleton< T > 模板类 参考

用指针实现的单例模式的模版类 更多...

#include <tcsingleton.hpp>

Public 成员函数

TcSingleton ()
构造函数
TcSingleton (const this_type &)
构造函数
~TcSingleton ()
析构函数
T * | get () const
返回 T *
const T & | operator* () const
operator *
T * | operator-> () const
operator ->
this_type & | operator= (const this_type &)
operator =

详细描述

template<typename T>
class TcSingleton< T >

用指针实现的单例模式的模版类

作者
cnhem.nosp@m.iya@.nosp@m.gmail.nosp@m..com
日期
2013-05-25
示例:
.h文件
class demo
{
public:
int value;
}
typedef TcSingleton<demo> demo_singleton;
.cpp文件
初始化宏
TC_SINGLETON_INIT(demo)
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcsingleton.hpp


Tianchi: TcSortPaginationTableView类 参考

  • 类成员
Public 槽 | 信号 | Public 成员函数 | 所有成员列表
TcSortPaginationTableView类 参考

可排序和分页的TableView,使用时主要分两步: 更多...

#include <tcsortpaginationtableview.h>

类 TcSortPaginationTableView 继承关系图:

Public 槽

void fetchData (int page=-1, int section=-1, Qt::SortOrder order=Qt::AscendingOrder)
获取数据(实际上内部是发射fetchDataRequested()信号 更多...

信号

void fetchDataRequested ()
  请求数据时发出,比如排序和换页

Public 成员函数

TcSortPaginationTableView (QWidget *parent=0)
int | pageRowCount () const
返回每页显示记录条数
int | page () const
返回当前请求页码
int | sortSection () const
返回当前请求排序列
Qt::SortOrder | sortOrder () const
返回当前请求排序方向
void | setPageRowCount (int pageRowCount=-1)
设置每页显示记录条数, -1表示不分页
void | setPageInfo (int page, int totalCount)
设置paginator分页符字符串 更多...
void | setPaginator (QLabel *label)
设置分页部件
void | createTitleMenus ()
为横标头创建右键关联菜单

详细描述

可排序和分页的TableView,使用时主要分两步:

        1. 初始化TcSortPaginationTableView
        2. 处理获取数据请求(排序/分页/过滤)
  1. 初始化TcSortPaginationTableView
    model = new QStandardItemModel(this);
    ......
    tableView->setModel(model);
    tableView->setPaginator(labelPaginator); // 设置显示分页符的label
    tableView->setPageRowCount(20); // 设置每页显示记录数
    tableView->createTitleMenus(); // 创建标题行右键菜单,可显示/隐藏列
    connect(tableView, SIGNAL(fetchDataRequested()),
    this, SLOT(fetchData()));
  2. 处理获取数据请求(排序/分页/过滤)
    void XXXX::fetchData()
    {
    model->removeRows(0, model->rowCount());
    QSqlQuery q;
    QString strSql = "SELECT col1, col2, col3, col4 FROM table1 "
    "WHERE 1 = 1 ";
    QString strSqlCnt = "SELECT COUNT(*) FROM table1 "
    "WHERE 1 = 1 ";
    // 过滤条件
    strSql += " AND col1 LIKE 'xxx%%'";
    strSqlCnt += " AND col1 LIKE 'xxx%%'";
    // 根据是否排序,设定order语句
    if (tableView->isSortingEnabled())
    {
    switch (tableView->sortSection())
    {
    case 0:
    strSql += " ORDER BY col1";
    break;
    case 1:
    strSql += " ORDER BY col2";
    break;
    default:
    strSql += " ORDER BY col3";
    }
    if (tableView->sortOrder() == Qt::DescendingOrder)
    {
    strSql += " DESC";
    }
    }
    else
    { // 如果不可排序,则使用默认排序
    strSql += " ORDER BY col1";
    }
    int count = 0; // 代表符合条件的总记录数
    // 根据是否分页设定来读取当前页数据
    if (tableView->pageRowCount() > 0)
    { // 分页
    strSql += QString(" LIMIT %1 OFFSET %2")
    .arg(tableView->pageRowCount())
    .arg((tableView->page() - 1)
    * tableView->pageRowCount());
    q.exec(strSql);
    while (q.next())
    {
    .....// 获取当前页数据
    }
    // 获取符合条件的总数据条数
    q.exec(strSqlCnt);
    if (q.next())
    {
    count = q.value(0).toInt();
    }
    }
    else
    { // 不分页
    q.exec(strSql);
    while (q.next())
    {
    ......// 不分页，所以获取所有符合条件的数据
    count++;
    }
    }
    // 最后设置分页信息
    tableView->setPageInfo(tableView->page(), count);

成员函数说明

void TcSortPaginationTableView::fetchData | ( | int | page = -1,
 |  | int | section = -1,
 |  | Qt::SortOrder | order = Qt::AscendingOrder
 | ) |  |
slot

获取数据(实际上内部是发射fetchDataRequested()信号

参数
page | 指定页码(-1表示当前页码不变)
section | 指定排序列(-1表示排序列不变)
order | 指定排序方向(section为-1时无意义)
void TcSortPaginationTableView::setPageInfo | ( | int | page,
 |  | int | totalCount
 | ) |  |

设置paginator分页符字符串

参数
page | 当前页码
totalCount | 总记录数
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcsortpaginationtableview.h


Tianchi: TcString类 参考

  • 类成员
静态 Public 成员函数 | 所有成员列表
TcString类 参考

字符串功能增强与扩展 更多...

#include <tcstring.h>

静态 Public 成员函数

static QByteArray | first (QByteArray &str, const QByteArray &split="\t")
截取字符串的首部分 更多...
static int | find (const QStringList &ss, const QString &s)
在字符串序列中查到一个字符串 更多...
static int | findOf (const QStringList &list, const QString &key)
在字符串序列中查到一个字符串 更多...
static bool | filter (const QString &findText, const QStringList &filters)
判断一个字符串的合部工部分是否存在于一个字符串队列中 更多...
static QString | getTextByIndex (const char *strings, int index)
从一个字符串队列中返回指定索引行的字符串 更多...
static int | splitHumanName (QString full, QString &sur, QString &real, QString &english)
分割中文全名中的姓氏、名字和英文名

详细描述

字符串功能增强与扩展

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-16

成员函数说明

static bool TcString::filter | ( | const QString & | findText,
 |  | const QStringList & | filters
 | ) |  |
static

判断一个字符串的合部工部分是否存在于一个字符串队列中

参数
[in] | findText | 需要查找的子字符串
[in] | filters | 被查找的字符串队列
返回
true 存在
false 不存在
static int TcString::find | ( | const QStringList & | ss,
 |  | const QString & | s
 | ) |  |
static

在字符串序列中查到一个字符串

注解
未来可能会删除
参见
findOf
static int TcString::findOf | ( | const QStringList & | list,
 |  | const QString & | key
 | ) |  |
static

在字符串序列中查到一个字符串

注解
未来可能会删除
参见
find
static QByteArray TcString::first | ( | QByteArray & | str,
 |  | const QByteArray & | split = "\t"
 | ) |  |
static

截取字符串的首部分

参数
[in,out] | str | 被截取的字符串
[in] | split | 字符串的分隔符
返回
截取出的字符串
注解
分隔符将被丢弃，不含分隔符时截取整个字符串，被截取的字符串将被修改
static QString TcString::getTextByIndex | ( | const char * | strings,
 |  | int | index
 | ) |  |
static

从一个字符串队列中返回指定索引行的字符串

参数
[in] | strings | 字符串队列，以"\n"作为分隔
[in] | index | 需要返回的索引行，从 0 开始
返回
索引行的字符串，索引值越界时返回空字符串
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcstring.h


Tianchi: TcStringList类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcStringList类 参考

字符串集功能增强与扩展 更多...

#include <tcstring.h>

类 TcStringList 继承关系图:

Public 成员函数

bool | loadFrom (const QString &fileName)
装入一个文本文件的全部内容 更多...
bool | saveTo (const QString &fileName)
保存当前内容到一个文本文件中 更多...
QString | lineBreak () const
返回文本文件的行结尾符
void | lineBreak (const QString &value)
设置文本文件的行结尾符

详细描述

字符串集功能增强与扩展

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-16

成员函数说明

bool TcStringList::loadFrom ( const QString & fileName )

装入一个文本文件的全部内容

参数
[in] fileName 路径文件名
返回
true 操作成功
bool TcStringList::saveTo ( const QString & fileName )

保存当前内容到一个文本文件中

参数
[in] fileName 路径文件名
返回
true 操作成功
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcstring.h


Tianchi: TcTreeEx类 参考

  • 类成员
Public 类型 | Public 成员函数 | 静态 Public 成员函数 | 所有成员列表
TcTreeEx类 参考

把 QTreeWidget 的扩展功能，可直接导出到 Excel 中 更多...

#include <tctreeex.h>

Public 类型

enum ExportType { TextFile = 1, MSExcel = 2 }

Public 成员函数

TcTreeEx (QTreeWidget *widget=0)
构造函数 更多...
void | setWidget (QTreeWidget *widget)
设置导出模式 更多...
void | setExportType (int type)
设置导出模式 更多...
void | setSelectedState (int state)
设置导出模式 更多...
void | setTextFileName (const QString &filename)
设置导出的文本文件名 更多...
void | setMSExcelObject (TcMSExcel *excel, bool hasHeader=true, int startRow=1, int startCol=1)
设置 Excel 的对象实例
使用此方法后导出模式自动重置为 MSExcel
int | save ()
执行导出操作

静态 Public 成员函数

static void | createColumnMenu (QTreeWidget *widget, QWidget *object, const QString &methodName)
static void | setColumnBolds (QTreeWidget *widget)
static void | setColumnWidth (QTreeWidget *widget, int column, int width, bool hide=false)
static void | setColumnStyle (QTreeWidget *widget, int fontSize=8, const QString &fontName="Tahoma")
static void | CopyCellObject (QTreeWidget *view, int copyMode)

详细描述

把 QTreeWidget 的扩展功能，可直接导出到 Excel 中

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org

构造及析构函数说明

TcTreeEx::TcTreeEx ( QTreeWidget * widget = 0 )

构造函数

参数
[in] view 需要导出的 QTreeWidget 对象

成员函数说明

void TcTreeEx::setExportType ( int type )

设置导出模式

参数
[in] type 需要导出的类型(enum ExportType)
void TcTreeEx::setSelectedState ( int state )

设置导出模式

参数
[in] state 0 全部, 1 选中
void TcTreeEx::setTextFileName ( const QString & filename )

设置导出的文本文件名

参数
[in] filename 导出的文本文件名
void TcTreeEx::setWidget ( QTreeWidget * widget )

设置导出模式

参数
[in] widget 需要导出的 QTreeWidget 对象
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/widget/tctreeex.h


Tianchi: TcTreeItem类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTreeItem类 参考
类 TcTreeItem 继承关系图:

Public 成员函数

void | setCellFont (int col, bool bold=false, int alignment=Qt::AlignVCenter|Qt::AlignLeft)
void | setCellStyle (int startCol=-1, int endCol=-1, bool bold=true, int alignment=Qt::AlignVCenter|Qt::AlignRight, int cellHeight=25)
void | setCellColor (int col, QColor color)
QLabel * | createLabel (int col, const QString &htmlText, const QVariant &data=QVariant())
QDoubleSpinBox * | createDoubleSpinBox (int col, int decimals, double min, double max, double step, double value)
double | readDoubleSpinBoxValue (int col)
void | showValue (int column, const char *text, const QVariant &data=QVariant(), int size=0)
void | showValue (int column, const QString &text, const QVariant &data=QVariant(), int size=0)
void | showValue (int column, const QByteArray &text, const QVariant &data=QVariant(), int size=0)
void | showValue (int column, double value)
void | showValue (int column, double value, int digits)
void | showPrice (int column, double value, int digits=0)
void | showPercent (int column, double value=0.0, int digits=0)
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/widget/tctreeex.h


Tianchi: TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > 模板类 参考

Public 成员函数

TcTuple (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8, const T9 &v9)
TcTuple (const this_type &ref)
const this_type & | operator= (const this_type &ref)
bool | operator== (const this_type &ref) const
bool | operator!= (const this_type &ref) const
void | set (const this_type &ref)
void | set (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8, const T9 &v9)
void | set0 (const T0 &v0)
const T0 & | get0 () const
void | set1 (const T1 &v1)
const T1 & | get1 () const
void | set2 (const T2 &v2)
const T2 & | get2 () const
void | set3 (const T3 &v3)
const T3 & | get3 () const
void | set4 (const T4 &v4)
const T4 & | get4 () const
void | set5 (const T5 &v5)
const T5 & | get5 () const
void | set6 (const T6 &v6)
const T6 & | get6 () const
void | set7 (const T7 &v7)
const T7 & | get7 () const
void | set8 (const T8 &v8)
const T8 & | get8 () const
void | set9 (const T9 &v9)
const T9 & | get9 () const
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp


Tianchi: TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

Public 成员函数

TcTuple (const T0 &v0, const T1 &v1)
TcTuple (const this_type &ref)
const this_type & | operator= (const this_type &ref)
bool | operator== (const this_type &ref) const
bool | operator!= (const this_type &ref) const
void | set (const this_type &ref)
void | set (const T0 &v0, const T1 &v1)
void | set0 (const T0 &v0)
T0 & | get0 ()
void | set1 (const T1 &v1)
T1 & | get1 ()
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp


Tianchi: TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

Public 成员函数

TcTuple (const T0 &v0, const T1 &v1, const T2 &v2)
TcTuple (const this_type &ref)
const this_type & | operator= (const this_type &ref)
bool | operator== (const this_type &ref) const
bool | operator!= (const this_type &ref) const
void | set (const this_type &ref)
void | set (const T0 &v0, const T1 &v1, const T2 &v2)
void | set0 (const T0 &v0)
const T0 & | get0 () const
void | set1 (const T1 &v1)
const T1 & | get1 () const
void | set2 (const T2 &v2)
const T2 & | get2 () const
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp


Tianchi: TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

Public 成员函数

TcTuple (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3)
TcTuple (const this_type &ref)
const this_type & | operator= (const this_type &ref)
bool | operator== (const this_type &ref) const
bool | operator!= (const this_type &ref) const
void | set (const this_type &ref)
void | set (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3)
void | set0 (const T0 &v0)
const T0 & | get0 () const
void | set1 (const T1 &v1)
const T1 & | get1 () const
void | set2 (const T2 &v2)
const T2 & | get2 () const
void | set3 (const T3 &v3)
const T3 & | get3 () const
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp


Tianchi: TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

Public 成员函数

TcTuple (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4)
TcTuple (const this_type &ref)
const this_type & | operator= (const this_type &ref)
bool | operator== (const this_type &ref) const
bool | operator!= (const this_type &ref) const
void | set (const this_type &ref)
void | set (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4)
void | set0 (const T0 &v0)
const T0 & | get0 () const
void | set1 (const T1 &v1)
const T1 & | get1 () const
void | set2 (const T2 &v2)
const T2 & | get2 () const
void | set3 (const T3 &v3)
const T3 & | get3 () const
void | set4 (const T4 &v4)
const T4 & | get4 () const
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp


Tianchi: TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

Public 成员函数

TcTuple (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5)
TcTuple (const this_type &ref)
const this_type & | operator= (const this_type &ref)
bool | operator== (const this_type &ref) const
bool | operator!= (const this_type &ref) const
void | set (const this_type &ref)
void | set (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5)
void | set0 (const T0 &v0)
const T0 & | get0 () const
void | set1 (const T1 &v1)
const T1 & | get1 () const
void | set2 (const T2 &v2)
const T2 & | get2 () const
void | set3 (const T3 &v3)
const T3 & | get3 () const
void | set4 (const T4 &v4)
const T4 & | get4 () const
void | set5 (const T5 &v5)
const T5 & | get5 () const
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp


Tianchi: TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

Public 成员函数

TcTuple (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6)
TcTuple (const this_type &ref)
const this_type & | operator= (const this_type &ref)
bool | operator== (const this_type &ref) const
bool | operator!= (const this_type &ref) const
void | set (const this_type &ref)
void | set (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6)
void | set0 (const T0 &v0)
const T0 & | get0 () const
void | set1 (const T1 &v1)
const T1 & | get1 () const
void | set2 (const T2 &v2)
const T2 & | get2 () const
void | set3 (const T3 &v3)
const T3 & | get3 () const
void | set4 (const T4 &v4)
const T4 & | get4 () const
void | set5 (const T5 &v5)
const T5 & | get5 () const
void | set6 (const T6 &v6)
const T6 & | get6 () const
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp


Tianchi: TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 模板类 参考

Public 成员函数

TcTuple (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7)
TcTuple (const this_type &ref)
const this_type & | operator= (const this_type &ref)
bool | operator== (const this_type &ref) const
bool | operator!= (const this_type &ref) const
void | set (const this_type &ref)
void | set (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7)
void | set0 (const T0 &v0)
const T0 & | get0 () const
void | set1 (const T1 &v1)
const T1 & | get1 () const
void | set2 (const T2 &v2)
const T2 & | get2 () const
void | set3 (const T3 &v3)
const T3 & | get3 () const
void | set4 (const T4 &v4)
const T4 & | get4 () const
void | set5 (const T5 &v5)
const T5 & | get5 () const
void | set6 (const T6 &v6)
const T6 & | get6 () const
void | set7 (const T7 &v7)
const T7 & | get7 () const
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp


Tianchi: TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > 模板类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > 模板类 参考

Public 成员函数

TcTuple (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8)
TcTuple (const this_type &ref)
const this_type & | operator= (const this_type &ref)
bool | operator== (const this_type &ref) const
bool | operator!= (const this_type &ref) const
void | set (const this_type &ref)
void | set (const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8)
void | set0 (const T0 &v0)
const T0 & | get0 () const
void | set1 (const T1 &v1)
const T1 & | get1 () const
void | set2 (const T2 &v2)
const T2 & | get2 () const
void | set3 (const T3 &v3)
const T3 & | get3 () const
void | set4 (const T4 &v4)
const T4 & | get4 () const
void | set5 (const T5 &v5)
const T5 & | get5 () const
void | set6 (const T6 &v6)
const T6 & | get6 () const
void | set7 (const T7 &v7)
const T7 & | get7 () const
void | set8 (const T8 &v8)
const T8 & | get8 () const
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: TcUdp类 参考

  • 类成员
信号 | Public 成员函数 | Protected 槽 | Protected 属性 | 所有成员列表
TcUdp类 参考
类 TcUdp 继承关系图:

信号

void recvMessage (QHostAddress client, QByteArray datagram)
设置信号接收槽，只有回调方法未设置时才有效

Public 成员函数

int | start (int Port)
void | stop ()
bool | sendMessage (QHostAddress host, int port, QByteArray S)
向指定的服务器和端口发送字符集
bool | sendMessage (QHostAddress host, int port, QString S)
向指定的服务器和端口发送字符串
void | sendBroadcast (int port, QByteArray S)
向指定的端口发送广播字符集
void | sendBroadcast (int port, QString S)
向指定的端口发送广播字符串
void | setRecvMethod (QObject *recvObject, QByteArray recvMethod)
设置回调方法，优先于 signals 的接收方式

Protected 槽

void udpRecv ()

Protected 属性

QObject * | m_recvObject
QByteArray | m_recvMethod
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/network/tcudp.h
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: TcUtils类 参考

  • 类成员
静态 Public 成员函数 | 静态 Public 属性 | 所有成员列表
TcUtils类 参考

常用小功能综合函数集 更多...

#include <tcutils.h>

静态 Public 成员函数

static QHash< QString, QString > | StringToMap (const QString &mapStrings)
把 key=value 结构的文本转换为 map 结构
static QHash< QString, QString > | StringToMap (const QStringList &mapStrings)
把 key=value 结构的文本转换为 map 结构
static char | typeFrom (QVariant::Type type)
类型转字符代码
static char | typeFrom (const QVariant &v)
类型转字符代码
static QDateTime | toDateTime (const QString &text)
转换字符串为日期时间
static QDateTime | toDateTime (double timeDouble)
转换数据为日期时间
static char | getIDCardVerifyCode (const QByteArray &id)
返回18位身位证的最后一位校验码
static QDateTime | complieDateTime (const QString &complieDate, const QString &complieTime)
取编译日期和时间，调用处的代码必须重新编译
static QByteArray | addField (const QString &key, const QVariant &value)
static QHash< QString, QByteArray > | byFields (const QByteArray &fieldBytes)

静态 Public 属性

static const qint64 JULIAN_DAY = 2415019

详细描述

常用小功能综合函数集

作者
圣域天子 Jonix.nosp@m.@qtc.nosp@m.n.org
日期
2013-04-10
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcutils.h
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: TcVariantMapTableModel类 参考

  • 类成员
Public 成员函数 | 所有成员列表
TcVariantMapTableModel类 参考

以QVariantMap作为数据行的model,只可追加和清除,不可任意插入与任意 删除,使用时主要分成三部分： 更多...

#include <tcvariantmaptablemodel.h>

类 TcVariantMapTableModel 继承关系图:

Public 成员函数

TcVariantMapTableModel (QObject *parent=0)
virtual Qt::ItemFlags | flags (const QModelIndex &index) const
virtual QVariant | data (const QModelIndex &index, int role=Qt::DisplayRole) const
virtual QVariant | headerData (int section, Qt::Orientation orientation, int role=Qt::DisplayRole) const
virtual int | rowCount (const QModelIndex &parent=QModelIndex()) const
virtual int | columnCount (const QModelIndex &parent=QModelIndex()) const
返回横向表头(即标题)数量
virtual bool | setData (const QModelIndex &index, const QVariant &value, int role=Qt::EditRole)
virtual bool | setHeaderData (int section, Qt::Orientation orientation, const QVariant &value, int role=Qt::EditRole)
直接返回false,即不可设定横向和竖向表头
void | setFlags (const QModelIndex &index, Qt::ItemFlags flags)
设置flags属性
void | setCheckable (int row, int col, bool checkable)
设置某一项是否可选中
void | setChecked (int row, int col, bool checked)
设置某一项是否选中
bool | isCheckable (int row, int col) const
判断某一项是否可选中
bool | isChecked (int row, int col) const
判断某一项是否选中
void | addTitle (const QString &field, const QString &title, int precision=-1)
添加标题(即横表头)定义 更多...
void | addData (const QList< QVariantMap > &data)
添加数据行(多条) 更多...
void | addData (const QVariantMap &row)
添加数据行(一条) 更多...
const QList< QVariantMap > & | data () const
返回所有数据行常引用
QVariantMap | data (int row) const
返回某一行数据(如果无效则返回QVariantMap())
const QList< QPair< QString,
QString > > & 		title () const
返回所有标题定义(first为field, second为title)
QPair< QString, QString > | title (int col) const
返回某一列标题定义(first为field, second为title)
void | setNumberColumn (const QString &field, int precision)
设置某字段列显示精度
void | setNumberColumn (int column, int precision)
设置某列显示精度
void | clearData ()
清除所有数据行
void | clear ()
清除所有数据行及标题设定

详细描述

以QVariantMap作为数据行的model,只可追加和清除,不可任意插入与任意 删除,使用时主要分成三部分：

        1. 创建TcVariantMapTableModel,并定义标题和列属性
        2. 填充数据(即清除数据以及添加数据行)
        3. 获取指定数据行数据
  1. 创建model及定义标题和列属性
    TcVariantMapTableModel *model = new TcVariantMapTableModel(this);
    model->addTitle("col1", "Title 1"));
    model->addTitle("col2", "Title 2", 2));// 数字列，保留两位小数
    model->addTitle("col3", "Title 3"));
    model->addTitle("__col4", "Title 4")); // 非原始数据
    tableView->setModel(model);
  1. 填充数据
    model->clearData(); // 清除原来的数据行(保留标题不变)
    QSqlQuery q;
    q.exec("SELECT col1, col2, col3, col4 FROM table1");
    QList<QVariantMap> rows;
    QVariantMap row;
    while (q.next())
    {
    row["col1"] = q.value(0);
    row["col2"] = q.value(1);
    row["col3"] = q.value(2);
    row["col4"] = q.value(3);
    row["__col4"] = row["col4"].toInt() == 1 ? "Yes" : "No";
    rows << row;
    row.clear();
    }
    model->addData(rows);
  1. 获取指定数据行数据
    void XXXX::on_actionYYY_triggered()
    {
    QModelIndexList idxs = tableView->selectionModel()->selectedRows();
    if (idxs.isEmpty())
    {
    return;
    }
    int row = idxs.first().row();
    const QList<QVariantMap> &data = model->data();
    // 获取选定行的col1字段值
    QString strCol1 = data[row]["col1"].toString().trimmed();
    ......
    }

成员函数说明

void TcVariantMapTableModel::addData ( const QList< QVariantMap > & data )

添加数据行(多条)

参数
data 多条数据行
void TcVariantMapTableModel::addData ( const QVariantMap & row )

添加数据行(一条)

参数
row 一条数据行
void TcVariantMapTableModel::addTitle | ( | const QString & | field,
 |  | const QString & | title,
 |  | int | precision = -1
 | ) |  |

添加标题(即横表头)定义

参数
field | 字段名
title | 标题显示值
precision | 如果是数字列,设定其显示精度(-1表示无效)
该类的文档由以下文件生成:
  • D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcvariantmaptablemodel.h
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类索引

  • 类成员
类索引
N | S | T
N
TcCursorWait TcFlowLayout TcOperMode TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
TcDataAccess TcFormUtils TcOracle TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
null_type (_tc_tuple_ns_) TcDataAccessStatement TcFunctionalSortFilterProxyModel TcOS TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
S
TcDatabase TcGlowEffect TcPlayer TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
TcDateEdit TcHeaderSetupDialog TcSingleInstance TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
TcDatabase::SQLContext TcDBFields TcInvoke TcSingleton TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
T
TcDir TcJSONObject TcSortPaginationTableView TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
TcDownload TcLineEdit TcString TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >
TcChinese TcDownloadList TcLog TcStringList TcUdp
TcClickLabel TcExcelReader TcMarqueeLabel TcTreeEx TcUtils
TcCursorBusy TcFile TcMSExcel TcTreeItem TcVariantMapTableModel
TcCursorCustom TcFileIO TcMSSQL TcTuple
N | S | T
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类继承关系

  • 类成员
类继承关系
此继承关系列表按字典顺序粗略的排序:
[详情级别 12]
o C _tc_tuple_ns_::null_type |
o C QAbstractTableModel |
| \ C TcVariantMapTableModel | 以QVariantMap作为数据行的model,只可追加和清除,不可任意插入与任意 删除,使用时主要分成三部分：
o C QComboBox |
| \ C TcDateEdit | 可以输入或显示为空的日期选择控件
o C QDialog |
| \ C TcHeaderSetupDialog | 设置 QTreeWidget 标题的对话框
o C QGraphicsEffect |
| \ C TcGlowEffect | 发光效果的QGraphicsEffect
o C QLabel |
| o C TcClickLabel | Emit clicked() signal's label while mouse clicked
| \ C TcMarqueeLabel | 跑马灯类MarqueeLabel,点击时自动打开网址
o C QLayout |
| \ C TcFlowLayout | 流式布局FlowLayout
o C QLineEdit |
| \ C TcLineEdit | Extended QLineEdit widget
o C QObject |
| o C TcDir |
| o C TcDownload | 用于下载文件（或文件的一部分） 注意：此类尚未进行严格测试
| o C TcDownloadList | 用于管理文件的下载
| \ C TcPlayer | 玩家信息类，常用在 C/S 中的客户端用户信息保存
o C QSortFilterProxyModel |
| \ C TcFunctionalSortFilterProxyModel | 依所设过滤参数(QVariantMap)来使用已设滤函数进行过滤的 SortFilterProxyModel,使用时分三部分:
o C QStringList |
| \ C TcStringList | 字符串集功能增强与扩展
o C QTableView |
| \ C TcSortPaginationTableView | 可排序和分页的TableView,使用时主要分两步:
o C QTreeWidgetItem |
| \ C TcTreeItem |
o C QUdpSocket |
| \ C TcUdp |
o C TcDatabase::SQLContext |
o C TcChinese | 汉语相关处理类
o C TcCursorCustom | 光标形态变化类的根类，一般不直接使用
| o C TcCursorBusy | 后台忙光标的设置和自动恢复处理类
| \ C TcCursorWait | 等待光标的设置和自动恢复处理类
o C TcDataAccess |
o C TcDataAccessStatement |
o C TcDatabase |
o C TcDBFields | Key=value 数据格式转换类
o C TcExcelReader | Simple excel reader class, limit to read first sheet
o C TcFile | 文件操作常用处理类
o C TcFileIO | 一些文件复制和提取功能的类
o C TcFormUtils |
o C TcInvoke | 映射执行对象类
o C TcJSONObject | 兼容 Qt 4.x 的 JSON文生成和解析类
o C TcLog | 简单的文本文件输出日志。
o C TcMSExcel | 通过 OLE 方式操作 Microsoft Excel
o C TcMSSQL | 读取 ODBC 驱动和版本信息
o C TcOperMode | 操作模式的标识常量
o C TcOracle | 读取 ODBC 驱动和版本信息
o C TcOS | 与操作系统相关的操作类
o C TcSingleInstance | 应用程序单实例类
o C TcSingleton< T > | 用指针实现的单例模式的模版类
o C TcString | 字符串功能增强与扩展
o C TcTreeEx | 把 QTreeWidget 的扩展功能，可直接导出到 Excel 中
o C TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > |
o C TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > |
o C TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > |
\ C TcUtils | 常用小功能综合函数集
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- a -

  • active : TcMarqueeLabel
  • activeChanged() : TcMarqueeLabel
  • addBook() : TcMSExcel
  • addData() : TcVariantMapTableModel
  • addTitle() : TcVariantMapTableModel
  • Alignment : TcMSExcel
  • append() : TcFileIO
  • Append : TcOperMode
  • AUTH_ADMIN : TcPlayer
  • AUTH_GUEST : TcPlayer
  • AUTH_MANAGER : TcPlayer
  • AUTH_SYSADMIN : TcPlayer
  • AUTH_USER : TcPlayer
  • AuthLevel : TcPlayer
  • authority() : TcPlayer
  • availableODBCDrivers() : TcMSSQL , TcOracle
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- c -

  • cell() : TcExcelReader , TcMSExcel
  • Change : TcOperMode
  • clear() : TcPlayer , TcVariantMapTableModel , TcLineEdit
  • clearData() : TcVariantMapTableModel
  • clicked() : TcClickLabel
  • close() : TcMSExcel , TcDatabase
  • columnCount() : TcVariantMapTableModel
  • complieDateTime() : TcUtils
  • copy() : TcFileIO
  • CopyCell : TcOperMode
  • CopyCells : TcOperMode
  • CopyColumn : TcOperMode
  • copyDirs() : TcDir
  • copyFiles() : TcDir
  • CopyLine : TcOperMode
  • CopyTable : TcOperMode
  • create() : TcMSExcel
  • CreateDDL : TcDatabase
  • createTitleMenus() : TcSortPaginationTableView
  • currentFile() : TcDir
  • currentSheet() : TcMSExcel
  • currentSheetIndex() : TcExcelReader
  • currentSheetName() : TcMSExcel , TcExcelReader
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- d -

  • data : TcLineEdit , TcVariantMapTableModel
  • dataChanged() : TcLineEdit
  • debug() : TcLog
  • defaultBufferSize : TcFileIO
  • Delete : TcOperMode
  • directionChanged() : TcMarqueeLabel
  • doubleClicked() : TcLineEdit
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- e -

  • errors : TcDatabase
  • exec() : TcDatabase
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- f -

  • fetchData() : TcSortPaginationTableView
  • fetchDataRequested() : TcSortPaginationTableView
  • fileVersion() : TcFile
  • filter() : TcString
  • find() : TcString
  • findFiles() : TcDir
  • findOf() : TcString
  • first() : TcString , TcSingleInstance
  • firstPinyins() : TcChinese
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- g -

  • GB : TcFileIO
  • get() : TcSingleton< T >
  • getIDCardVerifyCode() : TcUtils
  • getTextByIndex() : TcString
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- i -

  • interval : TcMarqueeLabel
  • intervalChanged() : TcMarqueeLabel
  • invoke() : TcInvoke
  • isActive() : TcMarqueeLabel
  • isCheckable() : TcVariantMapTableModel
  • isChecked() : TcVariantMapTableModel
  • isNull() : TcExcelReader
  • isOpened() : TcDatabase
  • isValid() : TcInvoke
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- j -

  • join() : TcFileIO
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- k -

  • KB : TcFileIO
  • kick() : TcMSExcel
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- l -

  • labelText : TcLineEdit
  • labelTextChanged() : TcLineEdit
  • language() : TcOS
  • lineBreak() : TcStringList
  • loadEngine() : TcDatabase
  • loadFrom() : TcStringList
  • loadFromFile() : TcFile
  • loggedIn : TcPlayer
  • login() : TcOS
  • loginID() : TcPlayer
  • loginTime() : TcPlayer
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- m -

  • m_first : TcSingleInstance
  • m_instanceName : TcSingleInstance
  • m_localServer : TcSingleInstance
  • m_localSocket : TcSingleInstance
  • makeDummyFile() : TcFileIO
  • MB : TcFileIO
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- n -

  • name() : TcOS
  • noLoginTime() : TcPlayer
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- o -

  • ODBCDSN() : TcMSSQL , TcOracle
  • open() : TcMSExcel , TcDatabase , TcExcelReader
  • operator*() : TcSingleton< T >
  • operator->() : TcSingleton< T >
  • operator=() : TcSingleton< T > , TcInvoke , TcPlayer
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- p -

  • page() : TcSortPaginationTableView
  • pageRowCount() : TcSortPaginationTableView
  • password() : TcPlayer
  • prepare() : TcDatabase
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- q -

  • queued() : TcInvoke
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- r -

  • read() : TcMSExcel
  • recvMessage() : TcUdp
  • reset() : TcMarqueeLabel
  • resetCopyFileCount() : TcDir
  • restore() : TcCursorCustom
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- s -

  • save() : TcMSExcel , TcTreeEx
  • saveTo() : TcStringList
  • searchFiles() : TcFile
  • sendBroadcast() : TcUdp
  • sendMessage() : TcUdp
  • setActive() : TcMarqueeLabel
  • setAppFile() : TcLog
  • setAuthority() : TcPlayer
  • setAuthorityText() : TcPlayer
  • setCaption() : TcMSExcel
  • setCheckable() : TcVariantMapTableModel
  • setChecked() : TcVariantMapTableModel
  • setCurrentSheet() : TcExcelReader , TcMSExcel
  • setData() : TcLineEdit
  • setDatabase() : TcDatabase
  • setDirection() : TcMarqueeLabel
  • setExportType() : TcTreeEx
  • setFilterFunction() : TcFunctionalSortFilterProxyModel
  • setFilterParam() : TcFunctionalSortFilterProxyModel
  • setFlags() : TcVariantMapTableModel
  • setGlowColor() : TcGlowEffect
  • setHeader() : TcHeaderSetupDialog
  • setHeaderData() : TcVariantMapTableModel
  • setInterval() : TcMarqueeLabel
  • setLabelText() : TcLineEdit
  • setLogFile() : TcLog
  • setLoggedIn() : TcPlayer
  • setLoginID() : TcPlayer
  • setLoginTime() : TcPlayer
  • setMSExcelObject() : TcTreeEx
  • setNumberColumn() : TcVariantMapTableModel
  • setPageInfo() : TcSortPaginationTableView
  • setPageRowCount() : TcSortPaginationTableView
  • setPaginator() : TcSortPaginationTableView
  • setPassword() : TcPlayer
  • setRadius() : TcGlowEffect
  • setRecvMethod() : TcUdp
  • setSelectedState() : TcTreeEx
  • setTextFileName() : TcTreeEx
  • setUserID() : TcPlayer
  • setUserLevel() : TcPlayer
  • setUsername() : TcPlayer
  • setUserNo() : TcPlayer
  • setVisible() : TcMSExcel
  • setWidget() : TcTreeEx
  • sheetCount() : TcMSExcel , TcExcelReader
  • sheetNames() : TcExcelReader , TcMSExcel
  • sortOrder() : TcSortPaginationTableView
  • sortSection() : TcSortPaginationTableView
  • split() : TcFileIO
  • splitHumanName() : TcString
  • start() : TcMarqueeLabel
  • stop() : TcMarqueeLabel
  • StringToMap() : TcUtils
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- t -

  • TcInvoke() : TcInvoke
  • TcMSExcel() : TcMSExcel
  • TcPlayer() : TcPlayer
  • TcSingleInstance() : TcSingleInstance
  • TcSingleton() : TcSingleton< T >
  • TcTreeEx() : TcTreeEx
  • title() : TcVariantMapTableModel
  • toChars() : TcChinese
  • toDateTime() : TcUtils
  • toPinyin() : TcChinese
  • typeFrom() : TcUtils
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- u -

  • uniqueFileName() : TcFile
  • usedRange() : TcMSExcel
  • userID() : TcPlayer
  • userLevel() : TcPlayer
  • username : TcPlayer
  • userNo() : TcPlayer
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- w -

  • write() : TcLog , TcMSExcel
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- x -

  • xlBottom : TcMSExcel
  • xlCenter : TcMSExcel
  • xlLeft : TcMSExcel
  • xlRight : TcMSExcel
  • xlTop : TcMSExcel
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x
  • ~
这里列出了所有文档化的类成员，并附带类所属的文件:

- ~ -

  • ~TcMSExcel() : TcMSExcel
  • ~TcSingleton() : TcSingleton< T >
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员 - 函数

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • ~

- a -

  • activeChanged() : TcMarqueeLabel
  • addBook() : TcMSExcel
  • addData() : TcVariantMapTableModel
  • addTitle() : TcVariantMapTableModel
  • append() : TcFileIO
  • authority() : TcPlayer
  • availableODBCDrivers() : TcMSSQL , TcOracle

- c -

  • cell() : TcExcelReader , TcMSExcel
  • clear() : TcVariantMapTableModel , TcLineEdit , TcPlayer
  • clearData() : TcVariantMapTableModel
  • clicked() : TcClickLabel
  • close() : TcMSExcel , TcDatabase
  • columnCount() : TcVariantMapTableModel
  • complieDateTime() : TcUtils
  • copy() : TcFileIO
  • copyDirs() : TcDir
  • copyFiles() : TcDir
  • create() : TcMSExcel
  • createTitleMenus() : TcSortPaginationTableView
  • currentFile() : TcDir
  • currentSheet() : TcMSExcel
  • currentSheetIndex() : TcExcelReader
  • currentSheetName() : TcMSExcel , TcExcelReader

- d -

  • data() : TcVariantMapTableModel
  • dataChanged() : TcLineEdit
  • debug() : TcLog
  • directionChanged() : TcMarqueeLabel
  • doubleClicked() : TcLineEdit

- e -

  • exec() : TcDatabase

- f -

  • fetchData() : TcSortPaginationTableView
  • fetchDataRequested() : TcSortPaginationTableView
  • fileVersion() : TcFile
  • filter() : TcString
  • find() : TcString
  • findFiles() : TcDir
  • findOf() : TcString
  • first() : TcString , TcSingleInstance
  • firstPinyins() : TcChinese

- g -

  • get() : TcSingleton< T >
  • getIDCardVerifyCode() : TcUtils
  • getTextByIndex() : TcString

- i -

  • interval() : TcMarqueeLabel
  • intervalChanged() : TcMarqueeLabel
  • invoke() : TcInvoke
  • isActive() : TcMarqueeLabel
  • isCheckable() : TcVariantMapTableModel
  • isChecked() : TcVariantMapTableModel
  • isNull() : TcExcelReader
  • isOpened() : TcDatabase
  • isValid() : TcInvoke

- j -

  • join() : TcFileIO

- k -

  • kick() : TcMSExcel

- l -

  • labelTextChanged() : TcLineEdit
  • language() : TcOS
  • lineBreak() : TcStringList
  • loadEngine() : TcDatabase
  • loadFrom() : TcStringList
  • loadFromFile() : TcFile
  • loggedIn() : TcPlayer
  • login() : TcOS
  • loginID() : TcPlayer
  • loginTime() : TcPlayer

- m -

  • makeDummyFile() : TcFileIO

- n -

  • name() : TcOS
  • noLoginTime() : TcPlayer

- o -

  • ODBCDSN() : TcMSSQL , TcOracle
  • open() : TcMSExcel , TcDatabase , TcExcelReader
  • operator*() : TcSingleton< T >
  • operator->() : TcSingleton< T >
  • operator=() : TcSingleton< T > , TcInvoke , TcPlayer

- p -

  • page() : TcSortPaginationTableView
  • pageRowCount() : TcSortPaginationTableView
  • password() : TcPlayer
  • prepare() : TcDatabase

- q -

  • queued() : TcInvoke

- r -

  • read() : TcMSExcel
  • recvMessage() : TcUdp
  • reset() : TcMarqueeLabel
  • resetCopyFileCount() : TcDir
  • restore() : TcCursorCustom

- s -

  • save() : TcMSExcel , TcTreeEx
  • saveTo() : TcStringList
  • searchFiles() : TcFile
  • sendBroadcast() : TcUdp
  • sendMessage() : TcUdp
  • setActive() : TcMarqueeLabel
  • setAppFile() : TcLog
  • setAuthority() : TcPlayer
  • setAuthorityText() : TcPlayer
  • setCaption() : TcMSExcel
  • setCheckable() : TcVariantMapTableModel
  • setChecked() : TcVariantMapTableModel
  • setCurrentSheet() : TcExcelReader , TcMSExcel
  • setData() : TcLineEdit
  • setDatabase() : TcDatabase
  • setDirection() : TcMarqueeLabel
  • setExportType() : TcTreeEx
  • setFilterFunction() : TcFunctionalSortFilterProxyModel
  • setFilterParam() : TcFunctionalSortFilterProxyModel
  • setFlags() : TcVariantMapTableModel
  • setGlowColor() : TcGlowEffect
  • setHeader() : TcHeaderSetupDialog
  • setHeaderData() : TcVariantMapTableModel
  • setInterval() : TcMarqueeLabel
  • setLabelText() : TcLineEdit
  • setLogFile() : TcLog
  • setLoggedIn() : TcPlayer
  • setLoginID() : TcPlayer
  • setLoginTime() : TcPlayer
  • setMSExcelObject() : TcTreeEx
  • setNumberColumn() : TcVariantMapTableModel
  • setPageInfo() : TcSortPaginationTableView
  • setPageRowCount() : TcSortPaginationTableView
  • setPaginator() : TcSortPaginationTableView
  • setPassword() : TcPlayer
  • setRadius() : TcGlowEffect
  • setRecvMethod() : TcUdp
  • setSelectedState() : TcTreeEx
  • setTextFileName() : TcTreeEx
  • setUserID() : TcPlayer
  • setUserLevel() : TcPlayer
  • setUsername() : TcPlayer
  • setUserNo() : TcPlayer
  • setVisible() : TcMSExcel
  • setWidget() : TcTreeEx
  • sheetCount() : TcMSExcel , TcExcelReader
  • sheetNames() : TcExcelReader , TcMSExcel
  • sortOrder() : TcSortPaginationTableView
  • sortSection() : TcSortPaginationTableView
  • split() : TcFileIO
  • splitHumanName() : TcString
  • start() : TcMarqueeLabel
  • stop() : TcMarqueeLabel
  • StringToMap() : TcUtils

- t -

  • TcInvoke() : TcInvoke
  • TcMSExcel() : TcMSExcel
  • TcPlayer() : TcPlayer
  • TcSingleInstance() : TcSingleInstance
  • TcSingleton() : TcSingleton< T >
  • TcTreeEx() : TcTreeEx
  • title() : TcVariantMapTableModel
  • toChars() : TcChinese
  • toDateTime() : TcUtils
  • toPinyin() : TcChinese
  • typeFrom() : TcUtils

- u -

  • uniqueFileName() : TcFile
  • usedRange() : TcMSExcel
  • userID() : TcPlayer
  • userLevel() : TcPlayer
  • username() : TcPlayer
  • userNo() : TcPlayer

- w -

  • write() : TcLog , TcMSExcel

- ~ -

  • ~TcMSExcel() : TcMSExcel
  • ~TcSingleton() : TcSingleton< T >
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员 - 变量

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • Append : TcOperMode
  • Change : TcOperMode
  • CopyCell : TcOperMode
  • CopyCells : TcOperMode
  • CopyColumn : TcOperMode
  • CopyLine : TcOperMode
  • CopyTable : TcOperMode
  • CreateDDL : TcDatabase
  • defaultBufferSize : TcFileIO
  • Delete : TcOperMode
  • errors : TcDatabase
  • GB : TcFileIO
  • KB : TcFileIO
  • m_first : TcSingleInstance
  • m_instanceName : TcSingleInstance
  • m_localServer : TcSingleInstance
  • m_localSocket : TcSingleInstance
  • MB : TcFileIO
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员 - 枚举

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • Alignment : TcMSExcel
  • AuthLevel : TcPlayer
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员 - 枚举值

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • AUTH_ADMIN : TcPlayer
  • AUTH_GUEST : TcPlayer
  • AUTH_MANAGER : TcPlayer
  • AUTH_SYSADMIN : TcPlayer
  • AUTH_USER : TcPlayer
  • xlBottom : TcMSExcel
  • xlCenter : TcMSExcel
  • xlLeft : TcMSExcel
  • xlRight : TcMSExcel
  • xlTop : TcMSExcel
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 类成员 - 属性

  • 类成员
  • 全部
  • 函数
  • 变量
  • 枚举
  • 枚举值
  • 属性
  • active : TcMarqueeLabel
  • data : TcLineEdit
  • interval : TcMarqueeLabel
  • labelText : TcLineEdit
  • loggedIn : TcPlayer
  • loginTime : TcPlayer
  • userID : TcPlayer
  • username : TcPlayer
  • userNo : TcPlayer
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 文件列表

  • 文件列表
  • 文件成员
文件列表
这里列出了所有文档化的文件，并附带简要说明:
[详情级别 1234]
\ - include |
o - tianchi |
| o - chinese |
| | \ * tcchinese.h |
| o - core |
| | o * tcclasses.h |
| | o * tccommon.h |
| | o * tcfunctionalsortfilterproxymodel.h |
| | o * tcsingleton.hpp | 用指针实现的单例模式的模版类
| | o * tcstring.h |
| | o * tctuple.hpp | 简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版
| | o * tcutils.h |
| | \ * tcvariantmaptablemodel.h |
| o - file |
| | o * tcdir.h | 可以复制目录树的类，也可以查找文件夹内所有的文件
| | o * tcexcelreader.h |
| | o * tcfile.h |
| | o * tcfileio.h | 一些文件复制和提取功能
| | o * tcjson.h |
| | o * tclog.h |
| | \ * tcmsexcel.h |
| o - gui |
| | o * tcclicklabel.h |
| | o * tcdateedit.h |
| | o * tcflowlayout.h |
| | o * tcformutils.h |
| | o * tcgloweffect.h |
| | o * tcguiutils.h |
| | o * tcheadersetupdialog.h |
| | o * tclineedit.h |
| | o * tcmarqueelabel.h |
| | \ * tcsortpaginationtableview.h |
| o - network |
| | o * tcdownloadhttp.h |
| | o * tcsingleinstance.h |
| | \ * tcudp.h |
| o - os |
| | \ * tcos.h |
| o - sql |
| | o * tcdataaccess.h |
| | o * tcdatabase.h |
| | o * tcmssql.h |
| | \ * tcoracle.h |
| o - widget |
| | \ * tctreeex.h |
| \ * tcglobal.h |
\ * tianchi.h | 引用单元头文件
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include 目录参考

  • include
include 目录参考

目录

目录 tianchi

文件

文件 tianchi.h [代码]
引用单元头文件
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi 目录参考

  • include
  • tianchi
tianchi 目录参考

目录

目录 | chinese
目录 | core
目录 | file
目录 | gui
目录 | network
目录 | os
目录 | sql
目录 | widget

文件

文件 tcglobal.h [代码]
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/chinese 目录参考

  • include
  • tianchi
  • chinese
chinese 目录参考

文件

文件 tcchinese.h [代码]
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/chinese/tcchinese.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • chinese
tcchinese.h
1 // **************************************************************************
2 // Tianchi share library for Qt (C++)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明： 汉语相关处理
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.15 圣域天子 建立
13 //
14 // ==========================================================================
16 #ifndef TIANCHI_TCCHINESE_H
17 #define TIANCHI_TCCHINESE_H
18
19 #include <tianchi/tcglobal.h>
20
21 #include <QString>
22
25 class TIANCHI_API TcChinese
26 {
27 public:
40 static QString firstPinyins(const QString& HzString);
41
60 static QString toPinyin(const QString& Str, bool Tonality=false);
61
75 static QString toChars(const QString& Str, bool Tonality=false);
76 };
77
78 #endif // TIANCHI_CHINESE_H
生成于 2013年 七月 1日 星期一 16:50:30 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core 目录参考

  • include
  • tianchi
  • core
core 目录参考

文件

文件 | tcclasses.h [代码]
文件 | tccommon.h [代码]
文件 | tcfunctionalsortfilterproxymodel.h [代码]
文件 | tcsingleton.hpp [代码]
用指针实现的单例模式的模版类
文件 | tcstring.h [代码]
文件 | tctuple.hpp [代码]
简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版
文件 | tcutils.h [代码]
文件 | tcvariantmaptablemodel.h [代码]
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcclasses.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
tcclasses.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：一些常用的小类
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 // 2013.04.29 XChinux remove AuthLevel type's typedef keywords
14 // ==========================================================================
16 #ifndef TIANCHI_TCCLASSES_H
17 #define TIANCHI_TCCLASSES_H
18
19 #include <tianchi/tcglobal.h>
20
21 #include <QDateTime>
22 #include <QObject>
23 #include <QString>
24 #include <QStringList>
25 #include <QElapsedTimer>
26 #include <QHash>
27
31 class TIANCHI_API TcPlayer : public QObject
32 {
33 Q_OBJECT
34
35 Q_PROPERTY(int userNo READ userNo WRITE setUserNo )
36 Q_PROPERTY(QString userID READ userID WRITE setUserID )
37 Q_PROPERTY(QString username READ username WRITE setUsername )
38 Q_PROPERTY(bool loggedIn READ loggedIn WRITE setLoggedIn )
39 Q_PROPERTY(QDateTime loginTime READ loginTime WRITE setLoginTime)
40
41 public:
43 enum AuthLevel
44 {
45 AUTH_SYSADMIN = 999,
46 AUTH_ADMIN = 888,
47 AUTH_MANAGER = 99,
48 AUTH_USER = 9,
49 AUTH_GUEST = 1,
50 };
51
53 TcPlayer();
54
56 TcPlayer &operator=(const TcPlayer&);
57
59 inline int userNo() const
60 {
61 return m_userNo;
62 }
64 inline void setUserNo(int value)
65 {
66 m_userNo = value;
67 }
69 inline QString userID() const
70 {
71 return m_userID;
72 }
74 inline void setUserID(const QString& value)
75 {
76 m_userID = value.trimmed();
77 }
79 inline QString username() const
80 {
81 return m_username;
82 }
84 inline void setUsername(const QString& value)
85 {
86 m_username = value.trimmed();
87 }
89 inline int userLevel() const
90 {
91 return m_userLevel;
92 }
94 inline void setUserLevel(int value)
95 {
96 m_userLevel = value;
97 }
98
103 int authority(const QString& key) const;
105 inline void setAuthority(const QString& key, int auth)
106 {
107 m_authority[key] = auth;
108 }
110 void setAuthorityText(const QString& value);
112 void setAuthorityText(const QStringList& value);
113
115 inline QString loginID() const
116 {
117 return m_loginID;
118 }
120 inline void setLoginID(const QString& value)
121 {
122 m_loginID = value.trimmed();
123 }
125 inline QString password() const
126 {
127 return m_password;
128 }
130 inline void setPassword(const QString& value)
131 {
132 m_password = value.trimmed();
133 }
135 inline bool loggedIn() const
136 {
137 return m_loggedIn;
138 }
140 void setLoggedIn(bool value);
142 inline void setLoggedIn()
143 {
144 setLoggedIn(true);
145 }
147 inline QDateTime loginTime() const
148 {
149 return m_loginTime;
150 }
152 inline void setLoginTime(QDateTime value)
153 {
154 m_loginTime = value; m_loggedIn = true;
155 }
156
159 inline int noLoginTime()
160 {
161 return m_loggedIn ? 0 : m_noLoginTimer.elapsed() / 1000;
162 }
163
165 void clear();
166
167 private:
168 int m_userNo;
169 QString m_userID;
170 QString m_username;
171 int m_userLevel;
172 QHash<QString, int> m_authority;
173
174 QString m_loginID;
175 QString m_password;
176
177 bool m_loggedIn;
178 QDateTime m_loginTime;
179 QElapsedTimer m_noLoginTimer;
180 };
181
185 class TIANCHI_API TcInvoke
186 {
187 public:
189 TcInvoke(QObject* o=NULL, QByteArray m="")
190 {
191 init(o, m);
192 }
194 TcInvoke &operator=(const TcInvoke& from)
195 {
196 if ( this != &from )
197 {
198 this->m_object = from.m_object;
199 this->m_method = from.m_method;
200 }
201 return *this;
202 }
203
205 inline bool queued(QGenericArgument val0 = QGenericArgument(0),
206 QGenericArgument val1 = QGenericArgument(),
207 QGenericArgument val2 = QGenericArgument(),
208 QGenericArgument val3 = QGenericArgument(),
209 QGenericArgument val4 = QGenericArgument(),
210 QGenericArgument val5 = QGenericArgument(),
211 QGenericArgument val6 = QGenericArgument(),
212 QGenericArgument val7 = QGenericArgument(),
213 QGenericArgument val8 = QGenericArgument(),
214 QGenericArgument val9 = QGenericArgument())
215 {
216 try
217 {
218 return m_object != NULL ? m_object->metaObject()->invokeMethod(
219 m_object, m_method, Qt::QueuedConnection,
220 val0, val1, val2, val3, val4,
221 val5, val6, val7, val8, val9) : false;
222 }
223 catch (...)
224 {
225 return false;
226 }
227 }
228
230 bool invoke(QGenericArgument val0 = QGenericArgument(0),
231 QGenericArgument val1 = QGenericArgument(),
232 QGenericArgument val2 = QGenericArgument(),
233 QGenericArgument val3 = QGenericArgument(),
234 QGenericArgument val4 = QGenericArgument(),
235 QGenericArgument val5 = QGenericArgument(),
236 QGenericArgument val6 = QGenericArgument(),
237 QGenericArgument val7 = QGenericArgument(),
238 QGenericArgument val8 = QGenericArgument(),
239 QGenericArgument val9 = QGenericArgument());
240
243 inline bool isValid() const
244 {
245 return m_object != NULL && ! m_method.isEmpty();
246 }
247
248 private:
249 QObject* m_object;
250 QByteArray m_method;
251
252 inline void init(QObject* o, QByteArray m)
253 {
254 m_object = o;
255 m_method = m;
256 }
257 };
258
263 class TIANCHI_API TcDBFields
264 {
265 public:
266 TcDBFields() {}
267 inline TcDBFields(QHash<QString, QByteArray> fields)
268 { setFields(fields); }
269
270 static void addField(QByteArray& fieldBytes,
271 const QString& name, const QVariant& value);
272 static QHash<QString, QByteArray> getFields(const QByteArray& fieldBytes);
273
274 void setFields(QHash<QString, QByteArray> fields)
275 {
276 m_fields.clear();
277 m_keys.clear();
278
279 m_fields = fields;
280 m_keys = m_fields.keys();
281 }
282 inline QByteArray value(const QString& key) const
283 {
284 return m_fields.value(key.trimmed().toLower());
285 }
286
287 private:
288 QHash<QString, QByteArray> m_fields;
289 QStringList m_keys;
290 };
291
292 #endif // TIANCHI_CLASSES_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tccommon.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
tccommon.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：公共单元，此单元不使用 namespace Tianchi
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.15 圣域天子 建立
13 //
14 // ==========================================================================
16 #ifndef TIANCHI_TCCOMMON_H
17 #define TIANCHI_TCCOMMON_H
18
19 #include <tianchi/tcglobal.h>
20
21 #include <QTextCodec>
22 #include <QDateTime>
23
24 #ifdef QT_WIDGETS_LIB
25 #include <QMessageBox>
26 #endif
27
28 #if defined(QT_DEBUG)
29 #include <iostream>
30 using namespace std;
31 #endif
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54 QTextCodec* initQS(const QByteArray& name="GBK");
55
78 inline QString QS(const char* s)
79 {
80 return QTextCodec::codecForLocale()->toUnicode(s);
81 }
82
84 #define max(a,b) (((a) > (b)) ? (a) : (b))
85
86 #define min(a,b) (((a) < (b)) ? (a) : (b))
87
88 inline int iif(bool logic, int v1, int v2=0) { return logic ? v1 : v2; }
90 inline QString iif(bool logic, const QString& v1, const QString& v2="") { return logic ? v1 : v2; }
91
92 #ifdef QT_WIDGETS_LIB
93
94
95
96 inline void MsgBox(const QString& s)
97 {
98 QMessageBox::information(NULL, "", s);
99 }
100 #endif
101 #define TC_FREE(x) {delete x; x=NULL;}
102 #if defined(QT_DEBUG)
103
104
105
106
107 inline void debug_out(const char* file, int line, const QString& text="")
108 {
109 cout<<QDateTime::currentDateTime().toString("yyyy/MM/dd HH:mm:ss->").toLocal8Bit().data()<<file<<"("<<line<<"): "<<text.toLocal8Bit().data()<<endl;
110 }
115 inline void debug_out(const char* file, int line, int value)
116 {
117 debug_out(file, line, QString::number(value));
118 }
119
121 #define DEBUG_STEP debug_out(__FILE__, __LINE__);
122
123 #define DEBUG_OUT(x) debug_out(__FILE__, __LINE__, x);
124 #else
125
126 #define DEBUG_STEP
127
128 #define DEBUG_OUT(x)
129 #endif
130
132 QString YYYY_MM_DD_HH_MM_SS_ZZZ();
134 QString YYYY_MM_DD_HH_MM_SS();
135
136 #endif // TIANCHI_COMMON_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcfunctionalsortfilterproxymodel.h 文件参考

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
类 | 类型定义
tcfunctionalsortfilterproxymodel.h 文件参考
#include <tianchi/tcglobal.h>
#include <QVariantMap>
#include <QSortFilterProxyModel>

浏览源代码.

类

class TcFunctionalSortFilterProxyModel
依所设过滤参数(QVariantMap)来使用已设滤函数进行过滤的 SortFilterProxyModel,使用时分三部分: 更多...

类型定义

typedef bool(* TcFunctionalSortFilterProxyModelFilterFunction )(const QVariantMap &, const QModelIndex &)
过滤函数类型,第一个参数为过滤条件,第二个参数为sourceModel的对应行 第一列index


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcsingleton.hpp 文件参考

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
类 | 宏定义
tcsingleton.hpp 文件参考

用指针实现的单例模式的模版类 更多...

#include <cassert>

浏览源代码.

类

class TcSingleton< T >
用指针实现的单例模式的模版类 更多...

宏定义

#define TC_SINGLETON_INIT(__t)
初始化宏 更多...

详细描述

用指针实现的单例模式的模版类

宏定义说明

#define TC_SINGLETON_INIT ( __t )
值:
template<> int TcSingleton< __t >::m_count = 0; \
template<> __t * TcSingleton< __t >::m_pointer = 0;

初始化宏

生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcstring.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
tcstring.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：字符串功能增强与扩展
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.16 圣域天子 建立
13 //
14 // ==========================================================================
16 #ifndef TIANCHI_TCSTRING_H
17 #define TIANCHI_TCSTRING_H
18
19 #include <tianchi/tcglobal.h>
20
21 #include <QString>
22 #include <QStringList>
23
27 class TIANCHI_API TcString
28 {
29 public:
30 TcString();
31
37 static QByteArray first(QByteArray& str, const QByteArray& split="\t");
38
42 static int find(const QStringList& ss, const QString& s);
43
47 static int findOf(const QStringList& list, const QString& key);
48
54 static bool filter(const QString& findText, const QStringList& filters);
55
60 static QString getTextByIndex(const char* strings, int index);
61
63 static int splitHumanName(QString full, QString& sur, QString& real, QString& english);
64
65 };
66
70 class TIANCHI_API TcStringList : public QStringList
71 {
72 public:
73 TcStringList();
77 bool loadFrom(const QString& fileName);
81 bool saveTo(const QString& fileName);
82
84 inline QString lineBreak() const
85 {
86 return m_lineBreak;
87 }
89 inline void lineBreak(const QString& value)
90 {
91 m_lineBreak = value;
92 }
93
94 private:
95 QString m_lineBreak;
96 };
97
98 #endif // TIANCHI_STRING_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp 文件参考

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
类 | 命名空间
tctuple.hpp 文件参考

简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版 更多...

浏览源代码.

类

class | _tc_tuple_ns_::null_type
class | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >
class | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
class | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
class | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
class | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
class | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
class | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
class | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >
class | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >
class | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >

命名空间

namespace _tc_tuple_ns_
简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版

详细描述

简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版

生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcutils.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
tcutils.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：常用功能函数
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCUTILS_H
18 #define TIANCHI_TCUTILS_H
19
20 #include <tianchi/tcglobal.h>
21
22 #ifdef QT_WIDGETS_LIB
23 #include <QMessageBox>
24 #endif
25
26 #include <QTextCodec>
27 #include <QVariant>
28
29 #include <QDateTime>
30
31 #include <QString>
32 #include <QStringList>
33 #include <QByteArray>
34 #include <QComboBox>
35
36 #include <QThread>
37
39 struct TcOperMode
40 {
41 const static int Append = 1;
42 const static int Change = 2;
43 const static int Delete = 4;
44
45 const static int CopyCell = 301;
46 const static int CopyCells = 302;
47 const static int CopyColumn = 303;
48 const static int CopyLine = 304;
49 const static int CopyTable = 305;
50 };
51
55 class TIANCHI_API TcUtils
56 {
57 public:
59 static QHash<QString, QString> StringToMap(const QString& mapStrings);
61 static QHash<QString, QString> StringToMap(const QStringList& mapStrings);
62
64 static char typeFrom(QVariant::Type type);
66 static char typeFrom(const QVariant& v)
67 {
68 return typeFrom(v.type());
69 }
70
71 const static qint64 JULIAN_DAY = 2415019;
73 static QDateTime toDateTime(const QString& text);
75 static QDateTime toDateTime(double timeDouble);
76
78 static char getIDCardVerifyCode(const QByteArray& id);
79
81 static QDateTime complieDateTime(const QString& complieDate, const QString& complieTime);
82
83 static QByteArray addField(const QString& key, const QVariant& value);
84 static QHash<QString, QByteArray> byFields(const QByteArray& fieldBytes);
85
86 };
87
88 #endif // TIANCHI_UTILS_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcvariantmaptablemodel.h 文件参考

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
类 | 枚举
tcvariantmaptablemodel.h 文件参考
#include <tianchi/tcglobal.h>
#include <QVariantMap>
#include <QAbstractTableModel>

浏览源代码.

类

class TcVariantMapTableModel
以QVariantMap作为数据行的model,只可追加和清除,不可任意插入与任意 删除,使用时主要分成三部分： 更多...

枚举

enum { TcDataRole = Qt::UserRole + 999 }

枚举类型说明

anonymous enum
枚举值
TcDataRole

定义返回每行所有实际数据的角色

生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file 目录参考

  • include
  • tianchi
  • file
file 目录参考

文件

文件 | tcdir.h [代码]
可以复制目录树的类，也可以查找文件夹内所有的文件
文件 | tcexcelreader.h [代码]
文件 | tcfile.h [代码]
文件 | tcfileio.h [代码]
一些文件复制和提取功能
文件 | tcjson.h [代码]
文件 | tclog.h [代码]
文件 | tcmsexcel.h [代码]
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcdir.h 文件参考

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • file
类
tcdir.h 文件参考

可以复制目录树的类，也可以查找文件夹内所有的文件 更多...

#include <tianchi/tcglobal.h>
#include <QObject>
#include <QStringList>

浏览源代码.

类

class TcDir

详细描述

可以复制目录树的类，也可以查找文件夹内所有的文件

生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcexcelreader.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • file
tcexcelreader.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：通过 OLE 方式操作 Microsoft Excel（仅限 Windows 下使用，要求已
8 // 安装 Excel）
9 // ==========================================================================
10 // 开发日志：
11 // 日期 人员 说明
12 // --------------------------------------------------------------------------
13 // 2013.05.02 XChinux 建立
14 //
15 // ==========================================================================
17 // 要求已安装 Excel或WPSOffice）
18 // ==========================================================================
19 #ifndef TIANCHI_TCEXCELREADER_H
20 #define TIANCHI_TCEXCELREADER_H
21
22 #include <tianchi/tcglobal.h>
23
24 #include <QVariant>
25 #include <QStringList>
26
27 class TcExcelReaderPrivate;
28
32 class TIANCHI_API TcExcelReader
33 {
34 public:
35 TcExcelReader();
36 ~TcExcelReader();
38 bool isNull() const;
40 bool open(const QString &file);
44 QVariant cell(int row, int col);
45
47 int sheetCount();
49 QStringList sheetNames();
51 bool setCurrentSheet(int index);
53 bool setCurrentSheet(const QString &sheetName);
55 int currentSheetIndex();
57 QString currentSheetName();
58 private:
59 Q_DISABLE_COPY(TcExcelReader)
60 Q_DECLARE_PRIVATE(TcExcelReader)
61 TcExcelReaderPrivate* const d_ptr;
62 };
63
64 #endif
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcfile.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • file
tcfile.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：文件操作常用处理类
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.15 圣域天子 建立
13 // 2013.06.14 XChinux 为loadFromFile()函数增加codec参数
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCFILE_H
18 #define TIANCHI_TCFILE_H
19
20 #include <tianchi/tcglobal.h>
21
22 #include <QString>
23
27 class TIANCHI_API TcFile
28 {
29 public:
31 static bool loadFromFile(QString &context, const QString &filename,
32 const QString &codec = QString());
33
37 static QString uniqueFileName(const QString &dir,
38 const QString &fileTemplate, const QString &suffix= QString());
39
43 static QString fileVersion(const QString& exeFile);
44
46 static QStringList searchFiles(const QString& path);
47 };
48
49 #endif // TIANCHI_TCFILE_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcfileio.h 文件参考

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • file
类
tcfileio.h 文件参考

一些文件复制和提取功能 更多...

#include <QString>
#include <QStringList>
#include <QIODevice>
#include <tianchi/tcglobal.h>

浏览源代码.

类

class TcFileIO
一些文件复制和提取功能的类 更多...

详细描述

一些文件复制和提取功能

生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcjson.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • file
tcjson.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：JSON 创建和解析类
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ==========================================================================
16 #ifndef TIANCHI_TCJSON_H
17 #define TIANCHI_TCJSON_H
18
19 #include <tianchi/tcglobal.h>
20
21 #include <QDateTime>
22 #include <QMap>
23 #include <QList>
24 #include <QVariant>
25 #include <QString>
26 #include <QStringList>
27
31 class TIANCHI_API TcJSONObject
32 {
33 public:
34 enum ValueTypeFlag
35 {
36 vtfObject = 0,
37 vtfString = 1,
38 vtfInt = 2,
39 vtfDouble = 3,
40 vtfBool = 4, vtfDateTime=5, vtfNull=6, vtfArray=99 };
41
42 TcJSONObject(const QString& key="");
43 virtual ~TcJSONObject();
44
45 static QString quote(const QString& Text);
46 static QString dequote(const QString& S);
47
48 protected:
49 TcJSONObject* parent;
50
51 int m_index;
52 QMap<QString, TcJSONObject*> m_list;
53
54 ValueTypeFlag m_type;
55 QString m_key;
56 QVariant m_value;
57
58 QString jsonKey() const;
59 QString jsonValue() const;
60
61 void init();
62 const wchar_t* fromObject(const QString& Key, const wchar_t* ptr);
63 const wchar_t* fromArray(const wchar_t* ptr);
64
65 inline QString newKey(const QString& key)
66 { return key.trimmed().isEmpty() ? QString::number(m_index++) : key.trimmed(); }
67
68 const wchar_t* parseKey(QString& Value, const wchar_t* ptr);
69 const wchar_t* parseValue(QString Key, const wchar_t* ptr);
70 const wchar_t* parseNumber(QString& Value, const wchar_t* ptr);
71 static inline const wchar_t* skip(const wchar_t* in)
72 {
73 while(in && *in && *in<=32)
74 {
75 in++;
76 }
77 return in;
78 }
79
80 public:
81 int type() const { return m_type; }
82 void setType(int value) { m_type = (ValueTypeFlag) value; }
83
84 QString key() const;
85 void setKey(const QString& value);
86 QVariant value() const;
87 inline QVariant value(const QString& key) const
88 { QVariant ret; value(key, ret); return ret; }
89 bool value(const QString& key, QVariant& v) const;
90 inline bool exists(const QString& key) const
91 {
92 QMap<QString, TcJSONObject*>::const_iterator child = m_list.find(key);
93 return child != m_list.constEnd() && child.key() == key;
94 }
95 inline int count() const { return m_list.count(); }
96 inline TcJSONObject* get(const QString& key) const
97 { return m_list[key]; }
98 QList<TcJSONObject*> children() const;
99
100
101 TcJSONObject* addObject(const QString& key="");
102 TcJSONObject* addArray(const QString& key);
103 TcJSONObject* addNull(const QString& key);
104 inline TcJSONObject* add(const QString& key, const char* value) { return add(key, QString(value)); }
105 TcJSONObject* add(const QString& key, const QString& value);
106 TcJSONObject* add(const QString& key, int value);
107 TcJSONObject* add(const QString& key, double value);
108 TcJSONObject* add(const QString& key, bool value);
109 TcJSONObject* add(const QString& key, QDateTime value);
110
111 TcJSONObject* addNull();
112 inline TcJSONObject* add(const char* value) { return add(QString(value)); }
113 inline TcJSONObject* add(const QString& value) { return add(QString::number(m_index++), value); }
114 inline TcJSONObject* add(int value) { return add(QString::number(m_index++), value); }
115 inline TcJSONObject* add(double value) { return add(QString::number(m_index++), value); }
116 inline TcJSONObject* add(bool value) { return add(QString::number(m_index++), value); }
117 inline TcJSONObject* add(QDateTime value) { return add(QString::number(m_index++), value); }
118
119 void deleteChildren(const QString& key);
120 void clearChildren();
121 void clear();
122
123 virtual QString toString() const; // 取得
124
125 bool fromString(QString jsonText);
126 };
127 // ==========================================================================
128
129 #endif // TIANCHI_JSON_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tclog.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • file
tclog.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：简单的 Log 输出类
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCLOG_H
18 #define TIANCHI_TCLOG_H
19
20 #include <tianchi/tcglobal.h>
21
22 #include <QString>
23
27 class TIANCHI_API TcLog
28 {
29 public:
42 void setAppFile(const QString& AppFile);
43
51 void setLogFile(const QString& LogFile);
52
57 void write(const QString& S,
58 const QString& SourceName = QString(),
59 int SourceLine = 0);
60
65 inline void debug(const QString& S,
66 const QString& SourceName = QString(),
67 int SourceLine = 0)
68 {
69 #ifdef _DEBUG
70 write(S, SourceName, SourceLine);
71 #else
72 Q_UNUSED(S);
73 Q_UNUSED(SourceName);
74 Q_UNUSED(SourceLine);
75 #endif
76 }
77
78 private:
79 QString m_FileName;
80 };
81
83 //#define Log_Step Log.write("<<STEP>>", __FILE__, __LINE__);
84
86 //#ifdef _DEBUG
87 // #define Debug_Log(s) Log.write(s, __FILE__, __LINE__);
88 //#else
89 // #define Debug_Log(s)
90 //#endif
91
92
93 #endif // TIANCHI_LOGTINY_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcmsexcel.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • file
tcmsexcel.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：通过 OLE 方式操作 Microsoft Excel（仅限 Windows 下使用，要求已安
8 // 装 Excel）
9 // ==========================================================================
10 // 开发日志：
11 // 日期 人员 说明
12 // --------------------------------------------------------------------------
13 // 2013.04.10 圣域天子 建立
14 //
15 // ==========================================================================
17 // 要求已安装 Excel）
18 // ==========================================================================
19 #ifndef TIANCHI_TCMSEXCEL_H
20 #define TIANCHI_TCMSEXCEL_H
21
22 #include <tianchi/tcglobal.h>
23
24 #include <QString>
25 #include <QStringList>
26 #include <QVariant>
27
28 class TcMSExcelPrivate;
29
35 class TIANCHI_API TcMSExcel
36 {
37 public:
39 TcMSExcel();
41 virtual ~TcMSExcel();
42
43 private:
44 Q_DISABLE_COPY(TcMSExcel)
45 Q_DECLARE_PRIVATE(TcMSExcel)
46 TcMSExcelPrivate* const d_ptr;
47
48 public:
50 enum Alignment
51 {
52 xlTop = -4160,
53 xlLeft = -4131,
54 xlRight = -4152,
55 xlCenter = -4108,
56 xlBottom = -4107
57 };
58
60 bool create(const QString& filename = QString());
62 bool open(const QString& filename = QString());
64 void save(const QString& filename = QString());
66 void close();
70 void kick();
71
73 void setVisible(bool value);
75 void setCaption(const QString& value);
76
78 bool addBook();
79
81 int sheetCount();
82
84 QStringList sheetNames();
85
87 bool currentSheet();
88
91 bool setCurrentSheet(int index);
92
94 QString currentSheetName();
95
100 QVariant read(int row, int col);
101
106 inline QVariant cell(int row, int col) { return read(row, col); }
107
112 void write(int row, int col, const QVariant& value);
113
114 void cellFormat(int row, int col, const QString& format);
115 void cellAlign(int row, int col, Alignment hAlign, Alignment vAlign);
116
122 bool usedRange(int& rowStart, int& colStart, int &rowEnd, int &colEnd);
123 };
124
125 #endif // TIANCHI_MSEXCEL_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui 目录参考

  • include
  • tianchi
  • gui
gui 目录参考

文件

文件 | tcclicklabel.h [代码]
文件 | tcdateedit.h [代码]
文件 | tcflowlayout.h [代码]
文件 | tcformutils.h [代码]
文件 | tcgloweffect.h [代码]
文件 | tcguiutils.h [代码]
文件 | tcheadersetupdialog.h [代码]
文件 | tclineedit.h [代码]
文件 | tcmarqueelabel.h [代码]
文件 | tcsortpaginationtableview.h [代码]
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcclicklabel.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tcclicklabel.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：可发出clicked信号的Label部件
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.17 XChinux 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCCLICKLABEL_H
18 #define TIANCHI_TCCLICKLABEL_H
19
20 #include <tianchi/tcglobal.h>
21 #include <QLabel>
22
23 class TcClickLabelPrivate;
24
26 class TIANCHI_API TcClickLabel : public QLabel
27 {
28 Q_OBJECT
29 public:
30 TcClickLabel(QWidget *parent = 0, Qt::WindowFlags f = 0);
31 TcClickLabel(const QString &text, QWidget *parent = 0,
32 Qt::WindowFlags f = 0);
33 virtual ~TcClickLabel();
34 Q_SIGNALS:
36 void clicked();
37 protected:
38 virtual void mousePressEvent(QMouseEvent *e);
39 virtual void mouseReleaseEvent(QMouseEvent *e);
40 private:
41 Q_DISABLE_COPY(TcClickLabel)
42 Q_DECLARE_PRIVATE(TcClickLabel)
43 TcClickLabelPrivate* const d_ptr;
44 };
45
46 #endif
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcdateedit.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tcdateedit.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：允许为空的日期选择控件
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCDATEEDIT_H
18 #define TIANCHI_TCDATEEDIT_H
19
20 #include <tianchi/tcglobal.h>
21
22 #include <QComboBox>
23 #include <QCalendarWidget>
24
28 class TIANCHI_API TcDateEdit : public QComboBox
29 {
30 Q_OBJECT
31
32 Q_PROPERTY(QDate date READ date WRITE setDate RESET unsetDate)
33
34 private Q_SLOTS:
35 void calendarClicked(QDate);
36
37 private:
38 QCalendarWidget *m_calendar;
39
40 protected:
41 void focusInEvent(QFocusEvent *e);
42 void mousePressEvent(QMouseEvent *e);
43
44 public:
45 TcDateEdit(QWidget *parent = 0);
46 virtual ~TcDateEdit();
47
48 QDate date() const;
49 void setDate(QDate value);
50 void unsetDate();
51
52 inline void setDate(QDateTime value) { setDate(value.date()); }
53 };
54
55 #endif
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcflowlayout.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tcflowlayout.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) Qt Project
5 // 授权协议：LGPL
6 // **************************************************************************
7 // 文档说明：流式布局FlowLayout
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.21 XChinux 修改自Qt examples&demos里的flowlayout示例
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCFLOWLAYOUT_H
18 #define TIANCHI_TCFLOWLAYOUT_H
19
20 #include <tianchi/tcglobal.h>
21 #include <QLayout>
22
23 class TcFlowLayoutPrivate;
24
26 class TIANCHI_API TcFlowLayout : public QLayout
27 {
28 public:
29 TcFlowLayout(QWidget *parent, int margin = -1, int hSpacing = -1,
30 int vSpacing = -1);
31 TcFlowLayout(int margin = -1, int hSpacing = -1, int vSpacing = -1);
32 virtual ~TcFlowLayout();
33
34 void addItem(QLayoutItem *item);
35 int horizontalSpacing() const;
36 int verticalSpacing() const;
37 Qt::Orientations expandingDirections() const;
38 bool hasHeightForWidth() const;
39 int heightForWidth(int) const;
40 int count() const;
41 QLayoutItem *itemAt(int index) const;
42 QSize minimumSize() const;
43 void setGeometry(const QRect &rect);
44 QSize sizeHint() const;
45 QLayoutItem *takeAt(int index);
46
47 private:
48 Q_DISABLE_COPY(TcFlowLayout)
49 Q_DECLARE_PRIVATE(TcFlowLayout)
50 TcFlowLayoutPrivate* const d_ptr;
51 };
52
53 #endif
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcformutils.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tcformutils.h
1 #ifndef TIANCHI_TCFORMUTILS_H
2 #define TIANCHI_TCFORMUTILS_H
3
4 #include <tianchi/tcglobal.h>
5
6 #include <QWidget>
7
8 class TIANCHI_API TcFormUtils
9 {
10 public:
11 TcFormUtils();
12
13 inline QWidget* parentForm() const { return m_parentForm; }
14 inline void setParentForm(QWidget* value) { m_parentForm = value; }
15 private:
16 QWidget* m_parentForm;
17 };
18
19 #endif // TIANCHI_TCFORMUTILS_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcgloweffect.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tcgloweffect.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：发光效果的QGraphicsEffect
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2012.08.23 roywillow 原创
13 // 2013.04.22 XChinux 修改
14 //
15 // ==========================================================================
17 // ==========================================================================
26 #ifndef TIANCHI_TCGLOWEFFECT_H
27 #define TIANCHI_TCGLOWEFFECT_H
28
29 #include <tianchi/tcglobal.h>
30 #include <QGraphicsEffect>
31
32 class TcGlowEffectPrivate;
33
43 class TIANCHI_API TcGlowEffect : public QGraphicsEffect
44 {
45 Q_OBJECT
46 public:
47 TcGlowEffect(QObject *parent = 0);
48 virtual ~TcGlowEffect();
49
52 void setRadius(int radius);
55 void setGlowColor(const QColor &color);
56 virtual QRectF boundingRectFor(const QRectF &sourceRect) const;
57 protected:
58 virtual void draw(QPainter *painter);
59 virtual void sourceChanged(ChangeFlags flags);
60
61 private:
62 Q_DISABLE_COPY(TcGlowEffect)
63 Q_DECLARE_PRIVATE(TcGlowEffect)
64 TcGlowEffectPrivate* const d_ptr;
65 };
66
67 #endif // GLOWEFFECT_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcguiutils.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tcguiutils.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：GUI相关常用单元
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.15 圣域天子 建立
13 //
14 // ==========================================================================
16 #ifndef TIANCHI_TCGUIUTILS_H
17 #define TIANCHI_TCGUIUTILS_H
18
19 #include <tianchi/tcglobal.h>
20
21 #include <QLabel>
22 #include <QCursor>
23 #include <QWidget>
24 #include <QToolBar>
25 #include <QToolButton>
26 #include <QTreeWidget>
27 #include <QDoubleSpinBox>
28 #if (QT_VERSION >= QT_VERSION_CHECK(5, 0, 0))
29 #include <QGuiApplication>
30 #else
31 #include <QApplication>
32 #endif
33
39 class TIANCHI_API TcCursorCustom
40 {
41 protected:
42 TcCursorCustom(Qt::CursorShape shape)
43 {
44 #if (QT_VERSION >= QT_VERSION_CHECK(5, 0, 0))
45 QGuiApplication::setOverrideCursor(QCursor(shape));
46 #else
47 QApplication::setOverrideCursor(QCursor(shape));
48 #endif
49 }
50 virtual ~TcCursorCustom()
51 {
52 restore();
53 }
54 QWidget* m_parent;
55 QCursor m_cursor;
56 public:
58 inline void restore()
59 {
60 #if (QT_VERSION >= QT_VERSION_CHECK(5, 0, 0))
61 QGuiApplication::restoreOverrideCursor();
62 #else
63 QApplication::restoreOverrideCursor();
64 #endif
65 }
66 };
67
82 class TIANCHI_API TcCursorWait : public TcCursorCustom
83 {
84 public:
85 TcCursorWait()
86 : TcCursorCustom(Qt::WaitCursor)
87 {
88 }
89 };
90
106 class TIANCHI_API TcCursorBusy : public TcCursorCustom
107 {
108 public:
109 TcCursorBusy()
110 : TcCursorCustom(Qt::BusyCursor)
111 {
112 }
113 };
114
115 namespace Tc
116 {
117
118 // 在工具栏上创建一个按钮
119 TIANCHI_API QToolButton* createButton(QToolBar* toolBar,
120 QIcon icon, QString text, int width,
121 Qt::ToolButtonStyle style=Qt::ToolButtonTextBesideIcon);
122
123 inline void setColumnBold(QTreeWidget* view)
124 {
125 for( int i=0;i<view->headerItem()->columnCount();i++ )
126 {
127 QFont font = view->headerItem()->font(i);
128 font.setBold(true);
129 view->headerItem()->setFont(i, font);
130 }
131 }
132
133 inline void setColumnWidth(QTreeWidget* view, int column, int width, bool hide=false)
134 {
135 view->setColumnWidth(column, width);
136 view->setColumnHidden(column, hide);
137 }
138
139 TIANCHI_API void createColumnMenu(QTreeWidget* view, QWidget* widget, const QString& ColumnSetupFunc);
140
141
142 TIANCHI_API void setColumnStyle(QTreeWidget* view, int fontSize=8, const QString &fontName="Tahoma");
143
144 TIANCHI_API void cellStyle(QTreeWidgetItem* item, int startCol=-1, int endCol=-1,
145 bool bold=true, int alignment=Qt::AlignVCenter | Qt::AlignRight,
146 int cellHeight=25);
147
148
149 TIANCHI_API void cellFont(QTreeWidgetItem* item, int col, bool bold=false, int alignment=Qt::AlignVCenter | Qt::AlignLeft);
150 TIANCHI_API void cellColor(QTreeWidgetItem* item, int col, QColor color);
151
152 TIANCHI_API void changeFont(QWidget* widget, const QString& fontName="Arial Narrow", int fontSize=8, bool bold=false);
153 TIANCHI_API void setFontTahoma(QWidget* widget, int fontSize=8, bool bold=false);
154 // 在 QTreeWidgetItem 上显示数值
155 TIANCHI_API void cellValue(QTreeWidgetItem* item, int column, const char* text, const QVariant& data=QVariant(), int size=0);
156 TIANCHI_API void cellValue(QTreeWidgetItem* item, int column, const QString& text, const QVariant& data=QVariant(), int size=0);
157 TIANCHI_API void cellValue(QTreeWidgetItem* item, int column, const QByteArray& text, const QVariant& data=QVariant(), int size=0);
158 TIANCHI_API void cellValue(QTreeWidgetItem* item, int column, double value);
159 TIANCHI_API void cellValue(QTreeWidgetItem* item, int column, double value, int digits);
160 TIANCHI_API void cellPrice(QTreeWidgetItem* item, int column, double value=0.0, int digits=0);
161 TIANCHI_API void cellPercent(QTreeWidgetItem* item, int column, double value=0.0, int digits=0);
162
163 TIANCHI_API QLabel* createLabel(QTreeWidgetItem* item, int col, const QString& htmlText, const QVariant& data=QVariant());
164
165 TIANCHI_API QDoubleSpinBox* createDoubleSpinBox(QTreeWidgetItem* item, int col,
166 int decimals, double min, double max, double step, double value);
167 TIANCHI_API double readDoubleSpinBoxValue(QTreeWidgetItem* item, int col);
168
169 TIANCHI_API void CopyCell(QTreeWidget* view);
170 TIANCHI_API void CopyLine(QTreeWidget* view);
171 TIANCHI_API void CopyTable(QTreeWidget* view);
172 }
173
174 #endif // TIANCHI_GUIUTILS_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcheadersetupdialog.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tcheadersetupdialog.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：修改 QTreeWidget 列设置的对话框
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 // ==========================================================================
15 #ifndef TIANCHI_TCHEADERSETUPDIALOG_H
16 #define TIANCHI_TCHEADERSETUPDIALOG_H
17
18 #include <tianchi/tcglobal.h>
19
20 #include <QDialog>
21 #include <QTreeWidget>
22
23 namespace Ui
24 {
25 class TcHeaderSetupDialog;
26 }
27
31 class TIANCHI_API TcHeaderSetupDialog : public QDialog
32 {
33 Q_OBJECT
34
35 public:
36 explicit TcHeaderSetupDialog(QWidget *parent = 0);
37 ~TcHeaderSetupDialog();
38
42 void setHeader(QTreeWidget* view, int max=-1);
43
44 private Q_SLOTS:
45 void on_bnUpward_clicked();
46 void on_bnDownawrd_clicked();
47
48 void on_MasterView_itemClicked(QTreeWidgetItem *item, int column);
49 void on_bnLeft_clicked();
50 void on_bnCenter_clicked();
51 void on_bnRight_clicked();
52
53 private:
54 Ui::TcHeaderSetupDialog *ui;
55
56 QTreeWidget* m_view;
57 };
58
59
60 #endif // TIANCHI_TCHEADERSETUPDIALOG_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tclineedit.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tclineedit.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：extended QLineEdit widget
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.22 XChinux 建立
13 // 2013.04.29 XChinux add LineEditPrivate::_q_editingFinished()
14 // add LineEdit::clear()
15 // ==========================================================================
17 // ==========================================================================
18 #ifndef TIANCHI_TCLINEEDIT_H
19 #define TIANCHI_TCLINEEDIT_H
20
21 #include <tianchi/tcglobal.h>
22 #include <QLineEdit>
23
24 QT_BEGIN_NAMESPACE
25 class QPaintEvent;
26 class QMouseEvent;
27 class QContextMenuEvent;
28 QT_END_NAMESPACE
29
30 class TcLineEditPrivate;
31
35 class TIANCHI_API TcLineEdit : public QLineEdit
36 {
37 Q_OBJECT
38
40 Q_PROPERTY(QString labelText
41 READ labelText
42 WRITE setLabelText
43 NOTIFY labelTextChanged
44 DESIGNABLE true)
46 Q_PROPERTY(QVariant data
47 READ data
48 WRITE setData
49 NOTIFY dataChanged
50 DESIGNABLE false)
51 public:
52 TcLineEdit(QWidget *parent = 0);
53 virtual ~TcLineEdit();
54 QString labelText() const;
55 QVariant data() const;
56 Q_SIGNALS:
58 void labelTextChanged(const QString &labelText);
60 void dataChanged(const QVariant &userData);
62 void doubleClicked();
63 public Q_SLOTS:
65 void setLabelText(const QString &labelText);
67 void setData(const QVariant &userData);
69 void clear();
70 protected:
71 virtual void paintEvent(QPaintEvent *event);
72 virtual void mouseDoubleClickEvent(QMouseEvent *event);
73 virtual void contextMenuEvent(QContextMenuEvent *event);
74 private:
75 Q_DISABLE_COPY(TcLineEdit)
76 Q_DECLARE_PRIVATE(TcLineEdit)
77 Q_PRIVATE_SLOT(d_func(), void _q_editingFinished())
78 TcLineEditPrivate* const d_ptr;
79 };
80
81 #endif
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcmarqueelabel.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tcmarqueelabel.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：跑马灯Label,点击时自动打开网址
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.18 XChinux 建立
13 // 2013.05.19 XChinux 修改原移动Label位置的实现为使用contentsMargin来实现
14 // 2013.05.22 XChinux 增加interval active属性及相关信号和槽函数
15 // ==========================================================================
17 // ==========================================================================
18 #ifndef TIANCHI_TCMARQUEELABEL_H
19 #define TIANCHI_TCMARQUEELABEL_H
20
21 #include <tianchi/tcglobal.h>
22
23 #include <QLabel>
24
25 QT_BEGIN_NAMESPACE
26 QT_END_NAMESPACE
27
28 class TcMarqueeLabelPrivate;
32 class TIANCHI_API TcMarqueeLabel : public QLabel
33 {
34 Q_OBJECT
35
36 Q_ENUMS(Direction)
37
38 // @brief 设置文字滚动方向
39 Q_PROPERTY(Direction direction
40 READ direction
41 WRITE setDirection
42 NOTIFY directionChanged
43 DESIGNABLE true)
44
45
46 Q_PROPERTY(int interval
47 READ interval
48 WRITE setInterval
49 NOTIFY intervalChanged
50 DESIGNABLE true)
51
52
53 Q_PROPERTY(bool active
54 READ isActive
55 WRITE setActive
56 NOTIFY activeChanged
57 DESIGNABLE true)
58
59 Q_PROPERTY(Qt::Alignment alignment
60 READ alignment
61 WRITE setAlignment
62 DESIGNABLE true)
63 public:
64 TcMarqueeLabel(QWidget * parent = 0, Qt::WindowFlags f = 0);
65 TcMarqueeLabel(const QString &text, QWidget *parent = 0,
66 Qt::WindowFlags f = 0);
67 virtual ~TcMarqueeLabel();
69 int interval() const;
71 bool isActive() const;
72
73 enum Direction
74 {
75 RightToLeft = 0,
76 BottomToTop = 1
77 };
78
79 Direction direction() const;
80 void setAlignment(Qt::Alignment align);
81 Q_SIGNALS:
83 void intervalChanged(int interval);
85 void activeChanged(bool active);
87 void directionChanged(Direction direction);
88 public Q_SLOTS:
91 void reset();
94 void setActive(bool active);
97 void setInterval(int msec);
100 void start();
103 void stop();
106 void setDirection(Direction direciton);
107 protected:
108 virtual void enterEvent(QEvent *event);
109 virtual void leaveEvent(QEvent *event);
110 virtual void resizeEvent(QResizeEvent *event);
111 virtual void timerEvent(QTimerEvent *event);
112 virtual void paintEvent(QPaintEvent *event);
113 private:
114 Q_DISABLE_COPY(TcMarqueeLabel)
115 Q_DECLARE_PRIVATE(TcMarqueeLabel)
116 Q_PRIVATE_SLOT(d_func(), void _q_openLink(const QString &))
117 TcMarqueeLabelPrivate* const d_ptr;
118 };
119
120 #endif
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcsortpaginationtableview.h 文件参考

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
类
tcsortpaginationtableview.h 文件参考
#include <tianchi/tcglobal.h>
#include <QTableView>

浏览源代码.

类

class TcSortPaginationTableView
可排序和分页的TableView,使用时主要分两步: 更多...


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/network 目录参考

  • include
  • tianchi
  • network
network 目录参考

文件

文件 | tcdownloadhttp.h [代码]
文件 | tcsingleinstance.h [代码]
文件 | tcudp.h [代码]
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/network/tcdownloadhttp.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • network
tcdownloadhttp.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：HTTP 文件多线程下载器
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.19 圣域天子 建立
13 //
14 // ==========================================================================
16 #ifndef TIANCHI_TCDOWNLOADHTTP_H
17 #define TIANCHI_TCDOWNLOADHTTP_H
18
19 #include <tianchi/tcglobal.h>
20 #include <QtCore>
21 #include <QtNetwork>
22
27 class TIANCHI_API TcDownload : public QObject
28 {
29 Q_OBJECT
30 public:
31 TcDownload(int index, QObject *parent = 0);
32 void StartDownload(const QUrl &url, QFile* file,
33 qint64 startPoint=0, qint64 endPoint=-1);
34
35 Q_SIGNALS:
36 void DownloadFinished();
37
38 public Q_SLOTS:
39 void FinishedSlot();
40 void HttpReadyRead();
41
42 private:
43 QNetworkAccessManager m_Qnam;
44 QNetworkReply* m_Reply;
45 QFile* m_File;
46
47 const int m_Index;
48 qint64 m_HaveDoneBytes;
49 qint64 m_StartPoint;
50 qint64 m_EndPoint;
51
52 };
53
54 // 用于管理文件的下载
56 class TIANCHI_API TcDownloadList : public QObject
57 {
58 Q_OBJECT
59 public:
60 TcDownloadList(QObject *parent = 0);
61
62 void StartFileDownload(const QString &url, int count);
63 qint64 GetFileSize(QUrl url);
64
65 Q_SIGNALS:
66 void FileDownloadFinished();
67
68 private Q_SLOTS:
69 void SubPartFinished();
70
71 private:
72 int m_DownloadCount;
73 int m_FinishedNum;
74 int m_FileSize;
75 QUrl m_Url;
76 QFile *m_File;
77 };
78
79 #endif // TIANCHI_DOWNLOADHTTP_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/network/tcsingleinstance.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • network
tcsingleinstance.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：应用程序单实例类
8 // 使用了 QLocalSocket / QLocalServer 方式实现，为本地多实例应用间通
9 // 讯保留扩展的可能。
10 // ==========================================================================
11 // 开发日志：
12 // 日期 人员 说明
13 // --------------------------------------------------------------------------
14 // 2013.04.19 圣域天子 建立
15 //
16 // ==========================================================================
17 // @file SingleInstance.h 应用程序单实例类
18 // ==========================================================================
19 #ifndef TIANCHI_TCSINGLEINSTANCE_H
20 #define TIANCHI_TCSINGLEINSTANCE_H
21
22 #include <tianchi/tcglobal.h>
23
24 #include <QLocalSocket>
25 #include <QLocalServer>
26
50 class TIANCHI_API TcSingleInstance
51 {
52 public:
55 TcSingleInstance(QString instanceName)
56 {
57 init(0, instanceName);
58 }
62 TcSingleInstance(QObject* parent, QString instanceName)
63 {
64 init(parent, instanceName);
65 }
68 bool first() const { return m_first; }
69
70 protected:
71 bool m_first;
72 QString m_instanceName;
73 QLocalSocket m_localSocket;
74 QLocalServer* m_localServer;
75
76 private:
77 void init(QObject* parent, QString instanceName);
78 };
79
80 #endif // TIANCHI_SINGLEINSTANCE_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/network/tcudp.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • network
tcudp.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：UDP 协议的通讯器
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.05.03 圣域天子 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
18
19 #ifndef TIANCHI_TCUDP_H
20 #define TIANCHI_TCUDP_H
21
22 #include <tianchi/tcglobal.h>
23
24 #include <QtNetwork>
25
26 class TIANCHI_API TcUdp : public QUdpSocket
27 {
28 Q_OBJECT
29 typedef QUdpSocket inherited;
30 public:
31 TcUdp();
32 virtual ~TcUdp();
33
34 int start(int Port);
35 void stop();
36
38 bool sendMessage(QHostAddress host, int port, QByteArray S);
40 inline bool sendMessage(QHostAddress host, int port, QString S)
41 { return sendMessage(host, port, S.toUtf8()); }
43 void sendBroadcast(int port, QByteArray S);
45 inline void sendBroadcast(int port, QString S)
46 { return sendBroadcast(port, S.toUtf8()); }
47
49 inline void setRecvMethod(QObject* recvObject, QByteArray recvMethod)
50 { m_recvObject = recvObject; m_recvMethod = recvMethod; }
51
52 Q_SIGNALS:
54 void recvMessage(QHostAddress client, QByteArray datagram);
55
56 protected slots:
57 void udpRecv();
58
59 protected:
60 QObject* m_recvObject;
61 QByteArray m_recvMethod;
62 };
63
64 #endif // TIANCHI_TCUDP_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/os 目录参考

  • include
  • tianchi
  • os
os 目录参考

文件

文件 tcos.h [代码]
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/os/tcos.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • os
tcos.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：与操作系统相关
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.10 圣域天子 建立
13 // 2013.06.16 XChinux 修改name()方法,增加读取Linux发行版内容
14 // ==========================================================================
16 #ifndef TIANCHI_TCOS_H
17 #define TIANCHI_TCOS_H
18
19 #include <tianchi/tcglobal.h>
20 #include <QString>
21
25 class TIANCHI_API TcOS
26 {
27 public:
31 static QString name();
32
35 static QString language();
36
44 static bool login(const QString& Domain, const QString& UserID,
45 const QString& Password);
46 };
47
48 #endif // TIANCHI_TCOS_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql 目录参考

  • include
  • tianchi
  • sql
sql 目录参考

文件

文件 | tcdataaccess.h [代码]
文件 | tcdatabase.h [代码]
文件 | tcmssql.h [代码]
文件 | tcoracle.h [代码]
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcdataaccess.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • sql
tcdataaccess.h
1 #ifndef TIANCHI_TCDATAACCESS_H
2 #define TIANCHI_TCDATAACCESS_H
3
4 #include <tianchi/tcglobal.h>
5
6 #include <QString>
7 #include <QLatin1String>
8 #include <QVariant>
9 #include <QSqlQuery>
10 #include <QSqlRecord>
11 #include <QSqlDatabase>
12 #include <QVariantMap>
13 #include <QStringList>
14 #include <QVariantList>
15
16 class TcDataAccess;
17
18 // 数据访问语句类
19 class TIANCHI_API TcDataAccessStatement
20 {
21 public:
22 TcDataAccessStatement();
23 TcDataAccessStatement(const TcDataAccessStatement &da);
24 // 使用表名table和字段列表fields初始化
25 TcDataAccessStatement(const QString &table,
26 const QString &fields = QString("*"));
27 ~TcDataAccessStatement();
28
29 // 清除所有设定
30 void clear();
31
32 // 添加字段列表fields
33 TcDataAccessStatement& select(const QString &fields = QString("*"));
34
35 // 添加from表名tables
36 TcDataAccessStatement& from(const QString &tables);
37
38 // 增加左连接表table, cond为条件,bind为条件中的"?"值
39 TcDataAccessStatement& leftJoin(const QString &table,
40 const QString &cond,
41 const QVariantList &bind = QVariantList());
42
43 // 增加条件子句expr(AND连接), bind为条件中的"?"值
44 TcDataAccessStatement& where(const QString &expr,
45 const QVariantList &bind = QVariantList());
46
47 // 增加条件子句expr(OR连接), bind为条件中的"?"值
48 TcDataAccessStatement& orWhere(const QString &expr,
49 const QVariantList &bind = QVariantList());
50
51 // 增加group字段fields
52 TcDataAccessStatement& group(const QString &fields);
53
54 // 增加order字段fields
55 TcDataAccessStatement& order(const QString &fields);
56
57 // 增加limit限制
58 TcDataAccessStatement& limit(int count, int offset = 0);
59
60 // 增加limit限制
61 TcDataAccessStatement& limitPage(int page, int rowCount);
62
63 // 返回完整的SQL语句
64 QString toString() const;
65
66 // 返回WHERE子句
67 QString whereString() const;
68
69 // 返回WHERE中"?"的bind
70 QVariantList whereBind() const;
71
72 // 返回所有"?"的bind
73 QVariantList bind() const;
74
75 TcDataAccessStatement& operator=(const TcDataAccessStatement &da);
76 private:
77 QStringList _select;
78 QStringList _from;
79 QStringList _leftJoin;
80 QStringList _where;
81 QStringList _group;
82 QStringList _order;
83
84 QString _limit;
85 QVariantList _leftJoinBind;
86 QVariantList _whereBind;
87 };
88
89
90 // 数据访问类
91 class TIANCHI_API TcDataAccess
92 {
93 public:
94 enum AttrCase
95 {
96 CaseNatural, // 字段名保存不变
97 CaseLower, // 字段名转为小写
98 CaseUpper // 字段名转为大写
99 };
100
101 enum AttrTrim
102 {
103 TrimNone, // 保持字符串类型字段值不变
104 TrimAll // 保持字符串类型字段值去除前后空格
105 };
106
107 TcDataAccess(const QString &connectionName
108 = QLatin1String(QSqlDatabase::defaultConnection));
109 TcDataAccess(const QSqlDatabase &other);
110 ~TcDataAccess();
111
112 // 返回字段名处理方式
113 static AttrCase attrCase() {return _attrCase;}
114 // 返回字符串类型字段值处理方式
115 static AttrTrim attrTrim() {return _attrTrim;}
116 // 设置字段名处理方式
117 static void setAttrCase(AttrCase attrCase){_attrCase = attrCase;}
118 // 设置字符串类型字段值处理方式
119 static void setAttrTrim(AttrTrim attrTrim){_attrTrim = attrTrim;}
120
121 // 创建一个DataAccess对象，如果创建失败，返回NULL,使用完后请delete
122 static TcDataAccess* db(const QString &connectionName
123 = QLatin1String(QSqlDatabase::defaultConnection));
124
125 // 返回connectionName
126 QString connectionName() const {return _db->connectionName();}
127
128 // 返回QSqlQuery对象
129 QSqlQuery sqlQuery() const {return QSqlQuery(*_db);}
130 // 返回QSqlDatabase对象
131 QSqlDatabase sqlDatabase() const {return *_db;}
132
133 // 返回sql查询的所有记录集
134 QList<QVariantMap> fetchAll(const QString &sql,
135 const QVariantList &bind = QVariantList());
136 QList<QVariantMap> fetchAll(const TcDataAccessStatement &stat,
137 const QVariantList &bind = QVariantList());
138
139 // 返回SQL查询的所有记录集，
140 // 如果有记录，则第一行保存字段名，记录从第二行开始
141 QList<QVariantList> fetchAllList(const QString &sql,
142 const QVariantList &bind = QVariantList());
143 QList<QVariantList> fetchAllList(const TcDataAccessStatement &stat,
144 const QVariantList &bind = QVariantList());
145
146
147 // 返回sql查询的第一行
148 QVariantMap fetchRow(const QString &sql,
149 const QVariantList &bind = QVariantList());
150 QVariantMap fetchRow(const TcDataAccessStatement &stat,
151 const QVariantList &bind = QVariantList());
152
153
154 // 返回sql查询的第一列
155 QVariantList fetchCol(const QString &sql,
156 const QVariantList &bind = QVariantList());
157 QVariantList fetchCol(const TcDataAccessStatement &stat,
158 const QVariantList &bind = QVariantList());
159
160 // 返回第一行第一列数据
161 QVariant fetchOne(const QString &sql,
162 const QVariantList &bind = QVariantList());
163 QVariant fetchOne(const TcDataAccessStatement &stat,
164 const QVariantList &bind = QVariantList());
165
166 // 将第一列作为key,将第二列作为值返回
167 template <typename T> QMap<T, QVariant> fetchPairs(
168 const QString &sql,
169 const QVariantList &bind = QVariantList())
170 {
171 _prepareExec(sql, bind);
172
173 QMap<T,QVariant> rows;
174 while (_query->next())
175 {
176 rows[qvariant_cast<T>(_trim(_query->value(0)))] =
177 _trim(_query->value(1));
178 }
179 return rows;
180 }
181
182 template <typename T> QMap<T, QVariant> fetchPairs(
183 const TcDataAccessStatement &stat,
184 const QVariantList &bind = QVariantList())
185 {
186 return fetchPairs<T>(stat.toString(),
187 QVariantList() << stat.bind() << bind);
188 }
189
190 // 将第一列作为键，将每行作为值返回
191 template <typename T> QMap<T, QVariantMap> fetchAssoc(
192 const QString &sql,
193 const QVariantList &bind = QVariantList())
194 {
195 _prepareExec(sql, bind);
196
197 QMap<T,QVariantMap> rows;
198 QVariantMap row;
199 QVariant val;
200 while (_query->next())
201 {
202 QSqlRecord rec = _query->record();
203 for (int i = rec.count() - 1; i > -1; i--)
204 {
205 row[_case(rec.fieldName(i))] = _trim(rec.value(i));
206 }
207 rows[qvariant_cast<T>(_trim(rec.value(0)))] = row;
208 row.clear();
209 }
210 return rows;
211 }
212
213 template <typename T> QMap<T, QVariantMap> fetchAssoc(
214 const TcDataAccessStatement &stat,
215 const QVariantList &bind = QVariantList())
216 {
217 return fetchAssoc<T>(stat.toString(),
218 QVariantList() << stat.bind() << bind);
219 }
220
221 // 为sql语句添加limit参数,目前只支持MySQL、PGSQL、SQLite、MSSQL,对于不支持
222 // 的数据库类型，直接返回空字符串
223 QString limitPage(const QString &sql, int page, int rowCount) const;
224 QString limit(const QString &sql, int count, int offset = 0) const;
225
226 // 返回上次插入的ID,目前的实现无意义
227 QVariant lastInsertId(const QString &table = QString(),
228 const QString &primaryKey = QString()) const;
229 // 返回上次查询的错误信息
230 QSqlError lastError() const;
231
232 // 删除表table中的记录,条件为where, bind为"?"绑定
233 int doDelete(const QString &table,
234 const QString &where = QString(),
235 const QVariantList &bind = QVariantList());
236
237
238 // 更新表table中的记录,字段及值为field, 条件为where, bind为"?"绑定
239 int doUpdate(const QString &table, const QVariantMap &field,
240 const QString &where = QString(),
241 const QVariantList &bind = QVariantList());
242
243 // 插入表table中的记录,字段及值为field
244 int doInsert(const QString &table, const QVariantMap &field);
245 TcDataAccess& operator=(const TcDataAccess &da);
246 TcDataAccess& operator=(const QSqlDatabase &db);
247 private:
248 QVariant _trim(const QVariant &val);
249 QString _case(const QString &field);
250 private:
251 static AttrCase _attrCase;
252 static AttrTrim _attrTrim;
253 QSqlDatabase *_db;
254 QSqlQuery *_query;
255 void _prepareExec(const QString &sql, const QVariantList &bind);
256 };
257
258 typedef TcDataAccess TcDA;
259 typedef TcDataAccessStatement TcDAS;
260
261 #endif
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcdatabase.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • sql
tcdatabase.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：数据库操作类
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.05.03 圣域天子 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCDATABASE_H
18 #define TIANCHI_TCDATABASE_H
19
20 #include <tianchi/tcglobal.h>
21
22 #include <QVariant>
23 #include <QMultiHash>
24 #include <QStringList>
25 #include <QSqlDatabase>
26
27 typedef QHash<QString, QByteArray> TcParams;
28 class TIANCHI_API TcDatabase
29 {
30 public:
31 TcDatabase();
32 virtual ~TcDatabase(void);
33
34 enum DBType
35 {
36 SQLSERVER = 1,
37 SQLITE = 11
38 };
39
40 static char typeFrom(QVariant::Type type);
41
42 static int dbType(const QString& typeName);
43 static TcParams addParams(const QStringList& keys,
44 const QList<QByteArray>& values);
45
46
48 void setDatabase(int dbType,
49 const QString& hostName, int hostPort,
50 const QString& dbName, const QString& username,
51 const QString& password);
53 bool setDatabase(const QString& typeName,
54 const QString& hostName, int hostPort,
55 const QString& dbName, const QString& username,
56 const QString& password);
58 void setDatabase(int dbType,
59 const QString& dbName,
60 const QString& username = QString(),
61 const QString& password = QString());
63 bool setDatabase(const QString& typeName,
64 const QString& dbName,
65 const QString& username = QString(),
66 const QString& password = QString());
67
69 QString CreateDDL;
70
71 QString SqlLibrary;
72
74 QStringList errors;
75
76 QString lastError();
77
78 protected:
79 int m_dbType;
80 QString m_typeName;
81 QString m_hostName;
82 int m_hostPort;
83 QString m_dbName;
84 QString m_username;
85 QString m_password;
86
87 QSqlDatabase m_handle;
88
89 // 数据引擎
90 QString m_engineFile;
91 struct SQLContext
92 {
93 QString id;
94 QString text;
95 QMultiHash<QString, QString> params;
96 };
97 QHash<QString, SQLContext> m_sqls;
98 void clearComment(QString& s);
99
101 QSqlQuery* prepare(const QString& sqlID, TcParams prams,
102 QString& error, int userNo = 0,
103 const QString& userID = QString(),
104 const QString& username = QString());
105 public:
106 inline int dbType() const { return m_dbType; }
107 inline QString typeName() const { return m_typeName; }
108 inline QString hostName() const { return m_hostName; }
109 inline int hostPort() const { return m_hostPort; }
110 inline QString dbName() const { return m_dbName; }
111
112 inline QSqlDatabase handle() const { return m_handle; }
113 inline int sqlCount() const { return m_sqls.count(); }
114
115 public:
124 int open();
125
128 void close();
129
131 inline bool isOpened() const { return m_handle.isOpen(); }
132
134 void loadEngine();
136 void loadEngine(const QString& filename);
137
139 bool exec(int& result, const QString& sqlID,
140 const TcParams& prams,
141 int userNo = 0,
142 const QString& userID = QString(),
143 const QString& username = QString());
145 bool exec(QVariantList& list,
146 const QString& sqlID,
147 const TcParams& params,
148 int userNo = 0,
149 const QString& userID = QString(),
150 const QString& username = QString());
152 int exec(int& result, QVariantList& list,
153 const QString& sqlID, const TcParams& params,
154 int userNo = 0,
155 const QString& userID = QString(),
156 const QString& username = QString());
158 int exec(int& result, QList<QByteArray>& list,
159 const QString& sqlID, const TcParams& params,
160 int userNo = 0,
161 const QString& userID = QString(),
162 const QString& username = QString());
163 };
164
165 #endif // TIANCHI_TCDATABASE_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcmssql.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • sql
tcmssql.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：SQL Server 相关应用
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.18 XChinux 建立
13 // 2013.06.04 XChinux 增加ODBCDSN()函数
14 //
15 // ==========================================================================
17 #ifndef TIANCHI_TCMSSQL_H
18 #define TIANCHI_TCMSSQL_H
19
20 #include <tianchi/tcglobal.h>
21 #include <QStringList>
22
26 class TIANCHI_API TcMSSQL
27 {
28 public:
35 static QStringList availableODBCDrivers();
44 static QString ODBCDSN(const QString &driver,
45 const QString &server,
46 const QString &dbname,
47 const QString &user = QString(),
48 const QString &pass = QString());
49 };
50
51 #endif
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/sql/tcoracle.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • sql
tcoracle.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：Oracle 相关应用
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.06.04 XChinux 建立
13 // 2013.06.04 XChinux 增加ODBCDSN()函数
14 //
15 // ==========================================================================
17 #ifndef TIANCHI_TCORACLE_H
18 #define TIANCHI_TCORACLE_H
19
20 #include <tianchi/tcglobal.h>
21 #include <QStringList>
22
26 class TIANCHI_API TcOracle
27 {
28 public:
34 static QStringList availableODBCDrivers();
42 static QString ODBCDSN(const QString &driver,
43 const QString &tns,
44 const QString &user = QString(),
45 const QString &pass = QString());
46 };
47
48 #endif
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/widget 目录参考

  • include
  • tianchi
  • widget
widget 目录参考

文件

文件 tctreeex.h [代码]
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/widget/tctreeex.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • widget
tctreeex.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：QTreeWidget 控件扩展
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.05.03 圣域天子 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCTREEEX_H
18 #define TIANCHI_TCTREEEX_H
19
20 #include <tianchi/tcglobal.h>
21 #include <tianchi/file/tcmsexcel.h>
22
23 #include <QTreeWidget>
24 #include <QLabel>
25 #include <QDoubleSpinBox>
26
27 class TcTreeExPrivate;
28
31 class TIANCHI_API TcTreeEx
32 {
33 public:
34 enum ExportType
35 {
36 TextFile = 1
37 , MSExcel = 2
38 };
41 TcTreeEx(QTreeWidget* widget=0);
42
45 void setWidget(QTreeWidget* widget);
46
49 void setExportType(int type);
50
53 void setSelectedState(int state);
54
57 void setTextFileName(const QString& filename);
58
61 void setMSExcelObject(TcMSExcel* excel, bool hasHeader=true, int startRow=1, int startCol=1);
62
64 int save();
65
66 private:
67 Q_DISABLE_COPY(TcTreeEx)
68 Q_DECLARE_PRIVATE(TcTreeEx)
69 TcTreeExPrivate* d_ptr;
70
71 public:
72 static void createColumnMenu(QTreeWidget* widget, QWidget* object, const QString& methodName);
73
74 static void setColumnBolds(QTreeWidget* widget);
75 static void setColumnWidth(QTreeWidget* widget, int column, int width, bool hide=false);
76 static void setColumnStyle(QTreeWidget* widget, int fontSize=8, const QString &fontName="Tahoma");
77
78 static void CopyCellObject(QTreeWidget* view, int copyMode);
79 };
80
81 class TIANCHI_API TcTreeItem : public QTreeWidgetItem
82 {
83 public:
84 void setCellFont(int col, bool bold=false, int alignment=Qt::AlignVCenter | Qt::AlignLeft);
85 void setCellStyle(int startCol=-1, int endCol=-1,
86 bool bold=true, int alignment=Qt::AlignVCenter | Qt::AlignRight,
87 int cellHeight=25);
88 void setCellColor(int col, QColor color);
89
90 QLabel* createLabel(int col, const QString& htmlText, const QVariant& data=QVariant());
91 QDoubleSpinBox* createDoubleSpinBox(int col,
92 int decimals, double min, double max, double step, double value);
93 double readDoubleSpinBoxValue(int col);
94
95 void showValue(int column, const char* text, const QVariant& data=QVariant(), int size=0);
96 void showValue(int column, const QString& text, const QVariant& data=QVariant(), int size=0);
97 void showValue(int column, const QByteArray& text, const QVariant& data=QVariant(), int size=0);
98 void showValue(int column, double value);
99 void showValue(int column, double value, int digits);
100 void showPrice(int column, double value, int digits=0);
101 void showPercent(int column, double value=0.0, int digits=0);
102 };
103
104 #endif // TIANCHI_TCTREEEX_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/tcglobal.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
tcglobal.h
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：常用功能函数
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.11 cnhemiya 建立
13 // 2013.04.17 XChinux 参照Qt/qglobal.h文件重写Global.h
14 // ==========================================================================
15 // 注意事项:
16 // 1. 编译Tianchi DLL时请在 .pro 中添加：
17 // DEFINES += TIANCHI_EXPORT
18 // 2. 使用Tianchi DLL时请在.pro中添加
19 // DEFINES += TIANCHI_IMPORT
20 // ==========================================================================
21
22 #ifndef TIANCHI_TCGLOBAL_H
23 #define TIANCHI_TCGLOBAL_H
24
25 #ifndef __cplusplus
26 # error "Tianchi library only support C++ Compilers"
27 #endif
28
29 #include <QtCore/qglobal.h>
30
31 #define TIANCHI_VERSION_STR "0.0.2"
32 /*
33 TIANCHI_VERSION is (major << 16) + (minor << 8) + patch.
34 */
35 #define TIANCHI_VERSION 0x000002
36 /*
37 can be used like #if (TIANCHI_VERSION >= TIANCHI_VERSION_CHECK(4, 4, 0))
38 */
39 #define TIANCHI_VERSION_CHECK(major, minor, patch) ((major<<16)|(minor<<8)|(patch))
40
41 #if defined(TIANCHI_EXPORT)
42 # define TIANCHI_API Q_DECL_EXPORT
43 #elif defined(TIANCHI_IMPORT)
44 # define TIANCHI_API Q_DECL_IMPORT
45 #else
46 # define TIANCHI_API
47 #endif
48
49
50 #endif // TIANCHI_GLOBAL_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi.h 文件参考

  • 文件列表
  • 文件成员
  • include
tianchi.h 文件参考

引用单元头文件 更多...

#include <tianchi/chinese/tcchinese.h>
#include <tianchi/core/tcclasses.h>
#include <tianchi/core/tccommon.h>
#include <tianchi/core/tcstring.h>
#include <tianchi/core/tcutils.h>
#include <tianchi/core/tcfunctionalsortfilterproxymodel.h>
#include <tianchi/core/tcvariantmaptablemodel.h>
#include <tianchi/core/tcsingleton.hpp>
#include <tianchi/core/tctuple.hpp>
#include <tianchi/file/tcdir.h>
#include <tianchi/file/tcfile.h>
#include <tianchi/file/tcfileio.h>
#include <tianchi/file/tcjson.h>
#include <tianchi/file/tclog.h>
#include <tianchi/file/tcmsexcel.h>
#include <tianchi/file/tcexcelreader.h>
#include <tianchi/gui/tcclicklabel.h>
#include <tianchi/gui/tcdateedit.h>
#include <tianchi/gui/tcflowlayout.h>
#include <tianchi/gui/tcformutils.h>
#include <tianchi/gui/tcgloweffect.h>
#include <tianchi/gui/tcguiutils.h>
#include <tianchi/gui/tcheadersetupdialog.h>
#include <tianchi/gui/tclineedit.h>
#include <tianchi/gui/tcmarqueelabel.h>
#include <tianchi/gui/tcsortpaginationtableview.h>
#include <tianchi/network/tcdownloadhttp.h>
#include <tianchi/network/tcsingleinstance.h>
#include <tianchi/network/tcudp.h>
#include <tianchi/os/tcos.h>
#include <tianchi/sql/tcmssql.h>
#include <tianchi/sql/tcorcale.h>
#include <tianchi/sql/tcdatabase.h>
#include <tianchi/sql/tcdataaccess.h>
#include <tianchi/widget/tctreeex.h>

浏览源代码.

详细描述

引用单元头文件

生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 类型定义
  • 枚举值
  • 宏定义
这里列出了所有文档化的文件成员,并附带其详细说明:
  • TC_SINGLETON_INIT : tcsingleton.hpp
  • TcDataRole : tcvariantmaptablemodel.h
  • TcFunctionalSortFilterProxyModelFilterFunction : tcfunctionalsortfilterproxymodel.h
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 类型定义
  • 枚举值
  • 宏定义
  • TcFunctionalSortFilterProxyModelFilterFunction : tcfunctionalsortfilterproxymodel.h
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 类型定义
  • 枚举值
  • 宏定义
  • TcDataRole : tcvariantmaptablemodel.h
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 类型定义
  • 枚举值
  • 宏定义
  • TC_SINGLETON_INIT : tcsingleton.hpp
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 成员列表

  • 类成员
TcChinese 成员列表

成员的完整列表，这些成员属于 TcChinese,包括所有继承而来的类成员

firstPinyins(const QString &HzString) | TcChinese | static
toChars(const QString &Str, bool Tonality=false) | TcChinese | static
toPinyin(const QString &Str, bool Tonality=false) | TcChinese | static


Tianchi: 成员列表

  • 类成员
TcClickLabel 成员列表

成员的完整列表，这些成员属于 TcClickLabel,包括所有继承而来的类成员

clicked() | TcClickLabel | signal
mousePressEvent(QMouseEvent *e) (定义于 TcClickLabel) | TcClickLabel | protectedvirtual
mouseReleaseEvent(QMouseEvent *e) (定义于 TcClickLabel) | TcClickLabel | protectedvirtual
TcClickLabel(QWidget *parent=0, Qt::WindowFlags f=0) (定义于 TcClickLabel) | TcClickLabel |
TcClickLabel(const QString &text, QWidget *parent=0, Qt::WindowFlags f=0) (定义于 TcClickLabel) | TcClickLabel |
~TcClickLabel() (定义于 TcClickLabel) | TcClickLabel | virtual


Tianchi: 成员列表

  • 类成员
TcCursorBusy 成员列表

成员的完整列表，这些成员属于 TcCursorBusy,包括所有继承而来的类成员

m_cursor (定义于 TcCursorCustom) | TcCursorCustom | protected
m_parent (定义于 TcCursorCustom) | TcCursorCustom | protected
restore() | TcCursorCustom | inline
TcCursorBusy() (定义于 TcCursorBusy) | TcCursorBusy | inline
TcCursorCustom(Qt::CursorShape shape) (定义于 TcCursorCustom) | TcCursorCustom | inlineprotected
~TcCursorCustom() (定义于 TcCursorCustom) | TcCursorCustom | inlineprotectedvirtual


Tianchi: 成员列表

  • 类成员
TcCursorCustom 成员列表

成员的完整列表，这些成员属于 TcCursorCustom,包括所有继承而来的类成员

m_cursor (定义于 TcCursorCustom) | TcCursorCustom | protected
m_parent (定义于 TcCursorCustom) | TcCursorCustom | protected
restore() | TcCursorCustom | inline
TcCursorCustom(Qt::CursorShape shape) (定义于 TcCursorCustom) | TcCursorCustom | inlineprotected
~TcCursorCustom() (定义于 TcCursorCustom) | TcCursorCustom | inlineprotectedvirtual


Tianchi: 成员列表

  • 类成员
TcCursorWait 成员列表

成员的完整列表，这些成员属于 TcCursorWait,包括所有继承而来的类成员

m_cursor (定义于 TcCursorCustom) | TcCursorCustom | protected
m_parent (定义于 TcCursorCustom) | TcCursorCustom | protected
restore() | TcCursorCustom | inline
TcCursorCustom(Qt::CursorShape shape) (定义于 TcCursorCustom) | TcCursorCustom | inlineprotected
TcCursorWait() (定义于 TcCursorWait) | TcCursorWait | inline
~TcCursorCustom() (定义于 TcCursorCustom) | TcCursorCustom | inlineprotectedvirtual


Tianchi: 成员列表

  • 类成员
TcDBFields 成员列表

成员的完整列表，这些成员属于 TcDBFields,包括所有继承而来的类成员

addField(QByteArray &fieldBytes, const QString &name, const QVariant &value) (定义于 TcDBFields) | TcDBFields | static
getFields(const QByteArray &fieldBytes) (定义于 TcDBFields) | TcDBFields | static
setFields(QHash< QString, QByteArray > fields) (定义于 TcDBFields) | TcDBFields | inline
TcDBFields() (定义于 TcDBFields) | TcDBFields | inline
TcDBFields(QHash< QString, QByteArray > fields) (定义于 TcDBFields) | TcDBFields | inline
value(const QString &key) const (定义于 TcDBFields) | TcDBFields | inline


Tianchi: 成员列表

  • 类成员
TcDataAccess 成员列表

成员的完整列表，这些成员属于 TcDataAccess,包括所有继承而来的类成员

AttrCase 枚举名称 (定义于 TcDataAccess) | TcDataAccess |
attrCase() (定义于 TcDataAccess) | TcDataAccess | inlinestatic
AttrTrim 枚举名称 (定义于 TcDataAccess) | TcDataAccess |
attrTrim() (定义于 TcDataAccess) | TcDataAccess | inlinestatic
CaseLower 枚举值 (定义于 TcDataAccess) | TcDataAccess |
CaseNatural 枚举值 (定义于 TcDataAccess) | TcDataAccess |
CaseUpper 枚举值 (定义于 TcDataAccess) | TcDataAccess |
connectionName() const (定义于 TcDataAccess) | TcDataAccess | inline
db(const QString &connectionName=QLatin1String(QSqlDatabase::defaultConnection)) (定义于 TcDataAccess) | TcDataAccess | static
doDelete(const QString &table, const QString &where=QString(), const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
doInsert(const QString &table, const QVariantMap &field) (定义于 TcDataAccess) | TcDataAccess |
doUpdate(const QString &table, const QVariantMap &field, const QString &where=QString(), const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchAll(const QString &sql, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchAll(const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchAllList(const QString &sql, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchAllList(const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchAssoc(const QString &sql, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess | inline
fetchAssoc(const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess | inline
fetchCol(const QString &sql, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchCol(const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchOne(const QString &sql, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchOne(const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchPairs(const QString &sql, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess | inline
fetchPairs(const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess | inline
fetchRow(const QString &sql, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
fetchRow(const TcDataAccessStatement &stat, const QVariantList &bind=QVariantList()) (定义于 TcDataAccess) | TcDataAccess |
lastError() const (定义于 TcDataAccess) | TcDataAccess |
lastInsertId(const QString &table=QString(), const QString &primaryKey=QString()) const (定义于 TcDataAccess) | TcDataAccess |
limit(const QString &sql, int count, int offset=0) const (定义于 TcDataAccess) | TcDataAccess |
limitPage(const QString &sql, int page, int rowCount) const (定义于 TcDataAccess) | TcDataAccess |
operator=(const TcDataAccess &da) (定义于 TcDataAccess) | TcDataAccess |
operator=(const QSqlDatabase &db) (定义于 TcDataAccess) | TcDataAccess |
setAttrCase(AttrCase attrCase) (定义于 TcDataAccess) | TcDataAccess | inlinestatic
setAttrTrim(AttrTrim attrTrim) (定义于 TcDataAccess) | TcDataAccess | inlinestatic
sqlDatabase() const (定义于 TcDataAccess) | TcDataAccess | inline
sqlQuery() const (定义于 TcDataAccess) | TcDataAccess | inline
TcDataAccess(const QString &connectionName=QLatin1String(QSqlDatabase::defaultConnection)) (定义于 TcDataAccess) | TcDataAccess |
TcDataAccess(const QSqlDatabase &other) (定义于 TcDataAccess) | TcDataAccess |
TrimAll 枚举值 (定义于 TcDataAccess) | TcDataAccess |
TrimNone 枚举值 (定义于 TcDataAccess) | TcDataAccess |
~TcDataAccess() (定义于 TcDataAccess) | TcDataAccess |


Tianchi: 成员列表

  • 类成员
TcDataAccessStatement 成员列表

成员的完整列表，这些成员属于 TcDataAccessStatement,包括所有继承而来的类成员

bind() const (定义于 TcDataAccessStatement) | TcDataAccessStatement
clear() (定义于 TcDataAccessStatement) | TcDataAccessStatement
from(const QString &tables) (定义于 TcDataAccessStatement) | TcDataAccessStatement
group(const QString &fields) (定义于 TcDataAccessStatement) | TcDataAccessStatement
leftJoin(const QString &table, const QString &cond, const QVariantList &bind=QVariantList()) (定义于 TcDataAccessStatement) | TcDataAccessStatement
limit(int count, int offset=0) (定义于 TcDataAccessStatement) | TcDataAccessStatement
limitPage(int page, int rowCount) (定义于 TcDataAccessStatement) | TcDataAccessStatement
operator=(const TcDataAccessStatement &da) (定义于 TcDataAccessStatement) | TcDataAccessStatement
order(const QString &fields) (定义于 TcDataAccessStatement) | TcDataAccessStatement
orWhere(const QString &expr, const QVariantList &bind=QVariantList()) (定义于 TcDataAccessStatement) | TcDataAccessStatement
select(const QString &fields=QString("*")) (定义于 TcDataAccessStatement) | TcDataAccessStatement
TcDataAccessStatement() (定义于 TcDataAccessStatement) | TcDataAccessStatement
TcDataAccessStatement(const TcDataAccessStatement &da) (定义于 TcDataAccessStatement) | TcDataAccessStatement
TcDataAccessStatement(const QString &table, const QString &fields=QString("*")) (定义于 TcDataAccessStatement) | TcDataAccessStatement
toString() const (定义于 TcDataAccessStatement) | TcDataAccessStatement
where(const QString &expr, const QVariantList &bind=QVariantList()) (定义于 TcDataAccessStatement) | TcDataAccessStatement
whereBind() const (定义于 TcDataAccessStatement) | TcDataAccessStatement
whereString() const (定义于 TcDataAccessStatement) | TcDataAccessStatement
~TcDataAccessStatement() (定义于 TcDataAccessStatement) | TcDataAccessStatement


Tianchi: 成员列表

  • 类成员
TcDatabase 成员列表

成员的完整列表，这些成员属于 TcDatabase,包括所有继承而来的类成员

addParams(const QStringList &keys, const QList< QByteArray > &values) (定义于 TcDatabase) | TcDatabase | static
clearComment(QString &s) (定义于 TcDatabase) | TcDatabase | protected
close() | TcDatabase |
CreateDDL | TcDatabase |
dbName() const (定义于 TcDatabase) | TcDatabase | inline
DBType 枚举名称 (定义于 TcDatabase) | TcDatabase |
dbType(const QString &typeName) (定义于 TcDatabase) | TcDatabase | static
dbType() const (定义于 TcDatabase) | TcDatabase | inline
errors | TcDatabase |
exec(int &result, const QString &sqlID, const TcParams &prams, int userNo=0, const QString &userID=QString(), const QString &username=QString()) | TcDatabase |
exec(QVariantList &list, const QString &sqlID, const TcParams &params, int userNo=0, const QString &userID=QString(), const QString &username=QString()) | TcDatabase |
exec(int &result, QVariantList &list, const QString &sqlID, const TcParams &params, int userNo=0, const QString &userID=QString(), const QString &username=QString()) | TcDatabase |
exec(int &result, QList< QByteArray > &list, const QString &sqlID, const TcParams &params, int userNo=0, const QString &userID=QString(), const QString &username=QString()) | TcDatabase |
handle() const (定义于 TcDatabase) | TcDatabase | inline
hostName() const (定义于 TcDatabase) | TcDatabase | inline
hostPort() const (定义于 TcDatabase) | TcDatabase | inline
isOpened() const | TcDatabase | inline
lastError() (定义于 TcDatabase) | TcDatabase |
loadEngine() | TcDatabase |
loadEngine(const QString &filename) | TcDatabase |
m_dbName (定义于 TcDatabase) | TcDatabase | protected
m_dbType (定义于 TcDatabase) | TcDatabase | protected
m_engineFile (定义于 TcDatabase) | TcDatabase | protected
m_handle (定义于 TcDatabase) | TcDatabase | protected
m_hostName (定义于 TcDatabase) | TcDatabase | protected
m_hostPort (定义于 TcDatabase) | TcDatabase | protected
m_password (定义于 TcDatabase) | TcDatabase | protected
m_sqls (定义于 TcDatabase) | TcDatabase | protected
m_typeName (定义于 TcDatabase) | TcDatabase | protected
m_username (定义于 TcDatabase) | TcDatabase | protected
open() | TcDatabase |
prepare(const QString &sqlID, TcParams prams, QString &error, int userNo=0, const QString &userID=QString(), const QString &username=QString()) | TcDatabase | protected
setDatabase(int dbType, const QString &hostName, int hostPort, const QString &dbName, const QString &username, const QString &password) | TcDatabase |
setDatabase(const QString &typeName, const QString &hostName, int hostPort, const QString &dbName, const QString &username, const QString &password) | TcDatabase |
setDatabase(int dbType, const QString &dbName, const QString &username=QString(), const QString &password=QString()) | TcDatabase |
setDatabase(const QString &typeName, const QString &dbName, const QString &username=QString(), const QString &password=QString()) | TcDatabase |
sqlCount() const (定义于 TcDatabase) | TcDatabase | inline
SQLITE 枚举值 (定义于 TcDatabase) | TcDatabase |
SqlLibrary (定义于 TcDatabase) | TcDatabase |
SQLSERVER 枚举值 (定义于 TcDatabase) | TcDatabase |
TcDatabase() (定义于 TcDatabase) | TcDatabase |
typeFrom(QVariant::Type type) (定义于 TcDatabase) | TcDatabase | static
typeName() const (定义于 TcDatabase) | TcDatabase | inline
~TcDatabase(void) (定义于 TcDatabase) | TcDatabase | virtual


Tianchi: 成员列表

  • 类成员
TcDateEdit 成员列表

成员的完整列表，这些成员属于 TcDateEdit,包括所有继承而来的类成员

date (定义于 TcDateEdit) | TcDateEdit |
date() const (定义于 TcDateEdit) | TcDateEdit |
focusInEvent(QFocusEvent *e) (定义于 TcDateEdit) | TcDateEdit | protected
mousePressEvent(QMouseEvent *e) (定义于 TcDateEdit) | TcDateEdit | protected
setDate(QDate value) (定义于 TcDateEdit) | TcDateEdit |
setDate(QDateTime value) (定义于 TcDateEdit) | TcDateEdit | inline
TcDateEdit(QWidget *parent=0) (定义于 TcDateEdit) | TcDateEdit |
unsetDate() (定义于 TcDateEdit) | TcDateEdit |
~TcDateEdit() (定义于 TcDateEdit) | TcDateEdit | virtual


Tianchi: 成员列表

  • 类成员
TcDir 成员列表

成员的完整列表，这些成员属于 TcDir,包括所有继承而来的类成员

copyDirs(const QString &fromPath, const QString &toPath, const QStringList &nameFilters=QStringList(), bool overWrite=true) | TcDir |
copyFiles(const QStringList &files, const QString &toPath, bool overWrite=true) | TcDir |
currentFile(int count, const QString &name) | TcDir | signal
findFiles(const QString &path, const QStringList &nameFilters=QStringList()) | TcDir |
resetCopyFileCount() | TcDir |
TcDir(QObject *parent=0) (定义于 TcDir) | TcDir | explicit


Tianchi: 成员列表

  • 类成员
TcDownload 成员列表

成员的完整列表，这些成员属于 TcDownload,包括所有继承而来的类成员

DownloadFinished() (定义于 TcDownload) | TcDownload | signal
FinishedSlot() (定义于 TcDownload) | TcDownload | slot
HttpReadyRead() (定义于 TcDownload) | TcDownload | slot
StartDownload(const QUrl &url, QFile *file, qint64 startPoint=0, qint64 endPoint=-1) (定义于 TcDownload) | TcDownload |
TcDownload(int index, QObject *parent=0) (定义于 TcDownload) | TcDownload |


Tianchi: 成员列表

  • 类成员
TcDownloadList 成员列表

成员的完整列表，这些成员属于 TcDownloadList,包括所有继承而来的类成员

FileDownloadFinished() (定义于 TcDownloadList) | TcDownloadList | signal
GetFileSize(QUrl url) (定义于 TcDownloadList) | TcDownloadList |
StartFileDownload(const QString &url, int count) (定义于 TcDownloadList) | TcDownloadList |
TcDownloadList(QObject *parent=0) (定义于 TcDownloadList) | TcDownloadList |


Tianchi: 成员列表

  • 类成员
TcExcelReader 成员列表

成员的完整列表，这些成员属于 TcExcelReader,包括所有继承而来的类成员

cell(int row, int col) | TcExcelReader
currentSheetIndex() | TcExcelReader
currentSheetName() | TcExcelReader
isNull() const | TcExcelReader
open(const QString &file) | TcExcelReader
setCurrentSheet(int index) | TcExcelReader
setCurrentSheet(const QString &sheetName) | TcExcelReader
sheetCount() | TcExcelReader
sheetNames() | TcExcelReader
TcExcelReader() (定义于 TcExcelReader) | TcExcelReader
~TcExcelReader() (定义于 TcExcelReader) | TcExcelReader


Tianchi: 成员列表

  • 类成员
TcFile 成员列表

成员的完整列表，这些成员属于 TcFile,包括所有继承而来的类成员

fileVersion(const QString &exeFile) | TcFile | static
loadFromFile(QString &context, const QString &filename, const QString &codec=QString()) | TcFile | static
searchFiles(const QString &path) | TcFile | static
uniqueFileName(const QString &dir, const QString &fileTemplate, const QString &suffix=QString()) | TcFile | static


Tianchi: 成员列表

  • 类成员
TcFileIO 成员列表

成员的完整列表，这些成员属于 TcFileIO,包括所有继承而来的类成员

append(const QString &fromFile, const QString &toFile, qint64 bufferSize=defaultBufferSize) | TcFileIO | static
append(const QString &fromFile, const QString &toFile, qint64 fromFileOffset, qint64 appendSize=-1, qint64 bufferSize=defaultBufferSize) | TcFileIO | static
copy(const QString &fromFile, const QString &toFile, qint64 bufferSize=defaultBufferSize) | TcFileIO | static
copy(const QString &fromFile, const QString &toFile, qint64 fromFileOffset, qint64 copySize=-1, qint64 bufferSize=defaultBufferSize) | TcFileIO | static
defaultBufferSize | TcFileIO | static
GB | TcFileIO | static
join(const QStringList &fromFileList, const QString &toFile, qint64 bufferSize=defaultBufferSize) | TcFileIO | static
KB | TcFileIO | static
makeDummyFile(const QString &fileName, qint64 fileSize, const char fill=0x00, qint64 bufferSize=defaultBufferSize) | TcFileIO | static
MB | TcFileIO | static
split(const QString &fromFile, const QString &toDir, qint64 splitSize, qint64 bufferSize=defaultBufferSize) | TcFileIO | static


Tianchi: 成员列表

  • 类成员
TcFlowLayout 成员列表

成员的完整列表，这些成员属于 TcFlowLayout,包括所有继承而来的类成员

addItem(QLayoutItem *item) (定义于 TcFlowLayout) | TcFlowLayout |
count() const (定义于 TcFlowLayout) | TcFlowLayout |
expandingDirections() const (定义于 TcFlowLayout) | TcFlowLayout |
hasHeightForWidth() const (定义于 TcFlowLayout) | TcFlowLayout |
heightForWidth(int) const (定义于 TcFlowLayout) | TcFlowLayout |
horizontalSpacing() const (定义于 TcFlowLayout) | TcFlowLayout |
itemAt(int index) const (定义于 TcFlowLayout) | TcFlowLayout |
minimumSize() const (定义于 TcFlowLayout) | TcFlowLayout |
setGeometry(const QRect &rect) (定义于 TcFlowLayout) | TcFlowLayout |
sizeHint() const (定义于 TcFlowLayout) | TcFlowLayout |
takeAt(int index) (定义于 TcFlowLayout) | TcFlowLayout |
TcFlowLayout(QWidget *parent, int margin=-1, int hSpacing=-1, int vSpacing=-1) (定义于 TcFlowLayout) | TcFlowLayout |
TcFlowLayout(int margin=-1, int hSpacing=-1, int vSpacing=-1) (定义于 TcFlowLayout) | TcFlowLayout |
verticalSpacing() const (定义于 TcFlowLayout) | TcFlowLayout |
~TcFlowLayout() (定义于 TcFlowLayout) | TcFlowLayout | virtual


Tianchi: 成员列表

  • 类成员
TcFormUtils 成员列表

成员的完整列表，这些成员属于 TcFormUtils,包括所有继承而来的类成员

parentForm() const (定义于 TcFormUtils) | TcFormUtils | inline
setParentForm(QWidget *value) (定义于 TcFormUtils) | TcFormUtils | inline
TcFormUtils() (定义于 TcFormUtils) | TcFormUtils |


Tianchi: 成员列表

  • 类成员
TcFunctionalSortFilterProxyModel 成员列表

成员的完整列表，这些成员属于 TcFunctionalSortFilterProxyModel,包括所有继承而来的类成员

filterAcceptsRow(int source_row, const QModelIndex &source_parent) const (定义于 TcFunctionalSortFilterProxyModel) | TcFunctionalSortFilterProxyModel | protectedvirtual
setFilterFunction(TcFunctionalSortFilterProxyModelFilterFunction func) | TcFunctionalSortFilterProxyModel |
setFilterParam(const QVariantMap &param) | TcFunctionalSortFilterProxyModel | slot
TcFunctionalSortFilterProxyModel(QObject *parent=0) (定义于 TcFunctionalSortFilterProxyModel) | TcFunctionalSortFilterProxyModel |
~TcFunctionalSortFilterProxyModel() (定义于 TcFunctionalSortFilterProxyModel) | TcFunctionalSortFilterProxyModel |


Tianchi: 成员列表

  • 类成员
TcGlowEffect 成员列表

成员的完整列表，这些成员属于 TcGlowEffect,包括所有继承而来的类成员

boundingRectFor(const QRectF &sourceRect) const (定义于 TcGlowEffect) | TcGlowEffect | virtual
draw(QPainter *painter) (定义于 TcGlowEffect) | TcGlowEffect | protectedvirtual
setGlowColor(const QColor &color) | TcGlowEffect |
setRadius(int radius) | TcGlowEffect |
sourceChanged(ChangeFlags flags) (定义于 TcGlowEffect) | TcGlowEffect | protectedvirtual
TcGlowEffect(QObject *parent=0) (定义于 TcGlowEffect) | TcGlowEffect |
~TcGlowEffect() (定义于 TcGlowEffect) | TcGlowEffect | virtual


Tianchi: 成员列表

  • 类成员
TcHeaderSetupDialog 成员列表

成员的完整列表，这些成员属于 TcHeaderSetupDialog,包括所有继承而来的类成员

setHeader(QTreeWidget *view, int max=-1) | TcHeaderSetupDialog |
TcHeaderSetupDialog(QWidget *parent=0) (定义于 TcHeaderSetupDialog) | TcHeaderSetupDialog | explicit
~TcHeaderSetupDialog() (定义于 TcHeaderSetupDialog) | TcHeaderSetupDialog |


Tianchi: 成员列表

  • 类成员
TcInvoke 成员列表

成员的完整列表，这些成员属于 TcInvoke,包括所有继承而来的类成员

invoke(QGenericArgument val0=QGenericArgument(0), QGenericArgument val1=QGenericArgument(), QGenericArgument val2=QGenericArgument(), QGenericArgument val3=QGenericArgument(), QGenericArgument val4=QGenericArgument(), QGenericArgument val5=QGenericArgument(), QGenericArgument val6=QGenericArgument(), QGenericArgument val7=QGenericArgument(), QGenericArgument val8=QGenericArgument(), QGenericArgument val9=QGenericArgument()) | TcInvoke |
isValid() const | TcInvoke | inline
operator=(const TcInvoke &from) | TcInvoke | inline
queued(QGenericArgument val0=QGenericArgument(0), QGenericArgument val1=QGenericArgument(), QGenericArgument val2=QGenericArgument(), QGenericArgument val3=QGenericArgument(), QGenericArgument val4=QGenericArgument(), QGenericArgument val5=QGenericArgument(), QGenericArgument val6=QGenericArgument(), QGenericArgument val7=QGenericArgument(), QGenericArgument val8=QGenericArgument(), QGenericArgument val9=QGenericArgument()) | TcInvoke | inline
TcInvoke(QObject *o=NULL, QByteArray m="") | TcInvoke | inline


Tianchi: 成员列表

  • 类成员
TcJSONObject 成员列表

成员的完整列表，这些成员属于 TcJSONObject,包括所有继承而来的类成员

add(const QString &key, const char *value) (定义于 TcJSONObject) | TcJSONObject | inline
add(const QString &key, const QString &value) (定义于 TcJSONObject) | TcJSONObject |
add(const QString &key, int value) (定义于 TcJSONObject) | TcJSONObject |
add(const QString &key, double value) (定义于 TcJSONObject) | TcJSONObject |
add(const QString &key, bool value) (定义于 TcJSONObject) | TcJSONObject |
add(const QString &key, QDateTime value) (定义于 TcJSONObject) | TcJSONObject |
add(const char *value) (定义于 TcJSONObject) | TcJSONObject | inline
add(const QString &value) (定义于 TcJSONObject) | TcJSONObject | inline
add(int value) (定义于 TcJSONObject) | TcJSONObject | inline
add(double value) (定义于 TcJSONObject) | TcJSONObject | inline
add(bool value) (定义于 TcJSONObject) | TcJSONObject | inline
add(QDateTime value) (定义于 TcJSONObject) | TcJSONObject | inline
addArray(const QString &key) (定义于 TcJSONObject) | TcJSONObject |
addNull(const QString &key) (定义于 TcJSONObject) | TcJSONObject |
addNull() (定义于 TcJSONObject) | TcJSONObject |
addObject(const QString &key="") (定义于 TcJSONObject) | TcJSONObject |
children() const (定义于 TcJSONObject) | TcJSONObject |
clear() (定义于 TcJSONObject) | TcJSONObject |
clearChildren() (定义于 TcJSONObject) | TcJSONObject |
count() const (定义于 TcJSONObject) | TcJSONObject | inline
deleteChildren(const QString &key) (定义于 TcJSONObject) | TcJSONObject |
dequote(const QString &S) (定义于 TcJSONObject) | TcJSONObject | static
exists(const QString &key) const (定义于 TcJSONObject) | TcJSONObject | inline
fromArray(const wchar_t *ptr) (定义于 TcJSONObject) | TcJSONObject | protected
fromObject(const QString &Key, const wchar_t *ptr) (定义于 TcJSONObject) | TcJSONObject | protected
fromString(QString jsonText) (定义于 TcJSONObject) | TcJSONObject |
get(const QString &key) const (定义于 TcJSONObject) | TcJSONObject | inline
init() (定义于 TcJSONObject) | TcJSONObject | protected
jsonKey() const (定义于 TcJSONObject) | TcJSONObject | protected
jsonValue() const (定义于 TcJSONObject) | TcJSONObject | protected
key() const (定义于 TcJSONObject) | TcJSONObject |
m_index (定义于 TcJSONObject) | TcJSONObject | protected
m_key (定义于 TcJSONObject) | TcJSONObject | protected
m_list (定义于 TcJSONObject) | TcJSONObject | protected
m_type (定义于 TcJSONObject) | TcJSONObject | protected
m_value (定义于 TcJSONObject) | TcJSONObject | protected
newKey(const QString &key) (定义于 TcJSONObject) | TcJSONObject | inlineprotected
parent (定义于 TcJSONObject) | TcJSONObject | protected
parseKey(QString &Value, const wchar_t *ptr) (定义于 TcJSONObject) | TcJSONObject | protected
parseNumber(QString &Value, const wchar_t *ptr) (定义于 TcJSONObject) | TcJSONObject | protected
parseValue(QString Key, const wchar_t *ptr) (定义于 TcJSONObject) | TcJSONObject | protected
quote(const QString &Text) (定义于 TcJSONObject) | TcJSONObject | static
setKey(const QString &value) (定义于 TcJSONObject) | TcJSONObject |
setType(int value) (定义于 TcJSONObject) | TcJSONObject | inline
skip(const wchar_t *in) (定义于 TcJSONObject) | TcJSONObject | inlineprotectedstatic
TcJSONObject(const QString &key="") (定义于 TcJSONObject) | TcJSONObject |
toString() const (定义于 TcJSONObject) | TcJSONObject | virtual
type() const (定义于 TcJSONObject) | TcJSONObject | inline
value() const (定义于 TcJSONObject) | TcJSONObject |
value(const QString &key) const (定义于 TcJSONObject) | TcJSONObject | inline
value(const QString &key, QVariant &v) const (定义于 TcJSONObject) | TcJSONObject |
ValueTypeFlag 枚举名称 (定义于 TcJSONObject) | TcJSONObject |
vtfArray 枚举值 (定义于 TcJSONObject) | TcJSONObject |
vtfBool 枚举值 (定义于 TcJSONObject) | TcJSONObject |
vtfDateTime 枚举值 (定义于 TcJSONObject) | TcJSONObject |
vtfDouble 枚举值 (定义于 TcJSONObject) | TcJSONObject |
vtfInt 枚举值 (定义于 TcJSONObject) | TcJSONObject |
vtfNull 枚举值 (定义于 TcJSONObject) | TcJSONObject |
vtfObject 枚举值 (定义于 TcJSONObject) | TcJSONObject |
vtfString 枚举值 (定义于 TcJSONObject) | TcJSONObject |
~TcJSONObject() (定义于 TcJSONObject) | TcJSONObject | virtual


Tianchi: 成员列表

  • 类成员
TcLineEdit 成员列表

成员的完整列表，这些成员属于 TcLineEdit,包括所有继承而来的类成员

clear() | TcLineEdit | slot
contextMenuEvent(QContextMenuEvent *event) (定义于 TcLineEdit) | TcLineEdit | protectedvirtual
data | TcLineEdit |
data() const (定义于 TcLineEdit) | TcLineEdit |
dataChanged(const QVariant &userData) | TcLineEdit | signal
doubleClicked() | TcLineEdit | signal
labelText | TcLineEdit |
labelText() const (定义于 TcLineEdit) | TcLineEdit |
labelTextChanged(const QString &labelText) | TcLineEdit | signal
mouseDoubleClickEvent(QMouseEvent *event) (定义于 TcLineEdit) | TcLineEdit | protectedvirtual
paintEvent(QPaintEvent *event) (定义于 TcLineEdit) | TcLineEdit | protectedvirtual
setData(const QVariant &userData) | TcLineEdit | slot
setLabelText(const QString &labelText) | TcLineEdit | slot
TcLineEdit(QWidget *parent=0) (定义于 TcLineEdit) | TcLineEdit |
~TcLineEdit() (定义于 TcLineEdit) | TcLineEdit | virtual


Tianchi: 成员列表

  • 类成员
TcLog 成员列表

成员的完整列表，这些成员属于 TcLog,包括所有继承而来的类成员

debug(const QString &S, const QString &SourceName=QString(), int SourceLine=0) | TcLog | inline
setAppFile(const QString &AppFile) | TcLog |
setLogFile(const QString &LogFile) | TcLog |
write(const QString &S, const QString &SourceName=QString(), int SourceLine=0) | TcLog |


Tianchi: 成员列表

  • 类成员
TcMSExcel 成员列表

成员的完整列表，这些成员属于 TcMSExcel,包括所有继承而来的类成员

addBook() | TcMSExcel |
Alignment 枚举名称 | TcMSExcel |
cell(int row, int col) | TcMSExcel | inline
cellAlign(int row, int col, Alignment hAlign, Alignment vAlign) (定义于 TcMSExcel) | TcMSExcel |
cellFormat(int row, int col, const QString &format) (定义于 TcMSExcel) | TcMSExcel |
close() | TcMSExcel |
create(const QString &filename=QString()) | TcMSExcel |
currentSheet() | TcMSExcel |
currentSheetName() | TcMSExcel |
kick() | TcMSExcel |
open(const QString &filename=QString()) | TcMSExcel |
read(int row, int col) | TcMSExcel |
save(const QString &filename=QString()) | TcMSExcel |
setCaption(const QString &value) | TcMSExcel |
setCurrentSheet(int index) | TcMSExcel |
setVisible(bool value) | TcMSExcel |
sheetCount() | TcMSExcel |
sheetNames() | TcMSExcel |
TcMSExcel() | TcMSExcel |
usedRange(int &rowStart, int &colStart, int &rowEnd, int &colEnd) | TcMSExcel |
write(int row, int col, const QVariant &value) | TcMSExcel |
xlBottom 枚举值 | TcMSExcel |
xlCenter 枚举值 | TcMSExcel |
xlLeft 枚举值 | TcMSExcel |
xlRight 枚举值 | TcMSExcel |
xlTop 枚举值 | TcMSExcel |
~TcMSExcel() | TcMSExcel | virtual


Tianchi: 成员列表

  • 类成员
TcMSSQL 成员列表

成员的完整列表，这些成员属于 TcMSSQL,包括所有继承而来的类成员

availableODBCDrivers() | TcMSSQL | static
ODBCDSN(const QString &driver, const QString &server, const QString &dbname, const QString &user=QString(), const QString &pass=QString()) | TcMSSQL | static


Tianchi: 成员列表

  • 类成员
TcMarqueeLabel 成员列表

成员的完整列表，这些成员属于 TcMarqueeLabel,包括所有继承而来的类成员

active | TcMarqueeLabel |
activeChanged(bool active) | TcMarqueeLabel | signal
alignment (定义于 TcMarqueeLabel) | TcMarqueeLabel |
BottomToTop 枚举值 (定义于 TcMarqueeLabel) | TcMarqueeLabel |
direction (定义于 TcMarqueeLabel) | TcMarqueeLabel |
direction() const (定义于 TcMarqueeLabel) | TcMarqueeLabel |
Direction 枚举名称 (定义于 TcMarqueeLabel) | TcMarqueeLabel |
directionChanged(Direction direction) | TcMarqueeLabel | signal
enterEvent(QEvent *event) (定义于 TcMarqueeLabel) | TcMarqueeLabel | protectedvirtual
interval | TcMarqueeLabel |
interval() const | TcMarqueeLabel |
intervalChanged(int interval) | TcMarqueeLabel | signal
isActive() const | TcMarqueeLabel |
leaveEvent(QEvent *event) (定义于 TcMarqueeLabel) | TcMarqueeLabel | protectedvirtual
paintEvent(QPaintEvent *event) (定义于 TcMarqueeLabel) | TcMarqueeLabel | protectedvirtual
reset() | TcMarqueeLabel | slot
resizeEvent(QResizeEvent *event) (定义于 TcMarqueeLabel) | TcMarqueeLabel | protectedvirtual
RightToLeft 枚举值 (定义于 TcMarqueeLabel) | TcMarqueeLabel |
setActive(bool active) | TcMarqueeLabel | slot
setAlignment(Qt::Alignment align) (定义于 TcMarqueeLabel) | TcMarqueeLabel |
setDirection(Direction direciton) | TcMarqueeLabel | slot
setInterval(int msec) | TcMarqueeLabel | slot
start() | TcMarqueeLabel | slot
stop() | TcMarqueeLabel | slot
TcMarqueeLabel(QWidget *parent=0, Qt::WindowFlags f=0) (定义于 TcMarqueeLabel) | TcMarqueeLabel |
TcMarqueeLabel(const QString &text, QWidget *parent=0, Qt::WindowFlags f=0) (定义于 TcMarqueeLabel) | TcMarqueeLabel |
timerEvent(QTimerEvent *event) (定义于 TcMarqueeLabel) | TcMarqueeLabel | protectedvirtual
~TcMarqueeLabel() (定义于 TcMarqueeLabel) | TcMarqueeLabel | virtual


Tianchi: 成员列表

  • 类成员
TcOS 成员列表

成员的完整列表，这些成员属于 TcOS,包括所有继承而来的类成员

language() | TcOS | static
login(const QString &Domain, const QString &UserID, const QString &Password) | TcOS | static
name() | TcOS | static


Tianchi: 成员列表

  • 类成员
TcOracle 成员列表

成员的完整列表，这些成员属于 TcOracle,包括所有继承而来的类成员

availableODBCDrivers() | TcOracle | static
ODBCDSN(const QString &driver, const QString &tns, const QString &user=QString(), const QString &pass=QString()) | TcOracle | static


Tianchi: 成员列表

  • 类成员
TcPlayer 成员列表

成员的完整列表，这些成员属于 TcPlayer,包括所有继承而来的类成员

AUTH_ADMIN 枚举值 | TcPlayer |
AUTH_GUEST 枚举值 | TcPlayer |
AUTH_MANAGER 枚举值 | TcPlayer |
AUTH_SYSADMIN 枚举值 | TcPlayer |
AUTH_USER 枚举值 | TcPlayer |
AuthLevel 枚举名称 | TcPlayer |
authority(const QString &key) const | TcPlayer |
clear() | TcPlayer |
loggedIn | TcPlayer |
loggedIn() const | TcPlayer | inline
loginID() const | TcPlayer | inline
loginTime | TcPlayer |
loginTime() const | TcPlayer | inline
noLoginTime() | TcPlayer | inline
operator=(const TcPlayer &) | TcPlayer |
password() const | TcPlayer | inline
setAuthority(const QString &key, int auth) | TcPlayer | inline
setAuthorityText(const QString &value) | TcPlayer |
setAuthorityText(const QStringList &value) | TcPlayer |
setLoggedIn(bool value) | TcPlayer |
setLoggedIn() | TcPlayer | inline
setLoginID(const QString &value) | TcPlayer | inline
setLoginTime(QDateTime value) | TcPlayer | inline
setPassword(const QString &value) | TcPlayer | inline
setUserID(const QString &value) | TcPlayer | inline
setUserLevel(int value) | TcPlayer | inline
setUsername(const QString &value) | TcPlayer | inline
setUserNo(int value) | TcPlayer | inline
TcPlayer() | TcPlayer |
userID | TcPlayer |
userID() const | TcPlayer | inline
userLevel() const | TcPlayer | inline
username | TcPlayer |
username() const | TcPlayer | inline
userNo | TcPlayer |
userNo() const | TcPlayer | inline


Tianchi: 成员列表

  • 类成员
TcSingleInstance 成员列表

成员的完整列表，这些成员属于 TcSingleInstance,包括所有继承而来的类成员

first() const | TcSingleInstance | inline
m_first | TcSingleInstance | protected
m_instanceName | TcSingleInstance | protected
m_localServer | TcSingleInstance | protected
m_localSocket | TcSingleInstance | protected
TcSingleInstance(QString instanceName) | TcSingleInstance | inline
TcSingleInstance(QObject *parent, QString instanceName) | TcSingleInstance | inline


Tianchi: 成员列表

  • 类成员
TcSingleton< T > 成员列表

成员的完整列表，这些成员属于 TcSingleton< T >,包括所有继承而来的类成员

get() const | TcSingleton< T > | inline
operator*() const | TcSingleton< T > | inline
operator->() const | TcSingleton< T > | inline
operator=(const this_type &) | TcSingleton< T > | inline
TcSingleton() | TcSingleton< T > | inline
TcSingleton(const this_type &) | TcSingleton< T > | inline
~TcSingleton() | TcSingleton< T > | inline


Tianchi: 成员列表

  • 类成员
TcSortPaginationTableView 成员列表

成员的完整列表，这些成员属于 TcSortPaginationTableView,包括所有继承而来的类成员

createTitleMenus() | TcSortPaginationTableView |
fetchData(int page=-1, int section=-1, Qt::SortOrder order=Qt::AscendingOrder) | TcSortPaginationTableView | slot
fetchDataRequested() | TcSortPaginationTableView | signal
page() const | TcSortPaginationTableView |
pageRowCount() const | TcSortPaginationTableView |
setPageInfo(int page, int totalCount) | TcSortPaginationTableView |
setPageRowCount(int pageRowCount=-1) | TcSortPaginationTableView |
setPaginator(QLabel *label) | TcSortPaginationTableView |
sortOrder() const | TcSortPaginationTableView |
sortSection() const | TcSortPaginationTableView |
TcSortPaginationTableView(QWidget *parent=0) (定义于 TcSortPaginationTableView) | TcSortPaginationTableView |
~TcSortPaginationTableView() (定义于 TcSortPaginationTableView) | TcSortPaginationTableView | virtual


Tianchi: 成员列表

  • 类成员
TcString 成员列表

成员的完整列表，这些成员属于 TcString,包括所有继承而来的类成员

filter(const QString &findText, const QStringList &filters) | TcString | static
find(const QStringList &ss, const QString &s) | TcString | static
findOf(const QStringList &list, const QString &key) | TcString | static
first(QByteArray &str, const QByteArray &split="\t") | TcString | static
getTextByIndex(const char *strings, int index) | TcString | static
splitHumanName(QString full, QString &sur, QString &real, QString &english) | TcString | static
TcString() (定义于 TcString) | TcString |


Tianchi: 成员列表

  • 类成员
TcStringList 成员列表

成员的完整列表，这些成员属于 TcStringList,包括所有继承而来的类成员

lineBreak() const | TcStringList | inline
lineBreak(const QString &value) | TcStringList | inline
loadFrom(const QString &fileName) | TcStringList |
saveTo(const QString &fileName) | TcStringList |
TcStringList() (定义于 TcStringList) | TcStringList |


Tianchi: 成员列表

  • 类成员
TcTreeEx 成员列表

成员的完整列表，这些成员属于 TcTreeEx,包括所有继承而来的类成员

CopyCellObject(QTreeWidget *view, int copyMode) (定义于 TcTreeEx) | TcTreeEx | static
createColumnMenu(QTreeWidget *widget, QWidget *object, const QString &methodName) (定义于 TcTreeEx) | TcTreeEx | static
ExportType 枚举名称 (定义于 TcTreeEx) | TcTreeEx |
MSExcel 枚举值 (定义于 TcTreeEx) | TcTreeEx |
save() | TcTreeEx |
setColumnBolds(QTreeWidget *widget) (定义于 TcTreeEx) | TcTreeEx | static
setColumnStyle(QTreeWidget *widget, int fontSize=8, const QString &fontName="Tahoma") (定义于 TcTreeEx) | TcTreeEx | static
setColumnWidth(QTreeWidget *widget, int column, int width, bool hide=false) (定义于 TcTreeEx) | TcTreeEx | static
setExportType(int type) | TcTreeEx |
setMSExcelObject(TcMSExcel *excel, bool hasHeader=true, int startRow=1, int startCol=1) | TcTreeEx |
setSelectedState(int state) | TcTreeEx |
setTextFileName(const QString &filename) | TcTreeEx |
setWidget(QTreeWidget *widget) | TcTreeEx |
TcTreeEx(QTreeWidget *widget=0) | TcTreeEx |
TextFile 枚举值 (定义于 TcTreeEx) | TcTreeEx |


Tianchi: 成员列表

  • 类成员
TcTreeItem 成员列表

成员的完整列表，这些成员属于 TcTreeItem,包括所有继承而来的类成员

createDoubleSpinBox(int col, int decimals, double min, double max, double step, double value) (定义于 TcTreeItem) | TcTreeItem
createLabel(int col, const QString &htmlText, const QVariant &data=QVariant()) (定义于 TcTreeItem) | TcTreeItem
readDoubleSpinBoxValue(int col) (定义于 TcTreeItem) | TcTreeItem
setCellColor(int col, QColor color) (定义于 TcTreeItem) | TcTreeItem
setCellFont(int col, bool bold=false, int alignment=Qt::AlignVCenter|Qt::AlignLeft) (定义于 TcTreeItem) | TcTreeItem
setCellStyle(int startCol=-1, int endCol=-1, bool bold=true, int alignment=Qt::AlignVCenter|Qt::AlignRight, int cellHeight=25) (定义于 TcTreeItem) | TcTreeItem
showPercent(int column, double value=0.0, int digits=0) (定义于 TcTreeItem) | TcTreeItem
showPrice(int column, double value, int digits=0) (定义于 TcTreeItem) | TcTreeItem
showValue(int column, const char *text, const QVariant &data=QVariant(), int size=0) (定义于 TcTreeItem) | TcTreeItem
showValue(int column, const QString &text, const QVariant &data=QVariant(), int size=0) (定义于 TcTreeItem) | TcTreeItem
showValue(int column, const QByteArray &text, const QVariant &data=QVariant(), int size=0) (定义于 TcTreeItem) | TcTreeItem
showValue(int column, double value) (定义于 TcTreeItem) | TcTreeItem
showValue(int column, double value, int digits) (定义于 TcTreeItem) | TcTreeItem


Tianchi: 成员列表

  • 类成员
TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > 成员列表

成员的完整列表，这些成员属于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >,包括所有继承而来的类成员

get0() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
get1() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
get2() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
get3() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
get4() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
get5() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
get6() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
get7() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
get8() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
get9() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
operator!=(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
operator=(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
operator==(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8, const T9 &v9) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set0(const T0 &v0) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set1(const T1 &v1) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set2(const T2 &v2) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set3(const T3 &v3) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set4(const T4 &v4) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set5(const T5 &v5) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set6(const T6 &v6) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set7(const T7 &v7) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set8(const T8 &v8) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
set9(const T9 &v9) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
TcTuple() (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8, const T9 &v9) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline
TcTuple(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, T9 > | inline


Tianchi: 成员列表

  • 类成员
TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 成员列表

成员的完整列表，这些成员属于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >,包括所有继承而来的类成员

get0() (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get1() (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator!=(const this_type &ref) const (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator=(const this_type &ref) (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator==(const this_type &ref) const (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const this_type &ref) (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const T0 &v0, const T1 &v1) (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set0(const T0 &v0) (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set1(const T1 &v1) (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple() (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const T0 &v0, const T1 &v1) (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const this_type &ref) (定义于 TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline


Tianchi: 成员列表

  • 类成员
TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 成员列表

成员的完整列表，这些成员属于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >,包括所有继承而来的类成员

get0() const (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get1() const (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get2() const (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator!=(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator=(const this_type &ref) (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator==(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const this_type &ref) (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const T0 &v0, const T1 &v1, const T2 &v2) (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set0(const T0 &v0) (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set1(const T1 &v1) (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set2(const T2 &v2) (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple() (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const T0 &v0, const T1 &v1, const T2 &v2) (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const this_type &ref) (定义于 TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline


Tianchi: 成员列表

  • 类成员
TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 成员列表

成员的完整列表，这些成员属于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >,包括所有继承而来的类成员

get0() const (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get1() const (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get2() const (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get3() const (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator!=(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator=(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator==(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3) (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set0(const T0 &v0) (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set1(const T1 &v1) (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set2(const T2 &v2) (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set3(const T3 &v3) (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple() (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3) (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline


Tianchi: 成员列表

  • 类成员
TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 成员列表

成员的完整列表，这些成员属于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >,包括所有继承而来的类成员

get0() const (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get1() const (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get2() const (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get3() const (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get4() const (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator!=(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator=(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator==(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set0(const T0 &v0) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set1(const T1 &v1) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set2(const T2 &v2) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set3(const T3 &v3) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set4(const T4 &v4) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple() (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline


Tianchi: 成员列表

  • 类成员
TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 成员列表

成员的完整列表，这些成员属于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >,包括所有继承而来的类成员

get0() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get1() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get2() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get3() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get4() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get5() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator!=(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator=(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator==(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set0(const T0 &v0) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set1(const T1 &v1) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set2(const T2 &v2) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set3(const T3 &v3) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set4(const T4 &v4) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set5(const T5 &v5) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple() (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline


Tianchi: 成员列表

  • 类成员
TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 成员列表

成员的完整列表，这些成员属于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >,包括所有继承而来的类成员

get0() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get1() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get2() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get3() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get4() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get5() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get6() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator!=(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator=(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator==(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set0(const T0 &v0) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set1(const T1 &v1) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set2(const T2 &v2) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set3(const T3 &v3) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set4(const T4 &v4) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set5(const T5 &v5) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set6(const T6 &v6) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple() (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline


Tianchi: 成员列表

  • 类成员
TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > 成员列表

成员的完整列表，这些成员属于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >,包括所有继承而来的类成员

get0() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get1() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get2() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get3() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get4() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get5() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get6() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
get7() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator!=(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator=(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
operator==(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set0(const T0 &v0) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set1(const T1 &v1) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set2(const T2 &v2) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set3(const T3 &v3) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set4(const T4 &v4) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set5(const T5 &v5) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set6(const T6 &v6) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
set7(const T7 &v7) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple() (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline
TcTuple(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, _tc_tuple_ns_::null_type, _tc_tuple_ns_::null_type > | inline


Tianchi: 成员列表

  • 类成员
TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > 成员列表

成员的完整列表，这些成员属于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >,包括所有继承而来的类成员

get0() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
get1() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
get2() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
get3() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
get4() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
get5() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
get6() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
get7() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
get8() const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
operator!=(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
operator=(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
operator==(const this_type &ref) const (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set0(const T0 &v0) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set1(const T1 &v1) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set2(const T2 &v2) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set3(const T3 &v3) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set4(const T4 &v4) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set5(const T5 &v5) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set6(const T6 &v6) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set7(const T7 &v7) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
set8(const T8 &v8) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
TcTuple() (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
TcTuple(const this_type &ref) (定义于 TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type >) | TcTuple< T0, T1, T2, T3, T4, T5, T6, T7, T8, _tc_tuple_ns_::null_type > | inline
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 成员列表

  • 类成员
TcUdp 成员列表

成员的完整列表，这些成员属于 TcUdp,包括所有继承而来的类成员

m_recvMethod (定义于 TcUdp) | TcUdp | protected
m_recvObject (定义于 TcUdp) | TcUdp | protected
recvMessage(QHostAddress client, QByteArray datagram) | TcUdp | signal
sendBroadcast(int port, QByteArray S) | TcUdp |
sendBroadcast(int port, QString S) | TcUdp | inline
sendMessage(QHostAddress host, int port, QByteArray S) | TcUdp |
sendMessage(QHostAddress host, int port, QString S) | TcUdp | inline
setRecvMethod(QObject *recvObject, QByteArray recvMethod) | TcUdp | inline
start(int Port) (定义于 TcUdp) | TcUdp |
stop() (定义于 TcUdp) | TcUdp |
TcUdp() (定义于 TcUdp) | TcUdp |
udpRecv() (定义于 TcUdp) | TcUdp | protectedslot
~TcUdp() (定义于 TcUdp) | TcUdp | virtual
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 成员列表

  • 类成员
TcUtils 成员列表

成员的完整列表，这些成员属于 TcUtils,包括所有继承而来的类成员

addField(const QString &key, const QVariant &value) (定义于 TcUtils) | TcUtils | static
byFields(const QByteArray &fieldBytes) (定义于 TcUtils) | TcUtils | static
complieDateTime(const QString &complieDate, const QString &complieTime) | TcUtils | static
getIDCardVerifyCode(const QByteArray &id) | TcUtils | static
JULIAN_DAY (定义于 TcUtils) | TcUtils | static
StringToMap(const QString &mapStrings) | TcUtils | static
StringToMap(const QStringList &mapStrings) | TcUtils | static
toDateTime(const QString &text) | TcUtils | static
toDateTime(double timeDouble) | TcUtils | static
typeFrom(QVariant::Type type) | TcUtils | static
typeFrom(const QVariant &v) | TcUtils | inlinestatic
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 成员列表

  • 类成员
TcVariantMapTableModel 成员列表

成员的完整列表，这些成员属于 TcVariantMapTableModel,包括所有继承而来的类成员

addData(const QList< QVariantMap > &data) | TcVariantMapTableModel |
addData(const QVariantMap &row) | TcVariantMapTableModel |
addTitle(const QString &field, const QString &title, int precision=-1) | TcVariantMapTableModel |
clear() | TcVariantMapTableModel |
clearData() | TcVariantMapTableModel |
columnCount(const QModelIndex &parent=QModelIndex()) const | TcVariantMapTableModel | virtual
data(const QModelIndex &index, int role=Qt::DisplayRole) const (定义于 TcVariantMapTableModel) | TcVariantMapTableModel | virtual
data() const | TcVariantMapTableModel |
data(int row) const | TcVariantMapTableModel |
flags(const QModelIndex &index) const (定义于 TcVariantMapTableModel) | TcVariantMapTableModel | virtual
headerData(int section, Qt::Orientation orientation, int role=Qt::DisplayRole) const (定义于 TcVariantMapTableModel) | TcVariantMapTableModel | virtual
isCheckable(int row, int col) const | TcVariantMapTableModel |
isChecked(int row, int col) const | TcVariantMapTableModel |
rowCount(const QModelIndex &parent=QModelIndex()) const (定义于 TcVariantMapTableModel) | TcVariantMapTableModel | virtual
setCheckable(int row, int col, bool checkable) | TcVariantMapTableModel |
setChecked(int row, int col, bool checked) | TcVariantMapTableModel |
setData(const QModelIndex &index, const QVariant &value, int role=Qt::EditRole) (定义于 TcVariantMapTableModel) | TcVariantMapTableModel | virtual
setFlags(const QModelIndex &index, Qt::ItemFlags flags) | TcVariantMapTableModel |
setHeaderData(int section, Qt::Orientation orientation, const QVariant &value, int role=Qt::EditRole) | TcVariantMapTableModel | virtual
setNumberColumn(const QString &field, int precision) | TcVariantMapTableModel |
setNumberColumn(int column, int precision) | TcVariantMapTableModel |
TcVariantMapTableModel(QObject *parent=0) (定义于 TcVariantMapTableModel) | TcVariantMapTableModel |
title() const | TcVariantMapTableModel |
title(int col) const | TcVariantMapTableModel |
~TcVariantMapTableModel() (定义于 TcVariantMapTableModel) | TcVariantMapTableModel | virtual
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 首页

Tianchi 文档
生成于 2013年 七月 1日 星期一 16:50:32 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: 成员列表

  • 类成员
  • TcDatabase
  • SQLContext
TcDatabase::SQLContext 成员列表

成员的完整列表，这些成员属于 TcDatabase::SQLContext,包括所有继承而来的类成员

id (定义于 TcDatabase::SQLContext) | TcDatabase::SQLContext
params (定义于 TcDatabase::SQLContext) | TcDatabase::SQLContext
text (定义于 TcDatabase::SQLContext) | TcDatabase::SQLContext


Tianchi: 成员列表

  • 类成员
TcOperMode 成员列表

成员的完整列表，这些成员属于 TcOperMode,包括所有继承而来的类成员

Append | TcOperMode | static
Change | TcOperMode | static
CopyCell | TcOperMode | static
CopyCells | TcOperMode | static
CopyColumn | TcOperMode | static
CopyLine | TcOperMode | static
CopyTable | TcOperMode | static
Delete | TcOperMode | static


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcdir.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • file
tcdir.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi share library for Qt (C++)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：可以复制目录树的类，也可以查找文件夹内所有的文件
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.21 cnhemiya@gmail.com 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCDIR_H
18 #define TIANCHI_TCDIR_H
19
20 #include <tianchi/tcglobal.h>
21
22 #include <QObject>
23 #include <QStringList>
24
27 class TIANCHI_API TcDir : public QObject
28 {
29 Q_OBJECT
30 public:
31 explicit TcDir(QObject *parent = 0);
32
37 QStringList findFiles(const QString &path,
38 const QStringList &nameFilters = QStringList());
39
46 int copyDirs(const QString &fromPath, const QString &toPath,
47 const QStringList &nameFilters = QStringList(),
48 bool overWrite = true);
49
55 int copyFiles(const QStringList &files, const QString &toPath,
56 bool overWrite = true);
57
59 void resetCopyFileCount();
60
61 Q_SIGNALS:
65 void currentFile(int count, const QString &name);
66
67 private:
68 int m_copyFileCount;
69
70 void doDirTree(const QString &fromPath, const QString &toPath,
71 const QStringList &nameFilters, bool overWrite,
72 QStringList &findFiles, bool isFind);
73 QString formatPath(const QString &path);
74 };
75
76 #endif // TIANCHI_TCDIR_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/file/tcfileio.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • file
tcfileio.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：一些文件复制和提取功能
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.05.24 cnhemiya@gmail.com 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17
18 #ifndef TIANCHI_TCFILEIO_H
19 #define TIANCHI_TCFILEIO_H
20
21 #include <QString>
22 #include <QStringList>
23 #include <QIODevice>
24 #include <tianchi/tcglobal.h>
25
29 class TIANCHI_API TcFileIO
30 {
31 public:
32
39 static qint64 copy(const QString &fromFile, const QString &toFile,
40 qint64 bufferSize = defaultBufferSize);
41
50 static qint64 copy(const QString &fromFile, const QString &toFile,
51 qint64 fromFileOffset, qint64 copySize = -1,
52 qint64 bufferSize = defaultBufferSize);
53
60 static qint64 append(const QString &fromFile, const QString &toFile,
61 qint64 bufferSize = defaultBufferSize);
62
71 static qint64 append(const QString &fromFile, const QString &toFile,
72 qint64 fromFileOffset, qint64 appendSize = -1,
73 qint64 bufferSize = defaultBufferSize);
74
87 static int split(const QString &fromFile, const QString &toDir,
88 qint64 splitSize, qint64 bufferSize = defaultBufferSize);
89
96 static qint64 join(const QStringList &fromFileList, const QString &toFile,
97 qint64 bufferSize = defaultBufferSize);
98
106 static qint64 makeDummyFile(const QString &fileName, qint64 fileSize,
107 const char fill = 0x00,
108 qint64 bufferSize = defaultBufferSize);
109
111 static const int KB;
112
114 static const int MB;
115
117 static const int GB;
118
120 static const int defaultBufferSize;
121
122 private:
123 // 提取源文件数据到目的文件
124 static qint64 dump(const QString &fromFile, const QString &toFile,
125 QIODevice::OpenMode fromOpenMode, QIODevice::OpenMode toOpenMode,
126 qint64 fromFileOffset, qint64 toFileOffset,
127 qint64 dumpSize, qint64 bufferSize);
128
129 // 写入数据
130 static qint64 write(QIODevice &from, QIODevice &to, qint64 writeSize, qint64 bufferSize);
131 };
132
133 #endif // TIANCHI_TCFILEIO_H
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcfunctionalsortfilterproxymodel.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
tcfunctionalsortfilterproxymodel.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：依所设过滤参数(QVariantMap)来使用已设滤函数进行过滤的模型
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.06.07 XChinux 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17
18 #ifndef TIANCHI_TCFUNCTIONALSORTFILTERPROXYMODEL_H
19 #define TIANCHI_TCFUNCTIONALSORTFILTERPROXYMODEL_H
20
21 #include <tianchi/tcglobal.h>
22
23 //#include <functional> // TODO C++11
24 #include <QVariantMap>
25 #include <QSortFilterProxyModel>
26
29 typedef bool (*TcFunctionalSortFilterProxyModelFilterFunction)( \
30 const QVariantMap &, const QModelIndex &);
31
32 class TcFunctionalSortFilterProxyModelPrivate;
33
87 class TIANCHI_API TcFunctionalSortFilterProxyModel :
88 public QSortFilterProxyModel
89 {
90 Q_OBJECT
91 public:
92 TcFunctionalSortFilterProxyModel(QObject * parent = 0);
93 ~TcFunctionalSortFilterProxyModel();
95 void setFilterFunction(
96 TcFunctionalSortFilterProxyModelFilterFunction func);
97 //std::function<bool(const QVariantMap &, const QModelIndex &)> func); // TODO C++11
98 public Q_SLOTS:
100 void setFilterParam(const QVariantMap &param);
101 protected:
102 virtual bool filterAcceptsRow(int source_row,
103 const QModelIndex &source_parent) const;
104 private:
105 Q_DISABLE_COPY(TcFunctionalSortFilterProxyModel)
106 Q_DECLARE_PRIVATE(TcFunctionalSortFilterProxyModel)
107 TcFunctionalSortFilterProxyModelPrivate* const d_ptr;
108 };
109
110 #endif // TIANCHI_TCFUNCTIONALSORTFILTERPROXYMODEL_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcsingleton.hpp 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
tcsingleton.hpp
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：用指针实现的单例模式的模版类
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.05.25 cnhemiya@gmail.com 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
37
38 #ifndef TIANCHI_TCSINGLETON_HPP
39 #define TIANCHI_TCSINGLETON_HPP
40
41 #include <cassert>
42
43 template<typename T>
44 class TcSingleton
45 {
46 typedef TcSingleton<T> this_type;
47
48 public:
50 TcSingleton()
51 {
52 if (m_count == 0)
53 m_pointer = new T;
54
55 ++m_count;
56 }
57
59 TcSingleton(const this_type &)
60 {
61 ++m_count;
62 }
63
65 ~TcSingleton()
66 {
67 --m_count;
68
69 if (m_count == 0)
70 {
71 delete m_pointer;
72 m_pointer = 0;
73 }
74 }
75
77 inline T * get() const
78 {
79 assert(m_pointer != 0);
80 return m_pointer;
81 }
82
84 inline const T & operator *() const
85 {
86 assert(m_pointer != 0);
87 return *m_pointer;
88 }
89
91 inline T * operator ->() const
92 {
93 assert(m_pointer != 0);
94 return m_pointer;
95 }
96
98 inline this_type & operator =(const this_type &)
99 {
100 return *this;
101 }
102
103 private:
104 static T *m_pointer;
105 static int m_count;
106 };
107
109 #define TC_SINGLETON_INIT(__t) \
110 template<> int TcSingleton< __t >::m_count = 0; \
111 template<> __t * TcSingleton< __t >::m_pointer = 0;
112
113
114 #endif // TIANCHI_TCSINGLETON_HPP
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/gui/tcsortpaginationtableview.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • gui
tcsortpaginationtableview.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：可排序和分页的TableView
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.06.07 XChinux 建立
13 // ==========================================================================
15 // ==========================================================================
16 #ifndef TIANCHI_TCSORTPAGINATIONTABLEVIEW_H
17 #define TIANCHI_TCSORTPAGINATIONTABLEVIEW_H
18
19 #include <tianchi/tcglobal.h>
20 #include <QTableView>
21
22 class QLabel;
23
24 class TcSortPaginationTableViewPrivate;
25
108 class TIANCHI_API TcSortPaginationTableView : public QTableView
109 {
110 Q_OBJECT
111 public:
112 TcSortPaginationTableView(QWidget *parent = 0);
113 virtual ~TcSortPaginationTableView();
114
116 int pageRowCount() const;
118 int page() const;
120 int sortSection() const;
122 Qt::SortOrder sortOrder() const;
123
125 void setPageRowCount(int pageRowCount = -1);
126
130 void setPageInfo(int page, int totalCount);
131
133 void setPaginator(QLabel *label);
134
136 void createTitleMenus();
137 Q_SIGNALS:
139 void fetchDataRequested();
140 public Q_SLOTS:
145 void fetchData(int page = -1, int section = -1,
146 Qt::SortOrder order = Qt::AscendingOrder);
147 private:
148 Q_DISABLE_COPY(TcSortPaginationTableView)
149 Q_DECLARE_PRIVATE(TcSortPaginationTableView)
150 Q_PRIVATE_SLOT(d_func(), void _q_sortIndicatorChanged(int, Qt::SortOrder))
151 Q_PRIVATE_SLOT(d_func(), void _q_paginatorClicked(const QString &))
152 Q_PRIVATE_SLOT(d_func(), void _q_onColumnShown(bool checked))
153 TcSortPaginationTableViewPrivate* const d_ptr;
154 };
155
156 #endif // TIANCHI_TCSORTPAGETABLEVIEW_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tctuple.hpp 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
tctuple.hpp
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：简单的 Tuple(元组) 模版类, 提供2~10个类型参数的模版
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.05.25 cnhemiya@gmail.com 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
31
32 #ifndef TIANCHI_TCTUPLE_HPP
33 #define TIANCHI_TCTUPLE_HPP
34
35
36 namespace _tc_tuple_ns_
37 {
38
39 class null_type{ /* none */ };
40
41 }
42
43 template<typename T0 = _tc_tuple_ns_::null_type,
44 typename T1 = _tc_tuple_ns_::null_type,
45 typename T2 = _tc_tuple_ns_::null_type,
46 typename T3 = _tc_tuple_ns_::null_type,
47 typename T4 = _tc_tuple_ns_::null_type,
48 typename T5 = _tc_tuple_ns_::null_type,
49 typename T6 = _tc_tuple_ns_::null_type,
50 typename T7 = _tc_tuple_ns_::null_type,
51 typename T8 = _tc_tuple_ns_::null_type,
52 typename T9 = _tc_tuple_ns_::null_type>
53 class TcTuple;
54
55 template<typename T0, typename T1>
56 class TcTuple<T0, T1,
57 _tc_tuple_ns_::null_type,
58 _tc_tuple_ns_::null_type,
59 _tc_tuple_ns_::null_type,
60 _tc_tuple_ns_::null_type,
61 _tc_tuple_ns_::null_type,
62 _tc_tuple_ns_::null_type,
63 _tc_tuple_ns_::null_type,
64 _tc_tuple_ns_::null_type>
65 {
66 typedef TcTuple<T0, T1> this_type;
67
68 public:
69 TcTuple(){ /* none */ }
70
71 TcTuple(const T0 &v0, const T1 &v1)
72 {
73 set(v0, v1);
74 }
75
76 TcTuple(const this_type &ref)
77 {
78 set(ref);
79 }
80
81 inline const this_type & operator =(const this_type &ref)
82 {
83 set(ref);
84 return *this;
85 }
86
87 inline bool operator ==(const this_type &ref) const
88 {
89 return ((m_v0 == ref.m_v0) &&
90 (m_v1 == ref.m_v1));
91 }
92
93 inline bool operator !=(const this_type &ref) const
94 {
95 return !((*this) == ref);
96 }
97
98 inline void set(const this_type &ref)
99 {
100 set(ref.m_v0, ref.m_v1);
101 }
102
103 inline void set(const T0 &v0, const T1 &v1)
104 {
105 m_v0 = v0;
106 m_v1 = v1;
107 }
108
109 inline void set0(const T0 &v0)
110 {
111 m_v0 = v0;
112 }
113
114 inline T0 & get0()
115 {
116 return m_v0;
117 }
118
119 inline void set1(const T1 &v1)
120 {
121 m_v1 = v1;
122 }
123
124 inline T1 & get1()
125 {
126 return m_v1;
127 }
128
129 private:
130 T0 m_v0;
131 T1 m_v1;
132 };
133
134
135 template<typename T0, typename T1, typename T2>
136 class TcTuple<T0, T1, T2,
137 _tc_tuple_ns_::null_type,
138 _tc_tuple_ns_::null_type,
139 _tc_tuple_ns_::null_type,
140 _tc_tuple_ns_::null_type,
141 _tc_tuple_ns_::null_type,
142 _tc_tuple_ns_::null_type,
143 _tc_tuple_ns_::null_type>
144 {
145 typedef TcTuple<T0, T1, T2> this_type;
146
147 public:
148 TcTuple(){ /* none */ }
149
150 TcTuple(const T0 &v0, const T1 &v1, const T2 &v2)
151 {
152 set(v0, v1, v2);
153 }
154
155 TcTuple(const this_type &ref)
156 {
157 set(ref);
158 }
159
160 inline const this_type & operator =(const this_type &ref)
161 {
162 set(ref);
163 return *this;
164 }
165
166 inline bool operator ==(const this_type &ref) const
167 {
168 return ((m_v0 == ref.m_v0) &&
169 (m_v1 == ref.m_v1) &&
170 (m_v2 == ref.m_v2));
171 }
172
173 inline bool operator !=(const this_type &ref) const
174 {
175 return !((*this) == ref);
176 }
177
178 inline void set(const this_type &ref)
179 {
180 set(ref.m_v0, ref.m_v1, ref.m_v2);
181 }
182
183 inline void set(const T0 &v0, const T1 &v1, const T2 &v2)
184 {
185 m_v0 = v0;
186 m_v1 = v1;
187 m_v2 = v2;
188 }
189
190 inline void set0(const T0 &v0)
191 {
192 m_v0 = v0;
193 }
194
195 inline const T0 & get0() const
196 {
197 return m_v0;
198 }
199
200 inline void set1(const T1 &v1)
201 {
202 m_v1 = v1;
203 }
204
205 inline const T1 & get1() const
206 {
207 return m_v1;
208 }
209
210 inline void set2(const T2 &v2)
211 {
212 m_v2 = v2;
213 }
214
215 inline const T2 & get2() const
216 {
217 return m_v2;
218 }
219
220 private:
221 T0 m_v0;
222 T1 m_v1;
223 T2 m_v2;
224 };
225
226
227 template<typename T0, typename T1, typename T2, typename T3>
228 class TcTuple<T0, T1, T2, T3,
229 _tc_tuple_ns_::null_type,
230 _tc_tuple_ns_::null_type,
231 _tc_tuple_ns_::null_type,
232 _tc_tuple_ns_::null_type,
233 _tc_tuple_ns_::null_type,
234 _tc_tuple_ns_::null_type>
235 {
236 typedef TcTuple<T0, T1, T2, T3> this_type;
237
238 public:
239 TcTuple(){ /* none */ }
240
241 TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3)
242 {
243 set(v0, v1, v2, v3);
244 }
245
246 TcTuple(const this_type &ref)
247 {
248 set(ref);
249 }
250
251 inline const this_type & operator =(const this_type &ref)
252 {
253 set(ref);
254 return *this;
255 }
256
257 inline bool operator ==(const this_type &ref) const
258 {
259 return ((m_v0 == ref.m_v0) &&
260 (m_v1 == ref.m_v1) &&
261 (m_v2 == ref.m_v2) &&
262 (m_v3 == ref.m_v3));
263 }
264
265 inline bool operator !=(const this_type &ref) const
266 {
267 return !((*this) == ref);
268 }
269
270 inline void set(const this_type &ref)
271 {
272 set(ref.m_v0, ref.m_v1, ref.m_v2, ref.m_v3);
273 }
274
275 inline void set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3)
276 {
277 m_v0 = v0;
278 m_v1 = v1;
279 m_v2 = v2;
280 m_v3 = v3;
281 }
282
283 inline void set0(const T0 &v0)
284 {
285 m_v0 = v0;
286 }
287
288 inline const T0 & get0() const
289 {
290 return m_v0;
291 }
292
293 inline void set1(const T1 &v1)
294 {
295 m_v1 = v1;
296 }
297
298 inline const T1 & get1() const
299 {
300 return m_v1;
301 }
302
303 inline void set2(const T2 &v2)
304 {
305 m_v2 = v2;
306 }
307
308 inline const T2 & get2() const
309 {
310 return m_v2;
311 }
312
313 inline void set3(const T3 &v3)
314 {
315 m_v3 = v3;
316 }
317
318 inline const T3 & get3() const
319 {
320 return m_v3;
321 }
322
323 private:
324 T0 m_v0;
325 T1 m_v1;
326 T2 m_v2;
327 T3 m_v3;
328 };
329
330
331 template<typename T0, typename T1, typename T2, typename T3,
332 typename T4>
333 class TcTuple<T0, T1, T2, T3, T4,
334 _tc_tuple_ns_::null_type,
335 _tc_tuple_ns_::null_type,
336 _tc_tuple_ns_::null_type,
337 _tc_tuple_ns_::null_type,
338 _tc_tuple_ns_::null_type>
339 {
340 typedef TcTuple<T0, T1, T2, T3, T4> this_type;
341
342 public:
343 TcTuple(){ /* none */ }
344
345 TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4)
346 {
347 set(v0, v1, v2, v3, v4);
348 }
349
350 TcTuple(const this_type &ref)
351 {
352 set(ref);
353 }
354
355 inline const this_type & operator =(const this_type &ref)
356 {
357 set(ref);
358 return *this;
359 }
360
361 inline bool operator ==(const this_type &ref) const
362 {
363 return ((m_v0 == ref.m_v0) &&
364 (m_v1 == ref.m_v1) &&
365 (m_v2 == ref.m_v2) &&
366 (m_v3 == ref.m_v3) &&
367 (m_v4 == ref.m_v4));
368 }
369
370 inline bool operator !=(const this_type &ref) const
371 {
372 return !((*this) == ref);
373 }
374
375 inline void set(const this_type &ref)
376 {
377 set(ref.m_v0, ref.m_v1, ref.m_v2, ref.m_v3, ref.m_v4);
378 }
379
380 inline void set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3,
381 const T4 &v4)
382 {
383 m_v0 = v0;
384 m_v1 = v1;
385 m_v2 = v2;
386 m_v3 = v3;
387 m_v4 = v4;
388 }
389
390 inline void set0(const T0 &v0)
391 {
392 m_v0 = v0;
393 }
394
395 inline const T0 & get0() const
396 {
397 return m_v0;
398 }
399
400 inline void set1(const T1 &v1)
401 {
402 m_v1 = v1;
403 }
404
405 inline const T1 & get1() const
406 {
407 return m_v1;
408 }
409
410 inline void set2(const T2 &v2)
411 {
412 m_v2 = v2;
413 }
414
415 inline const T2 & get2() const
416 {
417 return m_v2;
418 }
419
420 inline void set3(const T3 &v3)
421 {
422 m_v3 = v3;
423 }
424
425 inline const T3 & get3() const
426 {
427 return m_v3;
428 }
429
430 inline void set4(const T4 &v4)
431 {
432 m_v4 = v4;
433 }
434
435 inline const T4 & get4() const
436 {
437 return m_v4;
438 }
439
440 private:
441 T0 m_v0;
442 T1 m_v1;
443 T2 m_v2;
444 T3 m_v3;
445 T4 m_v4;
446 };
447
448
449 template<typename T0, typename T1, typename T2, typename T3,
450 typename T4, typename T5>
451 class TcTuple<T0, T1, T2, T3, T4, T5,
452 _tc_tuple_ns_::null_type,
453 _tc_tuple_ns_::null_type,
454 _tc_tuple_ns_::null_type,
455 _tc_tuple_ns_::null_type>
456 {
457 typedef TcTuple<T0, T1, T2, T3, T4, T5> this_type;
458
459 public:
460 TcTuple(){ /* none */ }
461
462 TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4,
463 const T5 &v5)
464 {
465 set(v0, v1, v2, v3, v4, v5);
466 }
467
468 TcTuple(const this_type &ref)
469 {
470 set(ref);
471 }
472
473 inline const this_type & operator =(const this_type &ref)
474 {
475 set(ref);
476 return *this;
477 }
478
479 inline bool operator ==(const this_type &ref) const
480 {
481 return ((m_v0 == ref.m_v0) &&
482 (m_v1 == ref.m_v1) &&
483 (m_v2 == ref.m_v2) &&
484 (m_v3 == ref.m_v3) &&
485 (m_v4 == ref.m_v4) &&
486 (m_v5 == ref.m_v5));
487 }
488
489 inline bool operator !=(const this_type &ref) const
490 {
491 return !((*this) == ref);
492 }
493
494 inline void set(const this_type &ref)
495 {
496 set(ref.m_v0, ref.m_v1, ref.m_v2, ref.m_v3, ref.m_v4, ref.m_v5);
497 }
498
499 inline void set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3,
500 const T4 &v4, const T5 &v5)
501 {
502 m_v0 = v0;
503 m_v1 = v1;
504 m_v2 = v2;
505 m_v3 = v3;
506 m_v4 = v4;
507 m_v5 = v5;
508 }
509
510 inline void set0(const T0 &v0)
511 {
512 m_v0 = v0;
513 }
514
515 inline const T0 & get0() const
516 {
517 return m_v0;
518 }
519
520 inline void set1(const T1 &v1)
521 {
522 m_v1 = v1;
523 }
524
525 inline const T1 & get1() const
526 {
527 return m_v1;
528 }
529
530 inline void set2(const T2 &v2)
531 {
532 m_v2 = v2;
533 }
534
535 inline const T2 & get2() const
536 {
537 return m_v2;
538 }
539
540 inline void set3(const T3 &v3)
541 {
542 m_v3 = v3;
543 }
544
545 inline const T3 & get3() const
546 {
547 return m_v3;
548 }
549
550 inline void set4(const T4 &v4)
551 {
552 m_v4 = v4;
553 }
554
555 inline const T4 & get4() const
556 {
557 return m_v4;
558 }
559
560 inline void set5(const T5 &v5)
561 {
562 m_v5 = v5;
563 }
564
565 inline const T5 & get5() const
566 {
567 return m_v5;
568 }
569
570 private:
571 T0 m_v0;
572 T1 m_v1;
573 T2 m_v2;
574 T3 m_v3;
575 T4 m_v4;
576 T5 m_v5;
577 };
578
579
580 template<typename T0, typename T1, typename T2, typename T3,
581 typename T4, typename T5, typename T6>
582 class TcTuple<T0, T1, T2, T3, T4, T5, T6,
583 _tc_tuple_ns_::null_type,
584 _tc_tuple_ns_::null_type,
585 _tc_tuple_ns_::null_type>
586 {
587 typedef TcTuple<T0, T1, T2, T3, T4, T5, T6> this_type;
588
589 public:
590 TcTuple(){ /* none */ }
591
592 TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4,
593 const T5 &v5, const T6 &v6)
594 {
595 set(v0, v1, v2, v3, v4, v5, v6);
596 }
597
598 TcTuple(const this_type &ref)
599 {
600 set(ref);
601 }
602
603 inline const this_type & operator =(const this_type &ref)
604 {
605 set(ref);
606 return *this;
607 }
608
609 inline bool operator ==(const this_type &ref) const
610 {
611 return ((m_v0 == ref.m_v0) &&
612 (m_v1 == ref.m_v1) &&
613 (m_v2 == ref.m_v2) &&
614 (m_v3 == ref.m_v3) &&
615 (m_v4 == ref.m_v4) &&
616 (m_v5 == ref.m_v5) &&
617 (m_v6 == ref.m_v6));
618 }
619
620 inline bool operator !=(const this_type &ref) const
621 {
622 return !((*this) == ref);
623 }
624
625 inline void set(const this_type &ref)
626 {
627 set(ref.m_v0, ref.m_v1, ref.m_v2, ref.m_v3, ref.m_v4,
628 ref.m_v5, ref.m_v6);
629 }
630
631 inline void set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3,
632 const T4 &v4, const T5 &v5, const T6 &v6)
633 {
634 m_v0 = v0;
635 m_v1 = v1;
636 m_v2 = v2;
637 m_v3 = v3;
638 m_v4 = v4;
639 m_v5 = v5;
640 m_v6 = v6;
641 }
642
643 inline void set0(const T0 &v0)
644 {
645 m_v0 = v0;
646 }
647
648 inline const T0 & get0() const
649 {
650 return m_v0;
651 }
652
653 inline void set1(const T1 &v1)
654 {
655 m_v1 = v1;
656 }
657
658 inline const T1 & get1() const
659 {
660 return m_v1;
661 }
662
663 inline void set2(const T2 &v2)
664 {
665 m_v2 = v2;
666 }
667
668 inline const T2 & get2() const
669 {
670 return m_v2;
671 }
672
673 inline void set3(const T3 &v3)
674 {
675 m_v3 = v3;
676 }
677
678 inline const T3 & get3() const
679 {
680 return m_v3;
681 }
682
683 inline void set4(const T4 &v4)
684 {
685 m_v4 = v4;
686 }
687
688 inline const T4 & get4() const
689 {
690 return m_v4;
691 }
692
693 inline void set5(const T5 &v5)
694 {
695 m_v5 = v5;
696 }
697
698 inline const T5 & get5() const
699 {
700 return m_v5;
701 }
702
703 inline void set6(const T6 &v6)
704 {
705 m_v6 = v6;
706 }
707
708 inline const T6 & get6() const
709 {
710 return m_v6;
711 }
712
713 private:
714 T0 m_v0;
715 T1 m_v1;
716 T2 m_v2;
717 T3 m_v3;
718 T4 m_v4;
719 T5 m_v5;
720 T6 m_v6;
721 };
722
723
724 template<typename T0, typename T1, typename T2, typename T3,
725 typename T4, typename T5, typename T6, typename T7>
726 class TcTuple<T0, T1, T2, T3, T4, T5, T6, T7,
727 _tc_tuple_ns_::null_type,
728 _tc_tuple_ns_::null_type>
729 {
730 typedef TcTuple<T0, T1, T2, T3, T4, T5, T6, T7> this_type;
731
732 public:
733 TcTuple(){ /* none */ }
734
735 TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4,
736 const T5 &v5, const T6 &v6, const T7 &v7)
737 {
738 set(v0, v1, v2, v3, v4, v5, v6, v7);
739 }
740
741 TcTuple(const this_type &ref)
742 {
743 set(ref);
744 }
745
746 inline const this_type & operator =(const this_type &ref)
747 {
748 set(ref);
749 return *this;
750 }
751
752 inline bool operator ==(const this_type &ref) const
753 {
754 return ((m_v0 == ref.m_v0) &&
755 (m_v1 == ref.m_v1) &&
756 (m_v2 == ref.m_v2) &&
757 (m_v3 == ref.m_v3) &&
758 (m_v4 == ref.m_v4) &&
759 (m_v5 == ref.m_v5) &&
760 (m_v6 == ref.m_v6) &&
761 (m_v7 == ref.m_v7));
762 }
763
764 inline bool operator !=(const this_type &ref) const
765 {
766 return !((*this) == ref);
767 }
768
769 inline void set(const this_type &ref)
770 {
771 set(ref.m_v0, ref.m_v1, ref.m_v2, ref.m_v3, ref.m_v4,
772 ref.m_v5, ref.m_v6, ref.m_v7);
773 }
774
775 inline void set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3,
776 const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7)
777 {
778 m_v0 = v0;
779 m_v1 = v1;
780 m_v2 = v2;
781 m_v3 = v3;
782 m_v4 = v4;
783 m_v5 = v5;
784 m_v6 = v6;
785 m_v7 = v7;
786 }
787
788 inline void set0(const T0 &v0)
789 {
790 m_v0 = v0;
791 }
792
793 inline const T0 & get0() const
794 {
795 return m_v0;
796 }
797
798 inline void set1(const T1 &v1)
799 {
800 m_v1 = v1;
801 }
802
803 inline const T1 & get1() const
804 {
805 return m_v1;
806 }
807
808 inline void set2(const T2 &v2)
809 {
810 m_v2 = v2;
811 }
812
813 inline const T2 & get2() const
814 {
815 return m_v2;
816 }
817
818 inline void set3(const T3 &v3)
819 {
820 m_v3 = v3;
821 }
822
823 inline const T3 & get3() const
824 {
825 return m_v3;
826 }
827
828 inline void set4(const T4 &v4)
829 {
830 m_v4 = v4;
831 }
832
833 inline const T4 & get4() const
834 {
835 return m_v4;
836 }
837
838 inline void set5(const T5 &v5)
839 {
840 m_v5 = v5;
841 }
842
843 inline const T5 & get5() const
844 {
845 return m_v5;
846 }
847
848 inline void set6(const T6 &v6)
849 {
850 m_v6 = v6;
851 }
852
853 inline const T6 & get6() const
854 {
855 return m_v6;
856 }
857
858 inline void set7(const T7 &v7)
859 {
860 m_v7 = v7;
861 }
862
863 inline const T7 & get7() const
864 {
865 return m_v7;
866 }
867
868 private:
869 T0 m_v0;
870 T1 m_v1;
871 T2 m_v2;
872 T3 m_v3;
873 T4 m_v4;
874 T5 m_v5;
875 T6 m_v6;
876 T7 m_v7;
877 };
878
879
880 template<typename T0, typename T1, typename T2, typename T3,
881 typename T4, typename T5, typename T6, typename T7,
882 typename T8>
883 class TcTuple<T0, T1, T2, T3, T4, T5, T6, T7, T8,
884 _tc_tuple_ns_::null_type>
885 {
886 typedef TcTuple<T0, T1, T2, T3, T4, T5, T6, T7, T8> this_type;
887
888 public:
889 TcTuple(){ /* none */ }
890
891 TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4,
892 const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8)
893 {
894 set(v0, v1, v2, v3, v4, v5, v6, v7, v8);
895 }
896
897 TcTuple(const this_type &ref)
898 {
899 set(ref);
900 }
901
902 inline const this_type & operator =(const this_type &ref)
903 {
904 set(ref);
905 return *this;
906 }
907
908 inline bool operator ==(const this_type &ref) const
909 {
910 return ((m_v0 == ref.m_v0) &&
911 (m_v1 == ref.m_v1) &&
912 (m_v2 == ref.m_v2) &&
913 (m_v3 == ref.m_v3) &&
914 (m_v4 == ref.m_v4) &&
915 (m_v5 == ref.m_v5) &&
916 (m_v6 == ref.m_v6) &&
917 (m_v7 == ref.m_v7) &&
918 (m_v8 == ref.m_v8));
919 }
920
921 inline bool operator !=(const this_type &ref) const
922 {
923 return !((*this) == ref);
924 }
925
926 inline void set(const this_type &ref)
927 {
928 set(ref.m_v0, ref.m_v1, ref.m_v2, ref.m_v3, ref.m_v4,
929 ref.m_v5, ref.m_v6, ref.m_v7, ref.m_v8);
930 }
931
932 inline void set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3,
933 const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7,
934 const T8 &v8)
935 {
936 m_v0 = v0;
937 m_v1 = v1;
938 m_v2 = v2;
939 m_v3 = v3;
940 m_v4 = v4;
941 m_v5 = v5;
942 m_v6 = v6;
943 m_v7 = v7;
944 m_v8 = v8;
945 }
946
947 inline void set0(const T0 &v0)
948 {
949 m_v0 = v0;
950 }
951
952 inline const T0 & get0() const
953 {
954 return m_v0;
955 }
956
957 inline void set1(const T1 &v1)
958 {
959 m_v1 = v1;
960 }
961
962 inline const T1 & get1() const
963 {
964 return m_v1;
965 }
966
967 inline void set2(const T2 &v2)
968 {
969 m_v2 = v2;
970 }
971
972 inline const T2 & get2() const
973 {
974 return m_v2;
975 }
976
977 inline void set3(const T3 &v3)
978 {
979 m_v3 = v3;
980 }
981
982 inline const T3 & get3() const
983 {
984 return m_v3;
985 }
986
987 inline void set4(const T4 &v4)
988 {
989 m_v4 = v4;
990 }
991
992 inline const T4 & get4() const
993 {
994 return m_v4;
995 }
996
997 inline void set5(const T5 &v5)
998 {
999 m_v5 = v5;
1000 }
1001
1002 inline const T5 & get5() const
1003 {
1004 return m_v5;
1005 }
1006
1007 inline void set6(const T6 &v6)
1008 {
1009 m_v6 = v6;
1010 }
1011
1012 inline const T6 & get6() const
1013 {
1014 return m_v6;
1015 }
1016
1017 inline void set7(const T7 &v7)
1018 {
1019 m_v7 = v7;
1020 }
1021
1022 inline const T7 & get7() const
1023 {
1024 return m_v7;
1025 }
1026
1027 inline void set8(const T8 &v8)
1028 {
1029 m_v8 = v8;
1030 }
1031
1032 inline const T8 & get8() const
1033 {
1034 return m_v8;
1035 }
1036
1037 private:
1038 T0 m_v0;
1039 T1 m_v1;
1040 T2 m_v2;
1041 T3 m_v3;
1042 T4 m_v4;
1043 T5 m_v5;
1044 T6 m_v6;
1045 T7 m_v7;
1046 T8 m_v8;
1047 };
1048
1049 template<typename T0, typename T1, typename T2, typename T3,
1050 typename T4, typename T5, typename T6, typename T7,
1051 typename T8, typename T9>
1052 class TcTuple
1053 {
1054 typedef TcTuple<T0, T1, T2, T3, T4, T5, T6, T7, T8, T9> this_type;
1055
1056 public:
1057 TcTuple(){ /* none */ }
1058
1059 TcTuple(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3, const T4 &v4,
1060 const T5 &v5, const T6 &v6, const T7 &v7, const T8 &v8, const T9 &v9)
1061 {
1062 set(v0, v1, v2, v3, v4, v5, v6, v7, v8, v9);
1063 }
1064
1065 TcTuple(const this_type &ref)
1066 {
1067 set(ref);
1068 }
1069
1070 inline const this_type & operator =(const this_type &ref)
1071 {
1072 set(ref);
1073 return *this;
1074 }
1075
1076 inline bool operator ==(const this_type &ref) const
1077 {
1078 return ((m_v0 == ref.m_v0) &&
1079 (m_v1 == ref.m_v1) &&
1080 (m_v2 == ref.m_v2) &&
1081 (m_v3 == ref.m_v3) &&
1082 (m_v4 == ref.m_v4) &&
1083 (m_v5 == ref.m_v5) &&
1084 (m_v6 == ref.m_v6) &&
1085 (m_v7 == ref.m_v7) &&
1086 (m_v8 == ref.m_v8) &&
1087 (m_v9 == ref.m_v9));
1088 }
1089
1090 inline bool operator !=(const this_type &ref) const
1091 {
1092 return !((*this) == ref);
1093 }
1094
1095 inline void set(const this_type &ref)
1096 {
1097 set(ref.m_v0, ref.m_v1, ref.m_v2, ref.m_v3, ref.m_v4,
1098 ref.m_v5, ref.m_v6, ref.m_v7, ref.m_v8, ref.m_v9);
1099 }
1100
1101 inline void set(const T0 &v0, const T1 &v1, const T2 &v2, const T3 &v3,
1102 const T4 &v4, const T5 &v5, const T6 &v6, const T7 &v7,
1103 const T8 &v8, const T9 &v9)
1104 {
1105 m_v0 = v0;
1106 m_v1 = v1;
1107 m_v2 = v2;
1108 m_v3 = v3;
1109 m_v4 = v4;
1110 m_v5 = v5;
1111 m_v6 = v6;
1112 m_v7 = v7;
1113 m_v8 = v8;
1114 m_v9 = v9;
1115 }
1116
1117 inline void set0(const T0 &v0)
1118 {
1119 m_v0 = v0;
1120 }
1121
1122 inline const T0 & get0() const
1123 {
1124 return m_v0;
1125 }
1126
1127 inline void set1(const T1 &v1)
1128 {
1129 m_v1 = v1;
1130 }
1131
1132 inline const T1 & get1() const
1133 {
1134 return m_v1;
1135 }
1136
1137 inline void set2(const T2 &v2)
1138 {
1139 m_v2 = v2;
1140 }
1141
1142 inline const T2 & get2() const
1143 {
1144 return m_v2;
1145 }
1146
1147 inline void set3(const T3 &v3)
1148 {
1149 m_v3 = v3;
1150 }
1151
1152 inline const T3 & get3() const
1153 {
1154 return m_v3;
1155 }
1156
1157 inline void set4(const T4 &v4)
1158 {
1159 m_v4 = v4;
1160 }
1161
1162 inline const T4 & get4() const
1163 {
1164 return m_v4;
1165 }
1166
1167 inline void set5(const T5 &v5)
1168 {
1169 m_v5 = v5;
1170 }
1171
1172 inline const T5 & get5() const
1173 {
1174 return m_v5;
1175 }
1176
1177 inline void set6(const T6 &v6)
1178 {
1179 m_v6 = v6;
1180 }
1181
1182 inline const T6 & get6() const
1183 {
1184 return m_v6;
1185 }
1186
1187 inline void set7(const T7 &v7)
1188 {
1189 m_v7 = v7;
1190 }
1191
1192 inline const T7 & get7() const
1193 {
1194 return m_v7;
1195 }
1196
1197 inline void set8(const T8 &v8)
1198 {
1199 m_v8 = v8;
1200 }
1201
1202 inline const T8 & get8() const
1203 {
1204 return m_v8;
1205 }
1206
1207 inline void set9(const T9 &v9)
1208 {
1209 m_v9 = v9;
1210 }
1211
1212 inline const T9 & get9() const
1213 {
1214 return m_v9;
1215 }
1216
1217 private:
1218 T0 m_v0;
1219 T1 m_v1;
1220 T2 m_v2;
1221 T3 m_v3;
1222 T4 m_v4;
1223 T5 m_v5;
1224 T6 m_v6;
1225 T7 m_v7;
1226 T8 m_v8;
1227 T9 m_v9;
1228 };
1229
1230
1231 #endif // TIANCHI_TCTUPLE_HPP
生成于 2013年 七月 1日 星期一 16:50:31 , 为 Tianchi使用 doxygen 1.8.3.1


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi/core/tcvariantmaptablemodel.h 源文件

  • 文件列表
  • 文件成员
  • include
  • tianchi
  • core
tcvariantmaptablemodel.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：以QVariantMap作为数据行的model,只可追加和清除,不可插入与删除
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.06.07 XChinux 建立
13 //
14 // ==========================================================================
16 // ==========================================================================
17 #ifndef TIANCHI_TCVARIANTMAPTABLEMODEL_H
18 #define TIANCHI_TCVARIANTMAPTABLEMODEL_H
19
20 #include <tianchi/tcglobal.h>
21
22 #include <QVariantMap>
23 #include <QAbstractTableModel>
24
25 enum
26 {
28 TcDataRole = Qt::UserRole + 999
29 };
30
31 class TcVariantMapTableModelPrivate;
32
84 class TIANCHI_API TcVariantMapTableModel : public QAbstractTableModel
85 {
86 Q_OBJECT
87 public:
88 TcVariantMapTableModel(QObject *parent = 0);
89 virtual ~TcVariantMapTableModel();
90
91 // 继承实现部分开始-----------------
92 virtual Qt::ItemFlags flags(const QModelIndex &index) const;
93
94 virtual QVariant data(const QModelIndex &index,
95 int role = Qt::DisplayRole) const;
96
97 virtual QVariant headerData(int section, Qt::Orientation orientation,
98 int role = Qt::DisplayRole) const;
99
100 virtual int rowCount(
101 const QModelIndex &parent = QModelIndex()) const;
102
104 virtual int columnCount(
105 const QModelIndex &parent = QModelIndex()) const;
106
107 virtual bool setData(const QModelIndex &index, const QVariant &value,
108 int role = Qt::EditRole);
109
111 virtual bool setHeaderData(int section, Qt::Orientation orientation,
112 const QVariant &value, int role = Qt::EditRole);
113
114 // 继承实现部分结束-----------------
115
117 void setFlags(const QModelIndex &index, Qt::ItemFlags flags);
118
120 void setCheckable(int row, int col, bool checkable);
121
123 void setChecked(int row, int col, bool checked);
124
126 bool isCheckable(int row, int col) const;
127
129 bool isChecked(int row, int col) const;
130
135 void addTitle(const QString &field, const QString &title,
136 int precision = -1);
137
140 void addData(const QList<QVariantMap> &data);
141
144 void addData(const QVariantMap &row);
145
147 const QList<QVariantMap>& data() const;
148
150 QVariantMap data(int row) const;
151
153 const QList<QPair<QString, QString> >& title() const;
154
156 QPair<QString, QString> title(int col) const;
157
159 void setNumberColumn(const QString &field, int precision);
160
162 void setNumberColumn(int column, int precision);
163
165 void clearData();
166
168 void clear();
169 private:
170 Q_DISABLE_COPY(TcVariantMapTableModel)
171 Q_DECLARE_PRIVATE(TcVariantMapTableModel)
172 TcVariantMapTableModelPrivate* const d_ptr;
173 };
174
175 #endif // TIANCHI_TCVARIANTMAPTABLEMODEL_H


Tianchi: D:/work/Tianchi/xchinux_tianchi/include/tianchi.h 源文件

  • 文件列表
  • 文件成员
  • include
tianchi.h
浏览该文件的文档.
1 // **************************************************************************
2 // Tianchi C++ library for Qt (open source)
3 // 天池共享源码库
4 // 版权所有 (C) 天池共享源码库开发组
5 // 授权协议：请阅读天池共享源码库附带的授权协议
6 // **************************************************************************
7 // 文档说明：引用单元头文件
8 // ==========================================================================
9 // 开发日志：
10 // 日期 人员 说明
11 // --------------------------------------------------------------------------
12 // 2013.04.16 圣域天子 建立
13 // ==========================================================================
15 #ifndef TIANCHI_H
16 #define TIANCHI_H
17
18 #include <tianchi/chinese/tcchinese.h>
19
20 #include <tianchi/core/tcclasses.h>
21 #include <tianchi/core/tccommon.h>
22 #include <tianchi/core/tcstring.h>
23 #include <tianchi/core/tcutils.h>
24 #include <tianchi/core/tcfunctionalsortfilterproxymodel.h>
25 #include <tianchi/core/tcvariantmaptablemodel.h>
26 #include <tianchi/core/tcsingleton.hpp>
27 #include <tianchi/core/tctuple.hpp>
28
29 #include <tianchi/file/tcdir.h>
30 #include <tianchi/file/tcfile.h>
31 #include <tianchi/file/tcfileio.h>
32 #include <tianchi/file/tcjson.h>
33 #include <tianchi/file/tclog.h>
34 #include <tianchi/file/tcmsexcel.h>
35 #include <tianchi/file/tcexcelreader.h>
36
37 #include <tianchi/gui/tcclicklabel.h>
38 #include <tianchi/gui/tcdateedit.h>
39 #include <tianchi/gui/tcflowlayout.h>
40 #include <tianchi/gui/tcformutils.h>
41 #include <tianchi/gui/tcgloweffect.h>
42 #include <tianchi/gui/tcguiutils.h>
43 #include <tianchi/gui/tcheadersetupdialog.h>
44 #include <tianchi/gui/tclineedit.h>
45 #include <tianchi/gui/tcmarqueelabel.h>
46 #include <tianchi/gui/tcsortpaginationtableview.h>
47
48 #include <tianchi/network/tcdownloadhttp.h>
49 #include <tianchi/network/tcsingleinstance.h>
50 #include <tianchi/network/tcudp.h>
51
52 #include <tianchi/os/tcos.h>
53
54 #include <tianchi/sql/tcmssql.h>
55 #include <tianchi/sql/tcorcale.h>
56 #include <tianchi/sql/tcdatabase.h>
57 #include <tianchi/sql/tcdataaccess.h>
58
59 #include <tianchi/widget/tctreeex.h>
60
61 #endif // TIANCHI_H
生成于 2013年 七月 1日 星期一 16:50:30 , 为 Tianchi使用 doxygen 1.8.3.1