• 665阅读
  • 10回复

Qt_anroid自适应屏幕的问题 [复制链接]

上一主题 下一主题
离线mugua001
 

只看楼主 倒序阅读 楼主  发表于: 2020-11-22
我用Qt5.8.0 做的一个安卓APP,安装后,可以自适手机应屏幕尺寸;(Qt5.7.1编译的apk也可以自适应屏幕)
同一套代码,换成Qt5.9.3编译(期间试过比Qt5.9.6,5.9.9;QT5.12.x等版本),无法自适应手机屏幕。

如何处理高版本Qt编译的APK自适应屏幕的问题?谢谢。
离线20091001753

只看该作者 1楼 发表于: 2020-11-22
我目前就是用 Qt 5.14.2,widgets
屏幕适配很正常。
(づ ̄ 3 ̄)づ
离线mugua001

只看该作者 2楼 发表于: 2020-11-23
回 20091001753 的帖子
20091001753:我目前就是用 Qt 5.14.2,widgets
屏幕适配很正常。 (2020-11-22 22:06) 

啊?难道是 Qt5.14.X可以了?
离线mugua001

只看该作者 3楼 发表于: 2020-11-23
回 20091001753 的帖子
20091001753:我目前就是用 Qt 5.14.2,widgets
屏幕适配很正常。 (2020-11-22 22:06) 

我是C++写的,你是QML 么??
1条评分金钱+1
20091001753 金钱 +1 我是 Widgets,当然是 C++ 2020-11-23
离线mugua001

只看该作者 4楼 发表于: 2020-11-23
回 20091001753 的帖子
20091001753:我目前就是用 Qt 5.14.2,widgets
屏幕适配很正常。 (2020-11-22 22:06) 

花了我手机1.2GB流量,下载了Qt5.14.1 ,(Ubuntu16.04),编译,许多*.h文件都找不到……泪奔……换回我的Qt5.8.0,编译,正常。打死不换Qt版本了。
1条评分金钱+1
20091001753 金钱 +1 Qt 5.14.2 有离线安装包,我是 win 系统。 2020-11-23
离线20091001753

只看该作者 5楼 发表于: 2020-11-23
这个是 5.14.2 的离线安装包下载地址:
http://download.qt.io/official_releases/qt/5.14/5.14.2/

NDK 用 r20b
SDK Platform 29(也就是 安卓10)

APP 不正常,最好有截图。
(づ ̄ 3 ̄)づ
离线mugua001

只看该作者 6楼 发表于: 2020-11-25
回 20091001753 的帖子
20091001753:这个是 5.14.2 的离线安装包下载地址:
http://download.qt.io/official_releases/qt/5.14/5.14.2/
NDK 用 r20b
SDK Platform 29(也就是 安卓10)
....... (2020-11-23 22:15) 

谢谢!
我知道有离线包,我在外面出差中……连手机热点下载的安装包。

我用的NDK 13,SDK 28(安卓9);

用Qt5.8.0编译,正常,换成5.14.1编译,好多头文件找不到……就放弃折腾了。
重新换回Qt5.8.0版本了。
离线20091001753

只看该作者 7楼 发表于: 2020-11-25
回 mugua001 的帖子
Qt 安卓 找不到头文件,只有2种可能:Qt 或 ndk

如果是 Qt 的没找到,那应该是你用了已经被移除的类。

如果是 ndk 的没找到,那就更新 ndk 的版本。

跟尽可能新的 Qt 版本,当然是更好的。
(づ ̄ 3 ̄)づ
离线mugua001

只看该作者 8楼 发表于: 2020-11-25
回 20091001753 的帖子
20091001753:Qt 安卓 找不到头文件,只有2种可能:Qt 或 ndk
如果是 Qt 的没找到,那应该是你用了已经被移除的类。
如果是 ndk 的没找到,那就更新 ndk 的版本。
....... (2020-11-25 15:14) 

我忘了是哪些头文件了;
我用QT5.9.9也可以编译,但就是不能自适应手机屏幕;
暂时不折腾了,就用Qt5.8.0吧。这个版本正常;

有时间了,再折腾其他版本;谢谢。
离线mugua001

只看该作者 9楼 发表于: 2020-11-29


同一套代码用Qt5.7.1/5.8.0编译,则可以自适应屏幕;
当前是Qt5.9.9版本。
离线mugua001

只看该作者 10楼 发表于: 2020-12-01
无可奈何,我又换回Qt5.8.0了,打死不再折腾了。就用这个版本。
快速回复
限100 字节
 
上一个 下一个