• 8826阅读
  • 3回复

QT Creator 1.3 如何支持VC编译器? [复制链接]

上一主题 下一主题
离线loaden
 
只看楼主 倒序阅读 楼主  发表于: 2010-01-12
— 本帖被 XChinux 从 Qt for Linux/X11 移动到本区(2010-02-08) —
搜索论坛了,根据那个帖子的回答:要用VC编译器,除非使用CMake。
但很明显,用QT开发,还是qmake好用!

大家有没有什么好办法,让QT Creator支持VC编译器?
我看QT Creator 1.3已经支持cdb的调试了。
谢谢!
离线dbzhang800

只看该作者 1楼 发表于: 2010-01-13
引用楼主loaden于2010-01-12 21:05发表的 QT Creator 1.3 如何支持VC编译器? :
搜索论坛了,根据那个帖子的回答:要用VC编译器,除非使用CMake。
但很明显,用QT开发,还是qmake好用!
大家有没有什么好办法,让QT Creator支持VC编译器?
我看QT Creator 1.3已经支持cdb的调试了。
.......


只要你的Qt是VS编译的,Qtcreator不需要任何设置就是调用的vc编译器。

如果你的Qt是mingw编译的,Qtcreator设置也没用,只能用mingw。
离线loaden
只看该作者 2楼 发表于: 2010-01-16
引用第1楼dbzhang800于2010-01-13 18:19发表的  :
只要你的Qt是VS编译的,Qtcreator不需要任何设置就是调用的vc编译器。
如果你的Qt是mingw编译的,Qtcreator设置也没用,只能用mingw。

谢谢!真没想到原来是这样!嗯,可是,我用VC编译器,想编译静态版本,却总在最后时刻失败。
我是用Windows SDK 中的VC编译器编译的。

再次感谢,我会再尝试下!
离线loaden
只看该作者 3楼 发表于: 2010-01-27
确认可以,只要使用VC编译的Qt就可以了。
快速回复
限100 字节
 
上一个 下一个