• 665阅读
  • 3回复

[讨论]Qt 执行js V8引擎的问题 [复制链接]

上一主题 下一主题
在线liulin188
 

只看楼主 倒序阅读 楼主  发表于: 05-15
用QJSEngine执行js,无法用v8引擎。
对js不是很懂,也就是有些js需要v8才能运行,
但是QJSEngine无法执行,搞的我只能写个html把js加进去,然后再用QWebengineview来执行。。。

是不是需要在哪里设置呢
https://wiki.qt.io/Qt_5.12_Release
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
离线toby520

只看该作者 1楼 发表于: 05-15
丢具体的片段代码
QtQML多多指教开发社区 http://qtclub.heilqt.com
将QtCoding进行到底
关注移动互联网,关注金融
开发跨平台客户端,服务于金融行业
专业定制界面
群号:312125701   373955953(qml控件定做)
在线liulin188

只看该作者 2楼 发表于: 05-18
回 toby520 的帖子
toby520:丢具体的片段代码 [表情]  (2019-05-15 13:28) 

具体的js不方便放出来,对于js我也不是很懂,大概就是牵扯到很多类型的问题。

比如用js调试助手去运行,普通的运行提示类型错误,或者不支持,V8运行就可以。

所以我疑问QJSEngine是否支持v8。
https://wiki.qt.io/Qt_5.12_Release
https://www.qt.io/blog/qt-5.13.2-released
https://www.qt.io/blog/qt-creator-4.10.2-released
离线fsu0413

只看该作者 3楼 发表于: 05-23
QJSEngine是Qt自己写的引擎,不是V8
快速回复
限100 字节
 
上一个 下一个