• 183阅读
  • 10回复

[提问]求一个android的 5.15.11版本,谢谢 [复制链接]

上一主题 下一主题
在线angelus
 

只看楼主 倒序阅读 楼主  发表于: 06-03
论坛里有谁有留存5.15.11版本的安卓的编译文件的,可以共享下,或者其他低于11的也行,我测试下
14和13版本的opensll都有点问题,p12的证书解析总是失败

离线realfan

只看该作者 1楼 发表于: 06-04
4条评分好评度+1贡献值+1金钱+10威望+1
angelus 好评度 +1 - 06-04
angelus 贡献值 +1 - 06-04
angelus 威望 +1 - 06-04
angelus 金钱 +10 - 06-04
在线angelus

只看该作者 2楼 发表于: 06-04
回 realfan 的帖子
realfan:链接:https://pan.baidu.com/s/1QHOkylfLLzlfB9GZp8ETQg?pwd=lwx2
提取码:lwx2
下载自build-qt.fsu0413.me
 (2024-06-04 10:36) 

非常感谢!!!
在线angelus

只看该作者 3楼 发表于: 06-04
回 realfan 的帖子
realfan:链接:https://pan.baidu.com/s/1QHOkylfLLzlfB9GZp8ETQg?pwd=lwx2
提取码:lwx2
下载自build-qt.fsu0413.me
 (2024-06-04 10:36) 

版主有5.15.10的版本没,我测试过了5.15.11有个bug,多媒体模块没法使用,说未安装,没法用
离线realfan

只看该作者 4楼 发表于: 06-05
回 angelus 的帖子
angelus:版主有5.15.10的版本没,我测试过了5.15.11有个bug,多媒体模块没法使用,说未安装,没法用 (2024-06-04 14:30) 

链接:https://pan.baidu.com/s/1-iMPTaBQZmEmDx47tS-dDQ?pwd=mih2
提取码:mih2
在线angelus

只看该作者 5楼 发表于: 06-05
回 realfan 的帖子
realfan:链接:https://pan.baidu.com/s/1-iMPTaBQZmEmDx47tS-dDQ?pwd=mih2
提取码:mih2
 (2024-06-05 13:27) 

版主你真是哆啦A梦啊
在线angelus

只看该作者 6楼 发表于: 06-05
回 realfan 的帖子
realfan:链接:https://pan.baidu.com/s/1-iMPTaBQZmEmDx47tS-dDQ?pwd=mih2
提取码:mih2
(2024-06-05 13:27)

实测5.15.10安卓版本可以直接解析p12证书文件,后边的11版本不能调用多媒体模块,12,13,14版本解析p12都会失败,只能固化在10版本了
分析了编译的配置,应该是openssl的变动引起的,5.15.11以前的版本都是1.1编译的,12以后就换成3.0了,应该就是这个原因,大部分p12证书是在1.1版本一下生成的,换成3.0以后,肯定就解析不了了,除非证书是在3.0生成的,那应该就可以用最新版本了,但很多时候证书都是第三方提供的,没法更改
openssl 1.1 和 3.0 api不兼容真是个大坑啊



离线fsu0413

只看该作者 7楼 发表于: 06-07
回 angelus 的帖子
angelus:实测5.15.10安卓版本可以直接解析p12证书文件,后边的11版本不能调用多媒体模块,12,13,14版本解析p12都会失败,只能固化在10版本了
分析了编译的配置,应该是openssl的变动引起的,5.15.11以前的版本都是1.1编译的,12以后就换成3.0了,应该就是这个原因,大部分p12证书是在1. .. (2024-06-05 14:54)

如果换成openssl 1.1的话,我这边因为没有商业支持,只能停在1.1.1v
或许动态openssl是另一种出路

动态openssl的话,需要的就是Qt官方的下载部署openssl动态库的那些东西了,就不是我这个静态openssl+动态Qt的做法了
但是因为安卓NDK的二进制兼容的坑,需要NDK r22b编Qt
在线angelus

只看该作者 8楼 发表于: 06-11
回 fsu0413 的帖子
fsu0413:如果换成openssl 1.1的话,我这边因为没有商业支持,只能停在1.1.1v
或许动态openssl是另一种出路
动态openssl的话,需要的就是Qt官方的下载部署openssl动态库的那些东西了,就不是我这个静态openssl+动态Qt的做法了
....... (2024-06-07 07:28)

留在1.1v其实也不是什么大问题,只要稳定就好,贸然提升到3.0,就会有稀奇古怪的兼容问题,还在用5.15的估计也就是没法更新到6才没办法的,稳定还是第一位的
离线fsu0413

只看该作者 9楼 发表于: 06-11
回 angelus 的帖子
angelus:留在1.1v其实也不是什么大问题,只要稳定就好,贸然提升到3.0,就会有稀奇古怪的兼容问题,还在用5.15的估计也就是没法更新到6才没办法的,稳定还是第一位的
 (2024-06-11 09:56) 

然而3.0也发布了三年了。。。。。。
在线angelus

只看该作者 10楼 发表于: 06-12
回 fsu0413 的帖子
fsu0413:然而3.0也发布了三年了。。。。。。 (2024-06-11 19:32) 

哎,Qt6发布也快4年了,还不是一样用着5嘛
快速回复
限100 字节
 
上一个 下一个